Formule e funzioni

Funzione SOMMA

Funzione SOMMA

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

La funzione SOMMA, una delle funzioni matematiche e trigonometriche, somma i valori. È possibile sommare singoli valori, riferimenti o intervalli di celle o una combinazione dei tre.

Ad esempio:

  • =SOMMA(A2:A10)

  • =SOMMA(A2:A10; C2:C10)

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

SOMMA(num1;[num2];...)

Nome argomento

Descrizione

num1    (obbligatorio)

Primo numero da sommare. Il numero può essere ad esempio 4, un riferimento di cella come B6 o un intervallo di celle come B2:B8.

num2-255    (facoltativo)

Secondo numero da sommare. È possibile specificare fino a 255 numeri in questo modo.

In questa sezione vengono illustrate alcune procedure consigliate per l'uso della funzione somma. Molto di questo può essere applicato anche alle altre funzioni.

Metodo =1+2 o =A+B. È possibile immettere =1+2+3 o =A1+B1+C2 e ottenere risultati del tutto corretti, tuttavia questi metodi sono soggetti a errori per diversi motivi:

  1. Errori di digitazione. Supponiamo di dover immettere diversi valori di questo tipo:

    • =14598,93+65437,90+78496,23

    Prova quindi a verificare che le voci siano corrette. È molto più semplice inserire questi valori in singole celle e usare una formula somma. È inoltre possibile formattare i valori quando si trova nelle celle, rendendoli molto più leggibili quando si trova in una formula.

    Usare la funzione SOMMA invece di codificare i valori nelle formule.  La formula nella cella D5 è =SOMMA(D2:D4)
  2. Errori #VALORE! generati quando si fa riferimento a testo invece che a numeri

    Se si usa una formula di questo tipo:

    • =A1+B1+C1 o =A1+A2+A3

    Esempio di costruzione non corretta della formula.  La formula nella cella D2 è =A2+B2+C2

    La formula può essere interrotta se sono presenti valori non numerici (testo) nelle celle a cui si fa riferimento, che restituirà un #VALUE. errore. SUM ignorerà i valori di testo e darà la somma dei soli valori numerici.

    Costruzione corretta della formula.  Invece di =A2+B2+C2, la formula della cella D2 è =SOMMA(A2:C2)
  3. Errore #RIF! generato quando si eliminano righe o colonne

    Errore #RIF! causato dall'eliminazione di una colonna.  La formula è cambiata in =A2+#REF!+B2

    Se si elimina una riga o una colonna, la formula non viene aggiornata per escludere la riga o colonna eliminata e restituisce quindi un errore #RIF!, mentre una funzione SOMMA viene aggiornata automaticamente.

    La funzione SOMMA viene regolata automaticamente in base alle righe e colonne inserite o eliminate
  4. Le formule non aggiornano i riferimenti quando si inseriscono righe o colonne

    Le formule =A+B+C non vengono aggiornate se si aggiungono righe

    Se si inserisce una riga o una colonna, la formula non verrà aggiornata in modo da includere la riga aggiunta, in cui una funzione somma verrà aggiornata automaticamente (purché non si sia fuori dall'intervallo a cui si fa riferimento nella formula). Questo aspetto è particolarmente importante se ti aspetti che la formula venga aggiornata e non lo fa, perché ti lascerà risultati incompleti che potrebbero non essere intercettati.

    L'esempio ritrae una formula SOMMA che si espande automaticamente da =SOMMA(A2:C2) a =SOMMA(A2:D2) dopo l'inserimento di una colonna
  5. SOMMA con singoli riferimenti di cella o intervalli

    L'uso di una formula di questo tipo:

    • =SOMMA(A1;A2;A3;B1;B2;B3)

    È ugualmente incline all'errore quando si inseriscono o eliminano righe all'interno dell'intervallo a cui si fa riferimento per gli stessi motivi. È molto meglio usare singoli intervalli, ad esempio:

    • =SOMMA(A1:A3;B1:B3)

    Che vengono aggiornati quando si aggiungono e eliminano righe.

Problema

Descrizione dell'errore

La funzione SOMMA visualizza ##### invece del risultato.

Controllare la larghezza delle colonne. # # # # # in genere significa che la colonna è troppo stretta per visualizzare il risultato della formula.

La funzione SOMMA visualizza la formula come testo invece del risultato.

Verificare che la cella non sia formattata come testo. Selezionare la cella o l'intervallo in questione e premere CTRL + 1 per visualizzare la finestra di dialogo Formato celle , quindi fare clic sulla scheda numero e selezionare il formato desiderato. Se la cella è stata formattata come testo e non cambia dopo aver modificato il formato, potrebbe essere necessario usare F2 _GT_ invio per forzare la modifica del formato.

La funzione SOMMA non viene aggiornata.

Verificare che il calcolo sia impostato su automatico. Nella scheda formula andare alle Opzioni di calcolo. È anche possibile usare F9 per forzare il calcolo del foglio di lavoro.

Verificare che Opzioni di calcolo sia impostato su Automatico.  Nella scheda Formule passare a Opzioni di calcolo.

Alcuni valori non vengono sommati.

È possibile sommare solo i valori numerici nel riferimento o nell'intervallo della funzione. Le celle vuote, i valori logici come VERO o i valori di testo vengono ignorati.

Al posto del risultato previsto viene visualizzato l'errore #NOME?.

Questo errore indica in genere che la formula non è stata digitata correttamente, ad esempio =soma(A1:A10) invece di =SOMMA(A1:A10).

La funzione SOMMA visualizza un numero intero, ma dovrebbe visualizzare anche i decimali

Controllare la formattazione delle celle per assicurarsi di visualizzare i decimali. Selezionare la cella o l'intervallo in questione e premere CTRL+1 per visualizzare la finestra di dialogo Formato celle, quindi fare clic sulla scheda Numero e selezionare il formato desiderato, indicando il numero di posizioni decimali da visualizzare.

  1. Come si sommano/sottraggono/moltiplicano/dividono numeri? Vedere questa serie di video in Eseguire semplici operazioni matematiche in Excel o Usare Excel come calcolatrice.

  2. Cosa occorre fare per visualizzare più/meno posizioni decimali? È possibile cambiare il formato numerico. Selezionare la cella o l'intervallo in questione e premere CTRL+1 per visualizzare la finestra di dialogo Formato celle, quindi fare clic sulla scheda Numero e selezionare il formato desiderato, indicando il numero di posizioni decimali da visualizzare.

  3. Come si sommano o sottraggono le ore? È possibile sommare e sottrarre valori di ora in diversi modi. Ad esempio, per ottenere la differenza tra 8:00 AM - 12:00 PM per il pagamento delle retribuzioni, usare: =("12:00 PM"-"8:00 AM")*24, ossia l'ora di fine meno l'ora di inizio. Tenere presente che Excel calcola le ore come frazione di un giorno, quindi è necessario moltiplicare per 24 per ottenere le ore totali. Il primo esempio usa =((B2-A2)+(D2-C2))*24 per ottenere la somma delle ore dall'inizio alla fine, meno la pausa pranzo (8,50 ore totali).

    Se si vogliono semplicemente sommare ore e minuti, non è necessario moltiplicare per 24. Il secondo esempio quindi usa =SOMMA(A6:C6) poiché occorre calcolare solo il numero totale di ore e minuti per le attività assegnate (5:36 o 5 ore e 36 minuti).

    Calcolo delle ore

    Per altre informazioni, vedere: Sommare o sottrarre tempo.

  4. Come si ottiene la differenza tra le date? Come per gli orari, è possibile sommare e sottrarre date. Ecco un esempio molto comune per contare il numero di giorni tra due date. È semplice come = B2-a2. La chiave per lavorare con entrambe le date e le ore è che si inizia con la data/ora di fine e si sottrae la data di inizio/ora.

    Calcolo delle differenze tra date

    Per altre modalità di utilizzo delle date, vedere: calcolare la differenza tra due date.

  5. Come si sommano solo le celle visibili? Se, dopo aver nascosto manualmente alcune righe o aver usato il filtro automatico per visualizzare solo determinati dati, si vogliono sommare solo le celle visibili, è possibile usare la funzione SUBTOTALE. Se si usa una riga Totale in una tabella di Excel, qualsiasi funzione selezionata nell'elenco a discesa Totale viene immessa automaticamente come subtotale. Per altre informazioni, vedere Calcolare i totali in una tabella di Excel.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Leggi altre informazioni su SUM

La funzione SOMMA.SE somma solo i valori che soddisfano un singolo criterio

La funzione SOMMA.PIÙ.SE somma solo i valori che soddisfano più criteri

La funzione CONTA.SE conta solo i valori che soddisfano un singolo criterio

La funzione CONTA.PIÙ.SE conta solo i valori che soddisfano più criteri

Panoramica delle formule in Excel

Come evitare errori nelle formule

Trovare e correggere errori nelle formule

Scelte rapide da tastiera di Excel per Windows

Scelte rapide da tastiera di Excel per Mac

Funzioni matematiche e trigonometriche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×