Formule e funzioni

Funzione SOMMA

Funzione SOMMA

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

La funzione somma , una delle funzioni matematiche e trigonometriche, somma i valori. È possibile aggiungere singoli valori, riferimenti di cella o intervalli o una combinazione di tutti e tre.

Ad esempio:

  • =SOMMA(A2:A10)

  • =SOMMA(A2:A10; C2:C10)

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

SOMMA(num1;[num2];...)

Nome argomento

Descrizione

num1    (obbligatorio)

Primo numero da sommare. Il numero può essere ad esempio 4, un riferimento di cella come B6 o un intervallo di celle come B2:B8.

num2-255    (facoltativo)

Secondo numero da sommare. È possibile specificare fino a 255 numeri in questo modo.

In questa sezione verrà illustrate alcune procedure consigliate per l'utilizzo con la funzione somma. L'operazione può essere applicata a lavorare con altre funzioni.

Metodo =1+2 o =A+B. È possibile immettere =1+2+3 o =A1+B1+C2 e ottenere risultati del tutto corretti, tuttavia questi metodi sono soggetti a errori per diversi motivi:

  1. Errori di digitazione. Supponiamo di dover immettere diversi valori di questo tipo:

    • =14598,93+65437,90+78496,23

    Provare a verificare che le voci siano corrette. È molto più facile inserire questi valori in singole celle e utilizzare una formula somma. Inoltre, è possibile formattare i valori quando sono nelle celle, rendendoli molto più leggibile quindi quando sono in una formula.

    Usare la funzione SOMMA invece di codificare i valori nelle formule.  La formula nella cella D5 è =SOMMA(D2:D4)
  2. Errori #VALORE! generati quando si fa riferimento a testo invece che a numeri

    Se si usa una formula di questo tipo:

    • =A1+B1+C1 o =A1+A2+A3

    Esempio di costruzione non corretta della formula.  La formula nella cella D2 è =A2+B2+C2

    La formula è possibile interrompere se sono presenti valori non numerici (testo) nelle celle cui viene fatto riferimento, che restituiranno un #VALUE! errore. SOMMA ignorerà i valori di testo e per ottenere la somma dei soltanto valori numerici.

    Costruzione corretta della formula.  Invece di =A2+B2+C2, la formula della cella D2 è =SOMMA(A2:C2)
  3. Errore #RIF! generato quando si eliminano righe o colonne

    Errore #RIF! causato dall'eliminazione di una colonna.  La formula è cambiata in =A2+#REF!+B2

    Se si elimina una riga o una colonna, la formula non viene aggiornata per escludere la riga o colonna eliminata e restituisce quindi un errore #RIF!, mentre una funzione SOMMA viene aggiornata automaticamente.

    La funzione SOMMA viene regolata automaticamente in base alle righe e colonne inserite o eliminate
  4. Le formule non aggiornano i riferimenti quando si inseriscono righe o colonne

    Le formule =A+B+C non vengono aggiornate se si aggiungono righe

    Se si inserisce una riga o colonna, la formula non verrà aggiornata per includere la riga aggiunta in una funzione somma viene aggiornato automaticamente con (purché non si è esterna all'intervallo di cui viene fatto riferimento nella formula). Questa operazione è particolarmente importante se si prevede che la formula per l'aggiornamento e non, come si lasciare con risultati incompleti che non è possibile rilevare.

    L'esempio ritrae una formula SOMMA che si espande automaticamente da =SOMMA(A2:C2) a =SOMMA(A2:D2) dopo l'inserimento di una colonna
  5. SOMMA con singoli riferimenti di cella o intervalli

    L'uso di una formula di questo tipo:

    • =SOMMA(A1;A2;A3;B1;B2;B3)

    È identico errore soggetto inserimento o eliminazione di righe all'interno dell'intervallo di cui viene fatto riferimento per gli stessi motivi. È consigliabile usare singoli intervalli, ad esempio:

    • =SOMMA(A1:A3;B1:B3)

    Che vengono aggiornati quando si aggiungono e eliminano righe.

Problema

Descrizione dell'errore

La funzione SOMMA visualizza ##### invece del risultato.

Controllare la larghezza delle colonne. # # # indica in genere che la colonna è troppo piccolo per visualizzare il risultato della formula.

La funzione SOMMA visualizza la formula come testo invece del risultato.

Verificare che la cella non è formattata come testo. Selezionare la cella o intervallo in questione e usare Ctrl + 1 per visualizzare la finestra di dialogo Formato celle , quindi fare clic su Numero scheda e selezionare il formato desiderato. Se la cella formattata come testo e non modifica dopo aver modificato il formato, potrebbe essere necessario usare F2 > invio per imporre il formato da modificare.

La funzione SOMMA non viene aggiornata.

Assicurarsi che calcolo sia impostato su automatico. Nella scheda formule passare alle Opzioni di calcolo. È anche possibile utilizzare F9 forzare il foglio di lavoro per il calcolo.

Verificare che Opzioni di calcolo sia impostato su Automatico.  Nella scheda Formule passare a Opzioni di calcolo.

Alcuni valori non vengono sommati.

È possibile sommare solo i valori numerici nel riferimento o nell'intervallo della funzione. Le celle vuote, i valori logici come VERO o i valori di testo vengono ignorati.

Al posto del risultato previsto viene visualizzato l'errore #NOME?.

Questo errore indica in genere che la formula non è stata digitata correttamente, ad esempio =soma(A1:A10) invece di =SOMMA(A1:A10).

La funzione SOMMA visualizza un numero intero, ma dovrebbe visualizzare anche i decimali

Controllare la formattazione delle celle per assicurarsi di visualizzare i decimali. Selezionare la cella o l'intervallo in questione e premere CTRL+1 per visualizzare la finestra di dialogo Formato celle, quindi fare clic sulla scheda Numero e selezionare il formato desiderato, indicando il numero di posizioni decimali da visualizzare.

  1. Come si sommano/sottraggono/moltiplicano/dividono numeri? Vedere questa serie di video in Eseguire semplici operazioni matematiche in Excel o Usare Excel come calcolatrice.

  2. Come visualizzare più/meno posizioni decimali? È possibile modificare il formato del numero. Selezionare la cella o intervallo in questione e usare Ctrl + 1 per visualizzare la finestra di dialogo Formato celle , quindi fare clic sulla scheda numero e scegliere il formato desiderato, assicurandosi di indicare il numero di posizioni decimali desiderate.

  3. Come si sommano o sottraggono le ore? È possibile sommare e sottrarre valori di ora in diversi modi. Ad esempio, per ottenere la differenza tra 8:00 AM - 12:00 PM per il pagamento delle retribuzioni, usare: =("12:00 PM"-"8:00 AM")*24, ossia l'ora di fine meno l'ora di inizio. Tenere presente che Excel calcola le ore come frazione di un giorno, quindi è necessario moltiplicare per 24 per ottenere le ore totali. Il primo esempio usa =((B2-A2)+(D2-C2))*24 per ottenere la somma delle ore dall'inizio alla fine, meno la pausa pranzo (8,50 ore totali).

    Se si vogliono semplicemente sommare ore e minuti, non è necessario moltiplicare per 24. Il secondo esempio quindi usa =SOMMA(A6:C6) poiché occorre calcolare solo il numero totale di ore e minuti per le attività assegnate (5:36 o 5 ore e 36 minuti).

    Calcolo delle ore

    Per altre informazioni, vedere: Sommare o sottrarre tempo.

  4. Come ottenere la differenza tra date? Come con i tempi, è possibile aggiungere e sottrarre date. Ecco un esempio molto comune di conteggio del numero di giorni tra due date. È semplice come = B2 A2. Il tasto per l'uso di date e ore è iniziare con la data/ora di fine e sottrarre la data di inizio/ora.

    Calcolo delle differenze tra date

    Per altri esempi di utilizzo delle date, vedere: Calcolare il numero di giorni tra due date.

  5. Come si sommano solo le celle visibili? Se, dopo aver nascosto manualmente alcune righe o aver usato il filtro automatico per visualizzare solo determinati dati, si vogliono sommare solo le celle visibili, è possibile usare la funzione SUBTOTALE. Se si usa una riga Totale in una tabella di Excel, qualsiasi funzione selezionata nell'elenco a discesa Totale viene immessa automaticamente come subtotale. Per altre informazioni, vedere Calcolare i totali in una tabella di Excel.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Altre informazioni sul somma

La funzione somma.Se somma solo i valori che soddisfano un singolo criterio

Somma la funzione somma solo i valori che soddisfano più criteri

Funzione CONTA.Se il conta solo i valori che soddisfano un singolo criterio

Conta la funzione conta solo i valori che soddisfano più criteri

Panoramica delle formule in Excel

Come evitare errori nelle formule

Trovare e correggere gli errori nelle formule

Scelte rapide da tastiera in Excel per Windows

Scelte rapide da tastiera in Excel per Mac

Matematiche e trigonometriche funzioni

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×