Formule e funzioni

Funzione SE

Funzione SE

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

La funzione se è una delle funzioni più diffuse in Excel e consente di effettuare confronti logici tra un valore e quello previsto.

Quindi un'istruzione SE può avere due risultati. Il primo risultato si ottiene se il confronto è Vero, il secondo se è Falso.

Ad esempio, SE(C2="Sì";1;2) significa: SE(C2 = Sì, allora restituisci 1, altrimenti restituisci 2).

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Usare la funzione SE, una delle funzioni logiche, per restituire un valore se una condizione è vera e un altro valore se è falsa.

SE(test;se_vero;[se_falso])

Ad esempio:

  • =SE(A2>B2;"Fuori budget";"OK")

  • =SE(A2=B2;B4-A4;"")

Nome argomento

Descrizione

test    (obbligatorio)

Condizione da testare.

se_vero    (obbligatorio)

Valore restituito se il risultato di test è VERO.

se_falso    (facoltativo)

Valore restituito se il risultato di test è FALSO.

Esempi di funzioni SE semplici

La cella D2 contiene la formula =SE(C2="Sì";1;2)
  • =SE(C2="Sì";1;2)

Nell'esempio qui sopra la formula nella cella D2 dice: SE(C2 = Sì, allora restituisci 1, altrimenti restituisci 2)

La cella D2 contiene la formula =SE(C2=1;"SÌ";"NO")
  • =SE(C2=1;"Sì";"No")

In questo esempio la formula nella cella D2 dice: if (C2 = 1, quindi return Yes, in caso contrario return no)come si vede, la funzione se può essere usata per valutare sia il testo che i valori. Può essere usato anche per valutare gli errori. Non si è limitati a controllare solo se una cosa è uguale a un'altra e si restituisce un singolo risultato, ma è anche possibile usare operatori matematici ed eseguire calcoli aggiuntivi a seconda dei criteri. Puoi anche annidare più funzioni se insieme per eseguire più confronti.

La formula nella cella D2 è =SE(C2>B2;"Fuori budget";"Nel budget")
  • =SE(C2>B2;"Fuori budget";"Nel budget")

Nell'esempio precedente la funzione SE nella cella D2 dice SE(C2 è maggiore di B2, allora restituisci "Fuori budget", altrimenti "Nel budget")

La formula nella cella E2 è =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Nella figura qui sopra, invece di restituire un risultato di testo verrà restituito un calcolo matematico. Quindi la formula nella cella E2 dice SE(Spese effettive è maggiore di Spese previste, allora sottrai l'importo di Spese previste dall'importo di Spese effettive, altrimenti non restituire nulla).

La formula nella cella F7 è SE(E7="Sì";F5*0,0825;0)
  • =SE(E7="Sì";F5*0,0825;0)

In questo esempio la formula nella cella F7 dice SE(E7 = "Sì", allora moltiplica l'importo totale nella cella F5 * 8,25%, altrimenti non sono dovute imposte quindi restituisci 0)

Nota: Se si intende usare testo nelle formule, è necessario racchiuderlo tra virgolette, ad esempio "Testo". L'unica eccezione è l'uso di VERO o FALSO, che Excel riconosce automaticamente.

Problemi comuni

Problema

Causa dell'errore

0 (zero) in una cella

Non è stato specificato un argomento per se_vero o se_falso. Per restituire il valore corretto, aggiungere del testo ai due argomenti o aggiungere VERO o FALSO all'argomento.

#NOME? in una cella

Questo errore indica in genere che la formula non è stata digitata correttamente.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Operatori di calcolo e precedenza in Excel

Usare funzioni annidate in una formula

Uso di se per verificare se una cella è vuota

Uso di se per verificare se una cella è vuota

Video: funzioni se avanzate

Funzione IFS (Office 365, Excel 2016 e versioni successive)

Funzioni if avanzate-utilizzo di formule annidate ed evitare insidie

Video di formazione: funzioni if avanzate

La funzione conta.se conta i valori in base a un singolo criterio

La funzione conta.più.se conta i valori in base a più criteri

La funzione somma.se somma i valori in base a un singolo criterio

La funzione somma.più.se somma i valori in base a più criteri

E la funzione

O una funzione

Funzione VLOOKUP

Panoramica delle formule in Excel

Come evitare

Usare il controllo degli errori per rilevare

Funzioni logiche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (per categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×