Firmare digitalmente il progetto macro

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Questo articolo descrive come firmare digitalmente un progetto macro tramite un certificato. Se non si ha già un certificato digitale, è necessario ottenerne uno. Per testare i progetti macro nel computer, è possibile creare un certificato autofirmato con lo strumento Selfcert.exe.

È possibile ottenere un certificato digitale da un'autorità di certificazione (CA) commerciale, dall'amministratore della sicurezza interna o da un professionista IT.

Per altre informazioni sulle autorità di certificazione che offrono servizi per i prodotti Microsoft, vedere l'elenco dei membri del programma Microsoft Root Certificate.

Poiché un certificato digitale creato da un utente non viene rilasciato da un'autorità di certificazione formale attendibile, i progetti macro firmati usando un certificato di questo tipo vengono considerati progetti autofirmati. Microsoft Office considera attendibile un certificato autofirmato solo se tale certificato è stato aggiunto alla cartella Autorità di certificazione radice attendibili nell'archivio Certificati - Utente corrente.

Per informazioni su come creare un certificato autofirmato, vedere la sezione seguente.

  1. Passare a c:\Programmi (x86) \Microsoft Office\root\Office16.

  2. Fare clic su SelfCert.exe. Viene visualizzata la finestra di dialogo Crea certificato digitale.

  3. Nella casella Nome certificato digitare un nome descrittivo per il certificato.

  4. Fare clic su OK.

  5. Quando viene visualizzato il messaggio SelfCert eseguito, fare clic su OK.

  1. Passare a C:\Programmi\Microsoft Office\<versione di Office>\.

  2. Fare clic su SelfCert.exe. Viene visualizzata la finestra di dialogo Crea certificato digitale.

  3. Nella casella Nome certificato digitare un nome descrittivo per il certificato.

  4. Fare clic su OK.

  5. Quando viene visualizzato il messaggio SelfCert eseguito, fare clic su OK.

  1. Fare clic su Start, scegliere Tutti i programmi, Microsoft Office, Strumenti di Microsoft Office e quindi fare clic su Certificato digitale per progetti VBA.
    Verrà visualizzata la finestra di dialogo Crea certificato digitale .

  2. Nella casella Nome certificato digitare un nome descrittivo per il certificato.

  3. Fare clic su OK.

  4. Quando viene visualizzato il messaggio SelfCert eseguito, fare clic su OK.

Finestra di dialogo Crea certificato digitale

Per visualizzare il certificato nell'archivio Certificati personali, eseguire le operazioni seguenti:

  1. Aprire Internet Explorer.

  2. Scegliere Opzioni Internet dal menu Strumenti e quindi fare clic sulla scheda Contenuto.

  3. Fare clic su Certificati e quindi sulla scheda Personali.

  1. Aprire il file contenente il progetto macro che si desidera firmare.

  2. Nel gruppo Codice della scheda Sviluppo fare clic su Visual Basic.

    Nota: Se la scheda Sviluppo non è disponibile, fare clic sulla scheda File. Fare clic su Opzioni. Fare clic su Personalizza barra multifunzione. Nell'elenco Personalizza barra multifunzione selezionare Sviluppo e quindi fare clic su OK.

  3. In Visual Basic scegliere Firma digitale dal menu Strumenti.

  4. Verrà visualizzata la finestra di dialogo Firma digitale.

  5. Selezionare un certificato e fare clic su OK.

    Nota: Se non è stato selezionato alcun certificato digitale o si desidera utilizzarne un altro, fare clic su Scegli. Selezionare il certificato e fare clic su OK.

    Note: 

    • Si consiglia di firmare le macro solo dopo che la soluzione è stata testata e pronta per la distribuzione: quando il codice in un progetto di macro firmato viene modificato in qualsiasi modo, la firma digitale viene rimossa. Se però si ha il certificato digitale valido usato in precedenza per firmare il progetto nel computer in uso, il progetto macro viene automaticamente firmato di nuovo al momento del salvataggio.

    • Se si vuole impedire agli utenti della soluzione di modificare accidentalmente il progetto macro e di invalidare la firma, bloccare il progetto macro prima di firmarlo. La firma digitale implica la garanzia che il progetto non sia stato manomesso da quando è stato firmato. La firma digitale non mostra che il progetto è stato scritto. Di conseguenza, il blocco del progetto macro non impedisce a un altro utente di sostituire la firma digitale con un'altra firma. Gli amministratori aziendali possono firmare di nuovo i modelli e i componenti aggiuntivi in modo che possano controllare gli utenti che eseguono i propri computer.

    • Se si crea un componente aggiuntivo che consente di aggiungere codice a un progetto macro, il codice deve essere in grado di stabilire se il progetto contiene una firma digitale e avvisare gli utenti delle conseguenze derivanti dalla modifica di un progetto firmato prima che procedano.

    • Quando si firmano digitalmente le macro, è importante ottenere un indicatore di data e ora in modo che altri utenti possano verificare la firma se il certificato viene utilizzato dopo la scadenza o se è stato revocato dopo l'apposizione della firma. Se si firmano macro senza indicatore di data e ora, la firma rimarrà valida per il periodo di validità del certificato.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×