Tabelle pivot

Filtrare i dati in una tabella pivot

Filtrare i dati in una tabella pivot

Per focalizzare l'attenzione su una porzione ridotta di una grande quantità di dati in una tabella pivot per analizzarli in modo approfondito, è possibile filtrare i dati. Questa operazione può essere eseguita in diversi modi. Prima di tutto, inserire uno o più filtri dei dati per filtrare i dati in modo rapido ed efficace. I filtri dei dati contengono pulsanti sui quali è possibile fare clic per filtrare i dati e rimangono visibili insieme ai dati, consentendo così di sapere sempre quali campi sono visualizzati o nascosti nella tabella pivot filtrata.

Opzioni del filtro dei dati con il pulsante di selezione multipla evidenziato

Suggerimento: Ora Excel 2016 consente di selezionare più filtri dei dati facendo clic sul pulsante sull'etichetta, come mostrato nella figura qui sopra.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Filtrare i dati in una tabella pivot

  1. Selezionare una cella nella tabella pivot. Selezionare Analizza > Inserisci filtro dati Filtro dati .

  2. Selezionare i campi per cui si vogliono creare filtri dati, quindi selezionare OK.

  3. Selezionare gli elementi da visualizzare nella tabella pivot.

Filtrare i dati manualmente

  1. Selezionare la freccia dell'intestazione Freccia del menu a discesa Filtro della colonna da filtrare.

  2. Deselezionare(Seleziona tutto) e selezionare le caselle che si desidera visualizzare. Quindi selezionare OK.

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare le relative schede Analizza tabella pivot e Progettazione sulla barra multifunzione.

  2. Fare clic su Analizza tabella pivot > Inserisci filtro dati.

  3. Nella finestra di dialogo Inserisci filtri dati selezionare le caselle relative ai campi per cui si desidera creare filtri dei dati.

  4. Fare clic su OK.

    Verrà visualizzato un filtro dei dati per ogni campo selezionato nella finestra di dialogo Inserisci filtri dati.

  5. In ogni filtro dei dati fare clic sugli elementi da visualizzare nella tabella.

Suggerimento: Per modificare l'aspetto del filtro dei dati, fare clic su di esso per visualizzare la scheda Filtro dati sulla barra multifunzione. Usando le varie opzioni della scheda, è possibile applicare uno stile o modificare le impostazioni del filtro dei dati.

Altri modi per filtrare i dati di una tabella pivot

Per visualizzare i dati da analizzare, usare le seguenti funzionalità di filtro al posto o in aggiunta ai filtri dei dati.

Filtrare i dati manualmente

Usare un filtro rapporto per filtrare gli elementi

Visualizzare i primi o gli ultimi 10 elementi

Filtrare in base alla selezione per visualizzare o nascondere solo gli elementi selezionati

Attivare o disattivare le opzioni di filtro

Filtrare i dati manualmente

  1. Nella tabella pivot fare clic sulla freccia Freccia del menu a discesa Filtro in Etichette di riga o Etichette di colonna.

  2. Nell'elenco di etichette di riga o colonna deselezionare la casella (Seleziona tutto) in alto nell'elenco e selezionare le caselle relative agli elementi da visualizzare nella tabella pivot.

  3. La freccia di selezione del filtro si trasforma nell'icona Icona filtro applicato a indicare che è applicato un filtro. Fare clic su di essa per modificare o eliminare il filtro facendo clic su Cancella filtro da <Nome campo>.

    Per rimuovere tutti i filtri contemporaneamente, fare clic sulla scheda Analizza tabella pivot > Cancella > Cancella filtri.

Usare un filtro rapporto per filtrare gli elementi

Mediante un filtro rapporto è possibile visualizzare rapidamente un set di valori diverso nella tabella pivot. Gli elementi selezionati nel filtro vengono visualizzati nella tabella pivot, mentre gli elementi non selezionati rimangono nascosti. Si può anche impostare la visualizzazione delle pagine filtro (il set di valori corrispondenti agli elementi del filtro rapporto selezionati) in fogli di lavoro separati.

Aggiungere un filtro rapporto

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzato il riquadro Campi tabella pivot.

  2. Nel riquadro Elenco campi tabella pivot fare clic sul campo di un'area e selezionare Sposta in filtro rapporto.

È possibile ripetere questo passaggio per creare più filtri rapporto. I filtri rapporto sono visualizzati sopra la tabella pivot, per essere facilmente accessibili.

  • Per cambiare l'ordine dei campi, nell'area Filtri trascinare i campi nella posizione desiderata oppure fare doppio clic su un campo e selezionare Sposta su o Sposta giù. L'ordine dei filtri rapporto si rifletterà nella tabella pivot.

Visualizzare i filtri rapporto in righe o colonne

  1. Fare clic sulla tabella pivot o sulla tabella pivot associata a un grafico pivot.

  2. Fare clic con il pulsante destro del mouse in un punto qualsiasi della tabella pivot e scegliere Opzioni tabella pivot.

  3. Nella scheda Layout specificare queste opzioni:

    1. Nella casella di riepilogo Disponi campi nell'area Filtro rapporto eseguire una di queste operazioni:

      • Per visualizzare i filtri rapporto in righe dall'alto al basso, selezionare Da sotto a sopra.

      • Per visualizzare i filtri rapporto in colonne da sinistra a destra, selezionare Da sopra a sotto.

    2. Nella casella Filtra campi per colonna digitare o selezionare il numero di campi da visualizzare prima di passare a un'altra colonna o riga in base all'impostazione di Disponi campi specificata nel passaggio precedente.

Selezionare elementi nel filtro rapporto

  1. Nella tabella pivot fare clic sulla freccia in giù accanto al filtro rapporto.

  2. Selezionare le caselle di controllo accanto agli elementi da visualizzare nel rapporto. Per selezionare tutti gli elementi, fare clic sulla casella di controllo accanto a (Seleziona tutto).

    Il filtro rapporto ora mostra gli elementi filtrati.

Visualizzare le pagine del filtro rapporto in fogli di lavoro separati

  1. Fare clic in un punto qualsiasi della tabella pivot (o della tabella pivot associata a un grafico pivot) a cui sono applicati uno o più filtri rapporto.

  2. Fare clic su Analizza tabella pivot sulla barra multifunzione > Opzioni > Mostra pagine filtro rapporto.

  3. Nella finestra di dialogo Mostra pagine filtro rapporto selezionare un campo di filtro rapporto e fare clic su OK.

Visualizzare i primi o gli ultimi 10 elementi

È anche possibile applicare filtri per visualizzare i primi o gli ultimi 10 valori o dati che soddisfano specifiche condizioni.

  1. Nella tabella pivot fare clic sulla freccia Freccia del menu a discesa Filtro accanto a Etichette di riga o Etichette di colonna.

  2. Fare clic con il pulsante destro del mouse su un elemento nella selezione e scegliere Filtra > Primi 10 o Ultimi 10.

  3. Nella prima casella digitare un numero.

  4. Nella seconda casella scegliere l'opzione in base alla quale filtrare. Sono disponibili le opzioni seguenti:

    • Per filtrare in base al numero di elementi, scegliere Elementi.

    • Per filtrare in base alla percentuale, scegliere Percentuale.

    • Per filtrare in base alla somma, scegliere Somma.

  5. Se si vuole, nella casella di ricerca è possibile cercare un valore specifico.

Filtrare in base alla selezione per visualizzare o nascondere solo gli elementi selezionati

  1. Nella tabella pivot selezionare uno o più elementi nel campo che si vuole filtrare in base alla selezione.

  2. Fare clic con il pulsante destro del mouse su un elemento nella selezione e scegliere Filtra.

  3. Eseguire una delle operazioni seguenti:

    • Per visualizzare gli elementi selezionati, fare clic su Mantieni solo elementi selezionati.

    • Per nascondere gli elementi selezionati, fare clic su Nascondi elementi selezionati.

      Suggerimento: è possibile visualizzare di nuovo gli elementi nascosti rimuovendo il filtro. Fare clic con il pulsante destro del mouse su un altro elemento nello stesso campo, scegliere Filtra e quindi fare clic su Cancella filtro.

Attivare o disattivare le opzioni di filtro

Se si desidera applicare più filtri per campo o se si preferisce non visualizzare i pulsanti Filtro nella tabella pivot, di seguito è spiegato come attivare o disattivare queste e altre opzioni di filtro:

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare le schede della tabella pivot sulla barra multifunzione.

  2. Nella scheda Analizza tabella pivot fare clic su Opzioni.

    1. Nella finestra di dialogo Opzioni tabella pivot fare clic sulla scheda Layout.

    2. Nell'area Layout selezionare o deselezionare la casella Consenti più filtri per campo in base alle proprie esigenze.

    3. Per visualizzare o nascondere le didascalie dei campi e gli elenchi a discesa dei filtri, fare clic sulla scheda Visualizza e selezionare o deselezionare la casella di controllo Didascalie e filtri campi

È possibile visualizzare e interagire con le tabelle pivot in Excel Online, ad esempio filtrando manualmente i dati e usando i filtri dati creati nell'applicazione desktop Excel. Non è possibile creare nuovi filtri dati in Excel Online.

Per filtrare i dati di una tabella pivot, eseguire una delle operazioni seguenti:

  • Per applicare un filtro manuale, fare clic sulla freccia in Etichette di riga o Etichette di colonna, quindi selezionare le opzioni di filtro desiderate.

Opzioni di filtro per i dati di una tabella pivot

  • Se la tabella pivot include filtri dati, fare clic sugli elementi da visualizzare in ogni filtro dati.

filtro dati con gli elementi selezionati

Se si dispone dell'applicazione desktop Excel, è possibile fare clic sul pulsante Apri in Excel per aprire la cartella di lavoro e applicare altri filtri o creare nuovi filtri dati per i dati della tabella pivot. Ecco come:

Fare clic su Apri in Excel e filtrare i dati nella tabella pivot.

Pulsante per la modifica in Excel

Per essere sempre informati sugli aggiornamenti apportati alle funzionalità di Excel Online, visitare il blog di Microsoft Excel.

È possibile provare o acquistare la famiglia completa di applicazioni e servizi Office su Office.com.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Video: filtrare i dati in una tabella pivot

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Creare una tabella pivot per analizzare dati esterni

Creare una tabella pivot per analizzare i dati di più tabelle

Ordinare i dati in una tabella pivot

Raggruppare o separare dati in una tabella pivot

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×