Filtrare i dati importati in PowerPivot

Quando si importano dati da un'origine dati esterna in PowerPivot, è possibile scegliere le colonne da ogni tabella e applicare filtri per limitare il numero di righe nel modello di dati.

  1. In Excel fare clic sulla scheda PowerPivot > Gestisci modello di dati per aprire la finestra di PowerPivot.

  2. Fare clic su Home > Recupera dati esterni, quindi fare clic su uno di questi pulsanti per aprire l'Importazione guidata tabella: Da database, Da report, Da servizio dati o Da altre origini.

  3. Nella pagina Selezione tabelle e viste selezionare una tabella, quindi fare clic su Visualizza anteprima e applica filtro.

  4. Per escludere le colonne, deselezionare le caselle accanto alle colonne che non si desidera importare.

  5. Per ridurre le righe, individuare la colonna in cui sono contenuti i criteri in base ai quali si desidera filtrare, quindi fare clic sulla freccia GIÙ a destra dell'intestazione di colonna. Nel menu Filtro automatico effettuare uno dei passaggi seguenti:

    1. Nell'elenco di valori delle colonne selezionare o deselezionare uno o più valori da utilizzare come filtri. Ad esempio, se nelle colonne sono contenuti i nomi di categorie di prodotti, selezionare solo le categorie che si desidera importare. Se il numero di valori è estremamente elevato, singoli elementi potrebbero non essere visualizzati nell'elenco. Verrà invece visualizzato il messaggio "Troppi elementi da visualizzare".

    2. Fare clic su Filtri per numeri o su Filtri per testo (a seconda del tipo di colonna), quindi fare clic su uno dei comandi dell'operatore di confronto (ad esempio Uguale a) o su Filtro personalizzato. Nella finestra di dialogo Filtro personalizzato creare il filtro.

      Nota: Se si commette un errore ed è necessario ricominciare, fare clic su Cancella filtri di riga.

  6. Fare clic su OK per salvare la condizione di filtro e tornare alla pagina Selezione tabelle e viste della procedura guidata. Nella colonna Dettagli filtro è ora contenuto un collegamento, cioè Filtri applicati. Fare clic sul collegamento per rivedere l'espressione di filtro creata dalla procedura guidata. La sintassi per ogni espressione di filtro dipende dal provider e non può essere modificata manualmente. Fare clic su OK per chiudere la finestra di dialogo Dettagli filtro.

  7. Scegliere Fine per importare i dati con i filtri applicati.

I filtri tramite cui viene ridotta la quantità di dati importati vengono applicati solo durante le operazioni di importazione. Non è possibile aggiungere filtri dopo aver già importato i dati e, successivamente, effettuare un aggiornamento per ottenere set di righe più piccoli.

I filtri tramite cui vengono controllati i dati visualizzati in Excel o in PowerPivot possono essere applicati facilmente in qualsiasi momento. Si noti che tramite l'applicazione di filtri in un set di dati esistente, non vengono modificati i dati contenuti nella cartella di lavoro, bensì solo quelli visualizzati. Pertanto, se le dimensioni del file sono un problema, filtrando i dati durante l'importazione è possibile ottenere una cartella di lavoro più piccola.

Per i feed di dati, è possibile modificare solo le colonne importate. Non è possibile filtrare le righe in base ai valori, a meno che l'origine del feed di dati non sia un report con parametri.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×