E (funzione E)

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Usare la funzione E, cioè una delle funzioni logiche, per determinare se tutte le condizioni in un test sono vere.

Esempio

Esempi della funzione E

La funzione E restituisce VERO se tutti gli argomenti restituiscono VERO e restituisce FALSO se uno o più argomenti restituiscono FALSO.

La funzione E viene usata comunemente per estendere la capacità di altre funzioni che eseguono test logici. Questa funzione ad esempio esegue un test logico e quindi restituisce un valore se il test restituisce VERO e un altro valore se il test restituisce FALSO. Usando la funzione E come argomento test della funzione SE, è possibile verificare molte condizioni diverse anziché una sola.

Sintassi

E(logico1, [logico2], ...)

Gli argomenti della sintassi della funzione E sono i seguenti:

Argomento

Descrizione

Logico1

Obbligatorio. Prima condizione da verificare che può restituire VERO o FALSO.

Logico2;...

Facoltativo. Altre condizioni che si desidera verificare che possono restituire vero o falso, fino a un massimo di 255 condizioni.

Osservazioni

  • Gli argomenti devono restituire valori logici, ad esempio VERO o FALSO, oppure devono essere matrici o riferimenti contenenti valori logici.

  • Se una matrice o un riferimento contiene testo o celle vuote, tali valori verranno ignorati.

  • Se l'intervallo specificato non contiene valori logici, la funzione e restituirà il #VALUE. #VALORE!.

Esempi

Ecco alcuni esempi generali dell'uso della funzione E da sola e in combinazione con la funzione SE.

Esempi d'uso delle funzioni SE con AND

Formula

Descrizione

=E(A2>1;A2<100)

Visualizza VERO se A2 è maggiore di 1 E minore di 100, altrimenti visualizza FALSO.

=SE(E(A2<A3;A2<100); A2; "Il valore non è compreso nell'intervallo.")

Visualizza il valore nella cella A2 se è minore di A3 E minore di 100, altrimenti visualizza il messaggio "Il valore non è compreso nell'intervallo".

=SE(E(A3>1;A3<100); A3; "Il valore non è compreso nell'intervallo")

Visualizza il valore nella cella A3 se è maggiore di 1 E minore di 100, altrimenti viene visualizzato un messaggio. È possibile sostituire qualsiasi messaggio a scelta.

Calcolo del bonus

Ecco uno scenario abbastanza comune in cui è necessario calcolare se gli agenti di vendita sono idonei a ricevere un bonus usando le funzioni SE ed E.

Esempio di calcolo del bonus di vendita con se e e funzioni.  La formula nella cella E14 è = se (e (B14> = $B $7, C14> = $B $5), B14 * $B $8,0)
  • =SE(E(B14>=$B$7;C14>=$B$5);B14*$B$8;0)SE le vendite totali sono maggiori di o uguali (>=) all'obiettivo di vendita, E gli account sono maggiori di o uguali (>=) all'obiettivo dell'account, moltiplicare le vendite totali per la percentuale del bonus, altrimenti restituire 0.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Argomenti correlati

Video: funzioni
se avanzateimparano a usare funzioni annidate in una formula
se
funzioneo
funzionenon
funzionePanoramica delle formule in Excel
come evitare che
le formule interrotte rilevino glierrori nelle formule
scelte rapide da tastiera in excel 2016 per
lescelte rapide da tastiera di excel 2016 per Mac
logico
funzioni di Excel (riferimento) funzioni di Excel(in ordine alfabetico)
funzionidi Excel (per categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×