Dividere un database di Access

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

È possibile dividere i database utilizzati in condivisione da più utenti in rete. La divisione di un database condiviso consente di migliorarne le prestazioni e di ridurre il rischio di danneggiamento del file del database.

Dopo avere diviso un database, è possibile spostare il database back-end o utilizzarne uno diverso. A questo scopo è possibile utilizzare Gestione tabelle collegate.

Note: 

  • La divisione di un database è un'operazione diversa dall'archiviazione, che esula dal contenuto di questo articolo. L'archiviazione dei dati consiste nello spostamento periodico dei record meno recenti in un altro database. L'operazione si rende necessaria perché le dimensioni del file di database raggiungono troppo rapidamente il limite consentito oppure quando si desidera avere un file di database di piccole dimensioni e organizzare i dati in modo preciso per periodo di tempo. In alcuni casi è possibile archiviare i dati dividendo un database. Per ulteriori informazioni, vedere l'articolo Archiviare i dati di Access disponibile online.

  • Se si divide un database Web, tutte le tabelle Web presenti in tale database non verranno spostate nel database back-end e risulteranno non raggiungibili dal database front-end risultante.

Contenuto dell'articolo

Panoramica

Prima di iniziare

Dividere il database

Distribuire il database front-end

Modificare il database back-end da utilizzare

Panoramica

Quando si divide un database, lo si riorganizza in due file, ovvero un database back-end, contenente le tabelle di dati, e un database front-end, contenente tutti gli altri oggetti del database, quali query, maschere e report. Ogni utente interagisce con i dati utilizzando una copia locale del database front-end.

Per dividere un database, si utilizza la Divisione guidata database. Dopo avere completato l'operazione, è necessario distribuire il database front-end agli utenti.

Attenzione:  Per proteggere i dati se il database ha più utenti finali, si consiglia di non condividere copie di un database che contiene collegamenti a elenchi di SharePoint. Se si collega a una tabella in cui è riportato un elenco SharePoint, viene creata una possibilità per qualsiasi utente non autorizzato di modificare la destinazione del collegamento ed eventualmente modificare le autorizzazioni nel sito di SharePoint come le informazioni di connessione per le tabelle collegate sono crittografate.

Vantaggi di un database diviso

Di seguito sono elencati i principali vantaggi di un database diviso:

  • Miglioramento delle prestazioni    Le prestazioni del database migliorano in genere in modo significativo, perché in rete vengono inviati solo i dati, a differenza di quanto accade in un comune database condiviso, per cui vengono inviati in rete anche gli oggetti stessi del database ovvero tabelle, query, maschere, report, macro e moduli.

  • Maggiore disponibilità    Poiché vengono inviati in rete solo i dati, le transazioni del database, ad esempio le modifiche dei record, vengono completate più rapidamente, il che consente una maggiore disponibilità dei dati per la modifica.

  • Sicurezza avanzata    Se si archiviazione il database back-end in un computer che utilizza del file system, è possibile utilizzare funzioni di protezione NTFS per proteggere i dati. Perché gli utenti accedono il database back-end tramite tabelle collegate, pertanto è meno probabile che intrusi riescano a ottenere accesso non autorizzato ai dati di furto del database front-end o così come un utente autorizzato. Se non si sa quale file system viene utilizzato il file server, chiedere all'amministratore di sistema. Se si dispone di privilegi di amministratore nel file server, è possibile eseguire il comando msinfo32 per determinare manualmente il file system.

    Come utilizzare msinfo32 per verificare il file system?

    1. Fare clic sul pulsante Start, quindi scegliere Esegui.

    2. Nella finestra di dialogo Esegui digitare msinfo32, quindi scegliere OK.

    3. In Risorse di sistema fare clic sul simbolo più accanto a Componenti.

    4. In Componenti fare clic sul simbolo più accanto ad Archiviazione, quindi su Unità. Nel pannello di destra della finestra di dialogo verranno visualizzate le informazioni sulle unità disponibili.

  • Maggiore affidabilità    Se un utente riscontra un problema e il database si chiude improvvisamente, eventuali danneggiamenti al file del database sono in genere limitati alla copia del database front-end aperta dall'utente. Poiché l'utente accede solo ai dati nel database back-end utilizzando le tabelle collegate, è molto meno probabile che il file del database back-end venga danneggiato.

  • Ambiente di sviluppo flessibile    Ogni utente, poiché utilizza una copia locale del database front-end, può sviluppare in modo indipendente query, maschere, report e altri oggetti di database senza che ciò influisca sugli altri utenti. Analogamente, è possibile sviluppare e distribuire una nuova versione del database front-end senza interrompere l'accesso ai dati archiviati nel database back-end.

Inizio pagina

Prima di iniziare

Prima di dividere un database, è utile tenere in considerazione quanto segue:

  • È consigliabile eseguire sempre il backup di un database prima di dividerlo. Se si divide un database e in seguito ci si rende conto che in realtà l'operazione non era da eseguire, sarà così possibile ripristinare l'originale dalla copia di backup.

  • La divisione di un database può richiedere molto tempo. È consigliabile informare gli utenti in modo che non utilizzino il database durante la divisione. Se un utente modifica i dati durante la divisione del database, le modifiche non verranno applicate al database back-end.

    Suggerimento: Se un utente modifica i dati durante la divisione del database, al termine sarà possibile importare i nuovi dati nel database back-end.

  • Sebbene la divisione di un database sia un modo per condividere i dati, chiunque utilizzi il database deve disporre di una versione di Microsoft Office Access compatibile con il formato di file del database back-end. Se, ad esempio, il file del database back-end utilizza il formato di file accdb, gli utenti non possono accedere ai dati utilizzando Access 2003.

  • È consigliabile usare un formato di file precedente per il database back-end se si utilizzano caratteristiche che non sono più supportati. Ad esempio, se si utilizzano pagine di accesso ai dati (protocolli DAP); è possibile continuare a usarli se il database back-end si trova in un formato di file precedente che supporta protocolli DAP. È quindi possibile utilizzare il nuovo formato di file con il database front-end in modo che gli utenti abbiano accesso ai vantaggi del nuovo formato. Si noti che non è possibile modificare dati in una pagina di accesso ai dati con Access 2010 o versione successiva.

Inizio pagina

Dividere il database

  1. Sul computer in uso creare una copia del database che si desidera dividere. Iniziare con il file del database sull'unità disco rigido locale, non sulla condivisione di rete. Se il file del database è al momento condiviso dall'unità disco rigido locale, non è necessario spostarlo.

  2. Aprire la copia del database che si trova sull'unità disco rigido locale.

  3. Nel gruppo Sposta dati della scheda Strumenti Database fare clic su Database di Access. Verrà avviata la Divisione guidata database.

  4. Fare clic su Dividi database.

  5. Nella finestra di dialogo Crea database esterno specificare un nome, un tipo di file e una posizione per il file del database back-end.

    Note: 

    • Si consiglia di utilizzare il nome suggerito da Access, che conserva il nome del file originale e indica che si tratta di un database back-end inserendo _be nel nome, appena prima dell'estensione di file.

    • Non modificare il tipo di file, a meno che alcuni utenti non utilizzino una versione precedente di Access per accedere ai dati.

    • È possibile immettere il percorso rete nella casella Nome file, davanti al nome del file. Se, ad esempio, il percorso di rete del database back-end è \\server1\condivisione1\ e il nome del file è DBPersonale_be.accdb, è possibile immettere \\server1\condivisione1\DBPersonale_be.accdb nella casella Nome file.

    • Il percorso scelto deve essere disponibile per chiunque utilizzerà il database. Poiché i mapping delle unità possono variare, è consigliabile specificare il percorso UNC invece di utilizzare la lettera di unità mappata.

  6. Al termine della procedura guidata, verrà visualizzato un messaggio di conferma.

Il database è stato diviso. Il database front-end corrisponde al file da cui si è iniziato (la copia del database condiviso originale) e il database back-end si trova nel percorso di rete specificato nel passaggio 5 di questa procedura.

Limitare le modifiche alla struttura del database front-end

Per limitare le modifiche al database front-end distribuito, è possibile salvarlo come file binario compilato (un file con estensione accde). Un file binario compilato è un file di applicazione di database salvato con tutto il codice VBA (Visual Basic Access) compilato. In un file binario compilato di Access non rimane codice sorgente VBA. Gli utenti non possono modificare la struttura degli oggetti in un file accde.

  1. Aprire il file del database front-end (accdb) che si desidera salvare come file binario compilato (con estensione accde).

  2. are clic su File > Salva con nome > Crea ACCDE > Salva con nome.

    Se si utilizza Access 2007, nella scheda Strumenti Database, nel gruppo Strumenti Database fare clic su Crea ACCDE.

  3. Nella finestra di dialogo Salva con nome passare alla cartella in cui si desidera salvare il file, digitare un nome per il file nella casella Nome File e quindi fare clic su Salva.

Inizio pagina

Distribuire il database front-end

Dopo avere diviso il database, si distribuisce il database front-end agli utenti, in modo che possano iniziare a utilizzarlo.

Attenzione:  Per proteggere i dati se il database ha più utenti finali, si consiglia di non condividere copie di un database che contiene collegamenti a elenchi di SharePoint. Se si collega a una tabella in cui è riportato un elenco SharePoint, viene creata una possibilità per qualsiasi utente non autorizzato di modificare la destinazione del collegamento ed eventualmente modificare le autorizzazioni nel sito di SharePoint come le informazioni di connessione per le tabelle collegate sono crittografate.

Eseguire una delle operazioni seguenti:

  • Inviare un messaggio di posta elettronica agli utenti del database e allegare il file del database front-end al messaggio. Includere eventuali istruzioni che possano aiutare gli utenti a iniziare a utilizzare immediatamente il database.

  • Salvare il file del database front-end in un percorso di rete a cui possano accedere tutti gli utenti del database, quindi inviare agli utenti un messaggio di posta elettronica in cui sono specificati il percorso di rete ed eventuali altre istruzioni che potrebbero risultare utili per accedere al database.

  • Distribuire il file del database front-end tramite supporti rimovibili, ad esempio un CD-ROM o un'unità memoria flash USB. Se si installa il file manualmente, è possibile verificarne il funzionamento. Se gli utenti devono installare il file, è consigliabile includere un documento che spieghi quali operazioni eseguire per installare il file e a chi rivolgersi in caso di difficoltà.

Inizio pagina

Modificare il database back-end da utilizzare

È possibile spostare il database back-end o utilizzarne uno diverso mediante Gestione tabelle collegate.

Se si desidera spostare il database back-end, crearne innanzitutto una copia nel nuovo percorso e quindi eseguire la procedura seguente.

  1. Nella scheda Dati esterni fare clic su Gestione tabelle collegate nel gruppo Importa e collega.

    Se si utilizza Access 2007, nella scheda Strumenti Database, nel gruppo Strumenti Database fare clic su Gestione tabelle collegate.

  2. In Gestione tabelle collegate selezionare le tabelle presenti nel database back-end corrente.

    Suggerimento: Se non sono stati collegati altri database, fare clic su Seleziona tutto.

  3. Selezionare la casella di controllo Richiedi sempre nuovo percorso e quindi fare clic su OK.

  4. Individuare e selezionare il nuovo database back-end.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×