Distribuire un'applicazione di Access

Access offre una piattaforma ricca di funzionalità per lo sviluppo di applicazioni di database. Un'applicazione di database è un programma per computer che offre sia un modo per archiviare e gestire dati che un'interfaccia utente che segue la logica delle attività aziendali (logica dell'applicazione).

Per distribuire le applicazioni di Access che possono essere eseguite senza un'installazione di Access nel computer di un utente, è possibile distribuirle insieme al runtime di Access, disponibile gratuitamente nell'Area download di Microsoft.com.

Questo articolo offre informazioni di base sulla pianificazione distribuzione, descrive le funzionalità di Access Runtime e spiega come scaricare il Runtime. Offre anche una panoramica della distribuzione delle applicazioni di database tramite Access.

Per saperne di più

Pianificare la distribuzione

Informazioni su Access Runtime

Scaricare Access Runtime

Distribuire un'applicazione Access

Pianificare la distribuzione

Prima di iniziare, è necessario porsi le domande seguenti relative alla modalità di distribuzione dell'applicazione.

I dati e la logica devono essere separati?

È possibile creare un'applicazione Access che combina la gestione dei dati e la logica dell'applicazione in un unico file. Si tratta della struttura predefinita dell'applicazione in Access. La combinazione di gestione dei dati e logica dell'applicazione in un unico file costituisce il metodo di distribuzione più semplice, ma questo metodo funziona meglio se l'applicazione viene usata da una sola persona alla volta e comporta un certo rischio. Un utente potrebbe, ad esempio, causare involontariamente la perdita di dati eliminando o danneggiando il file dell'applicazione.

Nella maggior parte dei casi è consigliabile separare la gestione dei dati e la logica dell'applicazione. Questo consente di migliorare:

  • Sicurezza    L'uso di un server per l'archiviazione dei dati consente di proteggere i dati.

  • Prestazioni    L'uso di un database diviso o di un server di database consente di ridurre il traffico di rete.

  • Personalizzazione    Le nuove azioni di macro per il riquadro di spostamento consentono di controllare gli utenti autorizzati a visualizzare i diversi contenuti. È possibile distribuire file della logica dell'applicazione diversi a utenti diversi.

Modi per separare dati e logica

Un modo per separare i dati e la logica consiste nell'usare il comando Database di Access, disponibile nel gruppo Sposta dati della scheda Strumenti database. Il comando Database di Access consente di dividere l'applicazione di database in due file di Access, uno per i dati e uno per la logica. Quando si usa il comando Database di Access, Access crea un file al cui nome viene aggiunto il suffisso "_be" (che indica "back-end"). Se ad esempio il nome originale del file di database è "Database1.accdb", Access crea un nome file di database denominato "Database1_be.accdb".

Un altro modo per separare gestione dei dati e logica dell'applicazione consiste nell'usare un programma di server di database, come Microsoft SQL Server, per la gestione dei dati e l'accesso alla logica dell'applicazione.

Per decidere se basta un singolo file di Access sia per la gestione dei dati che per la logica dell'applicazione, tenere presente quanto segue:

  • Integrità e sicurezza dei dati    Gli utenti di Access devono avere le autorizzazioni di lettura/scrittura per il file che contiene la logica dell'applicazione. Se si combinano dati e logica in un file, i dati vengono esposti agli stessi rischi della logica dell'applicazione.

    Un'applicazione Access che usa file di logica e di dati separati può offrire una maggiore integrità e sicurezza dei dati sfruttando le funzionalità di sicurezza di NTFS. Dal momento che gli utenti hanno bisogno di accesso esplicito in lettura/scrittura solo al file della logica dell'applicazione, è possibile rendere più sicuro il file di dati.

    L'applicazione può richiedere ulteriori opzioni di sicurezza, ad esempio la possibilità di controllare quali utenti hanno accesso a dati specifici. In questo caso è opportuno usare un prodotto server, ad esempio SQL Server o un sistema operativo Windows Server con Windows SharePoint Services per archiviare e gestire i dati dell'applicazione e usare Access per specificare la logica dell'applicazione.

  • Scalabilità    Un file di Access può avere una dimensione massima di 2 gigabyte (GB). Anche se 2 GB corrisponde a una notevole quantità di dati di testo, potrebbe risultare insufficiente per alcune applicazioni, in particolare per le applicazioni che archiviano allegati nei record di database. Se dati e logica sono separati, l'applicazione può gestire una maggiore quantità di dati. Se si prevede che gli utenti archivino un volume elevato di dati, è possibile usare più file di dati di Access.

    È opportuno anche rivedere le specifiche del programma Access per altre informazioni sulla scalabilità. Per altre informazioni sulle specifiche di Access, vedere l'articolo Specifiche di Access.

  • Capacità della rete    Se più utenti devono usare contemporaneamente l'applicazione in una rete, è più probabile che si verifichino danneggiamenti dei dati se i dati e la logica sono combinati in un unico file. Se, inoltre, si combinano dati e logica in un unico file di Access, non è possibile ottimizzare il traffico di rete generato da Access. Se più utenti usano contemporaneamente l'applicazione in una rete, è consigliabile separare i dati e la logica, usando due o più file di Access oppure usando un prodotto server di database per i dati e Access per la logica dell'applicazione.

Come sarà l'ambiente di rete?

Se gli utenti faranno tutti parte della stessa rete locale o se l'applicazione non viene usata in rete, un unico file dell'applicazione garantisce prestazioni ottimali nella maggior parte dei casi.

Le prestazioni di rete risulteranno migliori se dati e logica vengono separati. Se gli utenti non faranno parte della stessa rete locale, usare un server per archiviare e gestire i dati e usare Access per la logica dell'applicazione.

Access sarà disponibile per tutti gli utenti?

Se Access verrà installato nei computer di tutti gli utenti, questi possono aprire e usare l'applicazione come con un qualsiasi file di database di Access.

Se Access non sarà installato nei computer di alcuni o tutti gli utenti, sarà necessario distribuire il software Access Runtime a tali utenti durante la distribuzione dell'applicazione.

Inizio pagina

Informazioni su Access Runtime

Access Runtime è un programma ridistribuibile che consente agli utenti che non hanno installato Access nel computer di usare applicazioni di database di Access. Quando si apre un database di Access con Access Runtime, il database viene aperto in modalità di runtime.

Che cos'è la modalità di runtime?

La modalità di runtime è una modalità operativa di Access in cui alcune funzionalità di Access non sono disponibili per impostazione predefinita. È però possibile rendere disponibili alcune di queste funzionalità nella modalità di runtime.

Quali funzionalità non sono disponibili nella modalità di runtime?

Le funzionalità seguenti di Access non sono disponibili nella modalità di runtime:

  • Riquadro di spostamento    Il riquadro di spostamento non è disponibile nella modalità di runtime. In questo modo si impedisce agli utenti di accedere a oggetti arbitrari nell'applicazione di database. Durante l'uso della modalità di runtime è possibile aprire solo gli oggetti esposti agli utenti, ad esempio tramite una maschera del pannello comandi. Non è possibile rendere disponibile il riquadro di spostamento nella modalità di runtime.

  • Barra multifunzione    Per impostazione predefinita, la barra multifunzione non è disponibile nella modalità di runtime. In questo modo si impedisce agli utenti di creare o modificare oggetti di database e di eseguire altre azioni potenzialmente nocive, ad esempio la connessione a nuove origini dati o l'esportazione di dati in modi non previsti. È possibile creare una barra multifunzione personalizzata e quindi associarla a una maschera o a un report. Non è possibile esporre le schede predefinite della barra multifunzione nella modalità di runtime.

  • Visualizzazione Struttura e visualizzazione Layout    La visualizzazione Struttura e la visualizzazione Layout non sono disponibili per gli oggetti di database nella modalità di runtime. In questo modo si impedisce agli utenti di modificare la struttura di oggetti nell'applicazione di database. Non è possibile abilitare la visualizzazione Struttura o la visualizzazione Layout nella modalità di runtime.

  • Guida    Per impostazione predefinita, la Guida integrata non è disponibile nella modalità di runtime. Dal momento che si controllano le funzionalità disponibili nell'applicazione nella modalità di runtime, alcuni argomenti della Guida integrata standard di Access potrebbero essere irrilevanti per gli utenti dell'applicazione e potrebbero essere fonte di confusione o frustrazione. È possibile creare un file della Guida personalizzato per integrare l'applicazione nella modalità di runtime.

È possibile aprire un database di Access nella modalità di runtime senza usare il software Access Runtime?

È possibile eseguire nella modalità di runtime qualsiasi database di Access in un computer in cui è installata la versione completa di Access. Per eseguire un database di Access nella modalità di runtime, eseguire una delle operazioni seguenti:

  • Modificare l'estensione del file di database da accdb ad accdr.

  • Creare un collegamento al database e includere nel collegamento l'opzione della riga di comando /Runtime.

La modalità di runtime rende più sicuro il database?

Anche se la modalità di runtime limita la disponibilità delle funzionalità di spostamento e progettazione, è consigliabile non usare la modalità di runtime come strumento principale per proteggere un'applicazione di database. In un computer in cui è installata la versione completa di Access un utente può aprire un'applicazione di database di runtime come una normale applicazione di database (ovvero con tutte le funzionalità disponibili) e quindi modificare la struttura o eseguire altre azioni indesiderate.

Anche se si distribuisce l'applicazione di database solo in computer in cui non è installata la versione completa di Access, un utente può comunque trasferire l'applicazione in un computer in cui è installata la versione completa di Access e quindi aprire l'applicazione di database di runtime come una normale applicazione di database.

Nota: Se si vuole distribuire un'applicazione Access in modo che gli utenti non possano modificare la struttura di maschere, report o moduli di Microsoft Visual Basic, Applications Edition (VBA), provare a usare un file binario compilato con estensione accde. Per altre informazioni sull'uso di un file binario compilato, vedere la sezione Scegliere il formato di file da usare, più avanti in questo articolo.

Inizio pagina

Scaricare Access Runtime

Per scaricare Access Runtime dall'Area download Microsoft, fare clic sul collegamento appropriato per la versione usata:

Non è necessario effettuare alcun acquisto per scaricare, usare o ridistribuire Access Runtime. Non è inoltre previsto alcun limite al numero di utenti a cui distribuire Runtime.

Inizio pagina

Distribuire un'applicazione Access

Per distribuire un'applicazione Access, è necessario eseguire almeno le attività seguenti:

  1. Creare l'applicazione    L'applicazione deve prevedere un modo per consentire agli utenti di aprire e usare oggetti di database. Se l'applicazione non offre tali funzionalità, gli utenti dovranno installare Access nel computer per usare l'applicazione. Non sarà inoltre possibile prevedere in che modo gli utenti potranno spostarsi all'interno dell'applicazione e sarà più difficile fornire una documentazione completa dell'applicazione. Se inoltre gli utenti aprono l'applicazione usando il software Access Runtime, le funzionalità di spostamento predefinite di Access non saranno disponibili.

    Un approccio consiste nel creare una maschera che includa pulsanti di comando per aprire oggetti di database o eseguire altre azioni e quindi specificare tale maschera come maschera predefinita da aprire all'avvio dell'applicazione.

    Nota: Per la Guida relativa alla creazione di una maschera, vedere l'argomento Creare una maschera usando lo strumento Maschera.

    Come si specifica la maschera predefinita da aprire?

    1. Fare clic su File > Opzioni. Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Opzioni di Access.

    2. Nel riquadro sinistro della finestra di dialogo Opzioni di Access fare clic su Database corrente.

    3. In Opzioni applicazione nel riquadro destro selezionare la maschera predefinita nella casella combinata Visualizza maschera.

    È anche possibile creare una barra multifunzione personalizzata e quindi associarla a una maschera che viene aperta all'avvio dell'applicazione. Per altre informazioni sulla creazione di una barra multifunzione personalizzata, vedere l'articolo Creare una barra multifunzione personalizzata in Access.

  2. Installare l'applicazione    Esistono diverse opzioni e considerazioni da fare per l'installazione di un'applicazione. Si può scegliere di distribuire un formato di file specifico per controllare meglio la modalità di utilizzo dell'applicazione da parte degli utenti. In alternativa, si può creare il pacchetto dell'applicazione per semplificare l'installazione oppure distribuire separatamente i componenti dei dati e della logica.

    Per altre informazioni su queste opzioni e considerazioni, vedere le sezioni seguenti.

Scegliere il formato di file da usare

Quando si distribuisce un'applicazione, è possibile usare quattro formati di file Access:

  • accdb    Si tratta del formato di file predefinito per Access. Quando si distribuisce un'applicazione in questo formato, gli utenti hanno a disposizione la maggior parte delle opzioni per personalizzare ed esplorare l'applicazione nel modo che preferiscono. Per evitare che gli utenti modifichino la struttura dell'applicazione, è opportuno usare il formato di file con estensione accde. Un utente non può inoltre determinare facilmente se un file con estensione accdb è stato modificato dopo la creazione del pacchetto. Per renderlo evidente, usare il formato di file con estensione accdc.

  • accdc    Questo formato è noto anche come file di distribuzione di Access. Un file di distribuzione di Access include un file dell'applicazione e una firma digitale associata a tale file. Questo formato di file assicura agli utenti che nessuno ha modificato il file dell'applicazione dopo la creazione del pacchetto. È possibile applicare questo formato a un file di formato predefinito Access (con estensione accdb) o a un file binario compilato di Access (con estensione accde).

    In un file di distribuzione di Access è possibile inserire un solo file di applicazione. Se l'applicazione contiene file di dati e di logica separati, è possibile creare un pacchetto per ognuno di essi.

  • accde    Questo formato è noto anche come file binario compilato. In Access un file binario compilato è un file dell'applicazione di database che è stato salvato con tutto il codice VBA compilato. Il codice sorgente VBA non rimane in un file binario compilato di Access.

    È possibile usare Access per aprire un file binario compilato di Access. Per impostazione predefinita, però, Runtime non riconosce l'estensione del nome file accde. Per aprire un file binario compilato con Access Runtime, creare un collegamento che punti a Runtime e includere il percorso del file binario compilato che deve essere aperto dal collegamento.

    Importante: Se gli utenti aprono un file binario compilato con una versione precedente di Access rispetto a quella in cui è stato compilato, il file non sarà accessibile. Per risolvere il problema, è necessario compilare il file binario nella versione di Access in cui è stato installato dagli utenti.

    Come si salva un file di Access come file binario compilato?

    1. In Access aprire il database (file con estensione accdb) che si vuole salvare come file binario compilato (con estensione accde).

    2. Fare clic sulla scheda File e quindi su Salva con nome.

    3. In Tipi di file di database fare clic su Crea ACCDE e quindi fare clic su Salva con nome.

    4. Nella finestra di dialogo Salva con nome selezionare la cartella in cui si vuole salvare il file, digitare un nome nella casella Nome file e quindi fare clic su Salva.

    Nota: Se si usa Access 2007, nel gruppo on the Strumenti database della scheda Strumenti database fare clic su Crea ACCDE.

  • accdr    Questo formato consente di distribuire un'applicazione che viene aperta nella modalità di runtime. La distribuzione di un'applicazione di runtime permette di controllare la modalità di utilizzo dell'applicazione, anche se non è uno strumento valido per proteggerla. Per altre informazioni sulla modalità di runtime, vedere la sezione Informazioni su Access Runtime.

Creare il pacchetto e firmare un database di Access

In Access è possibile firmare e distribuire un database in modo più semplice e rapido rispetto alle versioni precedenti. Dopo avere creato un file con estensione accdb o accde, è possibile creare un pacchetto del file, applicare una firma digitale al pacchetto e quindi distribuire il pacchetto firmato ad altri utenti. Grazie alla funzionalità Crea pacchetto e apponi firma il database viene inserito in un file di distribuzione di Access (con estensione accdc), il pacchetto viene firmato e quindi inserito in un percorso nel computer dell'utente specificato dall'utente stesso. Gli utenti hanno quindi la possibilità di estrarre il database dal pacchetto e di lavorare direttamente nel database e non nel file del pacchetto.

Nota: La funzionalità descritta in questa sezione consente di creare il pacchetto di un file Access e di applicare una firma digitale al pacchetto per indicare agli utenti che il file è attendibile.

Quando si passa alla creazione e alla firma di un pacchetto, tenere presente quanto segue:

  • La creazione di un pacchetto del database e la firma del pacchetto sono operazioni che contribuiscono all'attendibilità. Quando si riceve il pacchetto, la firma garantisce che il database non è stato alterato. Se si considera attendibile l'autore, è possibile abilitare il contenuto.

  • La funzionalità Crea pacchetto e apponi firma si applica solo ai database salvati nel formato di file accdb. In Access sono disponibili strumenti di versioni precedenti di Microsoft Office che è possibile usare per firmare e distribuire database creati in un formato di file mdb precedente. Non è possibile usare gli strumenti di versioni precedenti di Office per firmare e distribuire file creati nei formati di file accdb più recenti.

  • È possibile aggiungere un solo file di database a un pacchetto.

  • Quando si crea il pacchetto e si firma un database, viene firmato il codice di tutti gli oggetti presenti nel file di database, non solo delle macro o dei moduli di codice. Il processo di creazione del pacchetto e di firma include anche la compressione del file di pacchetto per ridurre i tempi di download.

  • È possibile estrarre i database dai file di pacchetto posizionati in server SharePoint.

Le sezioni seguenti descrivono come creare un file di pacchetto firmato e usare il database in un file di pacchetto firmato.

Nota: Per completare questa procedura, deve essere disponibile almeno un certificato di sicurezza. Se nel computer non è installato alcun certificato, è possibile crearne uno con lo strumento SelfCert. Per informazioni sulla creazione di un certificato di sicurezza privato, vedere l'articolo Dimostrare l'attendibilità mediante l'aggiunta di una firma digitale.

Creare un pacchetto firmato

  1. Aprire il database di cui si vuole creare il pacchetto firmato.

  2. Fare clic sulla scheda File e quindi su Salva con nome.

  3. In Tipi di file di database fare clic su Crea pacchetto e apponi firma e quindi fare clic su Salva con nome.

    Nota: Se si usa Access 2007, fare clic sul pulsante Microsoft Office, fare clic su Pubblica e quindi su Crea pacchetto e apponi firma.

  4. Nella finestra di dialogo Seleziona certificato selezionare un certificato digitale e quindi fare clic su OK.

    Viene visualizzata la finestra di dialogo Crea pacchetto firmato di Microsoft Office Access.

  5. Nell'elenco Salva in selezionare una posizione per il pacchetto di database firmato.

  6. Immettere un nome per il pacchetto firmato nella casella Nome file e quindi fare clic su Crea.

    Il file con estensione accdc verrà creato da Access e inserito nel percorso scelto.

Estrarre e usare un pacchetto firmato

  1. Fare clic su File > Apri.

    Nota: Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Apri.

  2. Nella finestra di dialogo Apri selezionare Pacchetti firmati di Microsoft Office Access (*.accdc) come tipo di file.

  3. Nell'elenco Cerca in individuare la cartella contenente il file con estensione accdc, selezionare il file e quindi scegliere Apri.

  4. Eseguire una delle operazioni seguenti:

    • Se si sceglie di considerare attendibile il certificato digitale applicato al pacchetto di distribuzione, verrà visualizzata la finestra di dialogo Estrai database in. Procedere con il passaggio 5.

    • Se non si è scelto di considerare attendibile il certificato digitale, verrà visualizzato un messaggio di avviso.

      1. Messaggio di avviso

      2. Se si considera attendibile il database, fare clic su Apri. Se si considera attendibile qualsiasi certificato del provider, fare clic su Considera attendibile tutto quello che proviene da questo autore. Viene visualizzata la finestra di dialogo Estrai database in.

  5. Nell'elenco Salva in è possibile selezionare una posizione per il database estratto, quindi nella casella Nome file immettere un nome diverso per il database estratto.

Se non si è sicuri se considerare attendibile o meno un certificato, vedere l'articolo Verifica dell'attendibilità di una firma digitale in cui vengono fornite informazioni generali sulla verifica delle date e degli altri elementi di un certificato per garantirne la validità.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×