Tabelle pivot

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Una tabella pivot è un efficace strumento di calcolo, riepilogo e analisi dei dati che consente di visualizzare confronti, schemi e tendenze nei dati.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Creare una tabella pivot

  1. Selezionare le celle con cui creare una tabella pivot.

    Nota: I dati non devono contenere righe o colonne vuote. Le intestazioni di colonna devono occupare una sola riga.

  2. Selezionare Inserisci > Tabella pivot.

    Tabella pivot

  3. In Specificare i dati da analizzare selezionare Seleziona tabella o intervallo.

    Tabella pivot

  4. In Tabella/Intervallo verificare l'intervallo di celle.

  5. In Specificare dove collocare il rapporto di tabella pivot selezionare Nuovo foglio di lavoro per inserire la tabella pivot in un nuovo foglio di lavoro oppure selezionare Foglio di lavoro esistente e quindi specificare la posizione in cui si vuole visualizzare la tabella pivot.

  6. Scegliere OK.

Strutturare la tabella pivot

  1. Per aggiungere un campo alla tabella pivot, selezionare la casella di controllo relativa al nome del campo nel riquadro Campi tabella pivot.

    Nota: I campi selezionati vengono aggiunti nelle rispettivi aree predefinite: i campi non numerici vengono aggiunti all'area Righe, le gerarchie di date e ore all'area Colonne e i campi numerici all'area Valori.

    Tabella pivot

  2. Per spostare un campo da un'area a un'altra, trascinare il campo nell'area di destinazione.

Prima di iniziare:

  • I dati devono essere organizzati in formato tabulare e non devono esserci righe o colonne vuote. Idealmente, è possibile usare una tabella di Excel come nell'esempio precedente.

  • Le tabelle costituiscono un'origine dati eccellente per le tabelle pivot, perché le righe aggiunte a una tabella vengono automaticamente incluse nella tabella pivot quando si aggiornano i dati e le nuove colonne vengono incluse nell'elenco Campi tabella pivot. In caso contrario, sarebbe necessario aggiornare manualmente l'intervallo dell'origine dati o usare una formula di intervallo denominato dinamico.

  • I tipi di dati nelle colonne devono corrispondere. Ad esempio, non si devono combinare date e testo nella stessa colonna.

  • Le tabelle pivot usano uno snapshot dei dati, detto cache, quindi i dati effettivi non vengono modificati in alcun modo.

Creare una tabella pivot

Se non si ha molta esperienza nella creazione di tabelle pivot o non si sa esattamente come iniziare, è preferibile usare una delle Tabelle pivot consigliate. Quando si usa questa funzionalità, Excel determina un layout significativo stabilendo una corrispondenza tra i dati e le aree appropriate nella tabella pivot. La tabella così ottenuta costituisce una base di partenza per sperimentare le varie disposizioni possibili. Dopo aver creato una tabella pivot consigliata, è possibile esaminare le diverse possibilità di orientamento e ridisporre i campi per ottenere risultati specifici.

È anche possibile scaricare l'esercitazione interattiva Creare la prima tabella pivot.

Tabelle pivot consigliate

Creare manualmente una tabella pivot

  1. Fare clic su una cella nei dati di origine o nell'intervallo della tabella.

  2. Selezionare Inserisci > Tabelle pivot consigliate.

    Passare a Inserisci > Tabelle pivot consigliate per fare in modo che Excel crei una tabella pivot

  3. Excel analizza i dati e fornisce diverse opzioni, come in questo esempio che usa i dati delle spese domestiche.

    Finestra di dialogo Tabelle pivot consigliate di Excel
  4. Selezionare la tabella pivot preferita e premere OK. Excel creerà una tabella pivot in un nuovo foglio e visualizzerà l'elenco Campi tabella pivot.

  1. Fare clic su una cella nei dati di origine o nell'intervallo della tabella.

  2. Selezionare Inserisci > Tabella pivot.

    Se si usa Excel per Mac 2011 e versioni precedenti, il pulsante Tabella pivot si trova nel gruppo Analisi della scheda Dati.

    scheda dati, gruppo analisi

  3. Excel visualizzerà la finestra di dialogo Crea tabella pivot con il nome di tabella o l'intervallo selezionato. In questo caso viene usata una tabella denominata "tbl_HouseholdExpenses".

  4. Nella sezione Specificare dove collocare il rapporto di tabella pivot selezionare Nuovo foglio di lavoro o Foglio di lavoro esistente. Per Foglio di lavoro esistente selezionare la cella in cui inserire la tabella pivot.

  5. Fare clic su OK. Excel creerà una tabella pivot vuota e visualizzerà l'elenco Campi tabella pivot.

Nell'area Nome campo nella parte superiore selezionare la casella di controllo di ogni campo da aggiungere a una tabella pivot. Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Riga, i campi di data e ora vengono aggiunti all'area Colonna e i campi numerici vengono aggiunti all'area Valori. È anche possibile trascinare manualmente gli elementi disponibili e rilasciarli in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più avere un elemento in una tabella pivot, è sufficiente trascinarlo fuori dall'elenco dei campi o deselezionarlo. La possibilità di ridisporre gli elementi campo è una delle caratteristiche delle tabelle pivot grazie a cui è possibile cambiare l'aspetto in modo estremamente rapido.

Elenco Campi tabella pivot

Campi corrispondenti in una tabella pivot

Esempio di finestra di dialogo con l'elenco Campi tabella pivot di Excel



Esempio di tabella pivot e della modalità di correlazione tra i campi nell'elenco campi.

  • Riepiloga per

    Per impostazione predefinita, i campi di tabella pivot presenti nell'area Valori verranno visualizzati come SOMMA. Se Excel interpreta i dati come testo, verranno visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori. È possibile modificare il calcolo predefinito facendo clic sulla freccia a destra del nome del campo e quindi selezionando Impostazioni campo.

    Modificare quindi il calcolo nella sezione Riepiloga per. Si noti che quando si modifica il metodo di calcolo, Excel lo aggiunge automaticamente nella sezione Nome personalizzato, ad esempio "Somma di NomeCampo". È comunque possibile modificare questo nome. Se si fa clic sul pulsante Numero, è possibile modificare il formato numerico dell'intero campo.

    Suggerimento: Poiché modificando il calcolo nella sezione Riepiloga per si modifica il nome del campo della tabella pivot, è preferibile non rinominare i campi della tabella pivot fino a quando non è stata completata la configurazione della tabella pivot. Un possibile metodo consiste nell'usare il comando Sostituisci (nel menu Modifica) > Trova > "Somma di", quindi Sostituisci con > lasciare vuoto per sostituire tutti gli elementi contemporaneamente invece di dover digitare di nuovo.

  • Mostra dati

    Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

    Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

    Dopo aver aperto la finestra di dialogo Impostazioni campo, è possibile effettuare le selezioni desiderate nella scheda Mostra dati.

  • Visualizzare un valore sia come calcolo che come percentuale.

    Trascinare semplicemente l'elemento nella sezione Valori due volte, fare clic con il pulsante destro del mouse sul valori e scegliere Impostazioni campo, quindi impostare le opzioni Riepiloga per e Mostra dati per ogni elemento.

Se si aggiungono nuovi dati all'origine dati della tabella pivot, tutte le tabelle pivot basate su tale origine dovranno essere aggiornate. Per aggiornare una sola tabella pivot, è possibile fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intervallo di tabella pivot e quindi scegliere Aggiorna. Se ci sono più tabelle pivot, selezionare prima di tutto una cella in una tabella pivot e quindi sulla barra multifunzione selezionare la scheda Analizza, fare clic sulla freccia sotto il pulsante Aggiorna e selezionare Aggiorna tutti.

Se dopo aver creato una tabella pivot si decide che non è più necessaria, è sufficiente selezionare l'intero intervallo della tabella pivot e premere CANC. L'operazione non avrà alcun effetto su altri dati né su altri grafici o tabelle pivot. Se la tabella pivot si trova in un altro foglio che non contiene altri dati da conservare, è possibile rimuovere rapidamente la tabella pivot eliminando tale foglio.

Ora è possibile inserire una tabella pivot in un foglio di calcolo in Excel Online.

Importante: Non è consigliabile creare o modificare una tabella pivot in un foglio di calcolo a cui stanno lavorando contemporaneamente anche altri utenti.

  1. Selezionare la tabella o l'intervallo nel foglio di calcolo.

  2. Selezionare Inserisci > Tabella pivot.

  3. Excel visualizzerà la finestra di dialogo Crea tabella pivot con il nome di tabella o l'intervallo selezionato.

    Crea tabella pivot
  4. Nella sezione Specificare dove collocare il rapporto di tabella pivot selezionare Nuovo foglio di lavoro o Foglio di lavoro esistente. Per Foglio di lavoro esistente selezionare la cella in cui inserire la tabella pivot.

    Nota: La cella a cui si fa riferimento deve essere esterna alla tabella o all'intervallo.

  5. Fare clic su OK. Excel creerà una tabella pivot vuota e visualizzerà l'elenco Campi tabella pivot.

Nell'area Campi tabella pivot in alto selezionare la casella di controllo di ogni campo da aggiungere alla tabella pivot. Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Righe, i campi di data e ora vengono aggiunti all'area Colonne e i campi numerici vengono aggiunti all'area Valori. È anche possibile trascinare manualmente gli elementi disponibili e rilasciarli in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più avere un elemento in una tabella pivot, è sufficiente trascinarlo fuori dall'elenco dei campi o deselezionarlo. La possibilità di ridisporre gli elementi campo è una delle funzionalità delle tabelle pivot grazie a cui è possibile cambiare l'aspetto in modo estremamente rapido.

Elenco Campi tabella pivot

Campi corrispondenti in una tabella pivot

Esempio di finestra di dialogo con l'elenco Campi tabella pivot di Excel



Esempio di tabella pivot e della modalità di correlazione tra i campi nell'elenco campi.

  • Riepiloga valori per

    Per impostazione predefinita, i campi di tabella pivot presenti nell'area Valori verranno visualizzati come SOMMA. Se Excel interpreta i dati come testo, verranno visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori. È possibile modificare il calcolo predefinito facendo innanzitutto clic sulla freccia a destra del nome del campo e quindi scegliendo Impostazioni campo valore.

    Finestra di dialogo Impostazioni campo valore di Excel

    Modificare quindi il calcolo nella sezione Riepiloga valori per. Si noti che quando si modifica il metodo di calcolo, Excel lo aggiunge automaticamente nella sezione Nome personalizzato, ad esempio "Somma di NomeCampo". È comunque possibile modificare questo nome. Se si fa clic sul pulsante Formato numeri, è possibile modificare il formato dei numeri per l'intero campo.

    Finestra di dialogo Impostazioni campo valore di Excel con le opzioni Riepiloga valori per

    Suggerimento: Poiché modificando il calcolo nella sezione Riepiloga valori per si modifica il nome del campo della tabella pivot, è preferibile non rinominare i campi della tabella pivot fino a quando non è stata completata la configurazione della tabella pivot. Un possibile metodo consiste nell'usare Trova e sostituisci (CTRL+H) > Trova > "Somma di", quindi Sostituisci con > lasciare vuoto per sostituire tutti gli elementi contemporaneamente invece di dover digitare di nuovo.

  • Mostra valori come

    Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

    Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

    Dopo aver aperto la finestra di dialogo Impostazioni campo valore, è possibile effettuare le selezioni desiderate nella scheda Mostra valori come.

    Finestra di dialogo Impostazioni campo valore > Mostra valori come, per una tabella pivot
  • Visualizzare un valore sia come calcolo che come percentuale.

    Trascinare semplicemente l'elemento nella sezione Valori due volte e quindi impostare le opzioni Riepiloga valori per e Mostra valori come per ogni elemento.

Se si aggiungono nuovi dati all'origine dati della tabella pivot, sarà necessario aggiornare tutte le tabelle pivot basate su tale origine dati. Per aggiornare la tabella pivot, è possibile fare clic con il pulsante destro del mouse all'interno dell'intervallo della tabella pivot e scegliere Aggiorna.

Aggiorna tabella pivot

Se dopo aver creato una tabella pivot si decide che non è più necessaria, è sufficiente selezionare l'intero intervallo della tabella pivot e premere CANC. L'operazione non avrà alcun effetto su altri dati né su altri grafici o tabelle pivot. Se la tabella pivot si trova in un altro foglio che non contiene altri dati da conservare, è possibile rimuovere rapidamente la tabella pivot eliminando tale foglio.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Creare un grafico pivot

Filtri dei dati di utilizzo per filtrare i dati di tabella pivot

Creare una sequenza temporale di tabella pivot per filtrare date

Creare una tabella pivot con il modello di dati da analizzare i dati in più tabelle

Usare l'elenco campi per disporre i campi in una tabella pivot

Modificare i dati di origine di una tabella pivot

Calcolare i valori in una tabella pivot

Eliminare una tabella pivot

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×