Creare una soluzione di registro delle risorse con InfoPath ed Excel

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Microsoft Office InfoPath consente di creare modelli di modulo per l'immissione dei dati e raccolta. Microsoft Office Excel 2007 consente agli utenti di calcolare il numero, grafico e analizzare i dati. Utilizzando sia di questi programmi e XML, è possibile creare con facilità una semplice ma soluzione aziendale efficace, senza codice per la registrazione dei beni dell'azienda.

Panoramica della soluzione di inventario beni mobili

In questo articolo

Introduzione alla creazione di una soluzione di registro delle risorse

Passaggio 1: Personalizzare il modello di modulo Registro delle risorse

Passaggio 2: Eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel

Passaggio 3: Creare un rapporto di tabella pivot e grafico pivot

Passaggio 4: Raccogliere le informazioni sui beni dagli utenti

Passaggio 5: Importare i moduli in Excel

Considerazioni finali: si consiglia di utilizzare un elenco di SharePoint o di un database di Access

Introduzione alla creazione di una soluzione di registro delle risorse

È possibile scambiare dati XML tra InfoPath e in Excel. Anche se il comando Infopath esportare un semplice, semplice modo inviare dati del modulo in Excel, non esiste un altro approccio, è possibile eseguire, che offre maggiore flessibilità. Mapping esplicito il file di schema XML di InfoPath (con estensione XSD) in Excel e quindi l'importazione di file del modulo di InfoPath (con estensione XML) in Excel, è possibile personalizzare il layout dei dati e meglio sfruttare le caratteristiche di Excel che consentono di gestire e analizzare i dati in modo più efficiente.

In questo articolo verrà usata il modello di modulo di esempio registro delle risorse di InfoPath per illustrare come è possibile apportare InfoPath, XML ed Excel collaborare. Si supponga che ogni anno, l'organizzazione inventario beni in ogni ufficio di un dipendente. Eseguita quindi un report di Excel per capire come allocare il budget di apparecchiature per l'anno successivo. Nel diagramma seguente viene fornita una panoramica di come è possibile raccogliere, tenere traccia e registrare i dati di risorse del reparto.

Grafico a barre

1. il modello di modulo Registro delle risorse viene creato.

2. il file di schema sia associato a una tabella di Excel e il layout di tabella è personalizzato.

3. un report di riepilogo e tabella pivot vuoto viene creato.

4. il modulo Registro delle risorse viene utilizzato per raccogliere dati dagli utenti.

5. nella tabella di Excel vengono esportati tutti i dati di moduli e i rapporti di tabella pivot e grafico pivot vengono aggiornati.

Questa soluzione prevede i prodotti e i ruoli utente seguenti:

Icona Supporto completo = necessari Icona Nessun supporto = non necessari

Requisiti software

Ruoli

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Soluzione Designer

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Apparenza

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Dipendenti

Icona Supporto completo

Icona Supporto completo

Icona Nessun supporto

Torna all'inizio

Passaggio 1: Personalizzare il modello di modulo Registro delle risorse

Modello di modulo Registro delle risorse, sono disponibili in InfoPath, consente di raccogliere informazioni sulle singole risorse di office di un dipendente, il reparto a cui appartiene il dipendente, tipologie di attività e i dettagli di ogni risorsa. In questa soluzione, una finestra di progettazione di moduli invia il modello di modulo all'account di posta elettronica del maker decisione tramite Office Outlook 2007.

Modello per inventario beni

Attività 1: Aprire e personalizzare il modello di modulo Registro delle risorse

Poiché si non è possibile pubblicare un modello di modulo a un elenco di destinatari se dispone di un controllo casella di testo RTF contenente immagini collegate, è necessario apportare una piccola modifica al modulo del modello di esempio registro delle risorse.

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. Nella finestra di dialogo Progetta modello di modulo, aprire un modello di modulo, fare clic su Personalizza un campione.

  3. Nella finestra di dialogo Guida introduttiva fare clic su campione - Registro delle risorse e quindi nell'elenco Attività modulo, fare clic su Progetta modulo.

  4. Fare clic con il pulsante destro del controllo assetNotes, scegliere proprietà Casella di testo RTF, fare clic sulla scheda visualizzazione e quindi nel gruppo formattazione disponibile, deselezionare la casella di controllo Immagini collegate.

Attività 2: Definire le opzioni di invio

L'attività successiva consiste nel definire le opzioni di invio in modo che i dipendenti possono inviare un file in modo univoco denominato modulo (con estensione XML) all'account di posta elettronica del maker decisione come file allegato.

  1. Dal menu Strumenti fare clic su Opzioni invio.

  2. Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati del modulo a una singola destinazione e quindi nell'elenco fare clic su posta elettronica.

  4. Fare clic su Aggiungi.

    Verrà visualizzata la Connessione guidata dati.

  5. Nella casella a digitare l'alias del apparenza che riceverà tutti i moduli inviati.

  6. Per specificare l'oggetto univoco nella casella oggetto:

    • Fare clic su Inserisci Formula Icona del pulsante .

    • Digitare la formula seguente:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Fare clic su Verifica Formula e quindi fare clic su OK due volte.

  • Nella finestra di Introduzione, digitare un messaggio appropriato o aggiungere istruzioni importanti per questa soluzione.

  • Fare clic su Avanti.

  • Nella pagina successiva della procedura guidata, fare clic su Invia i dati del modulo come allegato e quindi selezionare la casella di controllo Connetti il modello di modulo per garantire che gli utenti possono aprire la maschera.

    In questo modo che i dipendenti hanno accesso al file di modello di modulo (con estensione xsn), nel caso in cui non è possibile accedervi dal relativo percorso di rete.

  • Per specificare un nome di file univoco per ogni file di modulo (con estensione XML) nella casella Nome dell'allegato:

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Digitare la stessa formula come quello indicato sulla riga dell'oggetto:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Fare clic su Verifica Formula e quindi fare clic su OK due volte.

  • Fare clic su Avanti.

  • Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  • Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

  • Salvare la maschera è in una cartella di rete pubblico accessibile all'apparenza e a tutti i dipendenti.

Torna all'inizio

Passaggio 2: Eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel

Configurare la connessione tra InfoPath ed Excel è necessario tre attività: l'estrazione di file di schema per il modello di modulo Registro delle risorse, il mapping di questo file di schema in Excel e personalizzare il layout predefinito della tabella di Excel che contiene tutti i file XML importato file di dati di modulo.

Attività 1: Estrarre il file di schema da InfoPath

  1. In InfoPath, aprire il file del modello modulo Registro delle risorse.

  2. Dal menu Strumenti fare clic su Progetta modulo.

  3. Nel menu File fare clic su Salva come file di origine.

  4. Nella finestra di dialogo Sfoglia per cartelle selezionare una cartella o creare una nuova cartella in cui si vuole archiviare il file di schema.

Prendere nota del percorso della cartella in cui vengono salvati tutti i file di origine e il nome del file di schema, in questo caso, myschema.xsd, che contiene la definizione dello schema del modulo dati XML.

Attività 2: Eseguire il mapping il file di schema InfoPath in Excel

  1. Creare un nuovo file di Excel e quindi salvarla in un percorso accessibile all'apparenza.

  2. In Excel, se la scheda sviluppo non è visibile, eseguire le operazioni seguenti:

    1. Fare clic sul pulsante Microsoft Office Pulsante Microsoft Office e quindi su Opzioni di Excel.

    2. Nella categoria Impostazioni generali, in Opzioni principali per l'utilizzo di Excel, selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione, quindi scegliere OK.

      Nota: La barra multifunzione è un componente dell'interfaccia utente Microsoft Office Fluent.

  3. Nel gruppo XML della scheda Sviluppo fare clic su Origine.

    Gruppo XML sulla barra multifunzione

    Viene visualizzato il riquadro attività Origine XML.

  4. Fare clic su Mapping XML e quindi fare clic su Aggiungi nella finestra di dialogo Mapping XML.

  5. In un computer che esegue Windows Vista   

    1. Sulla barra degli indirizzi, fare clic su unità o alla cartella che contiene il file myschema.xsd creato nel passaggio 2 della sezione attività 1: estrarre il file di schema da InfoPath.

      In un computer che esegue Microsoft Windows XP   

    2. Nell'elenco Cerca in fare clic su unità o alla cartella che contiene il file myschema.xsd creato nel passaggio 2 della sezione attività 1: estrarre il file di schema da InfoPath.

  6. Fare clic sul file e quindi su Apri.

  7. Quando viene visualizzata la finestra di dialogo Più radici, fare clic sul nodo principale assetTracking definite nel file myschema.xsd e quindi fare clic su OK.

    Il mapping XML verrà visualizzato nel riquadro attività Origine XML.

  8. Trascinare l'elemento nodo ns1:asset, ossia un elemento XML ripetuto, la posizione del foglio di lavoro in cui si desidera inserire la tabella di Excel.

    Mapping del file di schema InfoPath in Excel

Attività 3: Personalizzare il layout della tabella di Excel

Per impostazione predefinita, Excel utilizza nomi degli elementi XML come intestazioni di colonna per la tabella. Tuttavia, è possibile modificare le intestazioni di colonna modificando le celle di intestazione di colonna.

  1. Per modificare le intestazioni di colonna predefinito, mantenere la tabella di Excel selezionata, individuare il seguente prefisso di stringa, ns1:asset e rimuoverla. Ad esempio, cambiare ns1:assetID a ID.

    Personalizzazione delle intestazioni di tabella in Excel

  2. Per regolare la larghezza della colonna, fare clic sul pulsante Seleziona tutto e quindi fare doppio clic sul bordo di intestazione della colonna.

Torna all'inizio

Passaggio 3: Creare un rapporto di tabella pivot e grafico pivot

Responsabili utilizzano tabella pivot e grafico pivot per analizzare, esplorare e visualizzare dati di riepilogo. Installando e configurando i rapporti di tabella pivot e grafico pivot che si desidera utilizzare in questo scenario anticipo, sarà un'operazione semplice per apparenza eseguire il report con i dati completati in un secondo momento.

  1. Selezionare una cella nella tabella di Excel.

  2. Nel gruppo tabelle della scheda Inserisci fare clic su tabella pivot e quindi fare clic su tabella pivot.

    Immagine della barra multifunzione di Excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

  3. Per inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1, fare clic su Nuovo foglio di lavoro e quindi fare clic su OK.

    Excel aggiunge un rapporto di tabella pivot vuoto nella posizione specificata e visualizza l'Elenco dei campi di tabella pivot in modo che è possibile aggiungere campi, creare un layout e personalizzare il rapporto di tabella pivot.

  4. Per creare un report tabulare con tra i dati, trascinare il campo ID nell'area valori, il campo reparto all'area etichette di colonna, il campo categoria all'area etichette di riga e il campo AssegnatoA nell'area filtro rapporto.

  5. Fare clic sul rapporto di tabella pivot.

  6. Nel gruppo grafici della scheda Inserisci fare clic sul tipo di grafico a barre.

    immagine della barra multifunzione di excel

  7. In barre 2D, selezionare Barre raggruppate.

  8. Regolare le dimensioni e posizione del rapporto di grafico pivot secondo le proprie preferenze.

Rapporti di tabella pivot e grafico pivot vuoti

Torna all'inizio

Passaggio 4: Raccogliere le informazioni sui beni dagli utenti

Ora, che il modello di modulo è pronto per essere compilati dagli tutti i dipendenti, è necessario pubblicare il modulo e inviare a ogni dipendente. Quando tutti i dipendenti invia il modulo completato, viene inviato come file di dati XML (XML) allegato in un messaggio di posta elettronica all'account di posta elettronica del maker decisione. L'apparenza quindi possibile spostare tutti i messaggi in una cartella di InfoPath dedicata in Outlook. In questo scenario, si consiglia di assegnare un periodo di tempo specifico per tutti gli utenti completare i moduli in modo che il significa che può eseguire il report con tutti i moduli completati quando viene raggiunta la scadenza di raccolta dei dati.

Immissione di dati nei moduli di registrazione dei beni

  1. In InfoPath, aprire il modello di modulo (con estensione xsn) che è stato salvato in passaggio 1: progettare il modello di modulo di esempio registro delle risorse

  2. Dal menu Strumenti fare clic su Progetta modulo.

  3. Nel menu File fare clic su pubblica.

  4. Nella creazione guidata pubblicazione, fare clic su un elenco di destinatari di posta elettronica e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, nella casella nome modello di modulo, digitare un nome per il modello di modulo e quindi fare clic su Avanti. Il nome del modello di modulo verrà visualizzato nell'oggetto del messaggio viene inviato per i destinatari dei messaggi di posta elettronica.

  6. Nella pagina successiva della procedura guidata, facoltativamente, è possibile creare colonne che verranno visualizzate nelle cartelle di Outlook per organizzare i messaggi di posta elettronica.

  7. Fare clic su Avanti.

  8. Fare clic su Pubblica.

  9. Al termine della pubblicazione guidata pubblicazione del modello di modulo, verrà aperto un messaggio di posta elettronica con il modulo.

  10. Compilare il messaggio, digitare i nomi dei dipendenti o utilizzare una lista di distribuzione e quindi inviare il messaggio.

In Outlook, è possibile organizzare i significa che tutti i moduli XML inviati in uno dei due modi:

  • Se la finestra di messaggio cartelle moduli di InfoPath viene visualizzata la prima volta che viene visualizzato il messaggio, fare clic su Crea cartella moduli.

  • Creare una regola in Outlook per spostare tutti i moduli di InfoPath correlati a una cartella di InfoPath.

    Per ulteriori informazioni, vedere gestione dei messaggi mediante le regole.

Torna all'inizio

Passaggio 5: Importare i moduli in Excel

Poiché già stata creata la procedura di cartella di lavoro di Excel 2 e 3, è sufficiente per i dirigenti esportare e rivedere i dati del modulo. I dirigenti deve semplicemente esportare i file xml (XML) da Outlook, importare tutti i file di modulo (con estensione XML) tutta la cartella di lavoro di Excel e quindi l'aggiornamento dei dati.

Attività 1: Esportare i moduli da Outlook in una cartella di Windows

  1. In Outlook, selezionare la cartella che contiene tutti i moduli che sono state ricevute da dipendenti e quindi premere CTRL + A per selezionare tutti i messaggi di posta elettronica modulo.

  2. Fare clic con il pulsante destro della selezione, scegliere Azioni InfoPath e quindi fare clic su Esporta moduli.

  3. Nella finestra di dialogo Esporta moduli selezionare una cartella e fare clic su OK.

Attività 2: Importare i moduli in Excel

  1. Nella cartella di lavoro di Excel che è stato creato in passaggio 2: eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel, selezionare una delle celle mappate nella tabella di Excel.

  2. Nel gruppo XML della scheda sviluppo fare clic su Importa.

    Gruppo XML sulla barra multifunzione

    Viene visualizzata la finestra di dialogo Importa XML.

  3. In un computer che esegue Windows Vista   

  4. Eseguire una delle operazioni seguenti:

    • Se i file sono contigui, premere MAIUSC e quindi fare clic sul primo e l'ultimo file nell'elenco.

    • Se i file non adiacenti, tenere premuto CTRL e quindi fare clic su ogni file che si desidera importare nell'elenco.

  5. Fare clic su Importa.

    Tabella di Excel dei dati importati

Per impostazione predefinita, Excel sovrascritti gli eventuali dati esistenti in celle mappate, che è il risultato finale desiderato per questa soluzione aziendale. Tuttavia, un significa che potrebbe, ad esempio, importare i dati più volte in Percentage prima della scadenza pianificata.

Nota: In Excel, è possibile aggiungere i dati utilizzando l'opzione Aggiungi i nuovi dati alle tabelle XML esistenti (nel gruppo XML della scheda sviluppo fare clic su Mapping proprietà ), che può essere appropriato per altre soluzioni.

Per ulteriori informazioni, vedere dati XML di importazione.

Attività 3: Aggiornare i report di tabella pivot e grafico pivot

  • Fare clic su una cella nel rapporto di tabella pivot.

  • Nella scheda Opzioni, gruppo dati fare clic sulla freccia accanto ad Aggiorna tutto e quindi fare clic su Aggiorna.

    Gruppo Dimensioni sulla barra multifunzione di Excel

Rapporto finale tabella pivot e grafico pivot

La cartella di lavoro di Excel ora contiene tutti i dati e report di riepilogo che è necessario che consentono di allocare il budget di apparecchiature per l'anno successivo. Naturalmente, è possibile eseguire ulteriori analisi della cartella di lavoro di Excel se necessario, ad esempio l'ordinamento, filtro o la formattazione condizionale dei dati.

Torna all'inizio

Considerazioni finali: si consiglia di utilizzare un elenco di SharePoint o di un database di Access

In alternativa, è preferibile scegliere un elenco di SharePoint o di un database di Access anziché XML, per trasferire dati tra InfoPath e in Excel.

Usare un elenco SharePoint

Da InfoPath, è possibile utilizzare facilmente un elenco di SharePoint come origine dati di sola lettura. È possibile eseguire una delle seguenti operazioni:

  • Dall'elenco di SharePoint, esportare i dati in Excel, in cui viene creato automaticamente una connessione dati in Excel.

  • Da Excel, in modo esplicito creare una connessione dati per l'elenco di SharePoint.

Dopo aver creata una connessione dati, è possibile aggiornare i dati in Excel per recuperare i dati aggiornati.

È possibile utilizzare un elenco di SharePoint per aggiungere e aggiornare i dati, utilizzare un modulo di InfoPath per visualizzare un elemento nell'elenco (ad esempio una complessa o lunga voce migliore visualizzata verticalmente) e quindi utilizzare Excel per analizzare ulteriormente i dati.

Combinazione di InfoPath, elenco di SharePoint ed Excel

1. visualizzare un singolo elemento per la revisione semplice in InfoPath.

2. aggiungere e aggiornare i dati in un elenco di SharePoint.

3. aggiornare i e generare report aggiornati con Excel.

Per ulteriori informazioni, vedere aggiungere una connessione dati a una raccolta documenti di SharePoint o un elenco

Usare un database di Access

Da InfoPath, è possibile creare una connessione di lettura/scrittura a un database di Access. Da Excel, è possibile creare in modo esplicito una connessione dati al database di Access è possibile aggiornare per recuperare i dati aggiornati. È possibile definire anche la connessione per aggiornare automaticamente quando si apre la cartella di lavoro o aggiornare periodicamente, ad esempio, ogni 5 minuti.

È possibile usare un database di Access come valore intermedio tra InfoPath ed Excel. Quando si invia un modulo di InfoPath per l'accesso, si aggiorna il database di Access. Quando si aggiorna la connessione dati in Excel, si recuperano dati aggiornati da Access. In effetti, l'invio di dati indirettamente da InfoPath a una cartella di lavoro di Excel.

combinazione di infopath, access ed excel

1. visualizzare e inviare un modulo a un database di Access.

2. archiviare dati in un database di Access.

3. aggiornare i e generare report aggiornati con Excel.

Per ulteriori informazioni, vedere progettare un modello di modulo basato su un database di Microsoft Access.

Suggerimento: Non tutti sanno che è possibile creare un modulo di InfoPath direttamente da Access 2007. Se gli utenti dispongono di Outlook 2007 e InfoPath 2007 installato nel computer, è possibile raccogliere dati da diversi utenti direttamente da Access 2007 utilizzando la creazione guidata raccolta dati da messaggi di posta elettronica. Per ulteriori informazioni, vedere l'argomento della Guida di Access 2007, raccogliere dati tramite messaggi di posta elettronica.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×