Creare una casella di riepilogo a cascata

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Caselle di riepilogo a cascata consentono agli utenti di compilare più rapidamente i moduli e a garantire agli utenti di immettere dati in modo corretto. In questo articolo viene descritto come creare e popolare caselle di riepilogo a cascata con i dati. In Microsoft Office InfoPath, è possibile inserire un elenco con i dati che vengono utilizzati i valori dalla maschera, i valori di un documento Extensible Markup Language (XML) esterno o valori da un database di Microsoft Office Access.

In questo articolo

Che cos'è una casella di riepilogo a cascata?

Passaggio 1: Inserire una casella di riepilogo a cascata

Passaggio 2: Fornire i dati

Che cos'è una casella di riepilogo a cascata?

Una casella di riepilogo a cascata è una casella di riepilogo con opzioni che cambia in base al valore che l'utente seleziona in un'altra casella di riepilogo. Ad esempio, se un utente fa clic su condimenti nella casella categorie illustrata nella figura seguente, nella casella prodotti verrà visualizzato un elenco di.

Esempio di casella di riepilogo a cascata

Nelle sezioni seguenti viene illustrato come progettare un modello di modulo con due caselle di riepilogo, in cui viene filtrata la seconda casella di riepilogo in base al valore di che un utente seleziona nella prima casella di riepilogo. Quando il valore nella prima casella di riepilogo assume l'aspetto, il filtro viene applicato automaticamente alla seconda casella di riepilogo, che modifica i valori.

Considerazioni sulla compatibilità

Filtri possono essere utilizzati solo nei modelli di modulo progettati per essere compilati in InfoPath. Filtri non sono disponibili nei modelli di modulo compatibile con browser.

Torna all'inizio

Passaggio 1: Inserire una casella di riepilogo a cascata

Per creare una casella di riepilogo a cascata, è necessario inserire due caselle di riepilogo nel modello di modulo.

Nota: Quando si inserisce una casella di riepilogo a cascata nel modello di modulo, assicurarsi che le due caselle non sono in una sezione ripetuta o tabella ripetuta.

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. In Inserisci controlli nel riquadro attività controlli, fare clic su Casella di riepilogo a discesa. Durante la compilazione di un modulo basato sul modello di modulo, la selezione in questa casella di riepilogo consente di verificare le opzioni disponibili nella seconda casella di riepilogo.

  3. Fare clic su casella di riepilogo. Il modello di modulo ora deve contenere una casella di riepilogo a discesa e una casella di riepilogo standard.

    Elenco a discesa e casella di riepilogo in un modulo

  4. Fare doppio clic sull'elenco a discesa che è stato inserito nel modello di modulo nel passaggio 2.

  5. Nella finestra di dialogo Proprietà casella di riepilogo a discesa, fare clic sulla scheda dati.

  6. Nella casella nome campo digitare listBox1e quindi fare clic su OK.

  7. Fare doppio clic sulla casella di riepilogo che si è inserita nel modello di modulo nel passaggio 3.

  8. Nella finestra di dialogo Proprietà casella di riepilogo, fare clic sulla scheda dati.

  9. Nella casella nome campo digitare listBox2Cascadee quindi fare clic su OK.

Torna all'inizio

Passaggio 2: Fornire i dati

Dopo avere inserito le caselle di riepilogo nel modello di modulo, è necessario fornire i dati che verranno visualizzati. È quindi necessario applicare un filtro in modo che le scelte nella seconda casella di riepilogo si basano la selezione dell'utente nella prima casella di riepilogo.

In questa sezione viene descritto come connettere le caselle di riepilogo ai dati utilizzando tre metodi comuni: aggiunta di dati del modulo stesso; connettere il modulo a un documento XML esistente che contiene i dati. o connettere il modulo a un database che contiene i dati. Per completare la creazione di casella di riepilogo a cascata, fare clic su quello che si desidera utilizzare nell'elenco seguente.

Connettersi ai dati del modulo

Connettersi a un documento XML esterno

Connettersi a un database

Connettersi ai dati del modulo

In questa sezione, si imparerà a compilare le caselle di riepilogo con i dati del modulo. A tale scopo, è prima necessario configurare campi nel modello di modulo in modo da poter immettere i nomi delle categorie e un set di prodotti per ogni categoria.

Configurare i campi nel modello di modulo

  1. Se il riquadro attività Origine dati non è visibile, fare clic su Origine dati dal menu Visualizza.

  2. Nel riquadro attività Origine dati, pulsante destro del mouse sul gruppo campiPersonali e quindi fare clic su Aggiungi.

  3. Nella casella nome, nella finestra di dialogo Aggiungi campo o gruppo, digitare categoria.

  4. Nell'elenco tipo fare clic su gruppo.

  5. Selezionare la casella di controllo ripetuto e quindi fare clic su OK.

  6. Nel riquadro attività Origine dati, fare clic sul gruppo di categoria.

  7. Nella casella nome, nella finestra di dialogo Aggiungi campo o gruppo, digitare categoriae quindi fare clic su OK. In questo campo conterrà i nomi delle categorie per la prima casella di riepilogo.

  8. Destro del mouse sul gruppo della categoria e quindi fare clic su Aggiungi.

  9. Nella casella nome, nella finestra di dialogo Aggiungi campo o gruppo, digitare Product.

  10. Selezionare la casella di controllo ripetuto e quindi fare clic su OK. In questo campo conterrà i nomi dei prodotti per la seconda casella di riepilogo.

Poiché questa casella di riepilogo viene popolata con dati del modulo, i dati devono essere aggiunta alla maschera. A tale scopo, sarà necessario creare i valori predefiniti per i campi prodotto e categoria.

Suggerimento

È anche possibile creare caselle di riepilogo che visualizzano i valori che gli utenti digitare nel modulo se stessi. A tale scopo, associare la casella di riepilogo campi associati ai controlli nel modulo. Quando un utente immette valori nei controlli, modificare le opzioni nella casella di riepilogo.

Creare i valori predefiniti

  1. Nel menu Strumenti fare clic su Valori predefiniti.

  2. Nella finestra di dialogo Modifica valori predefiniti, nel gruppo categoria selezionare il campo categoria (non deselezionare la casella di controllo), quindi nella casella valore predefinito, digitare Seafood.

  3. Selezionare il campo prodotto (non deselezionare la casella di controllo), quindi nella casella valore predefinito, digitare granchio.

  4. Pulsante destro del mouse sul campo prodotto e quindi fare clic su Aggiungi un altro prodotto. Consente di aggiungere un secondo prodotto per Seafood come valore predefinito.

  5. Pulsante destro del mouse la seconda istanza del campo prodotto (non deselezionare la casella di controllo), quindi nella casella valore predefinito, digitare salmone.

  6. Destro del mouse sul gruppo della categoria e quindi fare clic su Aggiungi un'altra categoria. Consente di aggiungere una seconda categoria come valore predefinito.

  7. Usare i passaggi precedenti per specificare i valori predefiniti per la seconda istanza di campi categoria e prodottoLatticini, Crescenza e latte, rispettivamente.

  8. Fare clic su OK.

Dopo avere immesso i valori predefiniti per i campi prodotto e categoria, è possibile connettersi prima casella di riepilogo per i dati appena immesso.

Casella di riepilogo prima di connettersi ai dati

  1. Nel modello di modulo, fare doppio clic sull'elenco a discesa che è stato inserito in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo a discesa in voci casella di riepilogo, fare clic su Cerca valori nell'origine dati del modulo.

  4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  5. Nel gruppo categoria della finestra di dialogo Seleziona campo o gruppo fare clic sul campo categoria e quindi fare clic su OK due volte.

A questo punto è necessario connettere la seconda casella di riepilogo per i dati. Durante l'esecuzione di questa connessione dati, verrà si desidera applicare un filtro per la seconda casella di riepilogo. Questo filtro verrà popolare la seconda casella di riepilogo con i prodotti appropriate in base alla categoria selezionata nella prima casella di riepilogo. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco delle categorie salvate nel modulo (campo categoria).

Connettere la seconda casella di riepilogo ai dati

  1. Nel modello di modulo, fare doppio clic sulla casella di riepilogo che si è inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo in voci casella di riepilogo, fare clic su Cerca valori nell'origine dati del modulo.

  4. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  5. Nel gruppo categoria della finestra di dialogo Seleziona campo o gruppo fare clic sul campo prodotto e quindi fare clic su Filtro dati.

  6. Nella finestra di dialogo Filtro dei dati, fare clic su Aggiungi.

  7. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella prima casella.

  8. Nella finestra di dialogo Seleziona campo o gruppo fare clic su listBox1 e quindi fare clic su OK.

  9. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella terza casella.

  10. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo categoria e quindi fare clic su OK per chiudere tutte le finestre di dialogo aperte.

Ora che è connesso seconda casella di riepilogo per i dati e applicato il filtro, si è pronti testare le caselle di riepilogo per assicurarsi che funzionino correttamente.

Le caselle di riepilogo

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Nella casella di riepilogo a discesa, fare clic su Seafood. Casella di riepilogo deve essere visualizzati una riga vuota, granchio e salmone.

    Nota: La riga vuota consente agli utenti di annullare la scelta effettuata dalla casella di riepilogo.

Se le caselle di riepilogo non funzionano correttamente, controllare il filtro per la seconda casella di riepilogo per assicurarsi che confronta il campo listBox1 al campo categoria.

Parte superiore della sezione

Connettersi a un documento XML esterno

In questa sezione, si imparerà a creare una connessione dati a un documento XML che contiene valori di prodotto e categoria. Documento XML sarà l'origine dati secondaria. Per creare la connessione dati, sarà necessario creare il documento XML, associare le caselle di riepilogo nel modello di modulo con il documento XML e quindi applicare un filtro per la seconda casella di riepilogo in modo che l'elenco dei prodotti cambia in modo appropriato.

Prima che è possibile associare il modulo a un'origine dati secondaria, è necessario creare il documento XML.

Creare il documento XML

  1. Avviare Blocco note o un altro editor di testo.

  2. Copiare e incollare i dati XML seguenti nell'editor di testo:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Salvare il file nel computer come listBoxData. XML.

Una volta creato un documento XML, è possibile connettersi al modello di modulo. Verrà creato un'origine dati secondaria.

Connettere il documento XML al modello di modulo

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Nella connessione guidata dati fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su documento XML e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, fare clic su Sfoglia, selezionare il file listBoxData. XML che è stato salvato nel computer in uso e quindi fare clic su Apri.

  6. Nella pagina successiva della procedura guidata, fare clic su Includi i dati come file di risorse nel modello di modulo o parte modello e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare listBoxDataXMLFile.

  8. Selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo. In questo modo che i dati di casella di elenco sarà disponibili ogni volta che viene aperto il modulo, invece che richiede all'utente di query per renderla.

  9. Fare clic su Fine.

  10. Nella finestra di dialogo Connessioni dati, fare clic su Chiudi.

A questo punto si è pronti per la connessione prima casella di riepilogo nel modello di modulo per i dati nel documento XML.

Casella di riepilogo prima di connettersi ai dati

  1. Nel modello di modulo, fare doppio clic sull'elenco a discesa che è stato inserito in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo a discesa in voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella origine dati fare clic su listBoxDataXMLFile.

  5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  6. Nel gruppo categoria della finestra di dialogo Seleziona campo o gruppo fare clic sul campo categorie.

    Nota: Lo sfondo giallo nella finestra di dialogo Seleziona campo o gruppo indica che sta utilizzando un'origine dati secondaria.

  7. Fare clic su OK due volte.

A questo punto è necessario connettere la seconda casella di riepilogo al documento XML. Mentre si effettua la connessione dati, verranno si desidera applicare un filtro per la seconda casella di riepilogo. Questo filtro verrà popolare la seconda casella di riepilogo con i prodotti appropriate in base alla categoria selezionata nella prima casella di riepilogo. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco delle categorie salvate nel modulo (campo categoria).

Connettere la seconda casella di riepilogo ai dati

  1. Nel modello di modulo, fare doppio clic sulla casella di riepilogo che si è inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo in voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella origine dati fare clic su listBoxDataXMLFile.

  5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  6. Nel gruppo categoria della finestra di dialogo Seleziona campo o gruppo espandere il gruppo di prodotti e quindi fare clic sul campo prodotto.

  7. Fare clic su filtrare i dati.

  8. Nella finestra di dialogo Filtro dei dati, fare clic su Aggiungi.

  9. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella prima casella.

  10. Nella casella origine dati nella finestra di dialogo Seleziona campo o gruppo fare clic su principale.

  11. Fare clic su listBox1 e quindi fare clic su OK.

  12. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella terza casella.

  13. Nella casella origine dati nella finestra di dialogo Seleziona campo o gruppo fare clic su listBoxDataXMLFile (secondario) e quindi fare clic su categorie.

  14. Fare clic su OK per chiudere tutte le finestre di dialogo aperte.

Ora che è collegato la seconda casella di riepilogo al documento XML e applicato il filtro, si è pronti testare le caselle di riepilogo per assicurarsi che funzionino correttamente.

Le caselle di riepilogo

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Nella casella di riepilogo a discesa, fare clic su Seafood. Casella di riepilogo deve essere visualizzati solo una riga vuota, granchio e Salmone.

    Nota: La riga vuota consente agli utenti di annullare la scelta effettuata dalla casella di riepilogo.

Se le caselle di riepilogo non funzionano correttamente, controllare il filtro per la seconda casella di riepilogo per assicurarsi che confronta il campo listBox1 al campo categoria.

Parte superiore della sezione

Connettersi a un database

In questa sezione, si imparerà a creare una connessione dati a due tabelle in un database di Access. A tale scopo, associare le caselle di riepilogo nel modello di modulo con il database e quindi applicare un filtro per la seconda casella di riepilogo in modo che nell'elenco la seconda casella cambi in modo appropriato in base al valore selezionato nella prima casella di riepilogo. In questo esempio si presuppone che il database di Access contiene due tabelle denominate categorie e prodotti e che le due tabelle sono correlate tra loro tramite il campo IDCategoria, che viene utilizzato in ogni tabella.

Tabella categorie   

ID categoria

CategoryName

1

Seafood

2

Latticini

Tabella di prodotti   

ProductID

ID categoria

ProductName

1

1

Granchio

2

1

Salmone

3

2

Latte

4

2

Cheddar

Connettere il modello di modulo per l'origine dati

Prima di tutto, è necessario creare una connessione dati tra il modello di modulo e le tabelle del database. Poiché sta solo la visualizzazione dei dati del database, anziché modificare direttamente il database di Access sarà un'origine dati secondaria per il modello di modulo.

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. Nella connessione guidata dati fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su Database (Microsoft SQL Server o solo Microsoft Office Access) e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, fare clic su Seleziona Database e quindi individuare e fare doppio clic sul database di Access sul disco rigido.

  6. Nella finestra di dialogo Seleziona tabella fare clic sulla tabella che contiene i dati che si desidera mostrare nel primo elenco (in questo esempio, la tabella categorie) e quindi fare clic su OK. La tabella viene come tabella principale per la connessione dati.

  7. Nella procedura guidata, fare clic su Aggiungi tabella.

  8. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sulla tabella che contiene i dati che si desidera mostrare nel secondo elenco (in questo esempio, la tabella prodotti) e quindi fare clic su Avanti.

  9. Nella finestra di dialogo Modifica relazioni verificare che i campi di connessione siano corretti. In questo esempio, le tabelle sono correlate tra loro tramite il campo IDCategoria.

    Suggerimento: Se i campi di connessione non sono corretti, selezionare i campi e quindi fare clic su Rimuovi relazione. Quindi fare clic su Aggiungi relazione, selezionare i campi corretti e quindi fare clic su OK.

  10. Fare clic su Fine.

    Nota: In questo esempio, la tabella categorie con una relazione uno-a-molti alla tabella products, che indica che per ogni categoria possono essere diversi prodotti. In un database, questo tipo di relazione viene in genere stabilito utilizzando i campi chiave. In questo caso, il campo chiave IDCategoria consente l'accesso associare il set di prodotti corretto con la categoria appropriata.

  11. Nella procedura guidata, esaminare la struttura dell'origine dati. Verrà visualizzato due tabelle collegate tra loro: tabella principale e la tabella secondaria. Per visualizzare i singoli campi nella tabella, selezionare la casella di controllo Mostra le colonne della tabella. Dopo aver rivisto la struttura di dati, fare clic su Avanti.

  12. Deselezionare la casella di controllo memorizza una copia dei dati nel modello di modulo e quindi fare clic su Avanti.

  13. Nella casella Immettere un nome per la connessione dati nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  14. Selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

  15. Fare clic su Fine e quindi fare clic su Chiudi nella finestra di dialogo Connessioni dati.

Casella di riepilogo prima di connettersi ai dati

Dopo avere creato una connessione dati all'origine dati secondaria, è possibile connettersi prima casella di riepilogo nel modello di modulo per le tabelle del database.

  1. Nel modello di modulo, fare doppio clic sull'elenco a discesa che è stato inserito in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo a discesa in voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella origine dati, verificare che sia selezionata la connessione dati creata.

  5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  6. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome della tabella contenente i dati che si desidera visualizzare nell'elenco a discesa (in questo esempio d:categorie ) e quindi fare clic su OK.

    Nota: Lo sfondo giallo nella finestra di dialogo Seleziona campo o gruppo indica che sta utilizzando un'origine dati secondaria.

  7. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella valore.

  8. Nella finestra di dialogo Seleziona campo o gruppo assicurarsi che il campo connessione (in questo esempio, : IDCategoria ) sia selezionata e quindi fare clic su OK. Si tratta del valore che verrà salvato quando si effettua una selezione nella casella di riepilogo.

  9. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella nome visualizzato.

  10. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome del campo che si desidera visualizzare nell'elenco a discesa (in questo esempio, : CategoryName ).

  11. Fare clic su OK due volte.

Connettere la seconda casella di riepilogo ai dati

A questo punto è necessario connettersi seconda casella di riepilogo al database. Mentre si effettua la connessione dati, verranno si desidera applicare un filtro per la seconda casella di riepilogo. Questo filtro verrà popolare la seconda casella di riepilogo con i valori appropriati, in base al valore selezionato nella prima casella di riepilogo.

  1. Nel modello di modulo, fare doppio clic sulla casella di riepilogo.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Proprietà casella di riepilogo in voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella origine dati, verificare che sia selezionata la connessione dati creata.

  5. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella voci.

  6. Nella finestra di dialogo Seleziona campo o gruppo espandere il gruppo primario (in questo esempio d:categorie ) e quindi fare clic sul gruppo secondario che corrisponde alla tabella contenente i dati che si desidera visualizzare nella casella di riepilogo a cascata (in questo esempio prodotti ).

  7. Fare clic su filtrare i dati.

  8. Nella finestra di dialogo Filtro dei dati, fare clic su Aggiungi.

  9. Nella prima casella della finestra di dialogo Specifica condizioni filtro verificare che il campo di connessione dalla tabella secondaria (in questo esempio, prodotti,) sia selezionata.

    Importante: Se i campi di connessione hanno lo stesso nome in entrambe le tabelle, assicurarsi di selezionare quello corretto. I campi da ogni tabella vengono ordinati insieme nell'elenco. Pertanto, è possibile utilizzare i nomi dei campi adiacente per determinare quello corretto. In questo esempio abbiamo selezionare il campo IDCategoria che viene visualizzato con gli altri campi dalla tabella Products.

  10. Nella terza casella fare clic su Seleziona campo o gruppo.

  11. Nella casella origine dati nella finestra di dialogo Seleziona campo o gruppo fare clic su principale, fare clic sul campo listBox1 e quindi fare clic su OK.

    È stato configurato un filtro che confronta il valore selezionato nella casella di riepilogo (campo listBox1) con l'elenco di valori nella casella di riepilogo.

  12. Fare clic tre volte su OK per tornare alla finestra di dialogo Proprietà casella di riepilogo.

  13. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella valore.

  14. Nella finestra di dialogo Seleziona campo o gruppo selezionare il valore che si desidera salvare quando l'utente seleziona un elemento nella casella di riepilogo. In questo esempio, è possibile salvare il campo ID prodotto per successivi utilizzi. Di conseguenza, è necessario selezionare il : ProductID raggruppare e quindi fare clic su OK.

  15. Fare clic su Seleziona XPath Icona del pulsante accanto alla casella nome visualizzato.

  16. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome del campo che si desidera visualizzare nella casella di riepilogo (in questo esempio, : ProductName ).

  17. Fare clic su OK due volte.

Le caselle di riepilogo

Ora che è connessa la seconda casella di riepilogo al database e applicato il filtro, si è pronti testare le caselle di riepilogo per assicurarsi che funzionino correttamente.

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Selezionare un valore nella casella di riepilogo a discesa. Casella di riepilogo deve essere visualizzata i valori appropriati dalla tabella secondaria in base al campo connessione che si è scelto.

Suggerimento: Se le caselle di riepilogo non funzionano correttamente, controllare il filtro per la seconda casella di riepilogo per assicurarsi che confronta il campo listBox1 al campo IDCategoria.

Parte superiore della sezione

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×