Creare un grafico pivot

A volte è difficile capire il quadro generale se si hanno a disposizione solo dati non elaborati che non sono stati riepilogati, come nell'esempio riportato di seguito. Spesso il primo passaggio consiste nel creare una tabella pivot per riepilogare e analizzare i dati in un formato strutturato. Questa funzionalità è molto utile, ma non tutti riescono a guardare i numeri e interpretarli. I grafici pivot sono un ottimo modo per aggiungere visualizzazioni ai dati.

Dati spese domestiche

Grafico pivot corrispondente

Dati di esempio relativi alle spese domestiche per la creazione di una tabella pivot con mesi, categorie e importi

Esempio di grafico pivot di Excel

Se si hanno solo dati normali del foglio di lavoro e nessuna tabella pivot, è possibile scegliere un grafico pivot consigliato per i propri dati ed Excel creerà automaticamente una tabella pivot corrispondente. Ecco come fare:

  1. Fare clic in un punto qualsiasi dei dati.

  2. Nel gruppo Grafici della scheda Inserisci scegliere Grafici consigliati.

    Pulsante Grafici consigliati nella scheda Inserisci

  3. Nella scheda Grafici consigliati scegliere uno dei grafici con l'icona grafico pivot Pulsante indicatore Grafico pivot nell'angolo superiore. Nel riquadro dell'anteprima comparirà un'anteprima del grafico pivot.

    Finestra di dialogo Inserisci grafico che mostra i grafici pivot consigliati

  4. Dopo aver trovato il grafico pivot desiderato, fare clic su OK. Excel crea un nuovo foglio di lavoro con una tabella pivot e un grafico pivot.

  5. È possibile disporre il grafico pivot accanto alla tabella pivot per visualizzare sia i dati trasformati tramite Pivot che il grafico oppure, se si vuole visualizzare solo il grafico, è possibile inserire il grafico pivot sopra i dati.

  6. A questo punto, è possibile formattare il grafico pivot.

Se nessuna delle opzioni in Grafici consigliati è risultata soddisfacente, è possibile crearne una personalizzata.

  1. Selezionare una cella nei dati del foglio di lavoro e passare a Inserisci > Grafico pivot > Grafico pivot.

  2. Excel visualizza una finestra di dialogo che chiede dove inserire il grafico pivot. In genere è preferibile scegliere l'opzione Nuovo foglio di lavoro per modificare il grafico a piacimento finché non si è soddisfatti senza modificare altro nel foglio di lavoro.

    Inserisci > Opzioni grafico pivot di Excel
  3. Premere OK. Excel aggiunge un nuovo foglio di lavoro con una tabella pivot e un grafico pivot vuoti.

    Compariranno un grafico pivot vuoto e l'elenco dei campi, che consentono di aggiungere o riorganizzare i campi nel grafico pivot.

  4. In Elenco campi scegliere i campi da visualizzare nel grafico pivot.

    Elenco dei campi con la sezione campo e la sezione aree

  5. A questo punto, è possibile formattare il grafico pivot.

Se una tabella pivot è già stata creata e configurata nel modo desiderato, questo metodo consente di creare automaticamente il grafico più completo per le proprie esigenze.

  1. Selezionare una cella all'interno dell'intervallo della tabella pivot.

  2. Passare a Strumenti tabella pivot > Analizza > Grafico pivot.

  3. Selezionare il tipo di grafico desiderato e premere OK.

    Excel inserisce un nuovo grafico pivot nello stesso foglio della tabella pivot su cui si basa. Per questo esempio è stato scelto un istogramma standard. Se non si sa quale tipo di grafico si preferisce, è possibile selezionarne uno alla volta ed Excel li visualizzerà in anteprima nel riquadro Inserisci grafico.

    Esempio di grafico pivot con anteprima dinamica del tipo di grafico e un istogramma selezionato

    Alcuni grafici non supportano i dati delle tabelle pivot, quindi, se se ne seleziona uno di questo tipo, Excel lo segnala.

  4. A questo punto, è possibile formattare il grafico pivot.

  1. Fare clic su Dati > Da altre origini e scegliere l'origine dati desiderata. Ad esempio, per connettersi a un file cubo OLAP (Online Analytical Processing), scegliere Da Analysis Services.

    Pulsante Da altre origini nella scheda Dati

  2. Seguire i passaggi della Connessione guidata dati e fare clic su Fine.

  3. Nella finestra di dialogo Importa dati scegliere Grafico pivot e il percorso in cui inserire i dati, quindi fare clic su OK.

    Compariranno un grafico pivot vuoto e l'elenco dei campi, che consentono di aggiungere o riorganizzare i campi nel grafico pivot.

  4. In Elenco campi scegliere i campi da visualizzare nel grafico pivot.

    Elenco dei campi con la sezione campo e la sezione aree

  5. A questo punto, è possibile formattare il grafico pivot.

  1. Fare clic su Inserisci > Grafico pivot.

    Pulsante grafico pivot nella scheda Inserisci

  2. Nella finestra di dialogo Crea grafico pivot fare clic su Usa origine dati esterna e quindi su Seleziona connessione.

  3. Nella scheda Connessioni della finestra di dialogo Connessioni esistenti fare doppio clic sulla connessione desiderata.

  4. Fare clic su OK.

    Compariranno un grafico pivot vuoto e l'elenco dei campi, che consentono di aggiungere o riorganizzare i campi nel grafico pivot.

  5. In Elenco campi scegliere i campi da visualizzare nel grafico pivot.

Elenco dei campi con la sezione campo e la sezione aree

Dopo aver creato un grafico pivot, è possibile personalizzarlo allo stesso modo di qualunque altro grafico standard. Quando si seleziona il grafico pivot:

  1. Accanto al grafico compaiono due pulsanti che consentono di aggiungere o modificare gli elementi del grafico, come titoli o etichette dati, e di modificare stile e colori del grafico pivot allo stesso modo di qualunque grafico standard.

    Grafico pivot con le etichette che puntano ai pulsanti di campo e agli strumenti del grafico

  2. Pulsanti di campo -Excel visualizza automaticamente i campi della tabella pivot come pulsanti nel grafico pivot. Questi consentono di filtrare un singolo grafico pivot per visualizzare solo specifici dettagli. È anche possibile usare i filtri dei dati di tabelle pivot per filtrare più tabelle e grafici pivot in una sola volta invece di usare i pulsanti di campo. Per rimuoverli, fare clic sulla tabella pivot o sul grafico pivot, quindi deselezionare il pulsante Elenco campi nella scheda Analizza della barra multifunzione.

  3. Nella barra multifunzione sono presenti gli Strumenti grafico pivot. Nelle schede Analizza, Progettazione e Formato è possibile scegliere le opzioni per il funzionamento e la personalizzazione del grafico pivot.

    strumenti grafico pivot sulla barra multifunzione

  4. Un grafico pivot non deve necessariamente trovarsi nello stesso foglio di lavoro della tabella pivot sottostante, quindi quando il grafico pivot raggiunge l'aspetto desiderato, è possibile tagliarlo e incollarlo in un'altra posizione.

  5. Per rimuovere un grafico pivot, è sufficiente selezionarlo e premere Elimina.

Per creare un grafico pivot nel Mac, è necessario creare prima una tabella pivot e quindi inserire un grafico. Al termine, se si modificano i campi nell'elenco Campi tabella pivot, il grafico funzionerà come un grafico pivot. 

  1. Creare una tabella pivotse non è già disponibile. 

  2. Selezionare una cella all'interno della tabella pivot.

  3. Nella scheda Inserisci fare clic su un pulsante per inserire un istogramma oppure un grafico a linee, a torta o radar. Tenere presente che, al momento, gli altri tipi di grafici non funzionano con le tabelle pivot. Ad esempio, i grafici ad albero, statistici e combinati non funzionano ancora con le tabelle pivot.

  4. Dopo aver inserito un istogramma oppure un grafico a linee, a torta o radar, è possibile trasformarlo tramite Pivot modificando o spostando i campi con l'elenco Campi tabella pivot.

  5. È anche possibile filtrare i dati in una tabella pivot e usare i filtri dei dati. Quando vengono applicati, viene filtrato anche il grafico.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Argomenti correlati

Creare una tabella pivot
Usare l'Elenco campi per disporre i campi in una tabella pivot
Usare i filtri dei dati per filtrare i dati
Creare la sequenza temporale di una tabella pivot per filtrare date

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×