Copiare una formula trascinando il quadratino di riempimento in Excel per Mac

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

È possibile copiare rapidamente le formule nelle celle adiacenti con il quadratino di riempimento

Quadratino di riempimento

Quando si trascina il quadratino in altre celle, Excel mostra risultati differenti in ognuna.

Copiare una formula trascinando il quadratino di riempimento

Seguire questa procedura:

  1. Selezionare la cella contenente la formula da inserire nelle celle adiacenti.

  2. Posizionare il cursore sull'angolo inferiore destro finché non assume la forma di un segno più (+), come illustrato qui:

    Cursore posizionato sul quadratino di riempimento

  3. Trascinare il quadratino di riempimento verso il basso, verso l'alto o sulle celle che si desidera riempire. In questo esempio, di seguito è illustrata trascinando il quadratino di riempimento verso il basso:

    Cursore che trascina verso il basso il quadratino di riempimento

  4. Quando si rilascia il pulsante del mouse, la formula viene automaticamente inserita nelle altre celle:

    Visualizzazione dei valori per le celle riempite

  5. Per cambiare il modo in cui vengono riempite le celle, fare clic sul pulsante Opzioni riempimento automatico Pulsante Opzioni riempimento automatico visualizzato al termine del trascinamento e scegliere l'opzione desiderata.

Per altre informazioni sulla copia delle formule, vedere Copiare e incollare una formula in un'altra cella o un altro foglio di lavoro.

Suggerimenti: 

  • È anche possibile premere Ctrl + D per copiare la formula in basso in una colonna. Selezionare la cella contenente la formula che si desidera inserire e quindi selezionare le celle di sotto di esso e quindi premere Ctrl + D.

  • È anche possibile premere Ctrl + R per copiare la formula a destra in una riga. Selezionare la cella contenente la formula che si desidera inserire e quindi selezionare le celle a destra del e quindi premere Ctrl + R.

Se il riempimento non funziona

In alcuni casi completamento funziona correttamente e altre ore che non funziona come previsto. Ecco perché è importante controllare i riferimenti di cella della prima cella.

I riferimenti di cella non sono altro che puntatori ad altre celle. Si supponga ad esempio che la prima cella contenga questa formula:


=SOMMA(A1;B1)


A1 e B1 sono riferimenti relativi. Ciò significa semplicemente che quando si immette la formula verso il basso, i riferimenti verranno modificato in modo incrementale da A1 e B1 alla cella A2, B2 e così via, come segue:

=SUM(A1,B1)

=SOMMA(A2;B2)

=SUM(A3,B3)

Gli altri casi, è possibile evitare i riferimenti in altre celle da modificare. Ad esempio, si supponga che si desidera il primo riferimento A1, per restare fisse e B1 per modificare mentre si trascina il quadratino di riempimento. In questo caso, immettere un segno di dollaro ($) nel primo riferimento: =SUM($A$1,B1). Un segno di dollaro forza mantenere che punta alla cella A1, come si riempiono le altre celle di Excel. Ecco aspetto che avrà:

=SOMMA($A$1;B1)

=SOMMA($A$1;B2)

=SOMMA($A$3;B3)

I riferimenti con il simbolo del dollaro ($) si chiamano riferimenti assoluti. Quando si riempie verso il basso, il riferimento alla cella A1 rimane fisso, mentre Excel cambia i riferimenti a B1, in B2 e B3.

Problemi a visualizzare il quadratino di riempimento?

Se non viene visualizzato il riempimento gestire, può essere nascosta. Per visualizzarla:

  1. Nel menu Excel fare clic su Preferenze.

  2. Fare clic su Modifica.

  3. In Opzioni di modifica selezionare la casella Attiva quadratino di riempimento e trascinamento celle.

Se non funziona calcolo cartella di lavoro automatico, formule non vengono ricalcolate quando si riempiono le celle.

Ecco come attivare il componente aggiuntivo:

  1. Nel menu Excel fare clic su Preferenze.

  2. Far clic su Calcolo.

  3. Nelle Opzioni di calcolo, verificare che sia selezionato automatico.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×