Convertire un documento di Word in un modello di modulo di InfoPath

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Anche se è vero che è possibile utilizzare Microsoft Office Word per creare un documento che effettua una ricerca e l'aspetto di un modulo, Word è di un programma di elaborazione testi, non un programma la progettazione di moduli. Microsoft Office InfoPath invece è stato creato specificamente per la progettazione e compilazione dei moduli elettronici. Se si desidera convertire documenti di Word esistenti in modelli di modulo di InfoPath, è possibile utilizzare l'importazione guidata in InfoPath per farlo. È quindi possibile trarre vantaggio caratteristiche di InfoPath per la progettazione, la pubblicazione e compilazione dei moduli. In un modello di modulo rapporto vendite, ad esempio, è possibile utilizzare formattazione condizionale per applicare automaticamente un colore di sfondo rosso quando i numeri sono inferiori previsioni vendite. Nello stesso modello di modulo, è possibile utilizzare un regola per i moduli basati su tale modello di modulo per l'invio come allegato di un messaggio di posta elettronica quando un utente fa clic su un pulsante Invia. Inoltre, è possibile renderne il modello di modulo a un pubblico più ampio mediante la creazione di un modello di modulo abilitato per i browser.

Quando si converte un documento di Word in un modello di modulo di InfoPath, il modello di modulo risultante corrisponderà il layout del documento di Word. Inoltre, gli elementi nel documento di Word che soddisfano determinate condizioni vengono convertiti automaticamente in appositi controlli che gli utenti possono inserire i dati. Ad esempio, se il documento di Word contiene parentesi quadre dopo più spazi, in InfoPath utilizzato tale area racchiuso tra parentesi quadre come un campo della voce di testo e lo converte in un controllo casella di testo nel modello di modulo risultante. Eventuali campi del modulo di Word vengono convertiti in controlli corrispondenti in InfoPath.

È possibile utilizzare le impostazioni nella finestra di dialogo Opzioni di importazione di modificare le opzioni per la conversione di un documento di Word in un modello di modulo di InfoPath.

In questo articolo viene spiegato il concetto di base e alla procedura per la conversione di un documento di Word in un modello di modulo di InfoPath, comprese le caratteristiche e impostazioni che non sono supportate nel processo di conversione.

In questo articolo

Informazioni sulla conversione di un documento di Word in un modello di modulo di InfoPath

Caratteristiche di Word e impostazioni che non sono completamente supportate durante la conversione

Convertire un documento di Word in un modello di modulo di InfoPath

Convertire una tabella layout in una tabella ripetuta

Modificare le caselle di controllo a un gruppo di pulsanti di opzione

Esaminare i problemi di conversione nel riquadro attività controllo grafico

Informazioni sulla conversione di un documento di Word in un modello di modulo di InfoPath

Quando si converte un documento di Word in un modello di modulo di InfoPath, il documento viene utilizzato come un progetto per creare un nuovo modello di modulo. La struttura di base del documento verrà ricreata il più possibile nel modello di modulo. Un documento, "è un campo modulo" il percorso in cui è archiviato un particolare tipo di dati, ad esempio un nome o l'indirizzo. Se si sceglie di includere campi modulo di Word quando si converte il documento, una casella di testo, casella di controllo e caselle di riepilogo vengono aggiunti al modello di modulo di InfoPath in una posizione che corrisponde al percorso del file i campi nel documento di Word. Inoltre, InfoPath rileva automaticamente le parti del documento di Word che possono essere utilizzati come tabelle ripetute e caselle di testo RTF e convertirli in controlli appropriati. Ad esempio, se il documento una nota spese include un'area vuota, sottolineata in cui gli utenti possono digitare le note su una particolare spesa, InfoPath tale area verrà convertita in una casella di testo RTF. Gli utenti possono quindi digitare più righe di testo nella casella di testo e formattare il testo in base alle esigenze.

Per comprendere meglio la relazione tra un documento di Word convertito utilizzando la procedura guidata Importazione di InfoPath e il modello di modulo di InfoPath risultante, immaginare per degli ultimi anni l'organizzazione ha utilizzato un documento di Word denominato ExpenseReport.doc per la raccolta di dati della nota spese dei dipendenti. Il reparto IT desidera convertire il documento in un modello di modulo di InfoPath in modo che i dati del modulo possono essere inviati come Extensible Markup Language (XML) a un sistema di contabilità fornitori.

Se si utilizza l'importazione guidata per convertire ExpenseReport.doc in un modello di modulo, in InfoPath viene creato un modello di modulo denominato NotaSpese. Nell'esempio seguente la tabella Dettagli spesa nel documento di Word è stata convertita in una tabella ripetuta nel modello di modulo di InfoPath risultante. Tabella ripetuta consente agli utenti di inserire o rimuovere le spese in base alle esigenze facendo clic su comandi nel menu di scelta rapida.

Tabella di Word che è stata convertita in una tabella ripetuta di InfoPath

Quando il documento di Word viene convertito in un modello di modulo di InfoPath, il layout e altri elementi vengono mantenuti. Per impostazione predefinita, il numero di righe vuote della tabella ripetuta di InfoPath corrisponde al numero di righe vuote nella tabella di Word. Tuttavia, è possibile risparmiare spazio nel modello di modulo visualizzando solo uno o due righe per impostazione predefinita.

Il nuovo modello di modulo contiene elementi simili a quelle disponibili nel documento di Word, ad esempio la tabella di raccolta delle informazioni di spesa. Tuttavia, a seconda delle impostazioni che si è scelto nell'Importazione guidata, alcune caratteristiche potrebbero differire nel modello di modulo risultante:

  • Se si utilizza l'importazione guidata per importare il documento di Word mantenendo il layout solo    Modello di modulo risultante contiene una tabella ripetuta per l'immissione di voci nella nota spese. Tuttavia, eventuali campi del modulo del documento originale, ad esempio la casella di testo Nome, elenco a discesa reparto e caselle di controllo divisione, vengono eliminate dal modello di modulo risultante.

  • Se si utilizza l'importazione guidata per importare il documento di Word mantenendo il layout e tramite la conversione di campi del modulo Word ai controlli (impostazione predefinita)    Modello di modulo risultante contiene una tabella ripetuta per l'immissione di voci nella nota spese. Eventuali campi del modulo del documento originale, ad esempio la casella di testo Nome, elenco a discesa reparto e caselle di controllo divisione, vengono convertiti in controlli di InfoPath corrispondenti.

  • Se si utilizza l'importazione guidata per importare il documento di Word mantenendo il layout e tramite la conversione di campi del modulo ai controlli (personalizzato)    È possibile decidere esattamente quali campi verranno convertiti quando si importa la nota spese. Ad esempio, è possibile disattivare l'opzione per la conversione di celle di tabella vuota nel documento in caselle di testo nel modello di modulo risultante.

Torna all'inizio

Caratteristiche di Word e impostazioni che non sono completamente supportate durante la conversione

Formattazione nei documenti di Word e alcune impostazioni non sono supportate nei modelli di modulo di InfoPath. Quando si converte un documento di Word contenente tali impostazioni, il modello di modulo risultante non conterrà tali caratteristiche e impostazioni. Ad esempio, se il documento di Word include gli indicatori di revisione, i segni di revisione verranno eliminati nel modello di modulo risultante perché InfoPath non supporta questa funzionalità.

È possibile utilizzare il riquadro attività Controllo grafico in modalità progettazione per individuare eventuali problemi di conversione. È quindi possibile intervenire per risolvere i problemi.

Di seguito è un elenco delle caratteristiche e impostazioni che non vengono mantenute quando si converte un documento di Word in un modello di modulo di InfoPath. In alcuni casi, viene eliminata la formattazione ma viene mantenuto il testo sottostante. Ad esempio, se si dispone di colonne in stile notiziario, la InfoPath ignora le colonne, ma importare il testo contenuto in queste colonne.

  • Segnalibri

  • Testo animato

  • Temi

  • Filigrane

  • Numeri di riga

  • Bordi della pagina

  • Note a piè di pagina e di chiusura

  • Layout colonne in stile notiziario

  • File allegati

  • Oggetti collegati o incorporati, ad esempio i disegni di Microsoft Office Visio e fogli di lavoro di Microsoft Office Excel

  • Oggetti disegno, inclusi forme, curve, linee e un oggetto WordArt,

  • Spaziatura dei caratteri (inclusi proporzioni dei caratteri, spaziatura espansa o ridotta elevato o pedice posizionamento del testo e la crenatura per i tipi di carattere)

  • Controlli ActiveX

  • Commenti e revisioni (inclusi inserimenti, eliminazioni e modifiche di formattazione)

  • Alcune caratteristiche specifiche di Microsoft Office Word 2007 (inclusi i blocchi predefiniti e controlli contenuto)

  • Alcune impostazioni (tra cui formattazione carattere mista in intestazioni e piè di pagina, dispari e pari intestazioni e piè di pagina, intestazioni e piè di pagina per la prima pagina, le impostazioni di rilegatura, i valori negativi per i margini superiore e inferiore, orientamenti diversi per la pagina, di stampa e impostazioni di singole sezioni)

Nota: Non è possibile modificare alcuni documenti di Word senza una password. Se si tratta di maiuscole/minuscole con il documento, non sarà possibile importare correttamente in InfoPath. Per risolvere il problema, provare a rimuovere la password di protezione dal documento prima di importare. Inoltre, alcuni documenti di limitano gli utenti a determinati tipi di azioni, ad esempio l'immissione di dati in campi del modulo di modifica. Se si tratta di maiuscole/minuscole con il documento, non sarà possibile importare correttamente in InfoPath. Per risolvere il problema, provare a rimuovere le restrizioni per il documento prima di importare.

L'elenco seguente illustra le caratteristiche e le impostazioni supportate parzialmente quando si converte un documento di Word in un modello di modulo di InfoPath:

Testo verticale    InfoPath mantiene verticale di formattazione del testo in una parola documento se il testo verticale si trova all'interno di una cella della tabella. InfoPath consente di annullare la formattazione per la conversione di un documento di Word se il testo verticale si trova all'esterno di una cella della tabella, in un'altra parte del documento di Word del testo verticale.

Caselle di testo    Nei documenti di Word, caselle di testo sono contenitori di testo che può essere posizionato a una pagina e dimensioni. Se il documento di Word contiene una casella di testo, casella di testo viene convertito in una cella della tabella nel modello di modulo risultante. Il testo eventualmente contenuto nella casella di testo verrà visualizzato nella cella della tabella nel modello di modulo risultante.

Testo sottolineata    La sottolineatura è supportata nei modelli di modulo di InfoPath. Tuttavia, qualsiasi decorativa o doppia sottolineatura nel documento di Word vengono convertita in sottolineature nel modello di modulo risultante.

Collegamenti ipertestuali che fanno riferimento a protocolli non supportati     Vengono convertiti tutti i collegamenti ipertestuali, ma se il collegamento ipertestuale utilizza un protocollo diverso da HTTP, HTTPS, FILE, FTP:// o MAILTO, il collegamento ipertestuale non funziona quando si fa clic sul collegamento nel modello di modulo risultante.

Gli stili di carattere ed effetti di testo    Apice e pedice stili di formattazione barrato vengono mantenuti durante il processo di conversione. Altri stili ed effetti, inclusi testo strutturato, testo nascosto e ombreggiatura, formattazione vengono ignorati durante il processo di conversione. Testo in rilievo o incassato viene convertito in testo grigio nel modello di modulo risultante.

Impostazioni della sezione    In Word, sezioni vengono utilizzate per modificare il layout per un documento all'interno di una pagina o tra le pagine. InfoPath non supporta questi tipi di sezioni, vengono ignorati durante il processo di conversione. Le impostazioni applicate per la prima sezione nel documento di Word vengono applicate al modello di modulo di InfoPath risultante.

Intestazione e piè di pagina formattazione    Testo dell'intestazione e piè di pagina nel documento di Word viene convertito in testo dell'intestazione e piè di pagina nel modello di modulo di InfoPath risultante. Formattazione carattere possono essere ignorata durante il processo di conversione. Ad esempio, se è stata utilizzata la formattazione in grassetto e corsivo nell'intestazione di un documento di Word, InfoPath verrà utilizzato il primo stile di formattazione che incontra nel modello di modulo risultante e annullare la formattazione rimanente. Allo stesso modo, le impostazioni applicate per la prima sezione di intestazione o piè di pagina nel documento di Word vengono applicate all'intestazione risultante o al testo del piè di pagina nel modello di modulo di InfoPath.

Conversione di tipi di carattere    Sebbene InfoPath importi i tipi di carattere da un documento di Word quando si crea un nuovo modello di modulo, se i tipi di carattere nel documento non sono disponibili nel computer in cui si esegue l'importazione, tipi di carattere alternativi verranno automaticamente selezionati per il modello di modulo.

Margini di pagina negativi    Margini superiore e inferiore negativi verranno importati come 0.

Margine negativo, spaziatura e le impostazioni di rientro    Margini negativi, spaziatura e rientri verranno importati come 0.

Torna all'inizio

Convertire un documento di Word in un modello di modulo di InfoPath

  1. Se il documento di Word da importare è aperto, chiuderla.

  2. In modalità progettazione, nel menu File fare clic su Importa modulo.

  3. Nell'Importazione guidata fare clic su utilità di importazione di InfoPath per documenti di Word e quindi fare clic su Avanti.

  4. Fare clic su Sfoglia.

  5. Individuare e fare clic sul documento di Word che si desidera convertire e quindi fare clic su Apri.

    Nota: Se si importa un documento di Word con autorizzazioni limitate, è necessario avere accesso completo al documento. Se si dispone solo accesso in lettura o modifica al documento, verrà visualizzato un messaggio di errore quando si tenta di eseguire l'importazione.

  6. Per modificare il comportamento di importazione predefinito, fare clic su Opzioni e quindi selezionare le opzioni desiderate.

  7. Fare clic su Fine.

Torna all'inizio

Convertire una tabella layout in una tabella ripetuta

Se il documento di Word include una tabella, InfoPath può convertirlo in un tabella layout o una tabella ripetuta nel modello di modulo risultante. Il tipo di tabella prescelto dipende le decisioni apportate nel documento di Word. È possibile utilizzare la procedura seguente per modificare rapidamente una tabella layout convertita in una tabella ripetuta.

È possibile utilizzare le tabelle ripetute per offrire agli utenti un livello di flessibilità quando la compilazione dei moduli. Quando si utilizzano tabelle ripetute, non è disponibile il modello di modulo visualizzare più righe vuote quando l'utente viene aperto prima di tutto. Se, tuttavia, gli utenti in genere vedere solo una riga e solo aggiungerne altri al e se è necessaria. Risparmiare spazio nel modulo e offre agli utenti un livello di personalizzazione.

  1. In modello di modulo, fare clic in un punto qualsiasi all'interno di tabella layout che si desidera convertire.

  2. Menu di scelta rapida, scegliere Cambia in e quindi fare clic su Tabella ripetuta.

  3. Nella finestra di dialogo Cambia in tabella ripetuta eseguire una o più delle operazioni seguenti:

    • Per specificare le righe di intestazione per la tabella ripetuta, immettere un valore nella casella numero di righe da mantenere in un'intestazione di tabella. Riga di intestazione viene generalmente utilizzata per le intestazioni di colonna.

    • Per specificare le righe di piè di pagina per la tabella ripetuta, immettere un valore nella casella numero di righe da mantenere come piè di pagina tabella. Numero di tabelle non include righe piè di pagina.

    • Per specificare il numero di righe di dati da utilizzare, immettere un valore nella casella numero di ripetizione righe da includere durante la compilazione del modulo. Riga di dati è una riga che possa "ripetere" nel modulo il numero di volte in base alle esigenze

  4. Nel menu Inserisci, fare clic su Altri controlli o premere ALT + I, C.

  5. Inserire i controlli desiderati nelle celle della tabella.

Torna all'inizio

Convertire le caselle di controllo in un gruppo di pulsanti di opzione

Se si utilizzano più caselle di controllo in un documento di Word, InfoPath importati come caselle di controllo nel modello di modulo di InfoPath risultante. Se si preferisce utilizzare un gruppo di pulsanti di opzione, seguire la procedura seguente per convertire le caselle di controllo in pulsanti di opzione nel modello di modulo.

È possibile usare un gruppo di pulsanti di opzione in un modello di modulo di Microsoft Office InfoPath per consentire agli utenti la possibilità di effettuare una sola selezione da un numero limitato di opzioni.

  1. Nel modello di modulo, fare clic su una delle caselle di controllo che si desidera convertire, quindi tenere premuto CTRL e fare clic su ogni casella di controllo che si desidera convertire.

  2. Dal menu Modifica scegliere Cambia in e quindi fare clic su Pulsante di opzione.

    Un gruppo di pulsanti di opzione verrà visualizzata al posto le caselle di controllo nel modello di modulo. Ogni pulsante di opzione è associato allo stesso campo nell'origine dati. Quando un utente fa clic su un pulsante di opzione, il valore associato a tale pulsante di opzione viene memorizzato nel campo.

Torna all'inizio

Esaminare i problemi di conversione nel riquadro attività controllo grafico

In alcuni casi, gli elementi dal documento di Word originale non vengono visualizzati come previsto nel modello di modulo di InfoPath risultante o vengono rimossi durante il processo di conversione. Ad esempio, InfoPath non supporta la funzionalità di WordArt di Word e sostituisce gli oggetti WordArt con le immagini segnaposto nel modello di modulo risultante.

Se vengono rilevati problemi durante il processo di conversione, il riquadro attività Controllo grafico viene aperto automaticamente quando si chiude l'importazione guidata. Nel riquadro attività, è possibile consultare l'elenco dei problemi e le misure necessarie per correggerli.

  1. Se il riquadro attività Controllo grafico non è visibile, fare clic su Grafico dal menu Strumenti.

    Se sono presenti problemi con il modello di modulo, si vedranno i messaggi nel riquadro attività.

  2. Nel riquadro attività Controllo grafico, fare clic sul testo del messaggio che si desidera esaminare.

    Una finestra di dialogo Visualizza informazioni aggiuntive sul problema.

    Nota: Se il documento contiene un oggetto che non supporta InfoPath, ad esempio un oggetto disegno di Word, quindi viene aggiunto un'immagine segnaposto per il modello di modulo risultante, che indica l'oggetto è stato originariamente posizione nel documento di Word. Per saperne di più sull'oggetto, destro dell'immagine segnaposto nel modello di modulo e quindi scegliere Altri dettagli dal menu di scelta rapida.

  3. Risolvere i problemi nel modello di modulo, se necessario. Ad esempio, può essere necessario eliminare tutte le immagini segnaposto, non può essere utilizzato nel modello di modulo completato.

Nota: Si noterà che il riquadro attività Controllo grafico contiene un pulsante Aggiorna. Fare clic sul pulsante Aggiorna non è possibile aggiornare i messaggi che vengono visualizzati dopo l'importazione di un documento di Word in InfoPath. Se si desidera rimuovere importare messaggi dal riquadro attività Controllo grafico, è necessario aprire la finestra di dialogo File di risorse (menuStrumenti ) e quindi rimuovere il file denominato ImportErrors. Xml. Il file viene creato automaticamente quando si importa un documento di Word in InfoPath. Dopo aver rimosso il file ImportErrors. XML, fare clic su Aggiorna nel riquadro attività Controllo grafico per eliminare definitivamente i messaggi di importazione. Il file ImportErrors. XML non è necessario per il modello di modulo per il corretto funzionamento. Infatti, per motivi di sicurezza, è consigliabile rimuovere il file prima di pubblicare il modello di modulo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×