Come correggere un errore #VALORE! nella funzione MEDIA o SOMMA

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Se media o somma si riferiscono a celle contenenti #VALUE! errori, le formule comporteranno un #VALUE. Le aree C2:C3 ed E4:E6 non si intersecano, quindi se si immette la formula =SOMMA(C2:C3 E4:E6) verrà restituito l'errore #NULLO!.

Errore #VALORE! in MEDIA

Per ignorare i valori di errore, viene costruita una formula che ignora gli errori nell'intervallo riferimento durante il calcolo della media con i valori "normali" restanti.

Per risolvere questo scenario, viene usata una combinazione di MEDIA e SE più VAL.ERROREper determinare se è presente un errore nell'intervallo specificato. Questo specifico scenario richiede una formula di matrice:

=MEDIA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Questa è una formula in forma di matrice. Quindi è necessario premere invio (solo se si usa Office365) oppure Ctrl + Shift + Enter nella formula.

Nota: Se si dispone di una versione corrente di Office 365, è sufficiente immettere la formula nella cella di output, quindi premere invio per confermare la formula come formula in forma di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando prima la cella di output, immettendo la formula nella cella di output e premendo CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Funzione di matrice in media per risolvere il #VALUE. errore

Nota: La funzione precedente non funziona solo per #VALORE!, ma anche per #N/D, #NULLO, #DIV/0! e altre funzioni.

È possibile usare SOMMA in modo analogo:

=SOMMA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Correggere un errore #VALORE!

Funzione media

Somma (funzione somma

Panoramica delle formule in Excel

Rilevare gli errori nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×