Come correggere un errore #VALORE! nella funzione MATR.TRASPOSTA

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Questo argomento fornisce informazioni su come risolvere l'errore #VALORE! in MATR.TRASPOSTA.

Problema: La formula non è stata immessa come formula di matrice

Vedere l'esempio seguente in cui si usa:

=MATR.TRASPOSTA(B2:C8)

Errore #VALORE! in MATR.TRASPOSTA

La formula restituisce un #VALUE. Le aree C2:C3 ed E4:E6 non si intersecano, quindi se si immette la formula =SOMMA(C2:C3 E4:E6) verrà restituito l'errore #NULLO!.

Soluzione: è necessario convertire la formula in una formula in forma di matrice in un intervallo che corrisponde alle dimensioni dell'intervallo di origine. Per eseguire questa operazione:

  1. Selezionare un intervallo di celle vuote nel foglio di lavoro. Ricordare sempre che il numero di celle vuote selezionate deve essere uguale al numero di celle da copiare. In questo caso è stato selezionato un intervallo con 7 colonne in larghezza e 2 colonne verticali.

  2. Si tratta di una formula di matrice e deve essere immessa con CTRL+MAIUSC+INVIO. Excel inserisce automaticamente la formula tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

L'errore #VALORE! viene risolto quando si preme Ctrl+ALT+INVIO

Nota: Se si dispone di una versione corrente di Office 365, è sufficiente immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere invio per confermare la formula come formula in forma di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando innanzitutto l'intervallo di output, immettendo la formula nella cella superiore sinistra dell'intervallo di output e premendo CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Correggere un errore #VALORE!

TRASporre la funzione

Panoramica delle formule in Excel

Come evitare

Rilevare gli errori nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×