Come correggere un errore #RIF!

Come correggere un errore #RIF!

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

L' #REF. errore viene visualizzato quando una formula fa riferimento a una cella non valida. Questo accade più spesso quando le celle a cui fanno riferimento le formule vengono eliminate o incollate.

Esempio: errore #RIF! causato dall'eliminazione di una colonna

L'esempio seguente usa la formula =SOMMA(B2,C2,D2) nella colonna E.

Una formula che usa riferimenti di cella espliciti come =SOMMA(B2,C2,D2) può causare un errore #RIF! se una colonna viene eliminata.

Se si dovesse eliminare la colonna B, C o D, causerebbe un #REF. errore. In questo caso eliminiamo la colonna C (2007 Sales) e la formula ora legge = Sum (B2, #REF!, C2). Quando si usano riferimenti di cella espliciti come questo (in cui si fa riferimento a ogni cella singolarmente, separati da una virgola) ed eliminano una riga o una colonna a cui si fa riferimento, Excel non può risolverlo, quindi restituisce l'#REF. errore. Questo è il motivo principale per cui l'uso di riferimenti di cella espliciti nelle funzioni non è consigliato.

Esempio di errore #RIF! causato dall'eliminazione di una colonna.

Soluzione

  • Se si eliminano accidentalmente righe o colonne, è possibile ripristinarle facendo subito clic sul pulsante Annulla nella barra di accesso rapido o premendo CTRL+Z.

  • Modificare la formula in modo che usi un riferimento a un intervallo anziché singole celle, ad esempio = Sum (B2: D2). A questo punto è possibile eliminare qualsiasi colonna all'interno dell'intervallo di somma e Excel regola automaticamente la formula. È anche possibile usare = Sum (B2: B5) per una somma di righe.

Esempio: CERCA.VERT con riferimenti a un intervallo non corretti

Nell'esempio seguente =CERCA.VERT(A8,A2:D5,5,FALSO) restituisce un errore #RIF! perché cerca un valore da restituire per la colonna 5, ma l'intervallo di riferimento è A:D, che contiene solo 4 colonne.

Esempio di formula CERCA.VERT con un intervallo non corretto.  La formula è =CERCA.VERT(A8,A2:D5,5,FALSO).  L'intervallo CERCA.VERT non contiene una quinta colonna, quindi 5 restituisce un errore #RIF!.

Soluzione

Regolare l'intervallo per essere più grande o ridurre il valore di ricerca della colonna in base all'intervallo di riferimento. = VLOOKUP (A8, a2: E5; 5; falso) sarebbe un intervallo di riferimento valido, come sarebbe = VLOOKUP (A8, a2: D5, 4, false).

Esempio: INDICE con riferimento di riga o di colonna non corretto

In questo esempio la formula =INDICE(B2:E5,5,5) restituisce un errore #RIF! perché l'intervallo INDICE è di 4 righe per 4 colonne, mentre la formula chiede di restituire il contenuto della quinta riga e della quinta colonna.

Esempio di formula INDICE con un riferimento a un intervallo non valido.  La formula è =INDICE(B2:E5,5,5), ma l'intervallo è solo 4 righe per 4 colonne.

Soluzione

Modificare i riferimenti di riga o colonna in modo che si trovino all'interno dell'intervallo di ricerca dell'indice. = Index (B2: E5; 4; 4) restituirebbe un risultato valido.

Esempio: riferimento a una cartella di lavoro chiusa con INDIRETTO

Nell'esempio seguente una funzione INDIRETTO prova a fare riferimento a una cartella di lavoro chiusa, causando un errore #RIF!.

Esempio di errore #RIF! causato da un riferimento INDIRETTO a una cartella di lavoro chiusa.

Soluzione

Aprire la cartella di lavoro a cui si fa riferimento. Si verificherà lo stesso errore se si fa riferimento a una cartella di lavoro chiusa con una funzione di matrice dinamica.

Problemi OLE

Se si usa un collegamento OLE (Object Linking and Embedding) che restituisce un errore #RIF!, avviare il programma chiamato dal collegamento.

Nota: OLE è una tecnologia che consente di condividere informazioni tra i programmi.

Problemi DDE

Se è stato usato un argomento DDE (Dynamic Data Exchange) che restituisce un #REF. errore, verificare prima di tutto di fare riferimento all'argomento corretto. Se si sta ancora ricevendo un #REF. errore, controllare le impostazioni del Centro protezione per il contenuto esterno come descritto in bloccare o sbloccare il contenuto esterno nei documenti di Office.

Nota: DDE (Dynamic Data Exchange)è un protocollo consolidato per lo scambio di dati tra programmi basati su Microsoft Windows.

Problemi con le macro

Se una macro immette una funzione nel foglio di lavoro che fa riferimento a una cella sopra la funzione e la cella che contiene la funzione è nella riga 1, la funzione restituirà #REF. Poiché non ci sono celle sopra la riga 1. Selezionare la funzione per verificare se un argomento fa riferimento a una cella o a un intervallo di celle non valido. Potrebbe essere necessario modificare la macro in Visual Basic Editor (VBE) per tenere conto della situazione.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×