Che cos'è il salvataggio automatico?

Salvataggio automatico

L'abitudine di salvare spesso appartiene ormai al passato. Ora la funzionalità di salvataggio automatico salva il lavoro ogni pochi secondi, quindi non occorre più farlo manualmente.

Il salvataggio automatico è abilitato quando un file è archiviato in OneDrive, OneDrive for Business o SharePoint Online. Questa funzionalità salva automaticamente le modifiche nel cloud mentre si lavora. Se altre persone stanno lavorando sullo stesso file, il salvataggio automatico consente di visualizzare le modifiche dopo pochi secondi.

Nota : Si usa File > Salva con nome dopo aver apportato modifiche a un documento originale o un modello? Provare invece a usare File > Salva una copia prima di apportare le modifiche. Si eviterà così che il salvataggio automatico sovrascriva il file originale con le modifiche. Nel caso in cui il salvataggio automatico abbia sovrascritto il file con le modifiche, vedere la sezione "Come si annullano le modifiche salvate ma non desiderate?" di seguito.

Il salvataggio automatico in Windows è disponibile in Excel e PowerPoint 2016 per gli abbonati a Office 365. Ecco alcune domande frequenti sull'argomento.

Il salvataggio automatico in Windows è una nuova funzionalità disponibile in Excel e PowerPoint 2016 per gli abbonati a Office 365, che non dovranno più eseguire questa operazione manualmente.

Il salvataggio automatico salva i file a intervalli di pochi secondi, anche se l'intervallo può variare a seconda dei contenuti su cui si lavora.

È possibile ripristinare una versione precedente del file, che verrà considerata come la versione corrente.

Cursore posizionato sul nome file, Visualizza tutte le versioni

Nella parte superiore della finestra fare clic sul nome file, quindi fare clic su Visualizza tutte le versioni. Esaminare le date e le ore per trovare la versione da ripristinare e quindi fare clic su Apri versione. Verrà aperta una seconda finestra. Per ripristinare questa versione, fare clic sul pulsante Ripristina. Per altre informazioni sulla cronologia delle versioni, vedere Visualizzare le versioni storiche dei file di Office.

Se si è proprietari del file, è possibile aggiungere un'impostazione ai file di Excel e Word denominata "Consigliata sola lettura". Quando le persone aprono un file con questa impostazione, verrà visualizzato un messaggio che indica che l'autore consiglia di aprire il file in sola lettura. Per attivare questa impostazione per un file, passare a File > Salva una copia > Sfoglia. Quindi fare clic su Strumenti > Opzioni generali e selezionare la casella di controllo Consigliata sola lettura. Fare clic su OK, quindi salvare il file con un nome diverso o sovrascrivere il file corrente.

Ci sono altri modi per proteggere il file dalla modifica. Se il file si trova in OneDrive, è possibile modificare le autorizzazioni per il file. Se il file si trova in SharePoint, è possibile configurare una raccolta per l'estrazione obbligatoria.

File > Salva una copia

Il comando Salva con nome è assente nel menu File quando si apre un documento da OneDrive, OneDrive for Business o SharePoint Online. In questi casi, nel menu File viene visualizzato il comando Salva una copia.

Si usa molto il comando Salva con nome? Quando elaborano un file, molti utenti sono abituati a scegliere File > Salva con nome per mantenere le modifiche nella copia ma non nell'originale. Tuttavia, quando il salvataggio automatico è attivato, le modifiche vengono salvate continuamente nell'originale. È consigliabile quindi usare File > Salva una copiaimmediatamente se si vuole che le modifiche siano applicate alla copia e non all'originale.

Il comando Salva è assente nel menu File quando si apre un documento da OneDrive, OneDrive for Business o SharePoint Online. In questi casi, il salvataggio automatico è attivo per impostazione predefinita, dunque non c'è bisogno di scegliere File > Salva: il salvataggio avviene automaticamente.

Il pulsante del salvataggio automatico viene visualizzato nell'angolo in alto a sinistra se si è abbonati a Office 365 e sono state installate le versioni più recenti di Excel e PowerPoint 2016 per Windows. Se si ha un account aziendale o dell'istituto di istruzione, l'amministratore può controllare quale versione di Office può essere installata, che potrebbe non corrispondere all'ultima versione. Per altre informazioni, vedere Quando si ottengono le funzionalità più recenti di Office 2016 per Office 365?.

Se non si è abbonati, è comunque disponibile una funzionalità di salvataggio automatico che aiuta a proteggere i file in caso di arresto anomalo del sistema. Se si riapre il file dopo un arresto anomalo, viene visualizzata una versione del file con le ultime modifiche apportate in un riquadro Ripristino documenti. Per altre informazioni su come attivarlo, vedere Proteggere i file in caso di arresto anomalo del sistema.

Il salvataggio automatico viene abilitato quando si lavora su un file salvato in OneDrive, OneDrive for Business o SharePoint Online. Se il file viene salvato in un'altra posizione, il salvataggio automatico viene disabilitato. Questo succede se il file si trova in un sito di SharePoint in locale, un file server o se viene salvato in un percorso locale come C:\.

Ci sono anche altri motivi per cui il salvataggio automatico potrebbe essere disabilitato. Ecco un elenco di quelli più comuni:

  • Il file è in un formato meno recente, ad esempio XLS, PPT o DOC.

  • Il file si trova in una cartella di OneDrive locale e OneDrive è sospeso.

  • Il file viene sincronizzato tramite una versione precedente del client di sincronizzazione di OneDrive. Per altre informazioni sull'aggiornamento di OneDrive, vedere Guida introduttiva al nuovo client di sincronizzazione di OneDrive in Windows.

  • Il file è incorporato in un altro file di Office.

  • La presentazione è in modalità presentazione.

Se si usa Excel ed è stata provata la procedura precedente, il file potrebbe contenere funzionalità non supportate dal salvataggio automatico. Eseguire una o più delle operazioni seguenti per abilitarlo:

  • Disattivare la funzionalità Cartella di lavoro condivisa. Questa funzionalità è un metodo di condivisione precedente. Ha molti limiti ed è stata sostituita dalla creazione condivisa.

  • Se possibile, rimuovere la crittografia password dal file: Passare a File > Informazioni > Proteggi cartella di lavoro. Eliminare la password e fare clic su OK.

  • Se possibile, rimuovere l'accesso limitato: Passare a File > Informazioni > Proteggi cartella di lavoro > Accesso limitato e fare clic su Accesso illimitato.

  • Se si sta aprendo lo snapshot di una cartella di lavoro da SharePoint, aprire il file invece dello snapshot.

  • Disattivare l'opzione Aggiorna dati all'apertura del file per tutte le tabelle e le tabelle pivot del file. Selezionare la tabella o la tabella pivot, quindi passare alla scheda Progettazione di Strumenti tabella > Aggiorna > Proprietà connessione. Infine deselezionare Aggiorna dati all'apertura del file.

  • Disattivare il componente aggiuntivo che causa la disabilitazione del salvataggio automatico. Selezionare File > Opzioni > Componenti aggiuntivi > Componenti aggiuntivi di Excel > Vai, quindi deselezionare la casella di controllo relativa al componente aggiuntivo.

Questa operazione può essere eseguita in due modi. Il primo consiste nel selezionare File > Salva una copia e quindi salvare il file in un altro percorso. In questo modo si potrà elaborare una copia completamente separata del file.

L'altro modo consiste nel disattivare l'opzione Salvataggio automatico prima di procedere con le modifiche. Se le modifiche sono temporanee e non devono essere salvate, chiudere il file. Quindi fare clic su No quando viene richiesto di salvare.

Se non si vogliono che le modifiche siano salvate di continuo e che siano visibili ad altri utenti, è possibile disattivare il salvataggio automatico. Quindi, quando si è pronti, fare clic su Salva per consentire agli altri utenti di visualizzare le modifiche al file su cui si sta lavorando. In alternativa, è anche possibile riattivare l'opzione Salvataggio automatico per salvare e condividere le modifiche.

L'impostazione predefinita per il salvataggio automatico è sempre Attivato per i file presenti nel cloud. Tuttavia, se si disattiva il salvataggio automatico per un file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si torna nuovamente su Attivato per un file, il programma memorizza l'impostazione per lo specifico file.

No. Quando il salvataggio automatico è disattivato, il ripristino automatico continua a funzionare. Per altre informazioni, vedere Proteggere i file in caso di arresto anomalo del sistema. Quando il salvataggio automatico è attivato, il ripristino automatico è disattivato, ma non c'è problema. Il file viene salvato a intervalli di pochi secondi nel cloud. Quindi, in caso di arresto anomalo durante la modifica di un file nel cloud, basta riaprire il file.

No. Tuttavia, è possibile disattivare il salvataggio automatico per un file; il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si lo si riattiva per un solo file, il programma memorizza l'impostazione per lo specifico file.

Argomenti correlati

Collaborare alle cartelle di lavoro di Excel
Collaborare alle presentazioni di PowerPoint
Collaborare ai documenti di Word

Questa caratteristica è disponibile solo per gli abbonati a Office 365 che hanno aderito al programma Office Insider. Se si ha un abbonamento a Office 365, verificare di avere installato la versione più recente di Office.

Il salvataggio automatico nel Mac è disponibile in Excel 2016 per gli abbonati a Office 365. Ecco alcune domande frequenti sull'argomento.

Il salvataggio automatico nel Mac è una nuova funzionalità disponibile in Excel 2016 per gli abbonati a Office 365, che non dovranno più eseguire questa operazione manualmente.

Il salvataggio automatico salva i file a intervalli di pochi secondi, anche se l'intervallo può variare a seconda dei contenuti su cui si lavora.

È possibile ripristinare una versione precedente del file, che verrà impostata come versione corrente. Fare clic su File > Ripristina > Sfoglia cronologia versioni. Nel riquadro Cronologia versioni esaminare le date e le ore per trovare la versione da ripristinare, quindi fare clic su Apri versione. Verrà aperta una seconda finestra. Per ripristinare questa versione, fare clic sul pulsante Ripristina.

Se il file si trova in OneDrive, è possibile modificare le autorizzazioni per il file. Se il file si trova in SharePoint, è possibile configurare una raccolta per l'estrazione obbligatoria.

Il comando Salva con nome è assente nel menu File quando si apre un documento da OneDrive, OneDrive for Business o SharePoint Online. In questi casi, nel menu File viene visualizzato il comando Salva una copia.

Si usa molto il comando Salva con nome? Quando elaborano un file, molti utenti sono abituati a scegliere File > Salva con nome per mantenere le modifiche nella copia ma non nell'originale. Tuttavia, quando il salvataggio automatico è attivato, le modifiche vengono salvate continuamente nell'originale. È consigliabile quindi usare File > Salva una copiaimmediatamente se si vuole che le modifiche siano applicate alla copia e non all'originale.

Il pulsante del salvataggio automatico viene visualizzato nell'angolo in alto a sinistra se si è abbonati a Office 365 ed è stata installata la versione più recente di Excel 2016 per Mac. Se si ha un account aziendale o dell'istituto di istruzione, l'amministratore può controllare quale versione di Office può essere installata, che potrebbe non corrispondere all'ultima versione. Per altre informazioni, vedere Quando si ottengono le funzionalità più recenti di Office 2016 per Office 365?.

Se non si è abbonati, è comunque disponibile una funzionalità di salvataggio automatico che aiuta a proteggere i file in caso di arresto anomalo del sistema. Se si riapre il file dopo un arresto anomalo, viene visualizzata una versione del file con le ultime modifiche apportate in un riquadro Ripristino documenti. Per altre informazioni su come attivarlo, vedere Salvare e ripristinare automaticamente i file.

Il salvataggio automatico viene abilitato quando si lavora su un file salvato in OneDrive, OneDrive for Business o SharePoint Online. Se il file viene salvato in un'altra posizione, il salvataggio automatico viene disabilitato. Questo succede se il file si trova in un sito di SharePoint in locale, un file server o se viene salvato in una cartella locale del computer.

Ci sono anche altri motivi per cui il salvataggio automatico potrebbe essere disabilitato. Ecco un elenco di quelli più comuni:

  • Il file è in un formato meno recente, ad esempio XLS, PPT o DOC.

  • Il file si trova in una cartella di OneDrive locale e OneDrive è sospeso.

  • Il file viene sincronizzato con una versione precedente del client di sincronizzazione di OneDrive. Per altre informazioni sull'aggiornamento di OneDrive, vedere Guida introduttiva al nuovo client di sincronizzazione di OneDrive su Mac OS X.

  • Il file è incorporato in un altro file di Office.

  • La presentazione è in modalità presentazione.

Se si usa Excel ed è stata provata la procedura precedente, il file potrebbe contenere funzionalità non supportate dal salvataggio automatico. Eseguire una o più delle operazioni seguenti per abilitarlo:

  • Disattivare la funzionalità Cartella di lavoro condivisa. Questa funzionalità è un metodo di condivisione precedente. Ha molti limiti ed è stata sostituita dalla creazione condivisa.

  • Se possibile, rimuovere la crittografia password dal file: nella scheda Revisione fare clic su Proteggi cartella di lavoro, quindi eliminare la password e fare clic su OK.

  • Se possibile, rimuovere l'accesso limitato: Passare a File > Limita autorizzazioni > Nessuna restrizione.

  • Se si sta aprendo lo snapshot di una cartella di lavoro da SharePoint, aprire il file invece dello snapshot.

  • Disattivare l'impostazione Aggiorna dati all'apertura del file per tutte le tabelle e le tabelle pivot del file. Selezionare la tabella o la tabella pivot, quindi passare alla scheda Tabella. Fare clic su Aggiorna > Proprietà connessione e deselezionare Aggiorna dati all'apertura del file.

  • Disattivare il componente aggiuntivo che causa la disabilitazione del salvataggio automatico. Selezionare Strumenti > Componenti aggiuntivi di Excel, quindi deselezionare la casella di controllo relativa al componente aggiuntivo.

Questa operazione può essere eseguita in due modi. Il primo consiste nel selezionare File > Salva una copia e quindi salvare il file in un altro percorso. In questo modo si potrà elaborare una copia completamente separata del file.

L'altro modo consiste nel disattivare l'opzione Salvataggio automatico prima di procedere con le modifiche. Se le modifiche sono temporanee e non devono essere salvate, chiudere il file. Quindi fare clic su No quando viene richiesto di salvare.

Se non si vogliono che le modifiche siano salvate di continuo e che siano visibili ad altri utenti, è possibile disattivare il salvataggio automatico. Quindi, quando si è pronti, fare clic su Salva per consentire agli altri utenti di visualizzare le modifiche al file su cui si sta lavorando. In alternativa, è anche possibile riattivare l'opzione Salvataggio automatico per salvare e condividere le modifiche.

L'impostazione predefinita per il salvataggio automatico è sempre Attivato per i file presenti nel cloud. Tuttavia, se si disattiva il salvataggio automatico per un file, il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si torna nuovamente su Attivato per un file, il programma memorizza l'impostazione per lo specifico file.

No. Quando il salvataggio automatico è disattivato, il ripristino automatico continua a funzionare. Per altre informazioni, vedere Salvare e ripristinare automaticamente i file. Quando il salvataggio automatico è attivato, il ripristino automatico è disattivato, ma il file viene salvato comunque a intervalli di pochi secondi nel cloud. Quindi, in caso di arresto anomalo durante la modifica di un file nel cloud, basta riaprire il file.

No. Tuttavia, è possibile disattivare il salvataggio automatico per un file; il programma memorizza l'impostazione e la mantiene quando si riapre il file. Se si lo si riattiva per un solo file, il programma memorizza l'impostazione per lo specifico file.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×