Calcolare la differenza tra due orari

Calcolare la differenza tra due orari

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Si supponga di voler scoprire quanto tempo impiega un dipendente a completare un'operazione in una catena di montaggio o quanto ci vuole per elaborare un ordine a un fast food negli orari di punta. Esistono vari modi per calcolare la differenza tra due orari.

Presentare il risultato nel formato orario standard

Esistono due metodi che è possibile eseguire per presentare i risultati in formato ora standard (ore: minuti: secondi). Si utilizzare l'operatore di sottrazione (-) per trovare la differenza tra le ore e quindi eseguire una delle operazioni seguenti:

Applicare un codice di formato personalizzato alla cella eseguendo le operazioni seguenti:

  1. Selezionare la cella.

  2. Nel gruppo Numero della scheda Home fare clic sulla freccia accanto alla casella Generale, quindi fare clic su Altri formati numeri.

  3. Fare clic su Personalizzato nella finestra di dialogo Formato celle nell'elenco Categoria, quindi selezionare un formato personalizzato nella casella Tipo.

Utilizzare la funzione testo per formattare gli orari: Quando si utilizzano i codici di formato ora, ore mai superano 24 valore 60 minuti e secondi valore 60.

Tabella di esempio 1: Presentare il risultato nel formato ora standard

Copiare la tabella seguente in un foglio di lavoro vuoto e quindi modificare se necessario.

1

2

3


4


5


6

7


8


9

A

B

Orario iniziale

Orario finale

09/06/07 10.35.00

06/09/07 15.30.00

Formula

Descrizione (risultato)

=B2-A2

Ore tra due valori di ora (4). È necessario applicare manualmente il formato personalizzato "h" alla cella.

=B2-A2

Ore e minuti tra due valori di ora (4.55). È necessario applicare manualmente il formato personalizzato "h.mm" alla cella.

=B2-A2

Ore, minuti e secondi tra due valori di ora (4.55.00). È necessario applicare manualmente il formato personalizzato "h.mm.ss" alla cella.

=TESTO(B2-A2;"h")

Ore tra due orari con la cella formattata come "h" usando la funzione TESTO (4).

=TESTO(B2-A2;"h.mm")

Ore e minuti tra due orari con la cella formattata come "h:mm" usando la funzione TESTO (4:55).

=TESTO(B2-A2;"h.mm.ss")

Ore, minuti e secondi tra due orari con la cella formattata come "h:mm:ss" usando la funzione TESTO (4:55:00).

Nota: Se si utilizza sia un formato applicato con la funzione TESTO che un formato di numero applicato alla cella, la funzione TESTO avrà la precedenza sulla formattazione della cella.

Per altre informazioni su come usare queste funzioni, vedere Funzione TESTO e Visualizzare i numeri come date e ore.

Tabella di esempio 2: Presentare il risultato in base a una sola unità di tempo

Per eseguire questa operazione, è necessario utilizzare la funzione INT o le funzioni ora, minutoe secondo , come illustrato nell'esempio seguente.

Copiare tableto seguente un foglio di lavoro vuoto e quindi modificare in base alle esigenze.

1

2

3


4


5


6

7


8


9

A

B

Orario iniziale

Orario finale

09/06/07 10.35.00

06/09/07 15.30.00

Formula

Descrizione (risultato)

=INT((B2-A2)*24)

Totale ore tra due orari (4)

=(B2-A2)*1440

Totale minuti tra due orari (295)

=(B2-A2)*86400

Totale secondi tra due orari (17700)

=ORA(B2-A2)

Differenza in unità di ore tra due valori di ora. Questo valore non può superare 24 (4).

=MINUTO(B2-A2)

Differenza in unità di minuti tra due valori di ora. Questo valore non può superare 60 (55).

=SECONDO(B2-A2)

Differenza in unità di secondi tra due valori di ora. Questo valore non può superare 60 (0).

Per altre informazioni su come usare queste funzioni, vedere Funzione INDICE, Funzione ORA, Funzione MINUTO e Funzione SECONDO.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×