Bozze di elementi di interfaccia di Windows XP

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Il modello Windows XP - Interfaccia utente consente di creare formati di interfacce utente con forme progettate in base agli standard di Microsoft Windows XP. Le forme comprendono gli elementi comunemente utilizzati nelle interfacce, come ad esempio un form vuoto come base di una finestra dell'applicazione, schermate di procedure guidate, forme barra degli strumenti e menu e forme controllo.

È possibile utilizzare le forme per rendere tutti gli elementi da un modello di una finestra dell'applicazione complessa o nella finestra di dialogo a schede in una finestra di messaggio semplice o un singolo pulsante.

Per saperne di più

Creare una singola finestra di dialogo

Creare una finestra a schede

Creare una finestra dell'applicazione

Creare menu e barre degli strumenti

Per creare una finestra di dialogo

  1. Da Finestre e finestre di dialogo trascinare una forma Form vuoto nella pagina di disegno.

  2. Dopo avere selezionato la forma, digitare un titolo per la finestra di dialogo.

  3. Trascinare una forma Pulsanti di Windows nell'estremità destra della barra del titolo e selezionare il tipo di pulsante. In genere vi sono un pulsante Guida e un pulsante Chiudi, disposti da sinistra verso destra.

  4. Aggiungere alcuni pulsanti di comando, ad esempio OK, Annulla e Applica, nell'angolo inferiore destro della forma Form vuoto.

    come

    1. Da Controlli comuni trascinare le forme Pulsante di comando all'estremità inferiore destra della forma Form vuoto.

    2. Selezionare ogni pulsante e digitare il nome del controllo.

  5. Trascinare i controlli appropriati nella forma Form vuoto. Fare clic con il pulsante destro del mouse sulle forme per scegliere le opzioni desiderate.

    Per visualizzare informazioni della Guida su un forma controllo specifica, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

    Se si utilizza lo strumento Testo per creare un testo personalizzato nella forma Form vuoto, formattare il testo utilizzando il carattere Tahoma da 8 punti.

  6. Raggruppare i comandi in gruppi logici.

  7. Trascinare le forme Casella di gruppo e Linea nella forma Form vuoto per separare i gruppi a livello visivo.

    Utilizzare le Guide per allineare i controlli.

    La finestra di dialogo Stampa del menu File è un buon esempio di finestra di dialogo con molti elementi di uso più frequente.

Torna all'inizio

Per creare una finestra di dialogo a schede

  1. Da Finestre e finestre di dialogo trascinare una forma Form vuoto nella pagina di disegno.

  2. Dopo avere selezionato la forma, digitare un titolo per la finestra di dialogo.

  3. Trascinare una forma Pulsanti di Windows all'estremità destra della barra del titolo e selezionare il tipo di pulsante. In genere sono presenti un pulsante ? e un pulsante Chiudi, disposti da sinistra verso destra.

  4. Aggiungere alcuni pulsanti di comando, ad esempio OK, Annulla e Applica, nell'angolo inferiore destro della forma Form vuoto.

    come

    1. Da Controlli comuni trascinare le forme Pulsante di comando all'estremità inferiore destra della forma Form vuoto.

    2. Selezionare ogni pulsante e digitare il nome del controllo.

  5. Trascinare una forma Scheda (corpo) nella forma Form vuoto e ridimensionarla affinché si adatti al form lasciando spazio per le schede.

  6. Trascinare una forma Scheda (schede) e associarla all'estremità superiore della forma Scheda (corpo).

  7. Dopo avere selezionato la forma Scheda (schede), digitare un nome per la scheda.

  8. Ripetere i passaggi 6 e 7 per ogni scheda, associando le schede sia tra loro che alla forma Scheda (corpo).

  9. Fare clic con il pulsante destro del mouse sulla scheda che si desidera visualizzare nella posizione anteriore e scegliere Scheda in primo piano, quindi impostare le altre schede su Scheda in secondo piano.

  10. Trascinare i controlli appropriati nella forma Form vuoto. Fare clic con il pulsante destro del mouse sulle forme per scegliere le opzioni desiderate.

    Per visualizzare informazioni della Guida su un forma controllo specifica, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

    Se si utilizza lo strumento Testo per creare un testo personalizzato nella forma Form vuoto, formattare il testo utilizzando il carattere Tahoma da 8 punti.

  11. Raggruppare i comandi in gruppi logici.

  12. Trascinare le forme Casella di gruppo e Linea nella forma Form vuoto per separare i gruppi a livello visivo.

    Utilizzare le Guide per allineare i controlli.

    La finestra di dialogo Imposta pagina del menu File è un buon esempio di finestra di dialogo con molti degli elementi più comuni.

Torna all'inizio

Per creare una finestra dell'applicazione

  1. Da Finestre e finestre di dialogo trascinare una forma Form vuoto nella pagina di disegno.

  2. Dopo avere selezionato la forma, digitare un titolo per la finestra dell'applicazione.

  3. Per aggiungere un'icona a sinistra del testo nella barra del titolo, fare clic con il pulsante destro del mouse sulla forma Form vuoto e selezionare la casella di controllo Spazio per icona.

  4. Trascinare una forma Pulsanti di Windows all'estremità destra della barra del titolo, quindi selezionare il tipo di pulsante. Sono in genere disponibili tre tipi di pulsante, un pulsante di riduzione a icona, uno di ingrandimento o di ripristino e uno di chiusura, disposti da sinistra verso destra.

  5. Da Barre degli strumenti e menu trascinare una forma Barra dei menu nella forma Form vuoto, associarla alla parte inferiore della barra del titolo, quindi aggiungere le voci di menu.

    come

    1. Trascinare una forma Voce di menu di primo livello nella pagina e associarla all'estremità sinistra della Barra dei menu.

      È possibile posizionare un'icona a sinistra della prima voce di menu.

    2. Dopo avere selezionato la forma, digitare un nome. Se alla voce di menu corrisponde una scelta rapida da tastiera, sottolineare la lettera appropriata.

    3. Ripetere i passaggi 1 e 2, se necessario.

      Per informazioni della Guida su una forma, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

      Per nascondere la connessione punti Immagine del punto di connessione - X blu , nel menu Visualizza fare clic su Punti di connessione.

      È necessario che gli elementi di una colonna abbiano tutti la stessa larghezza dell'elemento più largo.

    Per visualizzare i punti di trascinamento all'estremità sinistra della barra dei menu, fare clic con il pulsante destro del mouse sulla forma e deselezionare la casella di controllo Blocca barra dei menu.

  6. Da Barre degli strumenti e menu trascinare una forma Barra degli strumenti nella forma Form vuoto, associarla alla parte inferiore della barra dei menu, quindi aggiungere i pulsanti della barra degli strumenti.

    come

    1. Trascinare una delle forme Pulsanti barra degli strumenti nella pagina e associarla all'estremità sinistra della forma Barra degli strumenti.

    2. Nella finestra di dialogo Proprietà forma scegliere il tipo di pulsante desiderato. Per cambiare il pulsante in un secondo momento, fare clic con il pulsante destro del mouse sulla forma e scegliere Imposta tipo di pulsante per visualizzare nuovamente la finestra di dialogo Proprietà forma.

    3. Se si desidera, trascinare altre forme Pulsanti barra degli strumenti e Separatore pulsanti, quindi associarle tra loro.

      Per informazioni della Guida su una forma, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

      Per nascondere la connessione punti Immagine del punto di connessione - X blu , nel menu Visualizza fare clic su Punti di connessione.

    Per visualizzare i punti di trascinamento all'estremità sinistra della barra degli strumenti, fare clic con il pulsante destro del mouse sulla forma e deselezionare la casella di controllo Blocca barra degli strumenti.

  7. Da Controlli comuni trascinare le barre di scorrimento orizzontali e verticali, se necessarie, nella parte destra e in quella inferiore della forma Form vuoto.

  8. Fare clic con il pulsante destro del mouse sulle barre di scorrimento e scegliere Imposta dimensione casella di scorrimento per indicare la distanza di scorrimento della finestra.

    Affinché sia visibile soltanto una piccola parte del documento, impostare una dimensione ridotta per la casella di scorrimento. Per rendere visibile la maggior parte del documento, impostare invece una dimensione elevata.

  9. Trascinare una forma Barra di stato nella parte inferiore della finestra dell'applicazione e assegnare il formato appropriato.

    come

    1. Trascinare una forma Divisore barra di stato nella pagina e associarla alla controllo handle immagine del punto di manipolazione di controllo - rombo giallo barra di stato della forma.

      I punti di manipolazione di controllo forniscono una posizione in cui è possibile associare una forma Divisore barra di stato a una forma Barra di stato oppure a un'altra forma Divisore barra di stato.

      Se non è possibile visualizzare la forma Divisore barra di stato dopo averla associata a una forma Barra di stato, selezionare la forma Barra di stato, scegliere Ordine dal menu Forma, quindi Porta indietro.

    2. Trascinare una forma Ridimensionamento finestra all'estremità destra della barra di stato per indicare che la finestra può essere ridimensionata.

Torna all'inizio

Creare menu e barre degli strumenti

È possibile utilizzare le forme di Windows XP per creare i menu, i menu a discesa e le barre degli strumenti di base.

Per creare un menu

  1. Da Barre degli strumenti e menu trascinare una forma Barra dei menu nella pagina di disegno. Per visualizzare i punti di trascinamento all'estremità sinistra della barra dei menu, fare clic con il pulsante destro del mouse sulla forma e deselezionare la casella di controllo Blocca barra dei menu.

  2. Trascinare una forma Voce di menu di primo livello e associarla all'estremità sinistra della Barra dei menu.

    Suggerimento: È possibile posizionare un'icona a sinistra della prima voce di menu.

  3. Dopo avere selezionato la forma, digitare un nome. Se alla voce di menu corrisponde una scelta rapida da tastiera, sottolineare la lettera appropriata.

  4. Ripetere i passaggi 2 e 3, se necessario.

    Per informazioni della Guida su una forma, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

    Per nascondere la connessione punti Immagine del punto di connessione - X blu , nel menu Visualizza fare clic su Punti di connessione.

    È necessario che gli elementi di una colonna abbiano tutti la stessa larghezza dell'elemento più largo.

Per creare un menu a discesa

  1. Trascinare una forma Voce di menu di primo livello nella pagina di disegno.

  2. Dopo avere selezionato la forma, digitare un nome. Se alla voce di menu corrisponde una scelta rapida da tastiera, sottolineare la lettera appropriata.

  3. Trascinare una forma Voce di menu a discesa, associarla alla parte inferiore della forma Voce di menu di primo livello e digitare un nome.

  4. Ripetere il passaggio 3 per tutte le voci di menu a discesa nella colonna.

  5. Ridimensionare tutte le forme Voce di menu a discesa in modo che abbiano la stessa larghezza dell'elemento più largo.

  6. Fare clic con il pulsante destro del mouse su ogni forma Voce di menu a discesa, scegliere Proprietà voce menu e selezionare le opzioni appropriate.

    Per informazioni della Guida su una forma, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

    Per nascondere la connessione punti Immagine del punto di connessione - X blu , nel menu Visualizza fare clic su Punti di connessione.

Per creare una barra degli strumenti

  1. Da Barre degli strumenti e menu trascinare una forma Barra degli strumenti nella pagina di disegno. Per visualizzare i punti di trascinamento all'estremità sinistra della barra degli strumenti, fare clic con il pulsante destro del mouse sulla forma e deselezionare la casella di controllo Blocca barra degli strumenti.

  2. Trascinare una forma Pulsanti barra degli strumenti e associarla all'estremità sinistra della forma Barra degli strumenti.

  3. Nella finestra di dialogo Proprietà forma scegliere il tipo di pulsante desiderato. Se si desidera cambiare il pulsante in un secondo momento, fare clic con il pulsante destro del mouse sulla forma e quindi scegliere Imposta tipo di pulsante per visualizzare nuovamente la finestra di dialogo Proprietà forma.

  4. Trascinare altre forme Pulsanti barra degli strumenti e Separatore pulsanti, se si desidera, e associarle tra loro.

    Per informazioni della Guida su una forma, fare clic con il pulsante destro del mouse su di essa e scegliere ?.

    Per nascondere la connessione punti Immagine del punto di connessione - X blu , nel menu Visualizza fare clic su Punti di connessione.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×