Attività iniziale: creare un sistema di Note riunione con InfoPath e SharePoint

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Apportare modifiche minori a un modello di modulo di esempio da Microsoft Office InfoPath 2007 e creando una raccolta documenti in un sito di Windows SharePoint Services 3.0, è possibile implementare un sistema che è possibile utilizzare per scrivere le note delle riunioni in modo coerente, inviare le note per ogni partecipante alla riunione e archiviare le note in una raccolta documenti di SharePoint Services. In questo articolo viene illustrato come creare questo sistema.

In questo articolo

Panoramica

Prima di iniziare

Creare un nuovo sistema di note della riunione

Aggiornare il modello di modulo

Panoramica

In InfoPath è incluso un modello di modulo di esempio progettati specificamente per la raccolta di dati riunione comuni, ad esempio agende, i partecipanti, gli elementi di discussione e azioni. Il modello di modulo di esempio è configurato in modo che sia possibile inviare una copia di una maschera in cui è basata sul modello tramite posta elettronica per ogni partecipante alla riunione.

Il modello di modulo di esempio è configurato per consentire il verbale raccogliere i dati che in genere registrati in una riunione. I controlli sono disposti in sezioni logiche per semplificare il verbale raccogliere i dati corretti e inoltre scaricare l'immagine dalla raccolta di dati che possono essere generati automaticamente. Il layout dei controlli vengono forniti anche un quadro coerenza fino al posto di verbale dover ricordare quali tipi di dati da raccogliere ha appena riempie gli spazi vuoti durante la riunione.

Sebbene sia possibile modificare il modello di modulo per raccogliere dati aggiuntivi, si consiglia di che utilizzare il modello di modulo esistenti e con una modifica che consente di salvare moduli completati in una raccolta documenti di SharePoint. È quindi possibile verificare l'efficacia del sistema di posta e utilizzare quanto appreso durante la prova per modificare il modello di modulo per soddisfare le esigenze del gruppo.

È possibile utilizzare questo modello di modulo di esempio nel sistema pubblicando prima il modello di modulo di esempio in una nuova raccolta documenti in un sito di SharePoint. È necessario creare una nuova raccolta documenti come parte del processo di pubblicazione. Dopo aver pubblicare il modello di modulo e creare la nuova raccolta documenti, quindi è modificare il modello di modulo, in modo che salva un modulo completato per la nuova raccolta documenti e invia una copia del modulo ai partecipanti alla riunione.

Per utilizzare questo sistema, il verbale passa alla raccolta documenti e crea un nuovo modulo basato su questo modello di modulo. Durante una riunione, il verbale inserisce i dati nei controlli appropriati nella maschera. Al termine della riunione, il verbale invia il modulo alla raccolta documenti e una copia della maschera viene inviata a ogni partecipante alla riunione. Coloro che non hanno partecipato alla riunione possa leggere le note, passare alla raccolta documenti e aprire il modulo in InfoPath.

Il modello di modulo di esempio con le sezioni seguenti:

Modello di modulo Agenda riunione con quattro sezioni

1. sezione del titolo contiene controlli per nome, scopo, posizione e riunione date e ore. Il controllo Data Visualizza automaticamente la data di che creazione del modulo. Per impostazione predefinita, il controllo casella di testo di Data/ora fine Visualizza automaticamente un'ora che è un'ora in un secondo momento rispetto all'ora immesso nel controllo casella di testo Ora di inizio.

2. partecipanti ripetuta sezione contiene controlli per i nomi e indirizzi di posta elettronica di ogni partecipante alla riunione. Quando il verbale invia il modulo completato, ogni partecipante elencato in questa sezione riceve una copia della maschera completata.

3. elemento di discussione sezione ripetuta contiene controlli per ogni relatore (un partecipante che conduce una discussione) e le note su ogni elemento di discussione. Il controllo casella di riepilogo relatore consente di visualizzare i nomi dalla sezione dei partecipanti.

4. azione sezione ripetuta contiene controlli per il nome, l'assegnazione e scadenza Data per ogni azione. Il controllo casella di riepilogo delle assegnazioni vengono visualizzati i nomi dalla sezione dei partecipanti.

Se ha familiarità con InfoPath, gli articoli seguenti consente di concetti importanti e definire meglio i termini che si verifichi dopo il completamento di ogni attività in questo articolo. Sono anche disponibili i collegamenti nelle sezioni appropriate in questo articolo nel caso in cui si desiderano maggiori informazioni dopo il completamento di un'attività.

Torna all'inizio

Prima di iniziare

Si sarà necessario Uniform Resource Locator (URL) e almeno delle autorizzazioni progettazione per la raccolta siti del sito di SharePoint che verrà utilizzato per il sistema. Se è possibile creare una raccolta documenti nella raccolta siti, si dispone delle autorizzazioni appropriate. Persone che hanno l'esigenza di trovare le note riunione verranno autorizzazioni di lettura alla raccolta siti. Se sono necessarie le autorizzazioni per creare una raccolta documenti o impostare le autorizzazioni di lettura per la raccolta siti per gli utenti del modulo, contattare l'amministratore della raccolta siti.

È anche necessario almeno un indirizzo a cui è possibile inviare una copia della maschera completata e client di posta elettronica, ad esempio Microsoft Office Outlook 2007, che è configurato per ricevere i messaggi in modo che è possibile testare il modello di modulo.

In questo articolo si presuppone che si sta utilizzando una configurazione predefinita di SharePoint Services.

Torna all'inizio

Creare un nuovo sistema di note della riunione

Per creare il sistema, verranno eseguire le operazioni seguenti:

  1. Aprire e salvare il modello di modulo di esempio.

  2. Pubblicare il modello di modulo di esempio per creare una nuova raccolta documenti per le note delle riunioni.

  3. Modificare il modello di modulo di esempio per salvare i moduli completati per la nuova raccolta documenti e quindi inviare una copia di ogni partecipante.

  4. Pubblicare il modello di modulo modificato.

  5. Testare il modello di modulo modificato e la nuova raccolta documenti con la creazione e invio di moduli di test basati sul modello di modulo.

Aprire e salvare il modello di modulo

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In aprire un modello di modulo, fare clic su Personalizza un campione.

  3. In Personalizza un campione, fare doppio clic su Agenda riunione di esempio.

  4. Scegliere Salva dal menu File.

  5. Se viene visualizzato un messaggio sulla pubblicazione il modello di modulo, fare clic su OK.

  6. Nella finestra di dialogo Salva con nome specificare il percorso in cui si desidera salvare il modello di modulo.

  7. Nella casella Nome File digitare un nome per il modello di modulo.

  8. Nell'elenco tipo file fare clic su Modello di modulo di InfoPath e quindi fare clic su Salva.

Pubblicare il modello di modulo

Come parte del processo di pubblicazione, è necessario creare una nuova raccolta documenti.

Per ulteriori informazioni sulla pubblicazione di un modello di modulo, vedere l'articolo Introduzione alla pubblicazione di un modello di modulo.

  1. Nel menu File fare clic su pubblica.

  2. La prima pagina della creazione guidata pubblicazione, fare clic su server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare l'URL della raccolta siti nel sito di SharePoint e quindi fare clic su Avanti. Ad esempio, per utilizzare una raccolta siti con l' URL http://www.adventureworks.com/EmployeesOnly, si digita http://www.adventureworks.com/EmployeesOnly nella casella.

  4. Nella pagina successiva, fare clic su Raccolta documenti e quindi fare clic su Avanti.

  5. Nella pagina successiva, fare clic su Crea una nuova raccolta documenti e quindi fare clic su Avanti.

  6. Nella pagina successiva digitare un nome e una descrizione per la nuova raccolta documenti e quindi fare clic su Avanti.

  7. Accettare le colonne suggerite e fare clic su Avanti.

  8. Nell'ultima pagina della procedura guidata, verificare che le informazioni visualizzate siano corrette e quindi fare clic su pubblica.

  9. Fare clic su Chiudi.

    Quando si pubblicare il modello di modulo, si riceverà un messaggio di conferma nell'ultima pagina della procedura guidata.

Annotare l'URL della raccolta documenti nuovi. sarà necessario queste informazioni più avanti in questo articolo. L'URL della raccolta documenti di nuovo sarà l'URL della raccolta siti, seguita da una barra (/), seguita dal nome della raccolta documenti. Ad esempio, se è stata creata una nuova raccolta documenti denominata venditore nella raccolta siti con l' URL http://www.adventureworks.com/EmployeeOnly, l'URL della raccolta documenti di nuovo sarà http://www.adventureworks.com/EmployeeOnly/MeetingNotes.

Modificare il modello di modulo

In questa sezione viene descritto come eseguire le operazioni seguenti:

  • Aggiungere una nuova connessione dati che consente di salvare il modulo completato per la nuova raccolta documenti.

    Per ulteriori che informazioni sull'invio di connessioni dati, vedere Introduzione alle connessioni dati.

  • Modificare le opzioni per la connessione dati in modo che consente di salvare il modulo completato alla raccolta documenti e invia una copia del modulo completato per ogni partecipante alla riunione.

  • Configurare il modello di modulo in modo che chiude il modulo dopo averlo inviato.

Per altre informazioni sull'invio di un modulo basato su un modello di modulo, vedere l'articolo Introduzione all'invio di dati del modulo.

Aggiungere una nuova connessione dati

In questa sezione verrà creata una nuova connessione dati per la nuova raccolta documenti e configurare la connessione dati per salvare la maschera con un nome univoco. Nome del modulo sarà una combinazione di titolo della riunione e la data in cui è stato creato il modulo.

Iniziare a creare la connessione dati
  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione, fare clic su Invia dati e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su in una raccolta documenti in un sito di SharePoint e quindi fare clic su Avanti. Selezione di una destinazione per i dati inviati nella Connessione guidata dati

  5. Nella pagina successiva della procedura guidata, nella finestra di raccolta documenti, digitare l'URL della raccolta documenti creata nella sezione precedente. Ad esempio, per utilizzare una raccolta documenti con l' URL http://www.adventureworks.com/EmployeesOnly/MeetingNotes, si digita http://www.adventureworks.com/EmployeesOnly/MeetingNotes nella finestra di raccolta documenti.

    La sezione successiva i passaggi del processo di definire un nome univoco modulo che richiede all'utente di restare in questa pagina della procedura guidata. Non fare clic su successivo ancora.

Definire un nome univoco modulo

Il modello di modulo Salva il modulo in una raccolta documenti con un nome predefinito. Se si usa il nome predefinito, la nuova raccolta documenti verrà archiviata solo una maschera completata. In questa sezione, configurare la connessione dati per salvare i moduli basati sul modello di modulo con un nome che composta il titolo della riunione e la data di riunione. È mediante la creazione di una formula che usa una funzione XPath .

Per ulteriori informazioni sulle formule e funzioni, vedere aggiungere una formula per un controllo.

  1. Fare clic su Inserisci Formula Icona del pulsante .

  2. Nella finestra di dialogo Inserisci Formula, fare clic su Inserisci funzione.

  3. Nell'elenco categorie della finestra di dialogo Inserisci funzione, fare clic su testo.

  4. Nell'elenco di funzioni, fare clic su concatena e quindi fare clic su OK.

  5. Nella casella Formula fare doppio clic la prima istanza di fare doppio clic per inserire un campo.

    Doppio clic per inserire il primo campo da utilizzare come parte del nome del modulo

  6. Nella finestra di dialogo Seleziona campo o gruppo aprire riunione, fare clic su meetingTitle e quindi fare clic su OK.

    Selezione del campo meetingTitle nella finestra di dialogo Seleziona campo o gruppo

  7. Nella Formula selezionare la seconda istanza di fare doppio clic per inserire un campo per selezionarlo (non fare doppio clic).

    Clic per inserire una lineetta come parte del nome del modulo

  8. Digitare un segno di virgolette doppie ("), seguito da un trattino (-), seguito da un altro segno di virgolette doppie.

    Inserimento di una lineetta come parte nel nome del modulo

  9. Fare doppio clic sulla terza istanza di fare doppio clic per inserire un campo.

    Doppio clic per inserire un altro campo da utilizzare come parte del nome del modulo

  10. Nella finestra di dialogo Seleziona campo o gruppo aprire riunione, fare clic su meetingDate e quindi fare clic su OK.

    Selezione del campo meetingDate nella finestra di dialogo Seleziona campo o gruppo

    Nella finestra di dialogo Inserisci Formula avrà un aspetto simile al seguente:

    Formula completata nella finestra di dialogo Inserisci formula per generare il nome del modulo

  11. Per verificare se la formula per la sintassi corretta, nella finestra di dialogo Inserisci Formula, fare clic su Verifica Formula.

  12. Se la formula non contiene alcun errore, fare clic su OK per chiudere la finestra di dialogo.

Completare la configurazione della connessione dati
  1. Nella procedura guidata, fare clic su Avanti.

  2. Nella pagina successiva della procedura guidata, nella casella Immettere un nome per la connessione dati digitare un nome descrittivo per questa connessione dati.

  3. Verificare che le informazioni siano corrette nella sezione Sommario e quindi fare clic su Fine.

  4. Fare clic su Chiudi.

  5. Scegliere Salva dal menu File.

Modificare le opzioni di invio usare entrambe le connessioni dati invia

  1. Dal menu Strumenti fare clic su Opzioni invio.

  2. Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Esegui azione personalizzata tramite le regole e quindi fare clic su regole.

  4. Nella finestra di dialogo regole per l'invio di moduli, fare clic su Aggiungi.

  5. Fare clic su Aggiungi azione.

  6. Nella casella dell'azione, fare clic su Invia tramite una connessione dati.

  7. Nell'elenco delle connessioni dati, fare clic sulla connessione dati per la raccolta documenti che è stato creato nella sezione precedente e quindi fare clic su OK.

  8. Fare clic su Aggiungi azione.

  9. Nella casella dell'azione, fare clic su Invia tramite una connessione dati.

  10. Nell'elenco delle connessioni dati, fare clic su Invia principale e quindi fare clic su OK.

    Inviare una copia del modulo a ogni partecipante si utilizzerà la connessione dati di invio principale.

  11. Nella casella nome della finestra di dialogo regola digitare regole di invio per identificare la regola appena creata.

  12. Fare clic due volte su OK.

Configurare il modello di modulo per chiudere il modulo dopo averlo inviato.

  1. Nella finestra di dialogo Opzioni invio, fare clic su Avanzate.

  2. Nell'elenco dopo l'invio, fare clic su Chiudi il modulo.

  3. Fare clic su OK.

  4. Scegliere Salva dal menu File.

Pubblicare il modello di modulo

Dopo aver modificato il modello di modulo, è necessario pubblicare alla raccolta documenti per distribuire le modifiche.

  1. Nel menu File fare clic su pubblica.

  2. La prima pagina della creazione guidata pubblicazione, fare clic su server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare la posizione della raccolta documenti nella raccolta siti del sito di SharePoint e quindi fare clic su Avanti.

  4. Nella pagina successiva, fare clic su Raccolta documenti e quindi fare clic su Avanti.

  5. Nella pagina successiva, fare clic su Aggiorna il modello di modulo in una raccolta documenti esistente.

  6. Nell'elenco raccolta documenti per l'aggiornamento, fare clic su raccolta documenti e quindi fare clic su Avanti.

  7. Fare clic su Avanti.

  8. Nella pagina successiva, verificare che le informazioni visualizzate siano corrette e quindi fare clic su pubblica.

    Quando si pubblicare il modello di modulo, si riceverà un messaggio di conferma nell'ultima pagina della procedura guidata.

Testare il modello di modulo e il sito

  1. Nell'ultima pagina della creazione guidata pubblicazione, fare clic su Apri questa raccolta documenti e quindi fare clic su Chiudi.

  2. Nella raccolta documenti fare clic su Nuovo.

  3. Compilare il modulo come se fosse prendere appunti durante una riunione. Dopo avere immesso un orario in ora di inizio controllo casella di testo, premere il tasto TAB per passare al controllo successivo. InfoPath inserirà automaticamente il controllo casella di testo di Data/ora fine.

  4. Immettere l'indirizzo di posta elettronica di un partecipante alla riunione nella casella posta elettronica della sezione dei partecipanti. Per aggiungere altri partecipanti e i relativi indirizzi di posta elettronica, fare clic su Aggiungi partecipanti.

  5. Sulla barra degli strumenti di InfoPath, fare clic su Invia.

  6. Nella finestra di dialogo verificare che siano visualizzati gli indirizzi di posta elettronica corretto.

  7. Fare clic su Invia e quindi fare clic su OK per chiudere la finestra di dialogo.

Le note della riunione deve essere visualizzato nella raccolta documenti e dovrebbero arrivare anche nella posta in arrivo come un nuovo messaggio di posta elettronica.

Il test del sistema mediante la creazione e invio di alcuni moduli basati su questo modello di modulo, è possibile iniziare a usare il sistema per archiviare e distribuire le note della riunione.

Torna all'inizio

Aggiornare il modello di modulo

Dopo che altri utenti hanno provato sistema di creare e salvare le note della riunione, può essere necessario modificare la struttura del modello di modulo in risposta a eventuali suggerimenti relativi. Per apportare modifiche al modello di modulo, è necessario eseguire le operazioni seguenti:

  1. Aprire il modello di modulo dalla raccolta documenti, modificare il modello di modulo in base alle esigenze e quindi salvare le modifiche.

  2. Salvare le modifiche alla raccolta documenti da pubblicare il modello di modulo.

Aprire il modello di modulo dalla raccolta documenti

  1. Aprire la raccolta documenti.

  2. Fare clic su Impostazioni e quindi fare clic su impostazioni Raccolta moduli.

  3. In Impostazioni generali fare clic su impostazioni Avanzate.

  4. Sotto la casella URL modello nella sezione Modello documento, fare clic su Modifica modello.

  5. Se viene visualizzato un messaggio sulla pubblicazione il modello di modulo, fare clic su .

Dopo aver modificato il modello di modulo, salvare il modello di modulo prima della pubblicazione.

Pubblicare il modello di modulo

Dopo aver apportato le modifiche, è necessario pubblicare il modello di modulo modificato alla raccolta documenti.

  1. Nel menu File fare clic su pubblica.

  2. La prima pagina della creazione guidata pubblicazione, fare clic su server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  3. Nella pagina successiva della procedura guidata, nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services, digitare la posizione della raccolta documenti nella raccolta siti del sito di SharePoint e quindi fare clic su Avanti.

  4. Nella pagina successiva, fare clic su Raccolta documenti e quindi fare clic su Avanti.

  5. Nella pagina successiva, fare clic su Aggiorna il modello di modulo in una raccolta documenti esistente.

  6. Nell'elenco raccolta documenti per l'aggiornamento, fare clic su raccolta documenti e quindi fare clic su Avanti.

  7. Fare clic su Avanti.

  8. Nella pagina successiva verificare che le informazioni visualizzate siano corrette e quindi fare clic su pubblica.

  9. Fare clic su Chiudi.

    Si riceverà un messaggio di conferma nell'ultima pagina della procedura guidata quando pubblicate il modello di modulo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×