Aggiungere una connessione dati a un servizio Web

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile aggiungere una o più connessioni dati secondaria al modello di modulo che può eseguire una query o inviare dati a un servizio Web.

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Aggiungere una connessione dati di query

Aggiungere una connessione dati

Panoramica

Una connessione dati secondaria è qualsiasi connessione dati a un'origine dati esterna da aggiungere a un modello di modulo. La connessione dati è la differenza tra la connessione dati principale che viene creata quando si progetta modello di modulo in base a un database, servizio Web o impostazioni in una raccolta di connessioni. Aggiungere una connessione dati secondaria solo se non è possibile eseguire una query o inviare i dati mediante la connessione dati principale.

Quando si aggiunge una connessione dati secondaria al modello di modulo che riceve i dati, Microsoft Office InfoPath consente di creare un secondario origine dati con gruppi e i campi di dati che corrisponde al XML Schema del servizio Web. Poiché la struttura di dati nell'origine dati secondaria deve corrispondere lo Schema XML, non è possibile modificare i campi o i gruppi nell'origine dati secondaria esistenti. Quando si aggiunge una connessione dati al modello di modulo, si configura il modello di modulo per consentire agli utenti di inviare i dati del modulo e configurare le opzioni di invio per i moduli basati sul modello di modulo.

Torna all'inizio

Considerazioni sulla compatibilità

È possibile configurare la connessione dati in un modello di modulo compatibile con browser per consentire agli utenti di invio modificare informazioni insieme i dati del modulo a un servizio Web che accetta un DataSet Microsoft ADO.NET. Modifica informazioni comprendono le modifiche apportate ai dati archiviati in un database di un utente. Il database utilizza un servizio Web per gli utenti di connettersi al database. ADO.NET è possibile usare le informazioni di modifica per determinare la modalità di aggiornare i dati nel database. Chiedere all'amministratore del servizio Web se il servizio Web richiede informazioni sulle modifiche per aggiornare un database. In caso affermativo, è necessario progettare un modello di modulo possono essere compilati cui moduli mediante InfoPath.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati secondaria al modello di modulo, è necessario le seguenti informazioni dall'amministratore del servizio Web:

  • La posizione del servizio Web.

  • Verifica che il servizio Web utilizza una codifica stile documento/letterale. InfoPath può utilizzare solo documento/letterale servizi Web di tipo.

  • Il nome dell'operazione del servizio Web che invia dati a o riceve i dati nei moduli basati sul modello di modulo.

Torna all'inizio

Aggiungere una connessione dati di query

Per consentire agli utenti eseguire query sui dati da un servizio Web usando il modello di modulo, è necessario eseguire le operazioni seguenti nel modello di modulo:

  1. Aggiungere una connessione dati secondaria.

  2. Configurare il modello di modulo per usare la connessione dati secondaria.

Passaggio 1: Aggiungere una connessione dati secondaria

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione a, fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. In dalla quale si desidera ricevere i dati, fare clic su servizio Web e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web e quindi fare clic su Avanti.

    Nota: Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  6. Nell'elenco Selezionare un'operazione nella pagina successiva della procedura guidata, fare clic su operazione del servizio Web che restituisce i dati alla maschera e quindi fare clic su Avanti.

  7. Se la connessione guidata dati rileva un elemento sconosciuto nello schema del servizio Web, la pagina successiva della procedura guidata potrebbe essere richiesto di specificare i valori di esempio per ogni parametro per determinare i campi o gruppi da aggiungere all'origine dati principale.

    Procedura

    1. Selezionare un parametro nella tabella parametri e quindi fare clic su Imposta valore di esempio.

    2. Nella casella valore di esempio, digitare un valore che l'utente può utilizzare per il campo e quindi fare clic su OK.

    3. Ripetere questi passaggi per ogni parametro nella tabella parametri e quindi fare clic su Avanti.

    Dettagli tecnici

    Quando si configura una connessione dati a un servizio Web nella connessione guidata dati, Microsoft Office InfoPath si connette al servizio Web e le richieste di servizio descrizione lingua file WSDL (Web). Il file WSDL contiene lo schema utilizzato dal servizio Web. Il servizio Web risponde alla richiesta inviando il file di InfoPath. Per aggiungere i campi appropriati e i gruppi all'origine dati secondaria nel modello di modulo, InfoPath utilizza le informazioni in questo file. Se viene rilevato un tipo di elemento sconosciuto nel file WSDL, InfoPath utilizza dati di esempio per determinare la definizione del tipo di elemento sconosciuto e ne somma i campi appropriati e i gruppi all'origine dati secondaria.

  8. Se si desidera che i risultati della query sia disponibile quando il modulo non è connesso a una rete, selezionare la casella di controllo memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza: Selezionare questa casella di controllo memorizza i risultati della query nel modello di modulo. Poiché i dati vengono archiviati nel modello di modulo, è disponibile nei moduli compilati dagli utenti, anche se il computer non si è connessi a una rete. Se si ottengono dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  9. Fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata, digitare un nome descrittivo per la connessione dati di query.

  11. Per attivare i moduli basati sul modello di modulo per ricevere automaticamente i dati quando vengono aperti, selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

  12. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

  13. Fare clic su Chiudi.

Passaggio 2: Configurare il modello di modulo per usare la connessione dati secondaria

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Con codice personalizzato, è necessario uno sviluppatore creare il codice personalizzato.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per recuperare dati dalla connessione dati query ogni volta che viene soddisfatta la condizione per la regola. La procedura seguente presuppone che è stata creata una connessione dati di query per il modello di modulo e che sia stato configurato un controllo nel modello di modulo per visualizzare i dati da tale connessione dati.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo che si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In regole di convalida e fare clic su regole.

  5. Nella finestra di dialogo regole fare clic su Aggiungi.

  6. Nella casella nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nella colonna azione, fare clic su Query tramite una connessione dati.

  10. Nell'elenco delle connessioni dati, selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere ogni finestra di dialogo Apri.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che gli utenti possono fare clic su per recuperare dati dalla connessione dati di query. La procedura seguente presuppone che è stata creata una connessione dati di query per il modello di modulo.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare il modello di modulo di un pulsante.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nella colonna azione, fare clic su Aggiorna.

  7. Nella casella etichetta digitare il nome che si desidera venga visualizzato sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su un'origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria, fare clic su origine dati secondaria associata alla connessione dati di query e quindi fare clic su OK per chiudere ogni finestra di dialogo Apri.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Aggiungere una connessione dati

Per consentire agli utenti di inviare moduli basati sul modello di modulo a un servizio Web, prima di tutto aggiungere una connessione dati secondaria al modello di modulo che invia i dati e quindi si configura il modello di modulo per consentire agli utenti di inviare i dati del modulo.

Passaggio 1: Aggiungere una connessione dati secondaria

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione, fare clic su Invia dati e quindi fare clic su Avanti.

  4. In che modo si desidera inviare i dati, fare clic su a un servizio Web e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, digitare il percorso del servizio Web in cui gli utenti verranno inviare i dati e quindi fare clic su Avanti.

    Nota: Se si desidera cercare un servizio Web utilizzando un server Universal Description Discovery e Integration (UDDI), fare clic su Cerca UDDI, immettere l'URL del server UDDI che si desidera eseguire una ricerca, specificare se si desidera eseguire una ricerca dal provider o da un servizio fornito, immettere una parola chiave di ricerca e quindi fare clic su Cerca. Servizi Web che soddisfano i criteri di ricerca verranno visualizzato nell'elenco dei risultati di ricerca. Selezionare il servizio Web che si desidera utilizzare e quindi fare clic su OK.

  6. Nell'elenco Selezionare un'operazione fare clic su operazione del servizio Web che riceverà i dati del modulo, quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata per selezionare i dati del modulo per inviare per ogni parametro nel servizio Web, eseguire una delle operazioni seguenti:

    Inviare i dati in un campo o gruppo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su campo o gruppo.

    3. Fare clic su Modifica Icona del pulsante .

    4. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo o gruppo di cui si desidera inviare i dati e quindi fare clic su OK.

    5. Nella casella Includi fare clic su testo ed elementi figlio solo per inviare solo i dati in questo campo e gli elementi figlio del campo o gruppo oppure fare clic su sottostruttura XML, incluso l'elemento selezionato per inviare il nome del campo, i dati nel campo e elementi figlio nel campo o gruppo selezionato.

    Inviare tutti i dati del modulo

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    Inviare i dati come una stringa

    1. Nell'elenco parametri fare clic sul parametro del servizio Web che riceverà i dati del modulo.

    2. In Opzioni del parametro, fare clic su intero modulo (documento XML, incluse le istruzioni di elaborazione).

    3. Selezionare la casella di controllo Invia dati come una stringa.

      Nota: In genere, si seleziona questa casella di controllo per inviare i dati con firma digitale. Nella maggior parte dei casi, deselezionare questa casella di controllo.

    Nota tecnica sugli oggetti ADO.NET set di dati

    Se il servizio Web richiede un oggetto di set di dati ADO.NET, selezionare un nodo set di dati quando si configura la connessione dati. Se si usa un altro tipo di nodo per una connessione dati a un servizio Web che richiede un oggetto di set di dati ADO.NET, l'azione di invio avrà esito negativo.

  8. Fare clic su Avanti.

  9. Nella pagina successiva della procedura guidata, digitare un nome per la connessione dati.

  10. Verificare che le informazioni nella sezione Riepilogo siano corrette e quindi fare clic su Fine.

  11. Fare clic su Chiudi.

Dopo aver aggiunto secondario connessione dati, è necessario configurare il modello di modulo per consentire agli utenti di inviare i dati del modulo mediante questa connessione dati.

Passaggio 2: Consentire l'invio del modello di modulo

Quando si configura il modello di modulo per consentire agli utenti di inviare i dati del modulo, InfoPath viene aggiunto un pulsante Invia nella barra degli strumenti Standard e un comando Invia al menu File nella maschera. È anche possibile personalizzare le opzioni di invio del modello di modulo nei modi seguenti:

  • Modificare il testo che viene visualizzato il pulsante Invia e il comando Invia.

  • Modificare i tasti di scelta rapida per il pulsante Invia e il comando Invia.

  • Creare messaggi personalizzati per la visualizzazione agli utenti quando si inviano i moduli.

  • Specificare se si desidera lasciare aperta la maschera, chiudere la maschera o aprire un modulo vuoto dopo l'invio.

  • Dal menu Strumenti fare clic su Opzioni invio.

  • Nella finestra di dialogo Opzioni invio, selezionare la casella di controllo Consenti agli utenti di inviare il modulo, fare clic su Invia dati del modulo a una singola destinazione e quindi nell'elenco, fare clic su Servizio Web.

  • Nell'elenco Selezionare una connessione dati per l'invio, fare clic sul nome della connessione dati al servizio Web creato in precedenza.

    1. Per modificare il nome del pulsante Invia visualizzata sulla barra degli strumenti Standard e il comando Invia che viene visualizzato nel menu File, quando gli utenti compilano il modulo, digitare il nuovo nome nella casella etichettaInvia Opzioni nella finestra di dialogo.

      Suggerimento: Se si desidera assegnare una scelta rapida da tastiera per questo pulsante e il comando, digitare una e commerciale (&) prima del carattere che si desidera utilizzare come tasti di scelta rapida. Ad esempio, per assegnare tasti di scelta rapida per il pulsante Invia e il comando ALT + B, digitare in & via.

  • Se non si desidera utilizzare un comando Invia o il pulsante Invia nella barra degli strumenti Standard durante la compilazione del modulo, deselezionare la casella di controllo Mostra il comando di menu e il pulsante Invia.

    1. Per impostazione predefinita, dopo l'invio di un modulo InfoPath mantiene il modulo aperto e viene visualizzato un messaggio per indicare se il modulo è stato inviato. Per modificare il comportamento predefinito, fare clic su Avanzate e quindi eseguire una delle operazioni seguenti:

      • Per chiudere la maschera o creare un nuovo modulo vuoto dopo l'utente invia un modulo completato, fare clic sull'opzione desiderata nell'elenco dopo l'invio.

      • Per creare un messaggio personalizzato per indicare se il modulo è stato inviato, selezionare la casella di controllo Usa messaggi personalizzati e quindi digitare i messaggi nelle caselle successo e in caso di errore.

        Suggerimento: Utilizzare un messaggio nella casella in caso di errore per informare gli utenti cosa fare se non riescono a inviare il modulo. Ad esempio, è possibile suggerire che gli utenti salvino il modulo e per ulteriori informazioni, contattare un utente.

      • Se non si desidera visualizzare un messaggio dopo l'utente invia un modulo, deselezionare la casella di controllo Mostra messaggi esito positivo o negativo.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×