Aggiungere una connessione dati a un database di Microsoft SQL Server

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

È possibile aggiungere una connessione dati secondaria al modello di modulo che richiede un database di Microsoft SQL Server. È possibile aggiungere una connessione dati secondaria al modello di modulo che invia dati a un database. Se si desidera utilizzare una connessione dati secondaria per inviare dati del modulo a un database, usare una connessione dati secondaria a un servizio Web compatibile con tale database. Sono disponibili collegamenti a ulteriori informazioni sull'aggiunta di una connessione dati secondaria a un servizio Web nella sezione Vedere anche.

Per aggiungere una connessione dati secondaria a un database, è necessario eseguire le operazioni seguenti:

Passaggio 1: aggiungere una connessione dati secondaria al modello di modulo    In questo passaggio consente di creare l'origine dati secondaria con i campi appropriati e gruppi in base alla modalità di archiviazione dei dati nel database. È anche possibile configurare il modello di modulo in modo da consentire l'utilizzo della connessione dati all'apertura prima del modulo.

Passaggio 2: configurare il modello di modulo per utilizzare la connessione dati    Se si vuole agli utenti di utilizzare questa connessione dati all'apertura del modulo, è possibile aggiungere una regola o un pulsante al modello di modulo per consentire agli utenti di recuperare dati da questa connessione dati.

In questo articolo

Panoramica

Prima di iniziare

Passaggio 1: Aggiungere una connessione dati secondaria

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Panoramica

Quando si crea un modello di modulo basato su un'origine dati esterna, Microsoft Office InfoPath viene creata una principale connessione dati all'origine dati esterna. Viene quindi creata l'origine dati principale per il modello di modulo in base alla modalità di archiviazione dei dati nell'origine dati esterna. Tuttavia, l'origine dati esterna utilizzata nella connessione dati principale potrebbe non essere i valori che si desidera inserire i controlli nel modello di modulo. Questi valori possono esistere in un'altra origine dati esterna, ad esempio un altro database di SQL Server. Per ottenere valori da un'altra origine dati esterna, è possibile aggiungere una connessione dati secondaria al modello di modulo.

Una connessione dati secondaria è una connessione dati che si aggiunge a un modello di modulo. La connessione dati può essere una connessione dati query o una connessione dati. È possibile aggiungere una connessione dati di query al modello di modulo solo come una connessione dati secondaria a un database di SQL Server. Aggiungere la connessione dati solo se è necessario dati da un'origine dati esterna diversa da quella nella connessione dati principale. È possibile aggiungere una connessione dati a un database di SQL Server come una connessione dati secondaria.

Quando si aggiunge una connessione dati di query a un database, viene creata una secondaria origine dati con campi dati e gruppi corrispondenti in modo che i dati sono stati memorizzati nel database. Perché la struttura di dati nell'origine dati secondaria deve corrispondere al modo che i dati vengono archiviati in tabelle di database, non è possibile modificare i campi o i gruppi nell'origine dati secondaria. È possibile configurare ogni connessione a dati query per salvare i risultati in modo che gli utenti abbiano accesso ai dati quando il modulo non è connesso a una rete. A seconda della natura dei dati, si desidera visualizzare i risultati della query solo quando gli utenti sono connessi a una rete.

Nota sulla sicurezza: Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Con codice personalizzato, è necessario uno sviluppatore creare il codice personalizzato.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati secondaria a un database di SQL Server per il modello di modulo, è necessario le seguenti informazioni all'amministratore del database:

  • Il nome del server con il database che verrà utilizzato con questo modello di modulo.

  • Il nome del database da utilizzare con questo modello di modulo.

  • Autenticazione necessaria per il database. Il database è possibile utilizzare l'autenticazione di Microsoft Windows o l'autenticazione di SQL Server per determinare come gli utenti possano accedere al database.

  • Il nome della tabella contenente i dati che si desidera inviare al modulo. Si tratta della tabella primaria. Se si prevede di utilizzare più di una tabella nel database, è necessario i nomi di queste altre tabelle figlio. È necessario anche i nomi dei campi della tabella figlio che sono state definite relazioni per i campi della tabella primaria.

  • Se è possibile memorizzare i risultati della query nel modulo per l'utilizzo fuori rete.

Torna all'inizio

Passaggio 1: Aggiungere una connessione dati secondaria

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione a, fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su Database (Microsoft SQL Server o solo Microsoft Office Access) e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, fare clic su Seleziona Database.

  6. Nella finestra di dialogo Seleziona origine dati fare clic su Nuova origine.

  7. Nell'elenco il tipo di origine dati si desidera connettersi, fare clic su Microsoft SQL Server e quindi fare clic su Avanti.

  8. Nella casella nome Server digitare il nome del server con il database.

  9. In credenziali di accesso, eseguire una delle operazioni seguenti:

    • Se il database determina chi ha accesso in base alle credenziali usate in una rete Microsoft Windows, fare clic su Usa autenticazione di Windows.

    • Se il database determina chi ha accesso in base a un nome utente specificato e la password che è possibile ottenere dall'amministratore del database, fare clic su utilizza il nome utente e la Password seguenti e quindi digitare il nome utente e la password nel Nome utente e Password caselle.

  10. Fare clic su Avanti.

  11. Nella pagina successiva della procedura guidata, nell'elenco Selezionare il database che contiene i dati desiderati, fare clic sul database che si desidera utilizzare, selezionare la casella di controllo Connetti a una tabella specifica, fare clic sul nome della tabella primaria e quindi fare clic su Avanti.

  12. Nella pagina successiva della procedura guidata, nella casella Nome File digitare un nome per il file che contiene le informazioni di connessione dati.

  13. Per salvare queste impostazioni, fare clic su Fine.

  14. Aggiungere altre tabelle che si desidera utilizzare nella connessione dati query.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Per aggiungere altre tabelle figlio, ripetere questi passaggi.

  15. Fare clic su Avanti.

  16. Per rendere disponibili i risultati della connessione dati query quando la maschera non è connesso a una rete, selezionare la casella di controllo memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza: Selezionare questa casella di controllo memorizza i dati nel computer dell'utente quando il modulo utilizza la connessione dati. Se il modulo dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  17. Fare clic su Avanti.

  18. Nella pagina successiva della procedura guidata, digitare un nome descrittivo per la connessione dati secondaria. Se si desidera ottenere automaticamente i dati all'apertura del modulo, selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

Torna all'inizio

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Se si vuole i moduli basati su questo modello di modulo per utilizzare questa connessione dati dopo l'apertura del modulo, è possibile aggiungere una regola al modello di modulo che utilizza la connessione dati in una determinata condizione oppure è possibile aggiungere un pulsante al modello di modulo che gli utenti possono cli nto consente l'utilizzo della connessione dati.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo per recuperare dati dalla connessione dati query ogni volta che viene soddisfatta la condizione per la regola. La procedura seguente presuppone che è stata creata una connessione dati di query per il modello di modulo e che sia stato configurato un controllo nel modello di modulo per visualizzare i dati da tale connessione dati.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo che si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In regole di convalida e fare clic su regole.

  5. Nella finestra di dialogo regole fare clic su Aggiungi.

  6. Nella casella nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nella colonna azione, fare clic su Query tramite una connessione dati.

  10. Nell'elenco delle connessioni dati, selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere ogni finestra di dialogo Apri.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che gli utenti possono fare clic su per recuperare dati dalla connessione dati di query.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare il modello di modulo di un pulsante.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nella colonna azione, fare clic su Aggiorna.

  7. Nella casella etichetta digitare il nome che si desidera venga visualizzato sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna fare clic su un'origine dati secondaria.

  10. Nell'elenco Selezionare l'origine dati secondaria, fare clic su origine dati secondaria associata alla connessione dati di query.

  11. Fare clic su OK per chiudere le finestre di dialogo aperte.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×