Aggiungere una connessione dati a un database di Microsoft Access

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Se gli utenti saranno necessario dati da un database Microsoft Office Access 2007 (con estensione accdb format) o da un database di Access salvato in una versione precedente (con estensione mdb format) di compilare un modulo basato sul modello di modulo di Microsoft Office InfoPath, è possibile aggiungere una connessione dati secondaria al modulo modello di query un database di Access.

È possibile aggiungere una connessione dati secondaria, ma la connessione dati eseguire una query solo un database di Access. È possibile aggiungere una connessione dati secondaria per inviare dati del modulo a un database di Access.

Se si vuole agli utenti di inviare i dati del modulo a un database di Access, è possibile progettare un modello di modulo basato su un database di Access e quindi attivare la connessione dati invia la connessione dati principale. In alternativa, è possibile aggiungere una connessione dati secondaria a un servizio Web che funziona con database di Access.

Sono disponibili collegamenti a ulteriori informazioni sulla creazione di modelli di modulo basato su un database di Access e aggiungere una connessione dati secondaria a un servizio Web nella sezione Vedere anche.

In questo articolo

Panoramica

Considerazioni sulla compatibilità

Prima di iniziare

Passaggio 1: Aggiungere una connessione dati secondaria

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Panoramica

Un secondario connessione dati è una connessione dati che si aggiunge a un modello di modulo. Una connessione dati secondaria è la differenza tra la connessione dati principale, che vanno creati durante la progettazione di un nuovo modello di modulo basato su un database o un servizio Web. Connessione dati principale di un modello di modulo possa ricevere i dati da un'origine dati esterna e può inoltre inviare dati del modulo a un'origine dati esterna. Tuttavia, un modello di modulo può avere solo una connessione dati principale.

È possibile aggiungere tanti connessioni di dati secondaria a un modello di modulo che si vuole. Si supponga ad esempio, si dispone di un database di Access contenente una tabella in cui sono archiviati i dati sui dipendenti e un'altra tabella contenente i dati dei clienti. È possibile aggiungere una connessione dati secondaria che recupera i dati dalla tabella dipendenti ed è inoltre possibile aggiungere una nuova connessione dati secondaria che recupera i dati dalla tabella clienti nello stesso database di Access.

Ma è possibile aggiungere una connessione dati secondaria al modello di modulo che può inviare dati del modulo a un'origine dati esterna, ad esempio un servizio Web o una raccolta di Windows SharePoint Services, è possibile utilizzare solo le connessioni dati secondaria per recuperare dati da un accesso database. È possibile aggiungere una connessione dati secondaria per inviare dati del modulo a un database di Access.

Quando si aggiunge una connessione dati di query a un database, viene creata una secondaria origine dati che contiene i campi dati e i gruppi che corrispondono in modo che i dati sono stati memorizzati nel database. Perché la struttura di dati nell'origine dati secondaria deve corrispondere al modo che i dati vengono archiviati in tabelle di database, non è possibile modificare i campi o i gruppi nell'origine dati secondaria.

È possibile configurare ogni connessione a dati query per salvare i risultati in modo che gli utenti abbiano accesso ai dati quando il modulo non è connesso a una rete. A seconda della natura dei dati, è consigliabile visualizzare i risultati della query solo quando gli utenti sono connessi a una rete.

Nota sulla sicurezza: Se si utilizza una connessione dati secondaria per recuperare dati riservati da un'origine dati esterna, è consigliabile disabilitare questa caratteristica per proteggere i dati da un utilizzo non autorizzato nel caso in cui è interrotta o furto del computer. Se si disattiva questa caratteristica, i dati sarà disponibili solo se l'utente è connesso alla rete.

Quando si aggiunge una connessione dati di query a un modello di modulo, per impostazione predefinita i moduli basati sul modello di modulo userà la connessione dati quando vengono aperti da un utente. È anche possibile configurare il modello di modulo per l'utilizzo della connessione dati di query in uno dei modi seguenti:

  • Aggiungere una regola    È possibile configurare una regola per l'utilizzo della connessione dati query ogni volta che si verifica la condizione della regola.

  • Pulsante Aggiungi    È possibile aggiungere un pulsante al modello di modulo che consente agli utenti di importare dati utilizzando la connessione dati di query.

  • Utilizzare codice personalizzato    Se non è possibile aggiungere una regola o un pulsante, è possibile utilizzare codice personalizzato per recuperare dati tramite la connessione dati di query. Con codice personalizzato, è necessario uno sviluppatore creare il codice personalizzato.

Torna all'inizio

Considerazioni sulla compatibilità

È possibile aggiungere una connessione dati a un database di Access da un modello di modulo compatibile con browser.

Torna all'inizio

Prima di iniziare

Prima di aggiungere una connessione dati secondaria a un database di Access per il modello di modulo, è necessario le informazioni seguenti:

  • Il nome e il percorso del database.

    Nota: Se il database di Access è archiviato in un percorso di rete, assicurarsi che il database sia accessibile agli utenti.

  • Il nome della tabella o query che fornirà dati per i moduli basati sul modello di modulo. Utilizzare la tabella o query come la tabella primaria o la query quando si configura la connessione dati di query.

  • I nomi di tabelle o query che forniscono dati aggiuntivi per la tabella primaria o la query. Nella maggior parte dei casi, tabella sono già state definite relazioni nel database. Se è necessario effettuare manualmente le relazioni tra la tabella primaria o query e un'altra tabella o la query, sarà necessario i nomi dei campi correlati di entrambe le tabelle o query.

Torna all'inizio

Passaggio 1: Aggiungere una connessione dati secondaria

  1. Dal menu Strumenti fare clic su Connessioni dati.

  2. Nella finestra di dialogo Connessioni dati, fare clic su Aggiungi.

  3. In connessione guidata dati fare clic su Crea una nuova connessione a, fare clic su dati di ricezione e quindi fare clic su Avanti.

  4. Nella pagina successiva della procedura guidata, fare clic su Database (Microsoft SQL Server o solo Microsoft Office Access) e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata, fare clic su Seleziona Database.

  6. Nella finestra di dialogo Seleziona origine dati individuare il percorso del database.

    Nota: Se il database è archiviato in un percorso di rete, selezionare il percorso universal naming convention (UNC) della posizione. Non visualizzare il percorso di rete tramite un'unità di rete. Se si usa un'unità di rete, gli utenti che creano moduli basati sul modello di modulo cercherà il database da un'unità di rete. Se l'utente non dispone di un'unità di rete, la maschera non troverà il database.

  7. Fare clic sul nome del database e quindi fare clic su Apri.

  8. Nella finestra di dialogo Seleziona tabella selezionare la tabella primaria o la query che si desidera utilizzare e quindi fare clic su OK.

  9. Nella pagina successiva della procedura guidata, selezionare la casella di controllo Mostra le colonne della tabella.

    Per impostazione predefinita, tutti i campi della tabella o query vengono aggiunti all'origine dati principale del modello di modulo.

  10. Deselezionare le caselle di controllo per i campi che non si desidera includere nell'origine dati secondaria.

    Aggiungere altre tabelle o query per la connessione dati.

    Procedura

    1. Fare clic su Aggiungi tabella.

    2. Nella finestra di dialogo Aggiungi tabella o Query, fare clic sul nome della tabella figlio e quindi fare clic su Avanti. InfoPath tenta di impostare la visualizzazione relazioni confrontando i nomi dei campi in entrambe le tabelle. Se non si desidera utilizzare la relazione suggerita, selezionare la relazione e quindi fare clic su Rimuovi relazione. Per aggiungere una relazione, fare clic su Aggiungi relazione. Nella finestra di dialogo Aggiungi relazione, fare clic sul nome di ogni campo correlato nella rispettiva colonna e quindi fare clic su OK.

    3. Fare clic su Fine.

    4. Per aggiungere altre tabelle figlio, ripetere questi passaggi.

  11. Fare clic su Avanti.

  12. Per rendere disponibili i risultati della connessione dati query quando la maschera non è connesso a una rete, selezionare la casella di controllo memorizza una copia dei dati nel modello di modulo.

    Nota sulla sicurezza: Selezionare questa casella di controllo memorizza i dati nel computer dell'utente quando il modulo utilizza la connessione dati. Se la maschera è si recuperano dati riservati da questa connessione dati, è consigliabile disabilitare questa caratteristica per proteggere i dati nel caso in cui è interrotta o furto del computer.

  13. Fare clic su Avanti.

  14. Nella pagina successiva della procedura guidata, digitare un nome descrittivo per la connessione dati secondaria e quindi verificare che le informazioni nella sezione Riepilogo siano corrette.

  15. Per configurare il modulo per automaticamente i dati all'apertura del modulo, selezionare la casella di controllo Recupera automaticamente i dati all'apertura di modulo.

Torna all'inizio

Passaggio 2: Configurare il modello di modulo per utilizzare la connessione dati

Se si vuole i moduli basati sul modello di modulo per utilizzare questa connessione dati dopo l'apertura del modulo, è possibile aggiungere un regola al modello di modulo che utilizza la connessione dati in una determinata condizione oppure è possibile aggiungere un pulsante al modello di modulo che gli utenti possono fare clic per utilizzare questa connessione dati.

Aggiungere una regola

È possibile aggiungere una regola al modello di modulo che serve per recuperare i dati dalla connessione dati query ogni volta che viene soddisfatta la condizione per la regola. Ad esempio, è possibile aggiungere una casella di testo per il modello di modulo che si può compilare per ottenere dati specifici da un'origine dati esterna. È quindi possibile aggiungere una regola che utilizza la connessione dati ogni volta che un utente immette dati nella casella di testo.

La procedura seguente presuppone che è stata creata una connessione dati di query per il modello di modulo e che sia stato configurato un controllo (ad eccezione di un pulsante) nel modello di modulo per visualizzare i dati da tale connessione dati.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Fare doppio clic sul controllo che si desidera aggiungere la regola.

  3. Fare clic sulla scheda Dati.

  4. In regole di convalida e fare clic su regole.

  5. Nella finestra di dialogo regole fare clic su Aggiungi.

  6. Nella casella nome digitare un nome per la regola.

  7. Per specificare una condizione quando deve essere eseguita la regola, fare clic su Imposta condizione e quindi immettere la condizione. La regola verrà eseguita quando si verifica la condizione. Se non è una condizione, la regola verrà eseguita ogni volta che l'utente modifica il valore del controllo e quindi sposta il cursore all'esterno del controllo.

  8. Fare clic su Aggiungi azione.

  9. Nella colonna azione, fare clic su Query tramite una connessione dati.

  10. Nell'elenco delle connessioni dati, selezionare la connessione dati per la query che si desidera utilizzare e quindi fare clic su OK per chiudere ogni finestra di dialogo Apri.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Aggiungere un pulsante

È possibile aggiungere un pulsante al modello di modulo che gli utenti possono fare clic su per recuperare dati dalla connessione dati di query.

  1. Se il modello di modulo include più visualizzazioni, fare clic su nome della visualizzazione nel menu Visualizza per passare alla visualizzazione con il controllo in cui si desidera visualizzare i dati di origine dati secondaria.

  2. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  3. Trascinare il modello di modulo di un pulsante.

  4. Fare doppio clic sul pulsante appena aggiunto al modello di modulo.

  5. Fare clic sulla scheda Generale.

  6. Nella colonna azione, fare clic su Aggiorna.

  7. Nella casella etichetta digitare il nome che si desidera venga visualizzato sul pulsante nel modello di modulo.

  8. Fare clic su Impostazioni.

  9. Nella finestra di dialogo Aggiorna eseguire una delle operazioni seguenti:

    • Per ricevere i dati più recenti da tutte le origini dati esterni con le connessioni dati secondaria al modello di modulo, fare clic su tutte le origini dati secondaria.

    • Per configurare il pulsante per ricevere i dati più recenti da un'origine dati esterni con una connessione dati secondaria al modello di modulo, fare clic su una connessione dati secondaria e quindi fare clic su un'origine dati secondaria nell'origine dati Scegli secondario elenco.

  10. Fare clic su OK per chiudere le finestre di dialogo aperte.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×