Aggiungere un pulsante per alternare le viste

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In Microsoft Office InfoPath, è possibile creare visualizzazioni diverse dello stesso modello di modulo. Una visualizzazione è un'alternativa per presentare i dati in un modello di modulo. Durante la compilazione moduli basati sul modello di modulo di utenti possono passare tra le visualizzazioni per scegliere la quantità di dati rappresentati nel modulo. In un modello di modulo rapporto di stato, ad esempio, si potrebbe progettare una visualizzazione Riepilogo oltre a una visualizzazione dettagliata. Gli utenti possono quindi scegliere la visualizzazione preferiscono esaminare, a seconda di quali tipi di informazioni hanno bisogno.

Visualizzazioni sono spesso progettate per funzionare con le regole. Le regole consentono di automatizzare alcune operazioni in un modello di modulo in risposta a eventi o azioni avviate dall'utente compilando il modulo. Ad esempio, in questo articolo descrive come è possibile inserire un pulsante nel modello di modulo e quindi creare una regola per passa da una visualizzazione quando si fa clic su tale pulsante.

In questo articolo

Passaggio 1: Inserire un pulsante in ogni visualizzazione

Passaggio 2: Creare una regola per passa da una visualizzazione

Passaggio 3: Verifica dell'esperienza utente

Passaggio 1: Inserire un pulsante in ogni visualizzazione

Nota: Per completare la procedura seguente, è necessario disporre di un modello di modulo con due visualizzazioni esistenti. Sono disponibili collegamenti a ulteriori informazioni sulla creazione di visualizzazioni, vedere la sezione Vedere anche.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione, fare clic sulla visualizzazione che si desidera aggiungere un pulsante.

  3. Nel modello di modulo, posizionare il cursore nel punto in cui si desidera inserire il pulsante.

  4. Nel menu Inserisci, fare clic su Altri controlli o premere ALT + I, C.

  5. In Inserisci controlli, nel riquadro attività controlli, fare clic su pulsante.

  6. Nel modello di modulo, fare doppio clic sul pulsante appena inserita.

  7. Fare clic sulla scheda Generale.

  8. Nella casella etichetta digitare il testo che si desidera venga visualizzato sul pulsante e quindi fare clic su OK.

  9. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  10. In Selezionare una visualizzazione, fare clic sul nome della seconda vista.

  11. Seguire i passaggi da 3 a 8 per aggiungere un pulsante alla seconda visualizzazione.

Torna all'inizio

Passaggio 2: Creare una regola per passa da una visualizzazione

Dopo aver aggiunto i pulsanti per ogni visualizzazione nel modello di modulo, è necessario creare regole che cambiare visualizzazione facendo clic su questi pulsanti.

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Selezionare una visualizzazione, fare clic sulla visualizzazione che si desidera utilizzare.

  3. Nel modello di modulo, fare doppio clic sul pulsante che si è inserita nella procedura precedente.

  4. Fare clic sulla scheda Generale.

  5. Nella colonna azione, fare clic su regole e codice personalizzato.

  6. Fare clic su regole.

  7. Nella finestra di dialogo regole fare clic su Aggiungi.

  8. Nella casella nome digitare un nome per la regola, ad esempio passare alla visualizzazione 2. Questo nome verrà visualizzato quando si lavora con la visualizzazione in modalità progettazione. Tuttavia, il nome non essere visualizzato dagli utenti compilando il modulo.

  9. Fare clic su Aggiungi azione.

  10. Nella colonna azione, fare clic su Cambia visualizzazione.

  11. Nell'elenco visualizzazione, fare clic sulla visualizzazione che si desidera passare a e quindi fare clic su OK.

  12. Fare clic su OK per chiudere tutte le finestre di dialogo aperte.

  13. Nel riquadro attività visualizzazioni, in Selezionare una visualizzazione, fare clic sulla seconda visualizzazione.

  14. Seguire i passaggi da 3 a 12 per creare una regola per il pulsante nella seconda visualizzazione.

Torna all'inizio

Passaggio 3: Verifica dell'esperienza utente

Dopo aver aggiunto i pulsanti alle visualizzazioni e creato le regole necessarie, è consigliabile verificare il modello di modulo per garantire che il funzionamento previsto.

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

    Nota: La visualizzazione che si stava lavorando più recente è la visualizzazione che verrà visualizzato nella finestra di anteprima.

  2. Per verificare che i pulsanti per cambiare visualizzazione funzionino correttamente, fare clic sui pulsanti creato nella procedura precedente.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×