Aggiungere un campo a una maschera o a un report

È possibile aggiungere rapidamente campi a una maschera o a un report usando il riquadro Elenco campi. Quando si fa doppio clic su un campo nel riquadro Elenco campi oppure si trascina un campo dall'elenco alla maschera o al report, Microsoft Access crea automaticamente il controllo appropriato per visualizzare il campo, ad esempio una casella di testo o una casella di controllo, e quindi associa il controllo al campo.

Se non si ha una maschera o un report esistente a cui aggiungere un campo, vedere Introduzione alle maschere o Introduzione ai report per iniziare.

Cosa si vuole fare?

Aggiungere un campo a una maschera o a un report usando il riquadro Elenco campi

Aggiungere un campo a una maschera o a un report senza usare il riquadro Elenco campi

Altre informazioni sul riquadro Elenco campi

Aggiungere un campo a una maschera o a un report usando il riquadro Elenco campi

  1. Aprire il report in visualizzazione Layout o Struttura.

    Se il riquadro Elenco campi non è visualizzato, eseguire una delle operazioni seguenti:

    • Nel gruppo Strumenti della scheda Struttura fare clic su Aggiungi campi esistenti. Se si usa Access 2007, nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti.
      OPPURE

    • Premere ALT+F8.

  2. Nel riquadro Elenco campi individuare la tabella che contiene il campo da aggiungere. Per visualizzare o nascondere l'elenco di campi per ogni tabella, fare clic sul segno più (+) o meno (-) accanto al nome della tabella.

    Nota: Se il database non contiene tabelle, il riquadro Elenco campi è vuoto.

  3. Dopo avere individuato il campo da aggiungere, eseguire una delle operazioni seguenti per aggiungerlo alla maschera o al report:

    • Fare doppio clic sul campo.

    • Trascinare il campo dal riquadro Elenco campi alla maschera o al report.

    • Fare clic su più campi tenendo premuto CTRL e quindi trascinarli insieme nella maschera o nel report.

      Nota: Questa tecnica può essere usata solo nella sezione Campi disponibili per la visualizzazione del riquadro Elenco campi.

    • Aggiungere un intervallo di campi inclusi nel riquadro Elenco campi alla maschera o al report eseguendo le operazioni seguenti:

    • Fare clic sul primo campo dell'intervallo.

    • Tenendo premuto MAIUSC, fare clic sull'ultimo campo nell'intervallo.

      Verranno selezionati i due campi su cui si è fatto clic, insieme a tutti quelli inclusi nell'intervallo.

    • Trascinare tutti i campi selezionati nella maschera o nel report.

      Nota: Questa tecnica può essere usata solo con i campi inclusi nella sezione Campi disponibili per la visualizzazione del riquadro Elenco campi.

  4. Access crea il controllo appropriato per visualizzare ogni campo e lo associa al campo. Per il controllo viene anche creata un'etichetta allegata. È possibile modificare l'etichetta. A questo scopo, fare clic sull'etichetta per selezionarla e quindi fare clic di nuovo per posizionare il punto di inserimento nell'etichetta. Sarà quindi possibile modificare l'etichetta allo stesso modo in cui si modifica il testo in un documento.

  5. Se si vuole che un campo venga visualizzato in un tipo di controllo diverso da quello creato automaticamente in Access, è possibile modificare il controllo in un altro tipo. Il controllo, tuttavia, può essere modificato solo in un tipo appropriato per il campo. Ad esempio, si può modificare una casella combinata in una casella di testo o una casella di riepilogo, ma non in un pulsante di comando.

    Modificare il tipo di un controllo

    1. Aprire la maschera o il report in visualizzazione Struttura facendo clic con il pulsante destro del mouse sulla maschera o sul report nel riquadro di spostamento e quindi scegliendo Visualizzazione Struttura.

    2. Fare clic con il pulsante destro del mouse sul controllo da modificare e quindi scegliere Cambia in.

      Se la voce di menu Cambia in non è disponibile, non sono presenti altri tipi di controllo appropriati per il campo. In caso contrario, in Access viene visualizzato un elenco di tipi di controllo.

    3. Fare clic su uno dei tipi di controllo disponibili per modificare il controllo di conseguenza.

      Il controllo rimane associato al campo, ma potrebbe essere necessario impostare alcune proprietà affinché il nuovo tipo di controllo funzioni nel modo desiderato. Per visualizzare la finestra delle proprietà per un controllo, fare clic sul controllo per selezionarlo e quindi premere F4.

Inizio pagina

Aggiungere un campo a una maschera o a un report senza usare il riquadro Elenco campi

In generale, usare il riquadro Elenco campi è il modo più semplice per aggiungere un campo a una maschera o a un report. Tuttavia, si può aggiungere un campo anche creando un controllo e quindi associandolo a un campo. Di seguito viene indicata la procedura per eseguire questa operazione.

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla maschera o sul report e quindi scegliere Visualizzazione Layout o Visualizzazione Struttura.

    Creazioni guidate Controllo    È possibile usare le procedure guidate per creare pulsanti di comando, caselle di riepilogo, sottomaschere, caselle combinate e gruppi di opzioni. Una Creazione guidata Controllo visualizza una serie di domande sulle preferenze relative all'aspetto e al funzionamento del controllo, quindi crea il controllo e ne imposta le proprietà in base alle risposte immesse. Nel gruppo Controlli della scheda Progettazione fare clic sulla freccia verso il basso accanto alla raccolta dei controlli. Se il pulsante Usa creazioni guidate Controllo non è evidenziato, fare clic su di esso per evidenziarlo.

    Icona del pulsante

    Se si preferisce creare controlli senza l'ausilio della creazione guidata, fare clic su Usa creazioni guidate Controllo in modo da deselezionarlo.

    Icona del pulsante

  2. Nel gruppo Controlli della scheda Progettazione fare clic sullo strumento corrispondente al tipo controllo che si vuole aggiungere.

    Per determinare il nome di uno strumento, posizionare il puntatore del mouse su di esso. Viene visualizzato il nome dello strumento.

  3. Fare clic sulla griglia di struttura della maschera o del report nel punto in cui si vuole posizionare l'angolo superiore sinistro del controllo. Fare clic una volta per creare un controllo con dimensioni predefinite oppure fare clic sullo strumento e quindi trascinare il mouse nella griglia di struttura per creare un controllo con le dimensioni desiderate.

  4. Se è stato selezionato Usa creazioni guidate Controllo e al controllo che si sta posizionando è associata una procedura guidata, verrà avviata la procedura guidata che consente di impostare il controllo.

  5. Se al primo tentativo non si riesce a posizionare il controllo perfettamente, è possibile spostarlo eseguendo le operazioni seguenti:

    1. Fare clic sul controllo per selezionarlo. Se esiste un'etichetta associata al controllo, fare clic sull'etichetta tenendo premuto CTRL per selezionare entrambi.

    2. Posizionare il puntatore del mouse sul controllo finché non assume la forma di una freccia a quattro punte Puntatore Sposta .

    3. Fare clic e trascinare il controllo nella posizione desiderata.

Se si usa una creazione guidata Controllo, è possibile che la procedura guidata contenga i passaggi che consentono di associare un controllo a un campo. Se la procedura guidata non esegue l'associazione del controllo a un campo e il controllo è di un tipo che consente la visualizzazione di dati, ad esempio una casella di testo o una casella combinata, è necessario immettere un nome di campo o un'espressione nella proprietà Origine controllo per il controllo prima che sia possibile visualizzare i dati. Usare la procedura seguente per associare il controllo a un campo.

  1. Per visualizzare la finestra delle proprietà di un controllo, fare clic su di esso e quindi premere F4.

  2. Nella scheda Dati della finestra delle proprietà fare clic sulla freccia accanto alla proprietà Origine controllo e selezionare il campo che si vuole visualizzare nel controllo. Nella casella Origine controllo è anche possibile digitare un'espressione.

    Per altre informazioni sulle espressioni, vedere l'articolo Generare un'espressione.

Inizio pagina

Altre informazioni sul riquadro Elenco campi

Di seguito sono elencati alcuni suggerimenti utili sull'uso del riquadro Elenco campi per aggiungere campi alla maschera o al report. Per visualizzare il riquadro Elenco campi, aprire una maschera o un report in visualizzazione Layout o Struttura e quindi premere ALT+F8.

  • Se la proprietà Origine record della maschera o del report è vuota e si trascina un campo dal riquadro Elenco campi alla maschera o al report, la proprietà Origine record della maschera o report viene impostata automaticamente.

  • Se la proprietà Origine record della maschera o del report è un'istruzione SELECT o un nome di tabella, è possibile alternare la visualizzazione del riquadro Elenco campi tra i due stati seguenti:

    • Tutti i campi di database    Visualizza le sezioni Campi disponibili per la visualizzazione, Campi disponibili nelle tabelle correlate (se tali tabelle sono presenti) e Campi disponibili in altre tabelle (se tali tabelle sono present).

    • Solo i campi di origine record    Visualizza solo la sezione Campi disponibili per la visualizzazione.

      Per passare tra le due modalità, fare clic su Mostra solo i campi dell'origine record corrente o Mostra tutte le tabelle nella parte inferiore del riquadro Elenco campi.

      Nota: Se la proprietà Origine recorddella maschera o del report è stata impostata su una query salvata, nel riquadro Elenco campi viene visualizzata solo la sezione Campi disponibili per la visualizzazione e nella parte inferiore del riquadro Elenco campi non è disponibile l'opzione Mostra tutte le tabelle. Per modificare l'origine record, fare clic con il pulsante destro del mouse su uno dei campi e quindi scegliere Modifica origine record.

  • Se la proprietà Origine record della maschera o del report è stata impostata su una tabella e quindi si trascina un campo dalla sezione Campi disponibili nelle tabelle correlate del riquadro Elenco campi alla maschera o al report, Access modifica la proprietà Origine record della maschera o del report in un'istruzione SELECT contenente il campo aggiunto. Se Access non è in grado di determinare come correlare le tabelle, viene visualizzata la finestra di dialogo Scegli relazioni, in cui è possibile scegliere la relazione appropriata.

  • Se si trascina un campo dalla sezione Campi disponibili in altre tabelle del riquadro Elenco campi alla maschera o al report, Access visualizzata la finestra di dialogo Specifica relazione. È necessario usare questa finestra di dialogo per specificare una relazione tra l'altra tabella e l'origine record della maschera o del report. In caso di dubbi sui campi da immettere in questa finestra di dialogo, è possibile fare clic su Annulla e quindi esaminare le relazioni tra tabelle.

    Per altre informazioni sulle relazioni, vedere Guida alle relazioni tra tabelle o Creare, modificare o eliminare una relazione.

    È possibile che un campo incluso nella sezione Campi disponibili in altre tabelle del riquadro Elenco campi sia indirettamente correlato all'origine record della maschera o del report tramite una delle tabelle incluse nella sezione Campi disponibili nelle tabelle correlate. In questo caso, se si trascina un campo da una delle tabelle correlate alla maschera o al report, è possibile che una o più tabelle vengano spostate dalla sezione Campi disponibili in altre tabelle alla sezione Campi disponibili nelle tabelle correlate.

  • Se l'origine record della maschera o del report è un'istruzione SELECT o una query salvata, è possibile visualizzarla o modificarla nel Generatore di query facendo clic con il pulsante destro del mouse su un campo nel riquadro Elenco campi e quindi scegliendo Modifica origine record. Se l'origine record è una tabella, questo comando richiama il Generatore di query nella tabella. Access chiede se si vuole creare una query basata sulla tabella. Fare clic su per modificare l'origine record in una query oppure su No per mantenere inalterata l'origine record.

  • È possibile aprire una tabella in visualizzazione Foglio dati facendo clic su Modifica tabella accanto al nome della tabella oppure facendo clic con il pulsante destro del mouse sul nome della tabella nel riquadro Elenco campi e quindi scegliendo Apri tabella in visualizzazione Foglio dati.

  • Si può usare il riquadro Elenco campi per aggiungere un campo di ricerca a una tabella seguendo questa procedura:

    1. Fare clic su Modifica tabella accanto alla tabella in cui si vuole aggiungere il campo di ricerca.

      La tabella viene aperta in visualizzazione Foglio dati.

    2. Trascinare un campo dal riquadro Elenco campi al foglio dati.

    3. Viene avviata la Ricerca guidata. Seguire le istruzioni della procedura guidata. Nell'ultima pagina fare clic su Fine.

  • È possibile disancorare il riquadro Elenco campi dal lato destro dell'area di lavoro di Access posizionando il puntatore sulla barra del titolo del riquadro Elenco campi finché non si trasforma in un puntatore di spostamento Puntatore Sposta e quindi trascinando il riquadro Elenco campi a sinistra. Si può posizionare l'elenco in qualsiasi punto dell'area di lavoro oppure ancorarlo al lato sinistro dell'area di lavoro trascinandolo completamente verso sinistra.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×