Aggiungere testo di Guida personalizzato a un modello di modulo

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Per consentire agli utenti di capire lo scopo del modulo e per aiutarli a compilare, è possibile aggiungere un testo informativo Guida al modello di modulo.

In questo articolo viene spiegato come determinare il tipo di testo della Guida per il modello di modulo da prendere in considerazione fattori quali il tipo di modello di modulo creato al pubblico, come ampiamente verrà distribuito il modello di modulo, e se gli utenti verranno compilare moduli in base ai modello di modulo tramite un Web browser.

In questo articolo

Considerazioni sulla compatibilità

Tipi di Guida

Creare una visualizzazione per visualizzare la Guida

Creare un riquadro attività personalizzato per visualizzare la Guida

Utilizzare la formattazione condizionale per visualizzare la Guida contestuale

Creare un collegamento ipertestuale a un file della Guida esterno o il sito Web

Aggiungere le istruzioni per gli utenti di visualizzare la Guida di InfoPath

Considerazioni sulla compatibilità

Quando si progetta un modello di modulo in Microsoft Office InfoPath 2007, è possibile progettare un modello di modulo compatibile con browser. Quando si progetta un modello di modulo compatibile con browser, alcune caratteristiche non sono disponibili. Ad esempio riquadri attività personalizzati, che vengono spesso utilizzati per visualizzare il testo della Guida personalizzato, non sono supportati nei modelli di modulo compatibile con browser. Per aggiungere contenuto della Guida a un modello di modulo compatibile con browser, è consigliabile un modo alternativo per aggiungere contenuto della Guida, ad esempio utilizzando formattazione condizionale per visualizzare la Guida contestuale.

Torna all'inizio

Tipi di Guida

A seconda della complessità del modello di modulo e le esigenze degli utenti, è possibile aggiungere diversi tipi di testo della Guida, utilizzando procedure diverse. A seconda del modello di modulo, è possibile utilizzare più di un tipo di testo di Guida nel modello di modulo. Di seguito è un elenco dei modi più comuni per visualizzare il testo di Guida nel modello di modulo:

  • Visualizzazione per la Guida    Creare una distinta visualizzazione per visualizzare il testo della Guida quando si desidera fornire istruzioni dettagliate per gli utenti. È possibile creare una visualizzazione della Guida che contiene solo il testo della Guida oppure è possibile duplicare i controlli aggiunti nella visualizzazione predefinita del modello di modulo e includere il testo della Guida corrispondente. Mediante l'aggiunta di controlli con testo della Guida, fornire una visualizzazione alternativa per compilando il modulo, ovvero quella contenente la Guida contestuale per ogni sezione o controllo. Questo è un approccio utile quando i destinatari contengono nuovi utenti che necessitano di ulteriore assistenza e utenti esperti che sa come compilare il modulo.

    Suggerimento: Poiché i modelli di modulo compatibile con browser non supporta i riquadri attività personalizzati, usando le visualizzazioni di Guida per visualizzare il testo della Guida è una buona alternativa ai riquadri attività personalizzati.

  • Riquadro attività personalizzato    Un riquadro attività personalizzato è un file HTML il cui contenuto viene visualizzato in un riquadro attività di InfoPath durante la compilazione di un modulo. È possibile specificare un solo file HTML per aprire il riquadro attività personalizzato predefinito per il modello di modulo, ma è possibile aggiungere altri file HTML al modello di modulo come file di risorse e quindi creare collegamenti ipertestuali tra di esse. Solo i file HTML possono essere visualizzati nei riquadri attività personalizzati. Riquadri attività personalizzati consentono di comandi specifici per una maschera e il contenuto della Guida. È possibile aggiungere un file HTML direttamente al modello di modulo, in modo che gli utenti possono visualizzare il riquadro attività personalizzato anche quando sono compilare il modulo offline o è possibile collegare il riquadro attività personalizzato a un file HTML memorizzati in un altro percorso. Ad esempio, se si intende aggiornare il contenuto della Guida frequentemente, ma non si desidera pubblicare il modello di modulo ogni volta che viene aggiornata del file della Guida HTML, è opportuno archiviare il file HTML in un altro percorso e il collegamento a tale dal riquadro attività personalizzato. Tenere presente che i modelli di modulo compatibile con browser non supporta riquadri attività personalizzati, quindi è necessario creare un riquadro attività personalizzato solo per i moduli che verranno compilati in InfoPath.

  • La formattazione condizionale     È possibile utilizzare la formattazione condizionale per specificare diverse opzioni di formattazione per un controllo che sono in base a condizioni che si verificano nel modulo. Se le condizioni specificate sono vere durante la compilazione di un modulo, viene applicata la formattazione condizionale. Quando si aggiunge il testo della Guida a una sezione nel modello di modulo e aggiungere condizionale formattazione di sezione, consentire all'utente di visualizzare o nascondere contestuale testo della Guida per una sezione o controllo in base alle esigenze, senza cambiare visualizzazione. Questo è utile per fornire all'interno del testo della Guida per sezioni o controlli per la Guida gli utenti specifici.

  • Guida esterna     È possibile aggiungere un collegamento a un file esterno, ad esempio un file HTML in un sito Web. Ad esempio, se il sito Web supporto tecnico dell'organizzazione contiene una pagina Web per avviare una sessione di chat in tempo reale con supporto tecnico, è possibile aggiungere un collegamento ipertestuale al modello di modulo che consente agli utenti di aprire la pagina nel browser Web. Questo approccio è utile quando si progetta un modello di modulo per un altro reparto all'interno dell'organizzazione e la specifica categoria più qualificata per offrire agli utenti assistenza o supporto tecnico.

  • Sistema della Guida di InfoPath per gli utenti che hanno la compilazione dei moduli     InfoPath include un sistema di Guida dedicato per gli utenti che la compilazione dei moduli. Per indicare agli utenti di premere F1 durante la compilazione di un modulo, si consente di accedere a questi argomenti della Guida sulle funzionalità standard di InfoPath. Usare questo approccio per i moduli compilati dagli utenti tramite InfoPath solo.

Torna all'inizio

Creare una visualizzazione per visualizzare la Guida

Per creare una visualizzazione distinta nel modello di modulo per gli utenti di visualizzare la Guida sulle compilando il modulo, è necessario prima di tutto creare una visualizzazione della Guida per il modello di modulo e quindi aggiungere un pulsante di visualizzazione del modulo predefinita che consente agli utenti per accedere alla visualizzazione della Guida.

Creare una visualizzazione della Guida

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. In Azioni nel riquadro attività visualizzazioni fare clic su Aggiungi nuova visualizzazione.

  3. Nella casella Nome nuova visualizzazione digitare un nome per la visualizzazione della Guida in linea e quindi fare clic su OK.

    Ad esempio, digitare Guida.

  4. Nel modello di modulo, fare clic sulla visualizzazione che appena aggiunto e digitare o incollare il testo della Guida che si desidera.

  5. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  6. Nel riquadro attività controlli, fare clic sul pulsante.

  7. Pulsante destro del mouse sul pulsante che è stato aggiunto e quindi scegliere Proprietà pulsante dal menu di scelta rapida.

  8. Fare clic sulla scheda Generale.

  9. Nella casella etichetta digitare un'etichetta per il pulsante. Digitare ad esempio, tornare al modulo.

  10. Fare clic su regole.

  11. Nella finestra di dialogo regole fare clic su Aggiungi.

  12. Fare clic su Aggiungi azione.

  13. Nella casella dell'azione, fare clic su Cambia visualizzazione.

  14. Nella finestra di visualizzazione, fare clic sul nome della visualizzazione predefinita.

  15. Fare clic su OK quattro volte per tornare al modello di modulo.

Dopo aver creato la visualizzazione della Guida per il modello di modulo, è necessario aggiungere un pulsante per la visualizzazione predefinita, in modo che gli utenti possono accedere facilmente la visualizzazione della Guida durante la compilazione del modulo.

Aggiungere un pulsante di visualizzazione predefinita

  1. Nel menu Visualizza fare clic su Gestisci visualizzazioni.

  2. Nel riquadro attività visualizzazioni fare clic sul nome della visualizzazione predefinita.

  3. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  4. Nel riquadro attività controlli, fare clic sul pulsante.

  5. Pulsante destro del mouse sul pulsante che è stato aggiunto e quindi scegliere Proprietà pulsante dal menu di scelta rapida.

  6. Fare clic sulla scheda Generale.

  7. Nella casella etichetta digitare un'etichetta per il pulsante. Ad esempio, digitare Guida.

  8. Fare clic su regole.

  9. Nella finestra di dialogo regole fare clic su Aggiungi.

  10. Fare clic su Aggiungi azione.

  11. Nella casella dell'azione, fare clic su Cambia visualizzazione.

  12. Nella finestra di visualizzazione, fare clic sul nome della visualizzazione della Guida aggiunto nella procedura precedente.

  13. Fare clic su OK quattro volte per tornare al modello di modulo.

Suggerimento: Facoltativamente, è possibile aggiungere gli stessi controlli per la visualizzazione della Guida quelli contenuti nella visualizzazione predefinita. Ciò consente agli utenti la scelta tra compilando il modulo nella visualizzazione predefinita se non è necessario ricevere assistenza oppure usare la visualizzazione della Guida per compilare il modulo se è necessaria vedere le istruzioni riportate nella Guida.

Torna all'inizio

Creare un riquadro attività personalizzato per visualizzare la Guida

Note: Prima di creare un riquadro attività personalizzato per visualizzare la Guida nel modello di modulo, tenere presente quanto segue:

  • Modelli di modulo compatibile con browser non supporta i riquadri attività personalizzati.

  • Prima di attivare un riquadro attività personalizzato, è necessario creare un file HTML per il riquadro attività personalizzato mediante HTML editor, ad esempio Microsoft Office SharePoint Designer 2007.

Per creare e attivare un riquadro attività personalizzato, eseguire le operazioni seguenti:

  1. Dal menu Strumenti fare clic su Opzioni modulo.

  2. In categoria fare clic su programmazione.

  3. Selezionare la casella di controllo Attiva riquadro attività personalizzato.

  4. Nella casella nome riquadro attività digitare il nome che si desidera venga visualizzato nella parte superiore del riquadro attività personalizzato. Ad esempio, digitare Guida.

  5. Per aggiungere un file al modello di modulo, fare clic su File di risorse.

    Nota: Per collegare un file al modello di modulo, nella casella posizione del riquadro attività digitare il percorso assoluto relativa al percorso del file HTML e quindi fare clic su OK.

    Nota sulla sicurezza: Si consiglia di collegare un file HTML che si trova nello stesso dominio il modello di modulo. Gli utenti che aprono una maschera in cui è basata sul modello di modulo in caso contrario, verranno visualizzato un avviso.

  6. Nella finestra di dialogo File di risorse, fare clic su Aggiungi.

  7. Nella finestra di dialogo Aggiungi File individuare e selezionare il file HTML desiderato e fare clic su OK.

  8. Se il file HTML aggiunto fa riferimento ad altri file, ad esempio fogli di stile CSS aggiunta anche tali file.

    Suggerimento: È possibile specificare un solo file HTML per aprire il riquadro attività personalizzato predefinito per il modello di modulo, ma è possibile aggiungere altri file HTML al modello di modulo come file di risorse e quindi creare collegamenti ipertestuali tra di esse.

  9. Nella finestra di dialogo Opzioni modulo, fare clic sul nome del file HTML aggiunti nella casella posizione del riquadro attività.

  10. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL + MAIUSC + B. Il riquadro attività personalizzato appena creata deve essere visualizzato per impostazione predefinita, quando si visualizza in anteprima il modello di modulo.

Torna all'inizio

Utilizzare la formattazione condizionale per visualizzare la Guida contestuale

La procedura seguente viene descritto come utilizzare la formattazione condizionale per mostrare o nascondere la Guida contestuale.

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. Nel riquadro attività controlli, fare clic su casella di controllo e quindi fare clic su sezione.

  3. Fare clic sulla sezione appena aggiunto al modello di modulo e digitare il testo della Guida.

  4. Eliminare il testo dell'etichetta predefinita per la casella di controllo e quindi digitare fare clic per visualizzare o nascondere la Guida.

  5. Fare clic sulla scheda della sezione nel modello di modulo e quindi nel menu formato fare clic su Formattazione condizionale.

  6. Fare clic su Aggiungi.

  7. In se tale condizione è vera, nella prima casella, fare clic su Seleziona campo o gruppo.

  8. Nella finestra di dialogo Seleziona campo o gruppo selezionare il campo che corrisponde al controllo casella di controllo aggiunti nel passaggio 2 e quindi fare clic su OK.

  9. Nella seconda casella, nella finestra di dialogo Formato condizionale, fare clic su è uguale a.

  10. Nella terza casella fare clic su FALSE.

  11. In formattazione da applicare, selezionare la casella di controllo Nascondi controllo.

    Nota: La condizione viene indicato se la casella di controllo è selezionata, verrà visualizzata la sezione.

  12. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Creare un collegamento ipertestuale a un file della Guida esterno o il sito Web

La procedura seguente viene descritto come aggiungere un collegamento ipertestuale dal modello di modulo a un file della Guida esterno, ad esempio un file HTML o un file della Guida (chm) compilato, o a un sito Web, ad esempio un sito Web supporto tecnico.

Note: 

  • Assicurarsi che il file della Guida esterno o il sito Web che si crea un collegamento a sia accessibile agli utenti. Se si desidera aggiungere un collegamento a un file HTML in un modello di modulo compatibile con InfoPath solo (in altre parole, gli utenti devono utilizzare InfoPath per compilare i moduli basati su tale modello), è possibile aggiungere file HTML al modello di modulo aggiungendoli come file di risorse aprono nel riquadro attività personalizzato. Per il modello di modulo compatibile con browser, si dovrà pubblicare i file HTML in un sito accessibile agli utenti preferenza lo stesso sito Web in cui si trova il modello di modulo e creare un collegamento ipertestuale statico nel modello di modulo che punti ai HTML esterno file.

  • Se si decide di usare un altro formato di file della Guida, ad esempio chm, non dimenticare di verificare se il formato di file che si è scelto è supportato nei sistemi operativi nei computer degli utenti.

Creare un collegamento ipertestuale statico in un file esterno

  1. Nel modello di modulo, fare clic nel punto in cui si desidera inserire un collegamento ipertestuale o selezionare il testo o l'immagine che si desidera trasformare in collegamento ipertestuale.

  2. Nella barra degli strumenti Standard fare clic su Inserisci collegamento ipertestuale   Icona del pulsante .

  3. Fare clic sulla scheda Generale.

  4. Nella casella indirizzo digitare l'URL che si desidera creare un collegamento a.

  5. Per modificare il testo del collegamento ipertestuale che viene visualizzato nel modello di modulo, digitare il testo desiderato nella casella di testo.

    Nota: Se è selezionata un'immagine nel passaggio 1, questa opzione è disponibile.

  6. Per assegnare una descrizione comando che verrà visualizzato quando si sposta il puntatore del mouse sul collegamento ipertestuale, fare clic sulla scheda Avanzate e quindi nella casella Descrizione digitare il testo che si desidera visualizzare.

  7. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Torna all'inizio

Aggiungere le istruzioni per gli utenti di visualizzare la Guida di InfoPath

InfoPath include un sistema di Guida dedicato che possa essere usato durante la compilazione dei moduli. Questa Guida in linea contiene informazioni sulle attività comuni, ad esempio attivare o disattivare Completamento automatico e il controllo ortografico del testo in un modulo. I progettisti di moduli, è possibile aprire la Guida di InfoPath per gli utenti dei moduli, premere F1 durante la visualizzazione di un modulo nella finestra di anteprima.

La Guida per gli utenti dei moduli è limitato alle attività che si applicano a tutti i moduli, pertanto è consigliabile fornire una Guida personalizzata per i modelli di modulo progettati personalmente. Per consentire agli utenti di visualizzare la Guida di InfoPath durante la compilazione di un modulo, è possibile aggiungere le istruzioni per il modello di modulo che spiegano come accedere al sistema di Guida di InfoPath. Ad esempio, è possibile includere uno degli esempi seguenti nel modello di modulo:

  • Per aprire la Guida di InfoPath, premere F1.

  • Per aprire la Guida di InfoPath, fare clic su Guida di Microsoft Office InfoPath dal menu ?.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×