Aggiungere, rimuovere o aggiornare file di risorse in un modello di modulo

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Un file di risorse è un file che consente di visualizzare informazioni aggiuntive in un modello di modulo. Quando si salva o pubblica un modello di modulo, eventuali file di risorse sono incluse nel modello di modulo.

È possibile aggiungere i seguenti tipi di file di risorse al modello di modulo:

File HTML    È possibile utilizzare file HTML per visualizzare le informazioni in un riquadro attività personalizzato.

Nota: Quando si aggiunge un file HTML come file di risorse a un modello di modulo, è consigliabile aggiungere anche qualsiasi file richiesti dal file HTML, ad esempio altri file HTML, fogli di stile o file di grafica.

File XML    È possibile usare i file XML per popolare controlli casella di riepilogo, controlli casella combinata o controlli casella di riepilogo a discesa. Se i dati in una casella di riepilogo, una casella combinata o un controllo casella di riepilogo a discesa sono costanti, inserire i dati in un file XML e aggiungere il file al modello di modulo come un file di risorse, piuttosto che utilizzare un connessione dati per popolare i controlli. Quando si utilizza un file di risorse, i moduli basati su tale modello aprire più rapidamente rispetto a moduli che utilizzano una connessione dati per popolare i controlli. Ciò avviene perché i dati in un file di risorse sono considerati parte del modello di modulo e non si basano su una connessione dati per l'accesso ai dati. Se il modello di modulo non è configurato in modo che il modulo sono archiviati i dati da un'origine dati esterna, la maschera deve essere connesso alla rete per ottenere i dati necessari. Un file di risorse non richiede una connessione dati, in quanto i dati sono già parte del modulo.

Per saperne di più

Aggiungere un file di risorse a un modello di modulo

Rimuovere un file di risorse da un modello di modulo

Aggiornare un file di risorse in un modello di modulo

Aggiungere un file di risorse a un modello di modulo

  1. Dal menu Strumenti fare clic su File di risorse.

  2. Nella finestra di dialogo File di risorse, fare clic su Aggiungi.

  3. Nella finestra di dialogo Aggiungi File selezionare il file che si desidera aggiungere.

Torna all'inizio

Rimuovere un file di risorse da un modello di modulo

  1. Dal menu Strumenti fare clic su File di risorse.

  2. Nell'elenco di file di risorse nel modello di modulo nella finestra di dialogo File di risorse, selezionare il file di risorse che si desidera rimuovere dal modello di modulo.

  3. Fare clic su Rimuovi.

Torna all'inizio

Aggiornare un file di risorse in un modello di modulo

È possibile aggiornare il file di risorse in un modello di modulo dopo la pubblicazione di modello di modulo. Ad esempio, è consigliabile aggiungere nuovi elementi o eliminare gli elementi esistenti in un file di risorse che sta utilizzando per popolare una casella di riepilogo nel modello di modulo. Per aggiornare il file di risorse, è necessario modificare una copia del file di risorse e quindi aggiungere il file di risorse aggiornato al modello di modulo. Quando si aggiunge il file di risorse aggiornato al modello di modulo, viene effettivamente sostituito il file di risorse esistenti. Dopo aver aggiunto il file di risorse aggiornato, pubblicare di nuovo il modello di modulo. Gli utenti riceveranno quindi il file di risorse aggiornato all'apertura di un nuovo modulo vuoto basato sul modello di modulo.

  1. Apportare le modifiche necessarie in una copia locale del file di risorse.

    Suggerimento: Se non si dispone di una copia locale del file di risorse, è possibile estrarre una copia dal modello di modulo. Sono disponibili collegamenti a ulteriori informazioni sull'estrazione dei file in un modello di modulo nella sezione Vedere anche.

  2. In modalità progettazione di InfoPath, aprire il modello di modulo che il file di risorse è associato.

  3. Dal menu Strumenti fare clic su File di risorse.

  4. Nella finestra di dialogo File di risorse, fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi File selezionare il file che è stato aggiornato e quindi fare clic su OK.

  6. Nella finestra di dialogo Microsoft Office InfoPath, fare clic su Sostituisci file esistente e quindi fare clic su OK.

  7. Nella finestra di dialogo File di risorse, fare clic su OK.

  8. Per pubblicare il modello di modulo, nel menu File fare clic su pubblica e quindi completare i passaggi della procedura guidata di pubblicazione.

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×