Aggiungere connettori tra le forme

Aggiungere connettori tra le forme

Con Visio diventa facile connettere le forme del disegno. È possibile usare Connessione automatica per connettere le forme aggiunte e quelle già presenti tramite lo strumento Connettore. È anche possibile modificare le forme visualizzate nella barra di formattazione rapida e attivare o disattivare la connessione automatica.

Connettere automaticamente una forma

Connettere forme già presenti nella pagina

Creare una connessione a una forma in un'altra pagina

Usare i temi per cambiare l'aspetto dei connettori

Usare forme connettore alternative

Modificare le forme sulla barra di formattazione rapida Connessione automatica

Attivare o disattivare la connessione automatica

Connettere automaticamente una forma

Uno dei possibili modi per connettere le forme consiste nel lasciar eseguire automaticamente questa operazione da Visio quando si aggiungono forme a una pagina. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

  1. Assicurarsi che l'opzione Connessione automatica sia attiva. Nel gruppo Strumenti visivi della scheda Visualizza verificare che l'opzione Connessione automatica sia selezionata.

  2. Trascinare una forma dal riquadro Forme alla pagina.

  3. Posizionare il puntatore del mouse sulla forma finché attorno a essa non vengono visualizzate frecce di connessione automatica.

    Quando l'opzione Connessione automatica è attiva, passare il puntatore del mouse sopra una forma per visualizzare le frecce di connessione.
  4. Posizionare il puntatore del mouse sulla freccia nella direzione in cui si desidera aggiungere una forma.

    Passando il puntatore del mouse su una freccia di Connessione automatica viene visualizzata una barra degli strumenti con le forme da aggiungere.

    Viene visualizzata una barra di formattazione rapida contenente le prime quattro forme rapide presenti nello stencil Forme rapide. Quando si posiziona il puntatore su una forma nella barra degli strumenti, Visio visualizza l'anteprima corrispondente nella pagina.

  5. Fare clic sulla forma che si desidera aggiungere.

  6. Se si vuole continuare, posizionare il puntatore su una freccia di Connessione automatica su una forma appena aggiunta per aggiungerne un'altra che verrà connessa automaticamente.

    Passando il puntatore del mouse sulla forma appena aggiunta, viene visualizzata l'opzione Connessione automatica che consente di aggiungere un'altra forma.

Inizio pagina

Connettere forme già presenti nella pagina

Suggerimento: I comandi nel gruppo Strumenti della scheda Home modificano lo stato o la modalità di Visio, fatto che in alcuni casi può creare confusione. Usare la tastiera per spostarsi facilmente tra Strumento Selezione Selezione di oggetti (CTRL+1) e Connettore Icona del pulsante (CTRL+3). Qualunque sia lo strumento in uso, ad esempio Blocco di testo o Punto di connessione, premere ESC più volte per tornare a Strumento Selezione.

  1. Nel gruppo Strumenti della scheda Home fare clic su Connettore Icona del pulsante o premere CTRL+3.

  2. Fare clic su una forma e trascinare un connettore su un'altra forma.

  3. Al termine, nel gruppo Strumenti della scheda Home fare clic su Strumento Selezione Selezione di oggetti o premere CTRL+1.

Lo strumento Connettore connette due forme con una connessione punto a punto a ogni estremità.

In alternativa, è possibile aggiungere il comando Connetti forme alla barra multifunzione e usarlo per connettere più forme nell'ordine in cui sono state selezionate.

Suggerimento: I comandi utili che non sono già visibili sulla barra multifunzione possono essere aggiunti scegliendo File > Opzioni > Personalizza barra multifunzione.

Inizio pagina

Creare una connessione a una forma in un'altra pagina

È possibile usare connettori solo tra le forme nella stessa pagina. Per creare una connessione a una forma in un'altra pagina, usare la forma Riferimento esterno pagina per creare un collegamento ipertestuale da una pagina alla successiva oppure aggiungere un collegamento ipertestuale e un'azione Doppio clic a qualsiasi forma in modo che possa passare a un'altra pagina nello stesso documento.

Usare Riferimento esterno pagina

  1. Aprire lo stencil Diagramma di flusso - Forme base e quindi trascinare la forma Riferimento esterno pagina nella pagina corrente.

    Forma Riferimento esterno pagina
  2. Nella finestra di dialogo Riferimento esterno pagina fare clic su OK per aggiungere la forma alla pagina corrente e una nuova pagina.

  3. Nella nuova pagina continuare a creare il diagramma.

  4. Per modificare l'aspetto della forma Riferimento esterno pagina, fare clic con il pulsante destro del mouse sulla forma e quindi scegliere In uscita, In ingresso, Cerchio o Freccia.

Per spostarsi tra le pagine, fare doppio clic sulla forma Riferimento esterno pagina in una delle pagine. Per altre informazioni, vedere Finestra di dialogo Riferimento esterno pagina.

Usare Collegamento ipertestuale e Doppio clic

  1. Fare clic con il pulsante destro del mouse su qualsiasi forma oppure premere CTRL+K e quindi scegliere Collegamento ipertestuale.

  2. Fare clic su Sfoglia accanto al campo Sottoindirizzo e quindi selezionare la pagina che si vuole nell'elenco a discesa accanto a Pagina.

    Finestra di dialogo Collegamento ipertestuale

    Nota: Il nome di una forma nella pagina di destinazione può essere specificato anche per un collegamento ipertestuale. Fare clic sulla scheda Sviluppo e scegliere Nome forma. Usare il nome predefinito nel campo Nome oppure modificarlo e quindi fare clic su OK.

  3. Per impostare l'azione doppio clic per una forma, fare clic sulla scheda Sviluppo e quindi scegliere Comportamento.

  4. Fare clic sulla scheda Doppio clic, selezionare l'opzione Vai a pagina e quindi selezionare la pagina che si vuole nell'elenco a discesa.

    Azione di doppio clic in Visio

    Nota: Eseguire questa operazione dopo aver modificato i nomi delle pagine perché qui non vengono aggiornati automaticamente.

Inizio pagina

Usare i temi per cambiare l'aspetto dei connettori

I connettori possono essere semplici righe per impostazione predefinita, ma è possibile progettarli per la compatibilità con temi che aggiungono dettagli decorativi, ad esempio punte di frecce. I temi predefiniti possono essere applicati dalla raccolta Temi nella scheda Progettazione.

Note: 

  • Per visualizzare altre decorazioni, fare clic sulla scheda Progettazione. Nel gruppo Varianti fare clic sulla freccia a discesa e quindi selezionare Connettori.

Usare forme connettore alternative

Per connettere le forme è possibile usare qualsiasi forma di connettore, ad esempio quelle disponibili nello stencil Altre forme > Visio Extra > Connettori, al posto della forma predefinita Connettore dinamico. Possono essere trascinate in una pagina o selezionate con gli strumenti Connettore e Connetti forme oppure usate semplicemente in sostituzione dei connettori esistenti.

  1. Aprire lo stencil contenente le forme di connettore alternative.

  2. Nella pagina selezionare i connettori esistenti da sostituire.

  3. Nel gruppo Modifica della scheda Home fare clic su Cambia forma e selezionare la forma del connettore che si vuole.

Nota: La funzionalità Cambia forma è stata introdotta in Visio 2013, mentre gli strumenti Connettore e Connetti forme sono precedenti a Visio 2007.

Inizio pagina

Modificare le forme sulla barra di formattazione rapida Connessione automatica

Le forme sulla barra di formattazione rapida provengono dallo stencil Forme rapide di un diagramma. La barra di formattazione rapida può visualizzare fino a quattro forme. È possibile personalizzare le forme presenti nella barra di formattazione rapida. La procedura seguente usa come esempio il Diagramma base.

  1. Per impostazione predefinita, le forme nella barra di formattazione rapida sono le prime quattro nello stencil che segue immediatamente lo stencil Forme rapide. Ad esempio, queste sono le prime quattro forme dello stencil Forme base.

    Barra di formattazione rapida con forme base predefinite
  2. Per visualizzare forme diverse nella barra di formattazione rapida per un determinato stencil, è possibile riordinare le forme trascinandole nella parte superiore dello stencil. Ad esempio, è possibile trascinare le forme Stella a 4 punte, Stella a 5 punte, Stella a 6 punte e Stella a 7 punte nella parte superiore dello stencil Forme base.

    Barra di formattazione rapida con nuove forme base
  3. Si può anche modificare l'ordine degli stencil trascinandoli più in alto o più in basso nel riquadro Forme. Un subset di queste forme viene visualizzato nello stencil Forme rapide, nello stesso ordine in cui si trovano nel riquadro Forme. Ad esempio, dopo aver trascinato lo stencil Forme decorative immediatamente dopo lo stencil Forme rapide nel riquadro Forme, la sequenza cambia nello stencil Forme rapide.

    Barra di formattazione rapida con un nuovo stencil tramite riordino

    Nota: Quando si chiude e si riapre un diagramma, l'ordine predefinito degli stencil nel riquadro Forme viene ripristinato automaticamente e riflesso in Forme rapide.

  4. Per usare un altro stencil come base per la barra di formattazione rapida, nello stencil Forme rapide selezionare una forma nel subset di queste forme per uno stencil. Ad esempio, selezionare Diagramma di Venn nello stencil Forme grafiche e matematiche.

    Barra di formattazione rapida con un nuovo stencil tramite selezione

Suggerimento: Per tornare alla sequenza predefinita delle forme in uno stencil, fare clic con il pulsante destro del mouse sul nome dello stencil nel riquadro Forme e quindi scegliere Reimposta stencil.

Nota: Non tutti gli stencil hanno forme che possono essere usate nella barra di formattazione rapida. Ad esempio, le forme nello stencil Frecce - Forme non vengono visualizzate nella barra di formattazione rapida.

Inizio pagina

Attivare o disattivare la connessione automatica

È possibile attivare e disattivare la funzionalità Connessione automatica per il disegno corrente o come impostazione predefinita per tutti i disegni di Visio.

Attivare o disattivare la connessione automatica nel diagramma attivo

  • Nel gruppo Strumenti visivi della scheda Visualizza selezionare o deselezionare Connessione automatica.

    Selezionare o deselezionare Connessione automatica nella scheda Visualizza per attivare o disattivare questa opzione.

Se la casella di controllo Connessione automatica non è disponibile, verificare se tale caratteristica è stata disattivata per tutti i diagrammi eseguendo la procedura seguente.

Attivare o disattivare la connessione automatica in tutti i diagrammi

  1. Fare clic sulla scheda File e quindi su Opzioni.

  2. Nella casella Opzioni di Visio fare clic su Avanzate.

  3. In Opzioni di modifica selezionare o deselezionare la casella di controllo Attiva connessione automatica rispettivamente per attivare o disattivare la caratteristica.

    Selezionare o deselezionare Attiva connessione automatica per attivare o disattivare questa opzione per tutti i diagrammi e i disegni.
  4. Fare clic su OK.

Inizio pagina

Connettere forme usando la connessione automatica

Uno dei modi disponibili per connettere le forme consiste nel consentire a Visio di eseguire automaticamente questa operazione quando si aggiungono forme a un disegno. Questa opzione risulta particolarmente utile quando si creano diagrammi di flusso.

Per aggiungere una forma nel disegno e consentire a Visio di connetterla automaticamente a una forma già presente, eseguire la procedura seguente.

Usare la connessione automatica durante il trascinamento di forme nella pagina

  1. Trascinare una forma da uno stencil nella pagina di disegno e posizionarla accanto a un'altra forma.

    Forma posizionata accanto a un'altra forma

  2. Tenendo premuto il pulsante del mouse, posizionare il puntatore del mouse su uno dei triangoli blu. Il triangolo diventerà blu scuro.

    Con il puntatore posizionato su uno dei triangoli blu, il triangolo diventa blu scuro.

  3. Rilasciare il pulsante del mouse. La forma verrà inserita nella pagina di disegno, un connettore viene aggiunto e associato a entrambe le forme.

    La forma viene inserita nella pagina di disegno, un connettore viene aggiunto e associato a entrambe le forme.

Suggerimento: Se si preferisce non trascinare le forme, è possibile ottenere lo stesso risultato selezionando una forma nello stencil, posizionando il puntatore su una forma nel disegno e quindi facendo clic su uno dei triangoli blu che compaiono accanto alla forma.

Usare la connessione automatica con forme già presenti nella pagina

  1. Posizionare il puntatore sulla forma da cui far partire la connessione.

    Puntatore posizionato sulla forma da cui far partire la connessione

  2. Posizionare il puntatore sul triangolo blu più vicino alla forma a cui creare la connessione.

    Puntatore posizionato sul triangolo blu più vicino alla forma a cui creare la connessione.

    Il triangolo diventa blu scuro e accanto alla forma a cui creare la connessione viene visualizzato un riquadro rosso.

    Nota: Se il riquadro rosso non compare, è possibile che la forma sia troppo distante. Spostarla più vicino e riprovare oppure usare lo strumento Connettore.

  3. Fare clic sul triangolo blu. Un connettore viene aggiunto e associato a entrambe le forme.

    La forma viene inserita nella pagina di disegno, un connettore viene aggiunto e associato a entrambe le forme.

Abilitare o disabilitare la connessione automatica

È possibile abilitare o disabilitare la funzionalità di connessione automatica in tutti i disegni di Visio o solo nel disegno corrente. Per tutti i disegni:

  1. Scegliere Opzioni dal menu Strumenti.

  2. Fare clic sulla scheda Generale.

  3. Nelle Opzioni finestra di disegno selezionare la casella di controllo Attiva connessione automatica.

Solo per il disegno corrente:

  • Sulla barra degli strumenti Standard fare clic sullo strumento Connessione automatica.

    Nota: Se facendo clic sullo strumento Connessione automatica la funzionalità non è disponibile, verificare che la casella di controllo Attiva connessione automatica sia selezionata nella finestra di dialogo Opzioni.

Connettere forme mediante lo strumento Connettore

Uno dei modi più flessibili per aggiungere e associare un connettore consiste nel disegnarlo usando lo strumento Connettore Icona del pulsante sulla barra degli strumenti Standard.

  1. Fare clic sullo strumento Connettore Icona del pulsante sulla barra degli strumenti Standard.

  2. Eseguire una delle operazioni seguenti:

    • Per mantenere il connettore associato a un punto specifico di una forma, trascinare da un punto di connessione Immagine del punto di connessione - X blu sulla prima forma a un punto di connessione sulla seconda forma. Quando le forme sono connesse, i punti finali del connettore diventano rossi. Questa è denominata connessione punto a punto. Con una connessione punto a punto, quando si sposta una delle forme il connettore resta associato agli stessi punti di connessione.

    • Per consentire al connettore di spostarsi sul punto di connessione disponibile più vicino, posizionare lo strumento Connettore al centro della prima forma finché questa non viene circondata da un riquadro rosso. Tenere premuto il pulsante del mouse e trascinare al centro della seconda forma. Quando attorno alla seconda forma compare un riquadro rosso, rilasciare il pulsante del mouse. Questa è denominata connessione forma a forma. Con una connessione forma a forma, il connettore resta associato a ogni forma, spostandosi sui punti di connessione disponibili più vicini quando una delle due forme viene spostata. Se non sono presenti punti di connessione, il connettore si sposta sui lati più vicini.

      Nota: È anche possibile creare connessioni tra le forme in cui un'estremità del connettore è connessa a un punto di connessione e l'altra è connessa alla forma (o viceversa).

  3. Fare clic sullo strumento Puntatore Icona del puntatore sulla barra degli strumenti Standard per tornare alle normali attività di modifica.

    Note: 

    • Per aggiungere un connettore da una forma a più forme, è necessario aggiungere più connettori. Non esiste una forma connettore di tipo "diramazione".

    • Se si sta provando a creare una connessione punto a punto e si hanno difficoltà ad associare un connettore esattamente nel punto desiderato, provare impostazioni di aggancio e associazione diverse:

    • Nel menu Strumenti fare clic su Aggancia e associa, quindi selezionare le opzioni desiderate nella scheda Generale.

      Se si associa alla geometria della forma, a un punto di controllo o al vertice di una forma, viene aggiunto automaticamente un punto di connessione se non ne esiste già uno.

Passare da connessioni punto a punto a connessioni forma a forma

È possibile associare connettori da un punto su una forma a un altro punto su una forma diversa oppure da un'intera forma a un'altra intera forma. È anche possibile creare connessioni in cui un'estremità del connettore è associata a un punto su una forma e l'altra estremità è associata a un'intera forma.

  1. Trascinare un punto finale del connettore allontanandolo dalla forma.

  2. Eseguire una delle operazioni seguenti:

    • Per associare un punto finale del connettore a un punto di connessione su una forma, trascinare il punto finale su uno dei punti di connessione della forma finché il punto di connessione non viene circondato da un riquadro rosso.

    • Per associare un punto finale del connettore all'intera forma, trascinare il punto finale verso il centro della forma finché attorno all'intera forma non compare un riquadro rosso.

Vedere anche

Aggiungere e modificare il testo del connettore

Creare un connettore personalizzato

Associare o rimuovere l'associazione dei connettori

Formazione su Visio

Tutto sui connettori di Visio Desktop (blog del team di Visio)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×