Aggiungere codici a barre per etichette o buste in Publisher

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Il servizio postale negli Stati Uniti (USPS) sviluppato recapito punto di codice a barre (DPBC) per automatizzare l'ordinamento della posta lettera a più di 100 milioni di punti di consegna univoci negli Stati Uniti. Quando si aggiungono i codici a barre postali ogni busta o l'etichetta nelle liste di distribuzione, è possibile usufruire del sistema di automazione.

Address label with barcode

Requisiti di codice a barre postale

Prima di aggiungere codici a barre a buste ed etichette, è necessario disporre di un tipo di carattere di codice a barre postale installato nel computer. È possibile ottenere i tipi di carattere di codice a barre da una varietà di società. Per individuare una società che offre i tipi di carattere di codice a barre, cercare "codice a barre carattere" o "codice a barre" online.

Leggere con attenzione la documentazione fornita con il tipo di carattere di codice a barre che si acquista. La documentazione deve compitare esattamente quali caratteri e i numeri da immettere per creare un codice a barre valido, come la dimensione del carattere da usare se si desidera soddisfare requisiti USPS, come creare il valore long barre tale intervallo di inizio e di fine del codice a barre e altro ancora.

Istruzioni USPS per i codici a barre postale variano in base al tipo di liste di distribuzione (lettera, indirizzata, periodici e così via). Assicurarsi di selezionare le linee guida per i requisiti che riguardano l'utilizzo specifico. Posta in blocco è necessario rispettare determinata gestione e procedure di posta elettronica. Inoltre, il servizio USPS modificare periodicamente le modalità di calcolo di codici a barre. Per questi motivi, assicurarsi di usare la centrale locale.

Aggiungere codici a barre per etichette o buste allo stesso modo aggiunge nomi e indirizzi, tramite la preparazione di un'origine dati e usando la stampa unione.

L'origine dati è l'elenco dei destinatari di Microsoft Office Publisher, tabella di database di Microsoft Office Access, foglio di lavoro di Microsoft Office Excel, elenco di contatti di Microsoft Office Outlook o un altro file strutturato in cui sono memorizzati i nomi e indirizzi che si unire in etichette o buste.

È necessario creare una colonna di codice a barre nell'origine dati. Ogni riga nella colonna codice a barre deve contenere una combinazione di caratteri e i numeri che verranno stampata in un tipo di carattere di codice a barre postale come le due barre che circondano il codice a barre, il codice ZIP + 4, il recapito scegliere codice e il carattere di correzione.

Excel worksheet containing Barcode column

1. ogni colonna in un'origine dati rappresenta una categoria di informazioni. È possibile aggiungere le informazioni specifiche memorizzate in ogni riga di una colonna per le buste ed etichette stampate inserendo un segnaposto di colonna (denominato anche un campo dati) nella pubblicazione busta o etichetta iniziale.

2. i caratteri e i numeri nella cella definiscono il codice a barre postale per l'indirizzo nella stessa riga. In questo esempio, le parentesi rappresentano le barre che circondano il codice a barre. Consultare la documentazione fornita con il tipo di carattere di codice a barre postale per scoprire i caratteri che è necessario utilizzare.

3. le informazioni in ogni riga corrispondono alle informazioni che verranno visualizzate in un'etichetta o busta.

Aggiungere codici a barre a un'origine dati

Se ancora non si dispone un elenco di indirizzi che è possibile utilizzare come origine dati, è necessario crearne uno. Per informazioni sulla creazione di liste di distribuzione, vedere suggerimenti per gli elenchi di indirizzi.

Se si dispone già di un elenco di indirizzi, è necessario aggiungere i numeri di codice a barre a ogni record. È possibile digitare i numeri in una colonna di origine dati che si prevede di utilizzare per la stampa unione.

Se l'origine dati è stato creato in Publisher, è possibile utilizzare la procedura seguente per aggiornare l'origine dati. Se è stato creato l'origine dati in Access, Excel, Outlook o un altro programma, è possibile aggiornare meglio l'origine dati nello stesso programma utilizzato per crearlo. È anche possibile modificare un'origine dati che è stata creata in uno di questi programmi dopo la connessione all'elenco dei destinatari durante una stampa unione in Publisher.

Aggiornare l'origine dati

  1. In Publisher fare clic su lettere > Seleziona destinatari > Usa elenco esistente.

  2. Selezionare l'origine dati che si desidera modificare e quindi fare clic su Apri.

  3. Nella finestra di dialogo Modifica origine dati fare clic su Personalizza colonne.

  4. Nella finestra di dialogo Personalizza elenco indirizzi, fare clic su Aggiungi.

  5. Nella finestra di dialogo Aggiungi campo digitare un campo nome (o sull'intestazione di colonna), ad esempio codice a barre, fare clic su OK e quindi fare clic su OK.

  6. Nella finestra di dialogo Modifica origine dati fare clic sulla prima cella nella nuova colonna nel punto in cui si desidera immettere i dati.

  7. Digitare un codice a barre e quindi premere il tasto freccia giù per spostarsi sulla riga riportata di seguito.

  8. Ripetere fino a quando non sono stati elencati tutti i codici a barre che si intende utilizzare.

  9. Fare clic su OK per salvare e chiudere il file.

    Nota: Anche se si dispone di una colonna di codice a barre nell'origine dati, è comunque necessario un'altra colonna codice postale se si desidera CAP e altri codici postali per visualizzare l'indirizzo nella Disponi etichette o buste.

Dopo aver configurato l'origine dati, si è pronti aprire la pubblicazione di buste o etichette. Se si dispone già di una pubblicazione utilizzati per lettere in passato, è possibile aprire la pubblicazione. Se si sta avviando da zero, aprire una pubblicazione che corrisponda alle dimensioni della buste o etichette su cui si desidera stampare i nomi, indirizzi e codici a barre. Se si desidera stampare etichette, nota il numero di prodotto, ad esempio 5160 o L7163, associato confezione di etichette che è stato acquistato. È necessario questo numero per aprire la pubblicazione corretta.

Aprire una pubblicazione esistente

  1. In Publisher fare clic su File > Apri.

  2. Individuare e aprire la pubblicazione busta o l'etichetta desiderata.

Iniziare da zero con le buste

  • Nell'elenco pubblicazioni, eseguire una delle operazioni seguenti:

    • Per iniziare con una busta predefinita, digitare Buste nella casella Cerca modelli online, fare doppio clic su un modello e quindi personalizzarla apportando le modifiche desiderate.

    • Per iniziare con una busta bianca semplice, fare clic su Più dimensioni pagina vuote e, in Tipo di pubblicazioni, fare clic su Buste.

Iniziare da zero con etichette

Molte pubblicazioni possono essere configurate per stampare su un'etichetta produttore specifico. Ad esempio, è possibile progettare etichette utilizzando uno dei modelli in Publisher e quindi stampare la pubblicazione su carta etichetta un produttore specifico, ad esempio Avery, NCR o Printec.

  1. In Publisher fare clic su Più dimensioni pagina vuote e, in Tipo di pubblicazioni, fare clic su Etichette indirizzi, Etichette di elementi multimediali o Altre etichette.

  2. Individuare il nome del produttore delle etichette ed espandere l'elenco.

  3. Scorrere le pubblicazioni etichetta e fare doppio clic sul numero di prodotto o alla dimensione che corrisponda a quelli del pacchetto di etichette.

    Se non è presente un numero di pubblicazione che corrisponde esattamente al numero indicato sulla confezione, esaminare il pacchetto e le informazioni fornite con le etichette. Potrebbero essere elencati altri numeri di prodotto che sono disponibili in Publisher, equivalenti dimensioni e layout per le etichette nel pacchetto acquistato. Per stampare su Avery 8163, ad esempio, è possibile selezionare Avery 8463, 8663, 15163 o 18163 in Publisher.

Con la pubblicazione etichetta o busta aperta, che si è pronti per connettersi a un'origine dati, ovvero un file che contiene i nomi, indirizzi e codici a barre che si desidera aggiungere. Dopo aver creato la connessione, sarà possibile aggiungere segnaposto (campi unione) alla pubblicazione iniziale per indicare nel punto in cui verrà visualizzato l'indirizzo e il codice a barre sul Disponi etichette o buste.

Se si desidera unire immagini nelle pagine della pubblicazione, per aggiungere un logo aziendale, ad esempio, l'origine dati deve includere i nomi di file o i percorsi per i file di immagine che si desidera unire. Non includere la le immagini nell'origine dati.

Connettersi all'origine dati

  1. Fare clic su lettere > Stampa unione > Creazione guidata stampa unione dettagliate.

  2. Nel riquadro attività Stampa unione, creare l'elenco di destinatari fare clic su Usa elenco esistente e quindi fare clic su successivo: creare o connettersi a un elenco di destinatari.

  3. Nella finestra di dialogo Seleziona origine dati fare clic su origine dati che contiene i codici a barre.

    Per impostazione predefinita, Microsoft Publisher archivia le origini dati nella cartella Origini dati. Potrebbe essere necessario individuare l'origine dati.

  4. Fare clic su Apri.

    A seconda del tipo di origine dati selezionata, altre finestre di dialogo possono essere visualizzati la richiesta di informazioni specifica. Ad esempio, se l'origine dati è una cartella di lavoro di Microsoft Office Excel che contiene informazioni su più fogli di lavoro, è necessario selezionare il foglio di lavoro che contiene le informazioni desiderate e quindi fare clic su OK.

  5. Nella finestra di dialogo Destinatari stampa unione consente di ridurre o ordinare le voci nel file di dati. È consigliabile, ad esempio, eseguire una spedizione solo ai clienti di una determinata città. Se non si desidera ridurre o ordinare le informazioni, fare clic su OK. Se si desidera ridurre o ordinare le informazioni, è possibile eseguire alcune o tutte le operazioni seguenti prima di scegliere OK.

    • Se non si vuole le informazioni in una determinata riga sia visibile in un'etichetta o busta, fare clic sulla casella di controllo all'inizio della riga per deselezionarla.

    • Per ordinare le righe in base all'ordine crescente o decrescente delle informazioni in una colonna specifica, fare clic sull'intestazione di colonna.

    • Per restringere l'elenco di righe in base a criteri specifici, fare clic sulla freccia accanto a un'intestazione di colonna.

      Nota: Se si utilizza un file di contatti di Outlook come origine dati e memorizzati codici a barre in uno dei campi utente (ad esempio, campo utente 1 ), sarà necessario scorrere lungo verso destra nella finestra di dialogo Destinatari stampa unione per visualizzare il campo. È possibile cambiare la posizione di un campo nella finestra di dialogo trascinando l'intestazione di colonna del campo a sinistra o a destra.

  6. Fare clic su OK per tornare al riquadro attività Stampa unione.

Aggiungere e formattare i segnaposto a buste o etichette

Segnaposto, detti anche campi dati, corrispondono alle intestazioni di colonna dell'origine dati. Inserendo un campo di codice a barre dei dati in una pubblicazione etichetta o busta, si indica in cui si desidera informazioni dalla colonna codice a barre all'interno di copie da stampare. È possibile formattare i campi in modo che le informazioni di buste o etichette stampate ha l'aspetto che si desidera cercare. È necessario formattare il campo codice a barre in modo che consente di stampare informazioni in questo campo a un tipo di carattere di codice a barre postale.

Aggiungere e formattare i segnaposto sulle buste

  1. Se è stato creato un set di informazioni aziendali, viene inserito come l'indirizzo del mittente. In caso contrario e se non vengono stampate su buste che già l'indirizzo del mittente stampato su di essi o se è stato avviato con un formato di pagina vuoto per creare la pubblicazione della busta, aggiungere l'indirizzo del mittente.

    • Se è presente testo di esempio per l'indirizzo del mittente, fare clic su esso e quindi digitare l'indirizzo del mittente.

    • Se non c'è alcun casella di testo indirizzo del mittente, fare clic su Inserisci > Disegna casella di testo Icona del pulsante .

      Scegliere la busta, trascinare in diagonale per creare una casella di testo per l'indirizzo del mittente e quindi digitare l'indirizzo del mittente.

  2. A questo punto, aggiungere campi per l'indirizzo e il codice a barre.

    • Se c'è testo di esempio per l'indirizzo postale sulla busta, passare alla sezione successiva.

    • Se non c'è alcun casella di testo per l'indirizzo postale, fare clic su Inserisci > Disegna casella di testo Icona del pulsante .

      Trascinare sulla busta, in diagonale per creare una casella di testo per l'indirizzo postale.

  3. Fare clic su Inserisci > Disegna casella di testo Icona del pulsante nuovamente.

    Trascinare sulla busta, sopra la casella di testo indirizzo postale, in diagonale per creare un'altra casella di testo per il codice a barre. Disegnare una casella di testo in base alle offset specificato da USPS dei codici a barre.

    Ad esempio, il codice a barre deve essere almeno.04 pollici dalla parte superiore della casella di testo indirizzo postale, nella parte inferiore della casella di testo codice a barre e il bordo della busta. Casella di testo, è probabile che è necessario essere quasi 3 pollici tempo per l'intero codice a barre stampato.

    Nota: Assicurarsi di verificare le istruzioni USPS per la misurazione della distanza tra gli elementi della busta.

  4. Fare clic nella casella di testo indirizzo postale.

  5. Nel riquadro attività Stampa unione, in più elementi, fare clic su Blocco di indirizzi.

  6. Nella finestra di dialogo Inserisci blocco di indirizzi, scegliere il formato per i nomi dei destinatari e quindi fare clic su Corrispondenza campi.

  7. Nella finestra di dialogo Corrispondenza campi assicurarsi che ogni componente elencato a sinistra che si sta utilizzando negli indirizzi deve corrispondere a una colonna del file di dati a destra. Fare clic su OK e quindi fare clic su OK.

    «Campo blocco di indirizzi» viene visualizzata nella pubblicazione della busta.

  8. Fare clic nella casella di testo codice a barre. Nel riquadro attività Stampa unione in Preparazione della pubblicazione, fare clic sul campo di dati di codice a barre nell'elenco per aggiungere un campo «Codice a barre» alla pubblicazione della busta.

    List of data fields in Mail Merge task pane

    Se si uniscono i codici a barre da un file di contatti di Outlook, il campo che contiene i codici a barre probabilmente denominato campo utente 1, campo utente 2, campo utente 3 o campo utente 4.

  9. Selezionare il campo «Codice a barre» o «Campo utente» appena aggiunto, incluse le virgolette («»).

  10. Fare clic su Home > tipo di carattere.

  11. Nella finestra di dialogo tipo di carattere, in tipo di carattere, scegliere il tipo di carattere di codice a barre postale.

    In dimensioni selezionare le dimensioni del carattere, in base alla documentazione del tipo di carattere, soddisfano i requisiti USPS.

  12. Fare clic su OK.

    Il campo «Codice a barre» o «Campo utente» può cambiare dimensioni e l'aspetto.

    È possibile modificare il tipo di carattere, dimensioni, colore e altro ancora per il testo dell'indirizzo postale anche. Selezionare il campo «Blocco di indirizzi», incluse le virgolette («»), applicare la formattazione desiderata.

Aggiungere e formattare segnaposto sulle etichette

  1. Aggiungere campi per l'indirizzo e codice a barre eseguendo una delle operazioni seguenti:

    • Se c'è testo di esempio sull'etichetta, fare clic su esso. Posizionare il puntatore su Cancella cerchio nella parte superiore della casella di testo. Trascinare verso il basso per aumentare la casella di testo circa due terzi o metà delle dimensioni originali. Fare clic all'esterno della casella di testo per annullare la selezione della casella di testo.

    • Se non è presente testo di esempio sull'etichetta, fare clic su Inserisci > Disegna casella di testo Icona del pulsante .

      Sull'etichetta, trascinare in diagonale per creare una casella di testo indirizzo postale che è la metà di due terzi l'altezza e quasi tutta la lunghezza dell'etichetta, ad eccezione di circa.25 pollici a ogni estremità. Assicurarsi di lasciare circa.125 pollici spazio nella parte inferiore dell'etichetta anche.

  2. Fare clic su Inserisci > Disegna casella di testo Icona del pulsante .

    Trascinare in diagonale per creare una casella di testo di codice a barre nell'area vuota superiore dell'etichetta. Verificare la nuova casella di testo la stessa lunghezza altro testo casella sull'etichetta e lasciare uno spazio di.04 pollici tra la parte superiore della casella di testo e il margine superiore dell'etichetta e tra la parte inferiore della casella di testo codice a barre e la casella di testo sotto di esso.

  3. Fare clic nella casella di testo indirizzo postale sull'etichetta. Nel riquadro attività Stampa unione in più elementi, fare clic su Blocco di indirizzi.

  4. Nella finestra di dialogo Inserisci blocco di indirizzi, scegliere il formato per i nomi dei destinatari e quindi fare clic su Corrispondenza campi.

  5. Nella finestra di dialogo Corrispondenza campi assicurarsi che ogni componente elencato a sinistra che si sta utilizzando negli indirizzi deve corrispondere a una colonna del file di dati a destra. Fare clic su OK e quindi fare clic su OK.

    «Campo blocco di indirizzi» viene visualizzata nella pubblicazione delle etichette.

  6. Fare clic nella casella di testo codice a barre. Nel riquadro attività Stampa unione in Preparazione della pubblicazione, fare clic sul campo di dati di codice a barre nell'elenco per aggiungere un campo «Codice a barre» alla pubblicazione della busta.

    List of data fields in Mail Merge task pane

    Se si uniscono i codici a barre da un file di contatti di Outlook, il campo che contiene i codici a barre probabilmente denominato campo utente 1, campo utente 2, campo utente 3 o campo utente 4.

  7. Selezionare i «codice a barre» «campo utente» appena aggiunto, incluse le virgolette acute («»).

  8. Fare clic su Home > tipo di carattere.

  9. Nella finestra di dialogo tipo di carattere, in tipo di carattere, scegliere il tipo di carattere di codice a barre postale. In dimensioni selezionare le dimensioni del carattere, in base alla documentazione del tipo di carattere, soddisfano i requisiti USPS. Fare clic su OK.

    Il campo «Codice a barre» o «Campo utente» può cambiare dimensioni e l'aspetto.

    È possibile modificare il tipo di carattere, dimensioni, colore e informazioni per il testo dell'indirizzo postale anche. È sufficiente selezionare il campo «Blocco di indirizzi» e applicare la formattazione desiderata.

A questo punto si è pronti unire la pubblicazione per creare una nuova etichetta o busta per ogni riga di informazioni che si sono scelto di unire le informazioni dal file di dati. Quando si visualizzare in anteprima le pubblicazioni, è possibile identificare gli eventuali problemi che devono essere corretti prima di stamparle.

Visualizzare in anteprima gli indirizzi e codici a barre

  1. Per visualizzare in anteprima le voci in ordine, fare clic sui pulsanti di spostamento Pulsante Successivo Pulsante Precedente per controllare come ogni voce apparirà nella pubblicazione unita.

    Ecco come una pubblicazione unita potrebbe apparire:

    Preview of label with barcode

  2. Se viene visualizzato problemi, è il momento per correggerli. Esempi di problemi che possono verificarsi:

    • Alcune del codice a barre non è presente

      Casella di testo codice a barre potrebbe essere troppo breve per consentire l'intero codice a barre da visualizzare. Fare clic sul bordo attorno alla casella di testo e quindi trascinare un quadratino bianco fino a ottenere la casella di testo della lunghezza corretta.

    • Gli indirizzi non vengono visualizzati correttamente

      Indirizzi potrebbero non essere visualizzati correttamente. Nel riquadro attività Stampa unione, fare clic sul collegamento Blocco di indirizzi. Spostare il puntatore nell'angolo in alto a sinistra della casella di testo che contiene il blocco di indirizzi, fare clic su di scelta rapida Merge Field options il Campo unione e quindi fare clic su Cambia blocco indirizzi.

      Nella finestra di dialogo Cambia blocco indirizzi, fare clic su Corrispondenza campi. Nella finestra di dialogo Corrispondenza campi assicurarsi che ogni componente elencato a sinistra che si sta utilizzando negli indirizzi deve corrispondere a una colonna del file di dati a destra. Fare clic su OK e quindi fare clic su OK.

    • La formattazione del testo non è corretta

      Può essere necessario modificare il tipo di carattere o dimensioni del carattere e colore nel blocco di indirizzi. Selezionare il campo «Blocco di indirizzi», incluse le virgolette («»).

      Fare clic su Home > tipo di carattere per apportare le modifiche desiderate.

  3. Se si è soddisfatti anteprime, nella parte inferiore del riquadro attività fare clic su successivo: creazione di pubblicazioni unite.

A questo punto si è pronti per la stampa. Se si stampa gli indirizzi e codici a barre sulle buste, stampare le pubblicazioni come fogli separati. Se si stampa gli indirizzi e codici a barre a etichette, è possibile stampare un intervallo di indirizzi e i codici a barre associati in un foglio di etichette o si può stampare più copie dello stesso indirizzo e il relativo associati codici a barre in tutte le etichette in un foglio.

Stampare gli indirizzi e codici a barre sulle buste

Dopo aver creato la busta e selezionare le dimensioni della pagina che si desidera, si è pronti stampare la busta.

  1. Nel riquadro attività Stampa unione, fare clic su Stampa e quindi fare clic sulla scheda Impostazioni pubblicazione e foglio.

  2. Controllare la finestra di anteprima. Se non si è certi di come inserire la busta, fare clic su Mostra come inserire il foglio e quindi fare clic su aprire la finestra di dialogo Imposta busta.

  3. Nella finestra di dialogo Imposta busta, l'immagine con bordo spesso blu Mostra l'opzione consigliata per la stampante.
    Immagine per l'impostazione della busta

    Il numero di unità e opzioni varia a seconda il produttore, tipo e modello della stampante in uso.

  4. Fare clic su OK e quindi fare clic su Stampa.

  5. Fare clic su File > Salva per salvare la pubblicazione.

    Nota: Tenere presente che si stanno salvando non sia l'insieme di buste aver stampato. Invece si desidera salvare la pubblicazione con la connessione con l'origine dati e dei relativi campi segnaposto. Per salvare la pubblicazione, è possibile creare rapidamente un'altra coppia di buste quando occorre eseguire. La pubblicazione mantiene il collegamento all'origine dati che connesso in modo che è possibile passare direttamente al passaggio anteprima.

Stampare gli indirizzi e codici a barre sulle etichette

  1. Scegliere File > Stampa.

  2. Eseguire una delle operazioni seguenti:

    • Per configurare le etichette in modo che un altro indirizzo e il relativo codice a barre associato stampare su ogni etichetta in un foglio, fare clic su più pagine per foglio.

    • Per configurare le etichette in modo da stampare più copie dello stesso indirizzo e il relativo codice a barre associato in tutte le etichette su ogni foglio, fare clic su più copie per foglio.

  3. Visualizzare in anteprima il risultato della stampa per assicurarsi che le informazioni etichetta allineate correttamente sul foglio di etichette. Nel riquadro attività Stampa unione in creazione di pubblicazioni unite, fare clic su Anteprima di stampa. Se necessario, apportare le modifiche per allineare gli indirizzi e codici a barre nelle etichette.

    Procedura

    1. Fare clic su Chiudi per chiudere la finestra di anteprima di stampa.

    2. Scegliere File > Stampa.

    3. In Impostazioni scegliere le impostazioni desiderate, assicurarsi di selezionare la casella di controllo Salva impostazioni con la pubblicazione.

    4. Nel riquadro attività Stampa unione in creazione di pubblicazioni unite, fare clic su Anteprima di stampa per esaminare le modifiche apportate.

  4. Nel riquadro attività Stampa unione in creazione di pubblicazioni unite, fare clic su Stampa. Scegliere le opzioni di stampa desiderata.

  5. Fare clic su File >Salva per salvare la pubblicazione.

    Nota: Tenere presente che si stanno salvando non sia l'insieme di buste aver stampato. Invece si desidera salvare la pubblicazione con la connessione con l'origine dati e dei relativi campi segnaposto. Per salvare la pubblicazione, è possibile creare rapidamente un'altra coppia di buste quando si presenta la necessità. La pubblicazione mantiene il collegamento all'origine dati che connesso in modo che è possibile passare direttamente al passaggio anteprima.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×