Aggiornare i dati della tabella pivot

Importante:  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile fare clic su Aggiorna in qualsiasi momento per aggiornare i dati delle tabelle pivot nella cartella di lavoro. Si possono aggiornare i dati per le tabelle pivot connesse a dati esterni, ad esempio un database (SQL Server, Oracle, Access o altro), a un cubo di Analysis Services, un feed di dati e molte altre origini. I dati possono essere aggiornati da una tabella di origine nella stessa cartella di lavoro o in una diversa. Si può anche impostare la cartella di lavoro in modo che i dati della tabella pivot siano aggiornati automaticamente all'apertura.

Per impostazione predefinita, le tabelle pivot non vengono aggiornate automaticamente, ma è possibile specificare che la tabella pivot vengono aggiornate automaticamente quando si apre la cartella di lavoro che contiene la tabella pivot.

Aggiornare manualmente

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Strumenti tabella pivot

  2. Fare clic su Analizza > Aggiorna o premere ALT+F5.

    Pulsante Aggiorna nella scheda Analizza

    Suggerimento: Per aggiornare tutte le tabelle pivot nella cartella di lavoro contemporaneamente, fare clic su Analizza > Aggiorna tutto.

Se l'aggiornamento dura più del previsto, fare clic su Analizza > Aggiorna > Stato aggiornamento per controllare lo stato dell'aggiornamento.

Per interrompere l'aggiornamento, fare clic su Annulla aggiornamento.

Impedire la modifica della larghezza delle colonne e della formattazione delle celle

Se la larghezza delle colonne e la formattazione delle celle cambia con l'aggiornamento dei dati della tabella pivot e non si vuole che questo accada, accertarsi che siano selezionate le opzioni seguenti:

  1. Fare clic su Analizza > Opzioni.

    Pulsante Opzioni nella scheda Analizza

  2. Nella scheda Layout e formato selezionare le caselle Adatta larghezza colonne all'aggiornamento e Mantieni formattazione celle all'aggiornamento.

Aggiornare automaticamente i dati all'apertura della cartella di lavoro

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Strumenti tabella pivot

  2. Fare clic su Analizza > Opzioni.

    Pulsante Opzioni nella scheda Analizza

  3. Nella scheda dati selezionare la casella Aggiorna dati all'apertura del file.

Aggiornare manualmente

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Verrà visualizzato il gruppo Strumenti tabella pivot con delle Opzioni e la scheda Progettazione.

  2. Nella scheda Opzioni, gruppo dati, eseguire una delle operazioni seguenti:

  3. Per aggiornare le informazioni in modo che corrisponda l'origine dati, fare clic sul pulsante Aggiorna o premere ALT + F5.

    Pulsante destro del mouse nella tabella pivot e quindi fare clic su Aggiorna.

  4. Per aggiornare tutte le tabelle pivot della cartella di lavoro, fare clic sulla freccia di pulsante Aggiorna e quindi fare clic su Aggiorna tutto.

    immagine della barra multifunzione di excel

    Se l'aggiornamento dura più tempo del previsto, fare clic su Opzioni > Aggiorna > Stato aggiornamento per controllare lo stato dell'aggiornamento.

    Per interrompere l'aggiornamento, fare clic su Annulla aggiornamento.

Impedire la modifica della larghezza delle colonne e della formattazione delle celle

Se la larghezza delle colonne e la formattazione delle celle cambia con l'aggiornamento dei dati della tabella pivot e non si vuole che questo accada, accertarsi che siano selezionate le opzioni seguenti:

  1. Fare clic su Opzioni > Opzioni.

    Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot
  2. Nella scheda Layout e formato selezionare le caselle Adatta larghezza colonne all'aggiornamento e Mantieni formattazione celle all'aggiornamento.

Aggiornare automaticamente i dati di tabella pivot quando si apre la cartella di lavoro

  1. Fare clic in un punto qualsiasi della tabella pivot.

  2. Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni.

    Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot

  3. Nella scheda dati della finestra di dialogo Opzioni tabella pivot selezionare la casella di controllo Aggiorna dati all'apertura del file.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Nota: Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×