Access 2010: attività di database

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Ecco alcune attività di database di base che è possibile eseguire per scoprire come usare Microsoft Access 2010.

 

In questo articolo

Che cos\u0027è Access?

Database relazionali in Access

Quando si apre Access

Trovare e applicare un modello

Creare un database partendo da zero

Aprire un database di Access esistente

Iniziare a usare il nuovo database

Aggiungere una tabella

Incollare dati da un'altra origine in una tabella di Access

Importare o collegare dati da un'altra origine

Passaggi successivi

Importare dati da un foglio di calcolo o da un altro programma

Importare un foglio di lavoro di Excel in Access

Importare un foglio di lavoro di Excel come tabella in un nuovo database

Usare la procedura guidata Analizzatore tabelle per organizzare i dati

Usare i dati di altre applicazioni

Usare un database di versioni precedenti in diverse versioni di Access

Usare un file di database di Access in diverse versioni di Access

Passaggio 1: creare una copia del database esistente e salvarlo in un nuovo formato

Passaggio 2: dividere il database di copia e usare il file originale come database back-end

Passaggio 3: connettere il nuovo front-end al database originale

Usare un'applicazione front-end/back-end in diverse versioni di Access

Che cos\u0027è Access?

Access 2010 è uno strumento per la progettazione e la distribuzione delle applicazioni di database che è possibile usare per tenere traccia delle informazioni importanti. È possibile mantenere i dati nel computer oppure pubblicarli sul Web, in modo che gli altri utenti possano usare il database con un Web browser.

Molte persone iniziano a usare Access quando il programma che sta usando per tenere traccia di qualcosa diventa progressivamente meno adatto per l'attività. Si supponga, ad esempio, che si sia un Event Planner e si voglia tenere traccia di tutti i dettagli che è necessario gestire per rendere più efficaci gli eventi. Se si usa un programma di elaborazione di testo o un foglio di calcolo per eseguire questa operazione, è possibile eseguire facilmente problemi con i dati duplicati e non coerenti. È possibile usare il software di calendario, ma il monitoraggio delle informazioni finanziarie in un calendario non è una buona misura.

Database relazionali in Access

A volte è necessario un database relazionale per tenere traccia di tali informazioni, ovvero un archivio di dati che sono stati separati in raccolte di dati di dimensioni ridotte (dette tabelle) per eliminare la ridondanza e quindi correlate tra loro in base a bit di informazioni comuni (detti campi). . Ad esempio, un database relazionale per la pianificazione di eventi potrebbe contenere una tabella con informazioni sui clienti, una tabella con informazioni sul fornitore e una tabella con informazioni sull'evento. La tabella con le informazioni sugli eventi potrebbe avere un campo per collegarla alla tabella Customer e un campo per collegarla alla tabella Vendor. In questo modo, ad esempio, se il numero di telefono di un fornitore è cambiato, le informazioni possono essere modificate una sola volta nella tabella Vendor, anziché in tutti gli eventi che hanno coinvolto il fornitore.

Access è uno strumento che è possibile usare per sviluppare rapidamente e facilmente applicazioni di database relazionali che consentono di gestire le informazioni. È possibile creare un database che consenta di tenere traccia di qualsiasi tipo di informazione, ad esempio inventario, contatti professionali o processi aziendali. In questo modo, Access include i modelli che è possibile usare immediatamente per tenere traccia di un'ampia gamma di informazioni, rendendo le cose più facili anche per un principiante.

Quando si apre Access

Quando si avvia Access 2010, viene visualizzata la visualizzazione Microsoft Office Backstage, in cui è possibile ottenere informazioni sul database corrente, creare un nuovo database, aprire un database esistente e visualizzare il contenuto in primo piano da Office.com.

Visualizzazione Backstage di Access 2010

La visualizzazione Backstage contiene anche molti altri comandi che è possibile usare per regolare, gestire o condividere i database. I comandi nella visualizzazione Backstage si applicano in genere a interi database, non agli oggetti all'interno di un database.

Nota: Puoi accedere alla visualizzazione Backstage in qualsiasi momento facendo clic sulla scheda file .

Inizio pagina

Trovare e applicare un modello

Access offre una vasta gamma di modelli che è possibile usare per velocizzare il processo di creazione del database. Un modello è un database pronto per l'uso che contiene tutte le tabelle, le query, le maschere e i report necessari per eseguire un'attività specifica. Ad esempio, ci sono modelli che possono essere usati per tenere traccia dei problemi, gestire i contatti o conservare un registro delle spese. Alcuni modelli includono alcuni record di esempio che ne illustrano l'utilizzo. I database dei modelli possono essere usati come sono, oppure puoi personalizzarli in base alle tue esigenze.

Per trovare e applicare un modello al database, eseguire le operazioni seguenti:

  1. Nella scheda File fare clic su Nuovo.

  2. In modelli disponibilieseguire una delle operazioni seguenti:

    • Per riutilizzare un modello usato di recente, fare clic su modelli recentie quindi selezionare il modello desiderato.

    • Per usare un modello già installato, fare clic su modelli personalie quindi selezionare il modello desiderato.

    • Per trovare un modello in Office.com, in Modelli Office.comfare clic su una categoria di modelli, selezionare il modello desiderato e quindi fare clic su download per scaricare il modello da Office. com nel computer.

      È anche possibile cercare i modelli in Office.com da Access. Nella casella Cerca In Office.com per i modelli Digitare uno o più termini di ricerca e quindi fare clic sul pulsante della freccia per eseguire la ricerca.

  3. Facoltativamente, fare clic sull'icona della cartella accanto alla casella nome file per passare alla posizione in cui si vuole creare il database. Se non si indica una posizione specifica, Access crea il database nella posizione predefinita visualizzata sotto la casella nome file .

  4. Fare clic su Crea.

Access crea il database e lo apre per l'uso.

Inizio pagina

Creare un database partendo da zero

Se si vuole un'introduzione più approfondita ai concetti relativi all'uso di Access per creare un database, vedere l'articolo nozioni fondamentali sulla progettazione di database.

Se nessuno dei modelli è adatto alle proprie esigenze oppure se si hanno dati in un altro programma che si vuole usare in Access, è possibile decidere che è preferibile creare un database da zero. In Access 2010 è possibile scegliere un database desktop standard o un database Web.

Per altre informazioni sui database Web, vedere l'articolo creare un database da condividere sul Web.

Per creare un nuovo database, eseguire le operazioni seguenti:

  1. Avviare Access.

  2. Nella scheda nuovo nella visualizzazione Backstage fare clic su database vuoto o database Web vuoto.

    Importante: La scelta da eseguire in questo articolo determinerà quali funzionalità sono disponibili nel database. I database desktop non possono essere pubblicati sul Web e i database Web non supportano alcune funzionalità desktop, ad esempio le query totali.

  3. Sulla destra digitare un nome per il database nella casella nome file .

    Per modificare la posizione in cui si crea il file, fare clic su Sfoglia Icona del pulsante accanto alla casella nome file , individuare e selezionare il nuovo percorso e quindi fare clic su OK.

  4. Fare clic su Crea.

    Access crea il database e quindi apre una tabella vuota (denominata Tabella1) in visualizzazione Foglio dati.

  5. Access inserisce il cursore nella prima cella vuota nella colonna fare clic per aggiungere la nuova tabella.

    Per aggiungere dati, iniziare a digitare oppure incollare i dati da un'altra origine, come descritto nella sezione incollare i dati da un'altra origine in una tabella di Access, più avanti in questo articolo.

    Note: 

    • L'immissione di dati in visualizzazione foglio dati è progettata in modo molto simile all'immissione di dati in un foglio di lavoro di Excel. La restrizione principale è che i dati devono essere immessi in righe e colonne contigue, a partire dall'angolo in alto a sinistra del foglio dati. Non provare a formattare i dati includendo righe o colonne vuote come si può fare in un foglio di lavoro di Excel, perché in questo modo si perde spazio nella tabella. La tabella contiene semplicemente i dati. Tutte le presentazioni visive dei dati verranno eseguite nelle maschere e nei report che verranno progettate in un secondo momento.

    • La struttura della tabella viene creata durante l'immissione dei dati. Ogni volta che si aggiunge una nuova colonna al foglio dati, viene definito un nuovo campo nella tabella. Access imposta la tipo di dati del campo in base al tipo di dati immessi. Ad esempio, se si ha una colonna in cui sono stati immessi solo i valori di data, Access importerà il tipo di dati del campo su data/ora. Se in seguito si tenta di immettere un valore non di data, ad esempio un nome o un numero di telefono, in questo campo verrà visualizzato un messaggio che informa che il valore non corrisponde al tipo di dati della colonna. Quando possibile, è consigliabile pianificare la tabella in modo che ogni colonna contenga lo stesso tipo di dati, che si tratti di testo, date, numeri o altri tipi. In questo modo è molto più semplice creare query, maschere e report che selezionano solo i dati desiderati.

Se non si vuole ancora immettere i dati, fare clic su Chiudi Icona del pulsante .

Nota: Access eliminerà Tabella1 se lo Chiudi senza salvare.

Inizio pagina

Aprire un database di Access esistente

Suggerimento: Per aprire rapidamente uno degli ultimi diversi database aperti, nella scheda file fare clic su recentie quindi sul nome del file.

  1. Nella scheda File fare clic su Apri.

  2. Fare clic su un collegamento nella finestra di dialogo Apri oppure, nella casella Cerca in , fare clic sull'unità o sulla cartella che contiene il database desiderato.

  3. Nell'elenco delle cartelle fare doppio clic su cartelle finché non si apre la cartella che contiene il database.

  4. Quando si trova il database, eseguire una delle operazioni seguenti:

    • Per aprire il database in modalità di apertura predefinita, fare doppio clic su di esso.

    • Per aprire il database per l'accesso condiviso in un ambiente multiutente, in modo che sia l'utente che gli altri utenti possano leggere e scrivere contemporaneamente nel database, fare clic su Apri.

    • Per aprire il database per l'accesso in sola lettura, in modo che sia possibile visualizzarlo ma non modificarlo, fare clic sulla freccia accanto al pulsante Apri e quindi fare clic su Apri di sola lettura.

    • Per aprire il database per l'accesso esclusivo, in modo che nessun altro possa aprirlo mentre è aperto, fare clic sulla freccia accanto al pulsante Apri e quindi fare clic su Apri esclusivo.

    • Per aprire il database per l'accesso in sola lettura, fare clic sulla freccia accanto al pulsante Apri e quindi fare clic su Apri esclusivo di sola lettura gli altri utenti possono comunque aprire il database, ma hanno solo accesso in sola lettura.

Se non si riesce a trovare il database che si vuole aprire    

  1. Nella finestra di dialogo Apri fare clic sul collegamento al computer personale oppure, nella casella Cerca in , fare clic su risorse del computer.

  2. Nell'elenco di unità fare clic con il pulsante destro del mouse sull'unità che potrebbe contenere il database e quindi scegliere Cerca.

  3. Immettere i criteri di ricerca e quindi premere INVIO per cercare il database.

  4. Se il database viene trovato, aprirlo facendo doppio clic su di esso nella finestra di dialogo Risultati ricerca .

    Dato che la ricerca è stata avviata dalla finestra di dialogo Apri , è necessario fare clic su Annulla nella finestra di dialogo prima che il database venga aperto.

È possibile aprire direttamente un file di dati in un formato di file esterno, ad esempio dBASE, Paradox, Microsoft Exchange o Excel. Si può anche aprire direttamente qualsiasi origine dati ODBC, come Microsoft SQL Server o Microsoft FoxPro. Access crea automaticamente un nuovo database di Access nella stessa cartella del file di dati e aggiunge i collegamenti a ogni tabella del database esterno.

Inizio pagina

Iniziare a usare il nuovo database

A seconda del modello usato, potrebbe essere necessario eseguire una o più delle operazioni seguenti per iniziare a usare il nuovo database:

  • Se in Access viene visualizzata una finestra di dialogo di accesso con un elenco di utenti vuoto, usare la procedura seguente per iniziare:

    1. Fare clic su nuovo utente.

    2. Compila il modulo Dettagli utente .

    3. Fare clic su Salva e chiudi.

    4. Selezionare il nome utente appena immesso e quindi fare clic su login.

  • Se in Access viene visualizzato un foglio dati vuoto, è possibile iniziare a digitare i dati direttamente nel foglio dati oppure fare clic su altri pulsanti e schede per esplorare il database.

  • Se in Access viene visualizzata una pagina introduttiva, è possibile fare clic sui collegamenti nella pagina per ottenere altre informazioni sul database oppure fare clic su altri pulsanti e schede per esplorare il database.

  • Se in Access viene visualizzato un messaggio di avviso di sicurezza nella barra dei messaggi e si considera attendibile l'origine del modello, fare clic su Abilita contenuto. Se il database richiede un account di accesso, sarà necessario eseguire di nuovo l'accesso.

Per i database desktop e Web, è anche necessario iniziare con una di queste operazioni:

Inizio pagina

Aggiungere una tabella

È possibile aggiungere una nuova tabella a un database esistente usando gli strumenti disponibili nel gruppo tabelle della scheda Crea .

Gruppo Tabelle nella scheda Crea

Nota: In un database Web è disponibile solo il comando tabella nel gruppo tabelle .

Indipendentemente dalla visualizzazione avviata, è sempre possibile passare all'altra visualizzazione usando i pulsanti Visualizza nella barra di stato della finestra di Access.

Creare una tabella vuota in visualizzazione foglio dati    In visualizzazione foglio dati è possibile immettere immediatamente i dati e consentire all'utente di creare la struttura della tabella dietro le quinte. I nomi dei campi vengono assegnati numericamente (campo1, campo2 e così via) e Access imposta il tipo di dati campo in base al tipo di dati immessi.

  1. Nel gruppo tabelle della scheda Crea fare clic su tabella Icona del pulsante .

  2. Access crea la tabella e quindi posiziona il cursore nella prima cella vuota nella colonna fare clic per aggiungere .

  3. Per aggiungere dati, iniziare a digitare nella prima cella vuota oppure incollare i dati da un'altra origine, come descritto più avanti in questo articolo.

    • Per rinominare una colonna (campo), fare doppio clic sull'intestazione di colonna e quindi digitare il nuovo nome.

      Suggerimento: Assegnare un nome significativo a ogni campo, in modo che sia possibile stabilire cosa contiene senza dover esaminare i dati.

    • Per spostare una colonna, selezionarla facendo clic sull'intestazione di colonna e quindi trascinarla nella posizione desiderata. È anche possibile selezionare diverse colonne contigue e trascinarle tutte in una nuova posizione insieme.

      Per aggiungere altri campi alla tabella, è possibile iniziare a digitare nella colonna fare clic per aggiungere in visualizzazione foglio dati oppure è possibile aggiungere nuovi campi usando i comandi del gruppo Aggiungi & Elimina nella scheda campi .

Creare una tabella a partire dalla visualizzazione struttura    In visualizzazione Struttura occorre prima di tutto creare la struttura della nuova tabella. È quindi possibile passare alla visualizzazione foglio dati per immettere dati oppure immettere i dati usando un altro metodo, ad esempio con un modulo.

La visualizzazione struttura non è disponibile per le tabelle di un database Web.

  1. Nel gruppo Tabelle della scheda Crea fare clic su Struttura tabella. Icona del pulsante

  2. Per ogni campo incluso nella tabella, digitare un nome nella colonna Nome campo e quindi selezionare il tipo di dati nell'elenco Tipo dati.

  3. È possibile immettere informazioni aggiuntive per ogni campo nella colonna Descrizione . La descrizione immessa viene visualizzata nella barra di stato quando il punto di inserimento si trova in tale campo e viene usato come testo della barra di stato per tutti i controlli creati trascinando il campo dal riquadro elenco campi a una maschera o a un report e per tutti i controlli creati per tale campo dalla creazione guidata maschera o creazione guidata report.

  4. Dopo aver aggiunto tutti i campi, salvare la tabella:

    • Nella scheda File fare clic su Salva.

  5. È possibile iniziare a immettere i dati nella tabella in qualsiasi momento passando alla visualizzazione foglio dati, facendo clic nella prima cella vuota e digitando. È anche possibile incollare dati da un'altra origine, come descritto nella sezione successiva.

Creare una tabella in base a un elenco di SharePoint    Con un elenco di SharePoint, i dati possono essere usati da utenti che non hanno accesso. Inoltre, i dati di elenco vengono archiviati in un server, che in genere offre una migliore protezione dalla perdita di dati rispetto ai file archiviati in un computer desktop. Si può iniziare con un nuovo elenco oppure è possibile creare un collegamento a un elenco esistente. È necessario disporre di autorizzazioni sufficienti per il sito di SharePoint in cui si vuole creare l'elenco. Questo può variare in base al sito in modo da contattare l'amministratore di SharePoint per informazioni dettagliate sulle opzioni.

Questa caratteristica non è disponibile in un database Web.

  1. Nel gruppo Tabelle della scheda Crea fare clic su Elenchi SharePoint.

  2. È possibile usare uno dei modelli di elenco per creare un elenco di SharePoint standard, ad esempio contatti o eventi.

    È anche possibile scegliere di creare un elenco personalizzato oppure di creare un collegamento o importare un elenco esistente. Fare clic sull'opzione desiderata.

  3. Se si sceglie uno dei modelli di elenco o si crea un elenco personalizzato, verrà visualizzata la finestra di dialogo Crea nuovo elenco per illustrare il processo. Se si sceglie di usare un elenco esistente, verrà visualizzata la finestra di dialogo Carica dati esterni .

Per altre informazioni sulle tabelle, vedere l'articolo Introduzione alle tabelle.

Inizio pagina

Incollare dati da un'altra origine in una tabella di Access

Se i dati sono attualmente archiviati in un altro programma, ad esempio Excel, è possibile copiare e incollare i dati in una tabella di Access. L'esito dell'operazione risulta in genere più accurato se i dati sono già separati in colonne, come nei fogli di lavoro di Excel. Se i dati sono contenuti in un programma di elaborazione di testo, è innanzitutto necessario separare le colonne di dati usando le schede oppure convertire i dati in una tabella nel programma di elaborazione di testo e quindi copiare i dati. Se i dati necessitano di modifiche o manipolazioni, ad esempio per separare i nomi completi in nomi e cognomi, è consigliabile eseguire questa operazione prima di copiare i dati, in particolare se non si ha familiarità con l'accesso.

Quando si incollano dati in una tabella vuota, il tipo di dati di ogni campo viene impostato automaticamente in base al tipo di dati copiati. Ad esempio, se in un campo vengono incollate solo date, Access applica il tipo di dati Data/ora. Se invece il campo in cui sono stati incollati i dati contiene solo le parole "sì" e "no", Access applica il tipo di dati Sì/No.

Ai campi viene attribuito un nome in base al contenuto della prima riga dei dati incollati. Se la prima riga di dati incollati è simile nel tipo alle righe che seguono, Access determina che la prima riga fa parte dei dati e assegna i campi nomi generici (campo1, campo2 e così via). Se la prima riga di dati incollati non è simile a quella seguita, Access utilizza la prima riga come nomi di campo ed esclude la prima riga dei dati effettivi.

Se vengono assegnati nomi generici ai campi, è consigliabile rinominarli appena possibile per evitare confusione. Seguire questa procedura:

  1. Nella scheda file fare clic su Salva per salvare la tabella.

  2. In visualizzazione foglio dati fare doppio clic su ogni intestazione di colonna e quindi digitare un nome per la colonna.

  3. Salvare di nuovo la tabella.

Inizio pagina

Importare o collegare dati da un'altra origine

Potresti avere dati che hai raccolto in un altro programma che desideri utilizzare in Access. Forse si lavora con persone che archiviano i propri dati in altri programmi e si vogliono usare i dati in Access. In alternativa, è possibile che siano presenti più origini di dati diversi e che sia necessaria una "piattaforma di atterraggio", in cui è possibile riunirle per un'analisi più approfondita.

Access facilita l'importazione o il collegamento di dati da altre applicazioni. È possibile inserire dati da un foglio di lavoro di Excel, da una tabella in un altro database di Access, da un elenco di SharePoint o da una varietà di altre origini. Il processo differisce leggermente in base all'origine dati, ma queste istruzioni vengono avviate:

  1. Nel gruppo Importa _AMP_ collegamento della scheda dati esterni fare clic sul comando corrispondente al tipo di file da cui si sta eseguendo l'importazione.

    Ad esempio, se si intende importare dati da un foglio di lavoro di Excel, fare clic su Excel. Se il tipo di programma corretto non è visualizzato, fare clic su altro.

    Nota: Se non si riesce a trovare il tipo di formato corretto nel gruppo Importa _AMP_ link , potrebbe essere necessario avviare il programma in cui sono stati creati originariamente i dati e quindi usare tale programma per salvare i dati in un formato di file supportato da Access, ad esempio file con testo delimitato. e quindi importare o collegare i dati.

  2. Nella finestra di dialogo Carica dati esterni , fare clic su Sfoglia per passare al file di dati di origine oppure digitare il percorso completo del file di dati di origine nella casella nome file .

  3. Fare clic sull'opzione desiderata in specificare come e dove archiviare i dati nel database corrente. È possibile creare una nuova tabella usando i dati importati oppure creare una tabella collegata che mantiene un collegamento all'origine dati.

  4. Fare clic su OK.

    A seconda della scelta, viene visualizzata la finestra di dialogo Collega oggetti o la finestra di dialogo Importa oggetti .

  5. Usare la finestra di dialogo per terminare il processo. La procedura esatta seguita dipende dall'opzione di importazione o collegamento scelta.

  6. Nell'ultima pagina della creazione guidata fare clic su Fine.

    Se si è scelto di importare, verrà richiesto se si vogliono salvare i dettagli dell'operazione di importazione appena completata.

  7. Se si ritiene che l'operazione di importazione venga eseguita di nuovo, fare clic su Salva passaggi di importazionee quindi immettere i dettagli.

    È quindi possibile riprodurre facilmente l'operazione di importazione facendo clic su imPortazioni salvate nel gruppo Importa della scheda dati esterni , facendo clic sulla specifica di importazione e quindi scegliendo Esegui.

  8. Se non si vogliono salvare i dettagli dell'operazione, fare clic su Chiudi.

Access importa i dati in una nuova tabella e quindi Visualizza la tabella sotto tabelle nel riquadro di spostamento.

Per altre informazioni su come importare dati in Access, seguire i collegamenti nella sezione vedere anche di questo articolo.

Inizio pagina

Passaggi successivi

Il resto del processo di progettazione varia in base ai tuoi obiettivi, ma probabilmente vorrai provare a creare query, maschere, report e macro. Questo articolo non fornisce informazioni sulla creazione di oggetti di database aggiuntivi.

Per altre informazioni, vedere questi articoli:

Inizio pagina

Importare dati da un foglio di calcolo o da un altro programma

Se si ha familiarità con altri programmi di database o fogli di calcolo, è probabile che si conoscano le nozioni di base per il funzionamento di queste applicazioni e per quali database vengono utilizzati. Access differisce da molte altre applicazioni di database consentendoti di creare database relazionali e differisce ulteriormente dalla maggior parte dei programmi di fogli di calcolo offrendo strumenti per lo sviluppo di query, maschere e report sofisticati. Access offre anche molte opzioni per l'uso di altre applicazioni di database, ad esempio SQL Server.

Importare un foglio di lavoro di Excel in Access

Molti utenti iniziano ad esplorare Access dopo aver creato un elenco in Excel. Excel è il luogo ideale in cui avviare un elenco, ma man mano che l'elenco cresce, diventa più difficile organizzarlo e mantenerlo aggiornato. Lo spostamento dell'elenco in Access è in genere il passaggio logico successivo.

Una tabella di database è simile alla struttura di un foglio di lavoro, in cui i dati vengono archiviati in righe e colonne. Di conseguenza, è in genere facile importare un foglio di lavoro in una tabella di database. La differenza principale tra l'archiviazione dei dati in un foglio di lavoro e l'archiviazione in un database è la modalità di organizzazione dei dati. L'importazione dell'intero foglio di lavoro come nuova tabella in un database non risolve i problemi associati all'organizzazione e all'aggiornamento dei dati, in particolare se il foglio di lavoro contiene dati ridondanti. Per risolvere questi problemi, è necessario suddividere i dati del foglio di calcolo in tabelle separate, ognuna contenente dati correlati. Per altre informazioni su come disporre i dati nelle tabelle, vedere l'articolo Nozioni fondamentali sulla progettazione di database.

Funzionalità di Access è la procedura guidata Analizzatore tabelle, che può essere utile per completare il processo. Dopo aver importato i dati in una tabella, la procedura guidata consente di dividere la tabella in tabelle separate, ognuna delle quali contiene dati non duplicati in nessuna delle altre tabelle. La procedura guidata crea anche le relazioni necessarie tra le tabelle.

Inizio pagina

Importare un foglio di lavoro di Excel come tabella in un nuovo database

  1. Nella scheda File fare clic su Nuovo e quindi su Database vuoto.

  2. Digitare un nome per il nuovo database nella casella nome file e quindi fare clic su Crea.

    Si apre il nuovo database e Access crea una nuova tabella vuota, Tabella1.

  3. Chiudere Tabella1.

    Quando viene richiesto se si desidera salvare le modifiche apportate alla struttura di Tabella1, fare clic su No.

  4. Nel gruppo Importa _AMP_ collegamento della scheda dati esterni fare clic su Excel. Icona del pulsante

  5. Nella finestra di dialogo Carica dati esterni fare clic su Sfoglia.

  6. Usare la finestra di dialogo Apri file per individuare il file.

  7. Selezionare il file e quindi fare clic su Apri.

  8. Nella finestra di dialogo Carica dati esterni verificare che l'opzione Importa dati di origine in una nuova tabella nell'opzione database corrente sia selezionata.

  9. Fare clic su OK.

    Verrà avviata l'importazione guidata foglio di calcolo e verranno poste alcune domande sui dati.

  10. Seguire le istruzioni, fare clic su Avanti o indietro per spostarsi tra le pagine. Nell'ultima pagina della creazione guidata fare clic su Fine.

    Nota: In Access viene chiesto se si vogliono salvare i dettagli dell'operazione di importazione appena completata. Se si ritiene che l'operazione di importazione venga eseguita di nuovo, fare clic su e quindi immettere i dettagli. È quindi possibile riprodurre facilmente l'operazione in futuro facendo clic su imPortazioni salvate nel gruppo Importa della scheda dati esterni . Se non si vogliono salvare i dettagli dell'operazione, fare clic su Chiudi.

Access importa i dati in una nuova tabella e quindi lo Visualizza in tutte le tabelle nel riquadro di spostamento.

Inizio pagina

Usare la procedura guidata Analizzatore tabelle per organizzare i dati

Dopo l'importazione dei dati in una tabella di Access, è possibile usare la procedura guidata Analizzatore tabelle per identificare rapidamente i dati ridondanti. La procedura guidata offre quindi un modo semplice per organizzare i dati in tabelle separate, in modo che vengano archiviati nel modo più efficiente. Access mantiene la tabella originale come backup e quindi crea nuove tabelle che è possibile usare come base per l'applicazione di database.

  1. Aprire il database di Access che contiene la tabella che si vuole analizzare.

  2. Nel gruppo analizza della scheda Strumenti database fare clic su Analizza tabella.

    Verrà avviata la creazione guidata Analizzatore tabelle.

    Le prime due pagine della procedura guidata contengono una breve esercitazione, completa di pulsanti che è possibile fare clic per visualizzare gli esempi. Se le pagine introduttive non sono visualizzate, ma viene visualizzata una casella di controllo Mostra pagine introduttive, selezionare la casella di controllo e quindi fare clic su indietro due volte per visualizzare l'introduzione. Se non si vuole visualizzare di nuovo le pagine introduttive dopo aver letto l'introduzione, è possibile deselezionare la casella di controllo Mostra pagine introduttive .

  3. Nella tabella che contiene i campi con valori ripetuti in molti record? , selezionare la tabella che si vuole analizzare e quindi fare clic su Avanti.

  4. È possibile lasciare che la procedura guidata decida quali campi vengono inseriti in quali tabelle oppure è possibile prendere questa decisione. Se si seguono i suggerimenti della procedura guidata, è comunque possibile apportare modifiche al layout di tabella nella pagina successiva della procedura guidata.

    Nota: Se si lascia che la procedura guidata decida quali campi inserire in quali tabelle, le relative opzioni potrebbero non essere sempre appropriate per i dati, in particolare se non ci sono molti dati da usare. Verifica attentamente i risultati della procedura guidata. D'altro canto, la procedura guidata potrebbe suggerire un'organizzazione più efficiente rispetto a quella a cui stai pensando, quindi è consigliabile provare almeno una volta le decisioni della procedura guidata. Se non si è soddisfatti dei suggerimenti, è comunque possibile ridisporre i campi manualmente, quindi è sempre possibile fare clic su indietro e disporre tutti i campi manualmente.

  5. Fare clic su Avanti. In questa pagina si specificano le tabelle che contengono i campi. Se si è scelto di consentire la creazione guidata, è consigliabile visualizzare più tabelle connesse tramite linee di relazione. In caso contrario, Access crea una sola tabella contenente tutti i campi. In entrambi i casi, puoi apportare modifiche in questa pagina.

    • È possibile trascinare i campi da una tabella in un'area vuota della pagina per creare una nuova tabella che contiene questi campi. Access richiede un nome di tabella.

    • È possibile trascinare i campi da una tabella a un'altra, se si ritiene che verranno archiviati in modo più efficiente.

    • Alla maggior parte delle tabelle verrà assegnato un ID o un campo ID univoco generato . Per altre informazioni sui campi ID, fare clic su suggerimenti nell'angolo in alto a destra della procedura guidata.

    • Per annullare una modifica, fare clic sul pulsante Annulla .

    • Per rinominare una tabella, fare doppio clic sulla barra del titolo, digitare il nuovo nome e quindi fare clic su OK.

  6. Dopo aver organizzato i campi nel modo desiderato, fare clic su Avanti.

  7. Se la procedura guidata trova i record con valori molto simili, li identificherà come possibili errori tipografici e presenta una schermata in cui è possibile confermare il comportamento. Scorrere l'elenco per trovare i valori nella colonna correzione e quindi fare clic sull'elemento appropriato nell'elenco a discesa. Selezionare (abbandona così com'è) per impedire alla procedura guidata di apportare modifiche al valore. Al termine, fare clic su Avanti.

  8. La procedura guidata chiede se si vuole creare una query simile alla tabella originale. Se sono già state create maschere e report basati sulla tabella originale, è consigliabile creare una query di questo tipo. Se si sceglie Sì, creare la query, la procedura guidata ridenomina la tabella originale aggiungendo "aggiunto" al nome della tabella e quindi assegna un nome alla nuova query usando il nome della tabella originale. Le maschere e i report basati sulla tabella ora usano la query per i dati e continuano a funzionare come prima.

  9. Fare clic su Fine.

    La procedura guidata crea le nuove tabelle come specificato e quindi le apre. Chiudili al termine del controllo dei risultati.

Inizio pagina

Usare i dati di altre applicazioni

Access 2010 fornisce funzionalità per l'utilizzo dei dati archiviati in altre applicazioni.

Creare un nuovo database di Access che si collega ai dati in un altro formato di file    È possibile usare Access per aprire un file in un altro formato di file, ad esempio testo, dBASE o un foglio di calcolo. Access crea automaticamente un database di Access e ne collega il file.

  1. Avviare Access.

  2. Nella scheda File fare clic su Apri.

  3. Nella finestra di dialogo Apri fare clic sul tipo di file che si desidera aprire nell'elenco. Se non si è sicuri del tipo di file, fare clic su tutti i file (*. *).

  4. Se necessario, passare alla cartella contenente il file che si vuole aprire. Quando si trova il file, fare doppio clic su di esso per aprirlo.

  5. Seguire le istruzioni della procedura guidata. Nell'ultima pagina della creazione guidata fare clic su Fine.

Importare o collegare dati a un database di Access esistente    È possibile importare dati da altre origini e programmi in tabelle di Access in modo che i dati siano contenuti all'interno del file di Access oppure sia possibile creare un collegamento ai dati da Access in modo che i dati rimangano nel file originale (al di fuori del file di Access).

  1. Nel gruppo Importa _AMP_ collegamento della scheda dati esterni fare clic sul formato in cui sono archiviati i dati.

    È possibile importare o collegare i dati dalle origini seguenti:

    • Excel    È possibile inserire dati da un foglio di lavoro o da un intervallo denominato in una cartella di lavoro di Excel. Ogni foglio di lavoro o intervallo denominato deve essere importato o collegato separatamente.

    • Access    Questo è molto utile per separare il processo dai dati, creando un database diviso. In altri casi, puoi usare un database per contenere tutti i moduli, i report e le macro e mantenere i dati in un altro database. Potrai quindi sviluppare miglioramenti senza interrompere il lavoro di nessuno. È anche possibile combinare i dati di diversi database di Access in uno, semplificando così il riepilogo dei dati tra reparti o tra partner commerciali.

    • database ODBC    Molti programmi supportano questo formato, tra cui molti prodotti server di database. In questo modo è possibile creare database di "piattaforma di atterraggio", in cui combinare i dati di sistemi diversi.

    • File di testo    È possibile connettersi a un file di testo semplice e può anche usare Access per modificare il contenuto di tale file. In questo modo, i dati di accesso possono essere facilmente utilizzabili con un'ampia gamma di programmi.

    • File XML    Questo formato offre anche la compatibilità con una varietà di altri programmi, tra cui alcuni server Web.

    • Elenco SharePoint    In questo modo i dati sono utilizzabili con un Web browser, il metodo standard per usare un elenco di SharePoint.

    • Servizi dati    È possibile connettersi ai servizi dati Web all'interno dell'organizzazione.

    • Documento HTML    

    • Cartella di Outlook    È possibile connettersi alle cartelle di Outlook, in modo da integrare più facilmente le informazioni di contatto con il resto dei dati.

    • file dBase    dBase è un sistema di database alternativo popolare supportato da Access

      Verrà visualizzata la finestra di dialogo Carica dati esterni .

  2. Seguire le istruzioni nella finestra di dialogo.

    Access importerà o collegherà i dati al database. Per la maggior parte dei formati, è necessario specificare la posizione dei dati e quindi scegliere come archiviare i dati nel database.

Inizio pagina

Usare un database di versioni precedenti in diverse versioni di Access

Se il database di Access o il progetto di Access è stato creato in Access 2000 o versioni successive, è possibile usare il database o il progetto nella versione di Access in cui è stato creato o in una versione successiva, anche se il file è abilitato per la sicurezza. Ad esempio, i file di Access 2000 possono essere usati in Access 2000, Access 2002, Access 2003, Access 2007 e Access 2010.

È possibile che si trovi una situazione in cui si vogliono mantenere i dati in una versione precedente di Access, ma si hanno utenti con una versione successiva di Access che desiderano creare un collegamento ai dati, ma che sfruttano ancora alcune delle funzionalità della versione successiva. La soluzione consiste nel creare un nuovo database "front-end" nella versione successiva (contenente maschere, report, query, macro, ma senza tabelle) e collegarlo alle tabelle nel file di versione precedente. Usare una delle procedure seguenti, a seconda che il database sia contenuto in un file o che sia già diviso in un applicazione front-end/back-end.

Usare un file di database di Access in diverse versioni di Access

Se tutte le tabelle, le maschere e gli altri oggetti del database di Access della versione precedente sono contenuti in un unico file e si vuole usare il database in diverse versioni di Access, è possibile creare un nuovo database front-end in una versione successiva e collegarlo al file originale. Gli utenti con la versione precedente di Access possono ancora usare il database originale. Gli utenti che hanno la versione successiva possono usare il nuovo database front-end per collegarsi agli stessi dati. È possibile creare diverse versioni front-end se è necessario adattare più versioni di Access.

Inizio pagina

Passaggio 1: creare una copia del database esistente e salvarlo in un nuovo formato

Usare la procedura seguente per convertire il database in uno dei tre formati più recenti: Access 2000, Access 2002-2003 o Access 2007. Questo comando conserva il database originale nel formato originale e crea una copia nel formato specificato.

  1. Chiudere il file di Access. Se il file è un database di Access multiutente che si trova in un server o in una cartella condivisa, assicurarsi che nessun altro sia aperto.

  2. Avviare Access 2010.

  3. Nella scheda File fare clic su Apri.

  4. Passare al percorso del file che si vuole convertire e quindi fare doppio clic su di esso per aprirlo.

    Se viene visualizzata la finestra di dialogo miglioramento database , che chiede se si vuole migliorare il database, fare clic su No.

  5. Se viene visualizzata una maschera quando si avvia il database, chiudere la maschera.

  6. Nella scheda file fare clic su Salva database con nome.

  7. Nella finestra di dialogo Salva con nome digitare un nome per il nuovo database.

    Nota: A meno che non si salvi il nuovo database in un percorso diverso, il nome deve essere diverso da quello del database originale. In entrambi i casi, in genere è consigliabile usare un nome diverso, in modo da poter distinguere facilmente tra il database front-end e il database back-end. Tuttavia, se si sta convertendo in formato Access 2007, l'estensione del nome file viene modificata da mdb a accdb, in modo da poter usare lo stesso nome file.

  8. Fare clic su Salva.

Inizio pagina

Passaggio 2: dividere il database di copia e usare il file originale come database back-end

Dividere il database convertito usando la procedura seguente:

  • Nel gruppo spostare dati della scheda Strumenti database fare clic su database di Access. Icona del pulsante

  • Nella finestra di dialogo database Splitter fare clic su Suddividi database.

    È possibile creare una copia di backup, se si vuole, ma è anche possibile ricrearla semplicemente usando il database originale.

  • Digitare un nome per il database back-end e quindi fare clic su Dividi.

Inizio pagina

Passaggio 3: connettere il nuovo front-end al database originale

  1. Eliminare il database back-end creato dallo strumento di divisione del database, facendo attenzione a non eliminare il database originale.

  2. Collegare il nuovo database front-end alle tabelle del database originale: nel gruppo Importa _AMP_ collegamento della scheda dati esterni fare clic su Gestione tabelle collegate. Icona del pulsante

  3. Fare clic su Seleziona tuttoe quindi selezionare la casella di controllo Richiedi sempre nuovo percorso .

  4. Fare clic su OK, passare al database di versioni precedenti e quindi fare doppio clic su di esso.

    Se tutto va bene, in Access viene visualizzato un messaggio che indica che tutte le tabelle collegate selezionate sono state aggiornate correttamente.

Ora è possibile migliorare il nuovo database front-end per supportare nuove funzionalità per gli utenti che dispongono di versioni più recenti di Access. Gli utenti che hanno versioni precedenti possono continuare a usare il database di versioni precedente.

Inizio pagina

Usare un'applicazione front-end/back-end in diverse versioni di Access

Se il database di Access è già applicazione front-end/back-end, è possibile convertire il front-end nel nuovo formato di file. Non sono necessarie modifiche per il database back-end.

La procedura seguente illustra come usare il comando Salva database come per convertire il database front-end in uno dei tre formati più recenti: Access 2000, Access 2002-2003 o Access 2007. Questo comando conserva il database originale nel formato originale e crea una copia nel formato specificato.

  1. Chiudere il database front-end. Se il file è un database di Access multiutente che si trova in un server o in una cartella condivisa, verificare che nessun altro sia aperto.

  2. Avviare Access 2010.

  3. Nella scheda File fare clic su Apri.

  4. Passare al percorso del database front-end e quindi fare doppio clic su di esso per aprirlo.

    Se viene visualizzata la finestra di dialogo miglioramento database , che chiede se si vuole migliorare il database, fare clic su No.

  5. Se un modulo viene visualizzato quando si apre il database, chiudere la maschera.

  6. Nella scheda file fare clic su Salva database con nome.

  7. Nella finestra di dialogo Salva con nome digitare un nome per il nuovo database.

  8. Fare clic su Salva.

Ora è possibile migliorare il nuovo database front-end per supportare nuove funzionalità.

Inizio pagina

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×