Visualizzare un modello di modulo in anteprima

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per assicurarsi che i moduli basati sul modello di modulo creato funzionino come previsto durante la compilazione, è possibile visualizzare il modello di modulo in anteprima per verificarne l'aspetto e le funzionalità. Se si visualizza l'anteprima durante la progettazione, è possibile verificare un controllo o una funzionalità in particolare. È inoltre consigliabile visualizzare il modello di modulo in anteprima prima di pubblicarlo.

Contenuto dell'articolo

Panoramica

Visualizzare un modello di modulo in anteprima

Visualizzare un modello di modulo in anteprima con attendibilità completa o livello di protezione con restrizioni

Visualizzare un modello di modulo in anteprima con livello di protezione Dominio

Visualizzare un modello di modulo in anteprima con dati di esempio

Panoramica

Quando si progetta un modello di modulo, è possibile utilizzare la caratteristica Anteprima per verificare la funzionalità e l'aspetto del modello di modulo. Visualizzazione in anteprima e verifica il modello di modulo consente di visualizzare e lavorare con il modello di modulo dal punto di vista degli utenti. Quando si fa clic su Anteprima nella barra degli strumenti Standard, verrà aperto un modulo basato sul modello di modulo in una nuova finestra di anteprima. È quindi possibile testare il modello di modulo tramite l'immissione di dati nei controlli per controllare varie caratteristiche, ad esempio formattazione condizionale, regole, formule e convalida dei dati formattazione di testo. Se si usano i livelli di protezione o aggiungere il modello di modulo ruoli utente, è anche possibile verificare queste caratteristiche durante l'anteprima del modello di modulo. Tramite la finestra di anteprima consente di identificare errori nella finestra di progettazione del modello di modulo e quindi passare rapidamente alla finestra di progettazione, in cui è possibile correggere. Per identificare più facilmente la finestra in uso, Anteprima o struttura viene visualizzato nella barra del titolo di ogni finestra.

Se si utilizza un blocco di dati coerente per verificare il modello di modulo, è possibile migliorare l'efficacia e l'accuratezza delle prove utilizzando un modulo con dati di esempio anziché immettere manualmente i dati ogni volta che si visualizza il modello di modulo in anteprima. I dati di esempio sono segnaposto visualizzati nei controlli del modulo e illustrano l'aspetto del testo durante la compilazione del modulo. I dati di esempio sono visibili solo quando si visualizza il modello di modulo in anteprima.

Inizio pagina

Visualizzare un modello di modulo in anteprima

  1. Per verificare un ruolo utente nel modello di modulo, specificare con quale ruolo utente si desidera verificare il modello di modulo.

    Procedura

    1. Scegliere Opzioni modulo dal menu Strumenti.

    2. Nell'elenco Categoria fare clic su Anteprima.

    3. Nell'elenco Anteprima come in Ruolo utente fare clic sul ruolo utente da verificare.

  2. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Visualizzare un modello di modulo in anteprima con attendibilità completa o livello di protezione con restrizioni

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco Categoria fare clic su Protezione e attendibilità.

  3. In Livello di protezione deselezionare la casella di controllo Determina automaticamente il livello di protezione (scelta consigliata) e fare clic sul livello di protezione che si desidera applicare al modello di modulo.

  4. Fare clic su OK.

  5. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Visualizzare un modello di modulo in anteprima con livello di protezione Dominio

  1. Scegliere Opzioni modulo dal menu Strumenti.

  2. Nell'elenco Categoria fare clic su Protezione e attendibilità.

  3. In Livello di protezione deselezionare la casella di controllo Determina automaticamente il livello di protezione (scelta consigliata) e fare clic su Dominio (il modulo può accedere a contenuto incluso nel dominio di appartenenza).

  4. Nell'elenco Categoria fare clic su Anteprima.

  5. Nella casella Dominio immettere il nome del dominio in cui verrà pubblicato il modello di modulo.

  6. Fare clic su OK.

  7. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Visualizzare un modello di modulo in anteprima con dati di esempio

Se si intende verificare più volte un modello di modulo, è possibile risparmiare tempo creando un modulo basato sul modello di modulo contenente dati di esempio e quindi configurando il modello di modulo affinché utilizzi i dati di esempio ogni volta che si visualizza il modello di modulo in anteprima. Se si sceglie di utilizzare un modulo con dati di esempio non sarà necessario immettere gli stessi dati ogni volta che si visualizza il modello di modulo in anteprima.

  1. Fare clic su Anteprima sulla barra degli strumenti Standard o premere CTRL+MAIUSC+B.

  2. Immettere i dati di esempio nei controlli appropriati.

  3. Scegliere Salva dal menu File.

  4. Nella finestra di dialogo Salva con nome selezionare la posizione in cui si desidera salvare il modulo con i dati di esempio e quindi fare clic su Salva.

  5. Fare clic su Chiudi anteprima sulla barra degli strumenti Standard.

  6. Scegliere Opzioni modulo dal menu Strumenti.

  7. Nell'elenco Categoria fare clic su Anteprima.

  8. Nella casella Percorso file in Dati di esempio fare clic su Sfoglia.

  9. Nella finestra di dialogo Sfoglia selezionare il percorso in cui si è salvato il modulo con i dati di esempio, fare clic sul modulo e quindi su Apri.

  10. Fare clic su OK.

  11. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×