Valutare una formula annidata un passaggio alla volta

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

In alcuni casi, la comprensione come un' annidata formula calcola il risultato finale è difficile, perché sono presenti numerosi calcoli intermedi e test logici. Tuttavia, utilizzando la finestra di dialogo Valuta Formula, è possibile visualizzare le diverse parti di una formula nidificata valutate nell'ordine che viene calcolata la formula. Ad esempio, la formula =IF(AVERAGE(F2:F5) > 50,SUM(G2:G5),0) è più semplice da comprendere quando è possibile visualizzare i risultati intermedi seguenti:

Passaggi visualizzati nella finestra di dialogo

Descrizione

=SE(MEDIA(F2:F5)>50,SOMMA(G2:G5),0)

La formula annidata viene inizialmente visualizzata. Le funzioni MEDIA e SOMMA sono annidate nella funzione SE.

=SE(40>50;SOMMA(G2:G5);0)

L'intervallo di celle F2: F5 contiene i valori 55, 35, 45 e 25 e il risultato della funzione F2: F5 sarà 40.

=SE(FalsoSOMMA(G2:G5);0)

40 non è maggiore di 50, in modo che l'espressione nel primo argomento della funzione se (l'argomento test) è falsa.

0

La funzione se restituisce il valore del terzo argomento (l'argomento se_falso). La funzione somma non viene valutata perché è il secondo argomento della funzione se (argomento se_vero) e viene restituito solo quando l'espressione è vera.

  1. Selezionare la cella da valutare. È possibile valutare solo una cella per volta.

  2. Nel gruppo Verifica formule della scheda Formule fare clic su Valuta formula.

    Gruppo Verifica formule della scheda Formule

  3. Fare clic su Valuta per esaminare il valore del riferimento sottolineato. Il risultato della valutazione viene visualizzato in corsivo.

    Se la parte sottolineata della formula è un riferimento a un'altra formula, fare clic su Entra per visualizzare l'altra formula nella casella Valutazione. Fare clic su Esci per tornare alla cella e alla formula precedenti.

    Nota: Il pulsante Entra non è disponibile per il riferimento la seconda volta che questo viene visualizzato nella formula o se la formula fa riferimento a una cella di una cartella di lavoro distinta.

  4. Continuare finché ogni parte della formula non è stata valutata.

  5. Per visualizzare nuovamente la valutazione, fare clic su Riavvia.

    Per terminare la valutazione, fare clic su Chiudi.

    Note: 

    • Alcune parti delle formule che utilizzano se e scegliere funzioni non vengono valutate e # n/d viene visualizzato nella casella valutazione.

    • Se un riferimento è vuoto, nella casella Valutazione viene visualizzato il valore zero (0).

    • Le formule con riferimenti circolari potrebbero non restituire come previsto. Volendo riferimenti circolari, è possibile Attiva calcolo iterativo.

    • Le funzioni seguenti vengono ricalcolate ogni volta viene modificato il foglio di lavoro e possono comportare lo strumento di Valuta Formula di risultati diversi rispetto a quanto visualizzato nella cella: casuale, scarto, cella, indiretto, adesso, oggi, casuale, informazioni e somma.Se (in alcuni scenari).

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×