Valutare una formula annidata un passaggio alla volta

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Le modalità adottate da una formula annidata per il calcolo del risultato finale non sono sempre semplici da capire, in quanto esistono diversi test logici e calcoli intermedi. Tuttavia, tramite la finestra di dialogo Valuta formula è possibile visualizzare le diverse parti di una formula annidata valutate nell'ordine in cui la formula viene calcolata. Ad esempio, la formula =SE(MEDIA(F2:F5)>50;SOMMA(G2:G5);0) può essere capita più facilmente se vengono visualizzati i risultati intermedi seguenti:

Passaggi visualizzati nella finestra di dialogo

Descrizione

=SE(MEDIA(F2:F5)>50,SOMMA(G2:G5),0)

La formula annidata viene inizialmente visualizzata. Le funzioni MEDIA e SOMMA sono annidate nella funzione SE.

=SE(40>50;SOMMA(G2:G5);0)

Poiché l'intervallo di celle F2:F5 contiene i valori 55, 35, 45 e 25, il risultato della funzione MEDIA(F2:F5) sarà 40.

=SE(FalsoSOMMA(G2:G5);0)

40 non è maggiore di 50, in modo che l'espressione nel primo argomento della funzione se (l'argomento test) è falsa.

0

La funzione se restituisce il valore del terzo argomento (l'argomento se_falso). La funzione somma non viene valutata perché è il secondo argomento della funzione se (argomento se_vero) e viene restituito solo quando l'espressione è vera.

  1. Selezionare la cella da valutare. È possibile valutare solo una cella per volta.

  2. Nel gruppo Verifica formule della scheda Formule fare clic su Valuta formula.

    The Formula Auditing group on the Formulas tab

  3. Fare clic su Valuta per esaminare il valore del riferimento sottolineato. Il risultato della valutazione viene visualizzato in corsivo.

    Se la parte sottolineata della formula è un riferimento a un'altra formula, fare clic su Entra per visualizzare l'altra formula nella casella Valutazione. Fare clic su Esci per tornare alla cella e alla formula precedenti.

    Nota : Il pulsante Entra non è disponibile per il riferimento la seconda volta che questo viene visualizzato nella formula o se la formula fa riferimento a una cella di una cartella di lavoro distinta.

  4. Continuare finché ogni parte della formula non è stata valutata.

  5. Per visualizzare nuovamente la valutazione, fare clic su Riavvia.

    Per terminare la valutazione, fare clic su Chiudi.

    Note : 

    • Alcune parti delle formule che utilizzano se e scegliere funzioni non vengono valutate e # n/d viene visualizzato nella casella valutazione.

    • Se un riferimento è vuoto, nella casella Valutazione viene visualizzato il valore zero (0).

    • Le funzioni seguenti vengono ricalcolate ogni volta viene modificato il foglio di lavoro e possono comportare la Valuta Formula potrebbe restituire risultati diversi rispetto a quanto visualizzato nella cella: casuale, aree, indice, scarto, cella, indiretto, righe, colonne, adesso, oggi, casuale.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×