Valutare una formula annidata un passaggio alla volta

Le modalità adottate da una formula annidata per il calcolo del risultato finale non sono sempre semplici da capire, in quanto esistono diversi test logici e calcoli intermedi. Tuttavia, tramite la finestra di dialogo Valuta formula è possibile visualizzare le diverse parti di una formula annidata valutate nell'ordine in cui la formula viene calcolata. Ad esempio, la formula = se (media (F2: F5) >50, somma (G2: G5), 0) è più facile da capire quando si possono vedere i risultati intermedi seguenti:

Passaggi visualizzati nella finestra di dialogo

Descrizione

=SE(MEDIA(F2:F5)>50,SOMMA(G2:G5),0)

La formula annidata viene inizialmente visualizzata. Le funzioni MEDIA e SOMMA sono annidate nella funzione SE.

=SE(40>50;SOMMA(G2:G5);0)

Poiché l'intervallo di celle F2:F5 contiene i valori 55, 35, 45 e 25, il risultato della funzione MEDIA(F2:F5) sarà 40.

=SE(FalsoSOMMA(G2:G5);0)

40 non è maggiore di 50, quindi l'espressione nel primo argomento della funzione se (l'argomento test) è false.

0

La funzione SE restituisce il valore del terzo argomento, ovvero di se_falso. La funzione somma non viene valutata perché è il secondo argomento della funzione se (argomento value_if_true) e viene restituito solo quando l'espressione è vera.

  1. Selezionare la cella da valutare. È possibile valutare solo una cella per volta.

  2. Nel gruppo Verifica formule della scheda Formule fare clic su Valuta formula.

    Gruppo Verifica formule della scheda Formule

  3. Fare clic su Valuta per esaminare il valore del riferimento sottolineato. Il risultato della valutazione viene visualizzato in corsivo.

    Se la parte sottolineata della formula è un riferimento a un'altra formula, fare clic su Entra per visualizzare l'altra formula nella casella Valutazione. Fare clic su Esci per tornare alla cella e alla formula precedenti.

    Nota: Il pulsante Entra non è disponibile per il riferimento la seconda volta che questo viene visualizzato nella formula o se la formula fa riferimento a una cella di una cartella di lavoro distinta.

  4. Continuare finché ogni parte della formula non è stata valutata.

  5. Per visualizzare nuovamente la valutazione, fare clic su Riavvia.

    Per terminare la valutazione, fare clic su Chiudi.

    Note: 

    • Alcune parti delle formule che usano le funzioni se e scegli non vengono valutate e #N/A viene visualizzata nella casella valutazione .

    • Se un riferimento è vuoto, nella casella Valutazione viene visualizzato il valore zero (0).

    • Le formule con riferimenti circolari potrebbero non essere valutate come previsto. Se si desiderano riferimenti circolari, è possibile abilitare il calcolo iterativo.

    • Le funzioni seguenti vengono ricalcolate ogni volta che il foglio di lavoro cambia e può causare lo strumento valuta formula per dare risultati diversi da quelli visualizzati nella cella: Rand, offset, cella, indiretto, ora, oggi, casuale, info e somma.se (in alcuni scenari).

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Vedere anche

Come evitare errori nelle formule

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×