Utilizzo dei report per la misurazione delle prestazioni e dell'utilizzo del sito

Di seguito sono indicate alcune domande frequenti relative alla gestione di un sito:

  • Quante persone visitano il sito?

  • Come è cambiato il traffico del sito nel tempo?

  • Chi sono i principali utenti del sito?

  • Da dove proviene il traffico del sito?

  • Quali sono le pagine e le risorse del sito visitate più di frequente?

  • Come è possibile sapere dove si trovano i documenti e le altre risorse nel processo del flusso di lavoro?

Di seguito sono indicate alcune domande specifiche relative alla gestione di un sito Web:

  • È possibile rimuovere dal sito le risorse che non sono più utilizzate o che sono obsolete?

  • Come è possibile individuare i problemi sul sito, ad esempio file non collegati, pagine lente e collegamenti ipertestuali interrotti, prima che vengano rilevati e riportati dagli utenti?

Queste domande possono sembrare molto complesse, ma con Microsoft Office SharePoint Designer 2007 e un sito Windows SharePoint Services 3.0 o un sito Microsoft Office SharePoint Server 2007 è possibile rispondere facilmente a tali domande utilizzando i report di Office SharePoint Designer 2007. In questo articolo viene descritto come utilizzare i report per misurare le prestazioni e l'utilizzo del sito.

Importante : I dati dei report creati da Office SharePoint Designer 2007 vengono salvati sul server in cui si trova il sito. Gli amministratori del server possono consentire o negare l'accesso a questi report. Se i report richiesti non contengono dati, rivolgersi all'amministratore del server per l'assistenza. Per eseguire i report di utilizzo, è necessario disporre dell'autorizzazione Visualizzazione dati di utilizzo e l'amministratore del server deve attivare la raccolta dei dati sull'utilizzo sul server. Per impostazione predefinita, la raccolta dei dati sull'utilizzo sul server è disattivata.

Per saperne di più

Visualizzare il report Riepilogo sito

Visualizzare i report sui file

Visualizzare i report sul contenuto condiviso

Visualizzare i report sui problemi

Visualizzare il report Riepilogo utilizzo

Visualizzare i report dettagliati sull'utilizzo

Rappresentare in un grafico i risultati dei dati sull'utilizzo

Ordinare un report

Filtrare un report

Copiare un report

Salvare un report

Visualizzare il report Riepilogo sito

Il report Riepilogo sito offre una panoramica dettagliata del sito, nonché i collegamenti a report più dettagliati. È possibile ad esempio creare un report Riepilogo sito come quello mostrato nella figura seguente.

Report Riepilogo sito

Per creare un report Riepilogo sito:

  1. Aprire il sito per cui si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Report dal menu Sito e quindi fare clic su Riepilogo sito.

    Verrà creato il report.

Nota : È possibile fare clic sui collegamenti ipertestuali nella colonna Nome per visitare i report più dettagliati. Ad esempio, fare clic su Collegamenti interrotti per andare direttamente al report Collegamenti interrotti.

Torna all'inizio

Visualizzare i report sui file

È possibile creare report che visualizzano tutti i file, i file aggiunti di recente, i file modificati di recente o i file vecchi. Se ad esempio si desidera evidenziare un nuovo contenuto nella home page del sito o in un notiziario che promuove il sito, è possibile utilizzare i report File aggiunti di recente per identificare rapidamente il nuovo contenuto. In alternativa, è possibile utilizzare il report Vecchi file per identificare il contenuto vecchio da rivedere per un eventuale aggiornamento o un'eventuale rimozione.

Per eseguire i report sui file, specificare innanzitutto le definizioni per i file recenti e i file vecchi e specificare inoltre quanti mesi visualizzare nei report per mese:

  1. Aprire il sito Web per il quale si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Opzioni applicazione dal menu Strumenti.

  3. Fare clic sulla scheda Visualizzazione Report.

    Finestra di dialogo Opzioni applicazione con la scheda Visualizzazione Report visualizzata

  4. Nella casella Considera "recenti" i file che risalgono a meno di immettere il numero di giorni che identificano una pagina recente.

  5. Nella casella Considera "vecchi" i file che risalgono a più di immettere il numero di giorni che identificano una pagina vecchia.

  6. Nella casella Numero di mesi visualizzati immettere il numero di mesi che deve essere visualizzato nei report per mense.

  7. Fare clic su OK.

    È possibile ora eseguire i report.

  8. Scegliere Report dal menu Sito, scegliere File e quindi fare clic sul report che si desidera eseguire:

    • Tutti i file     Visualizza un elenco di tutti i file presenti nel sito.

    • File aggiunti di recente     Visualizza un elenco dei file che sono stati aggiunti al sito entro il numero di giorni specificato al passaggio 4.

    • File modificati di recente     Visualizza un elenco dei file che sono stati modificati sul sito entro il numero di giorni specificato al passaggio 4.

    • Vecchi file     Visualizza un elenco dei file considerati "vecchi" in base a quanto indicato dal numero di giorni specificato al passaggio 5.

    • Stato estrazione     Visualizza un elenco di file del sito con lo Stato estrazione corrente di ogni file. Questo report include anche le colonne dei dati Estratto da, Versione e Data blocco.

      In Visualizzazione Report per i report sui file è possibile fare clic sulle opzioni nell'elenco per modificare rapidamente le impostazioni per i file recenti e i file vecchi.

      Visualizzazione Report con il menu del filtro per la data dei file visualizzato

Torna all'inizio

Visualizzare i report sul contenuto condiviso

Il contenuto condiviso può includere le pagine master, le pagine personalizzate e altre pagine incluse nella definizione del sito e i collegamenti ai fogli di stile. Con Office SharePoint Designer 2007 è semplice individuare il contenuto condiviso. Se ad esempio si desidera modificare un logo in tutte le pagine del sito Web e si utilizzano le pagine master per controllare la formattazione delle pagine, è possibile utilizzare il report Pagine master per trovare tutte le pagine master in cui è necessario modificare il logo. È inoltre possibile utilizzare il report Collegamenti a fogli di stile per trovare tutti i fogli di stile che devono essere aggiornati per riflettere una modifica al carattere o alla formattazione che si desidera applicare in tutto il sito.

  1. Aprire il sito Web per il quale si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Report dal menu Sito, scegliere Contenuto condiviso e quindi fare clic sul report che si desidera eseguire:

    • Modelli Web dinamici     Visualizza un elenco di tutte le pagine del sito dove nella colonna Modello Web dinamico viene indicato se ogni pagina è associata a un modello Web dinamico e, in tal caso, quale.

    • Pagine master     Visualizza un elenco di tutte le pagine del sito dove nella colonna Pagina master viene indicato se ogni pagina è associata a una pagina master e, in tal caso, quale.

    • Pagine personalizzate     Visualizza un elenco di tutte le pagine del sito dove nella colonna Personalizzato viene indicato se una pagina basata sulla definizione del sito è stata personalizzata.

    • Collegamenti a fogli di stile     Visualizza un elenco di tutte le pagine del sito dove nella colonna Collegamenti a fogli di stile viene indicato se ogni pagina è associata a un foglio di stile.

      Nota : I collegamenti ai fogli di stile visualizzati sono collegamenti statici (tag <link>). I collegamenti ai fogli di stile dinamici creati dai controlli Microsoft ASP.NET, ad esempio <SharePoint:CssLink>, non sono inclusi in questo report.

Torna all'inizio

Visualizzare i report sui problemi

I report sui problemi di Office SharePoint Designer 2007 consentono di prevedere eventuali problemi potenziali e di risolverli prima che possano essere individuati dagli utenti. È possibile ad esempio utilizzare tali report per identificare pagine lente, individuare collegamenti ipertestuali interrotti e trovare i file da eliminare poiché non sono più collegati ad altri file. Per eseguire i report Problemi, impostare innanzitutto le preferenze relative alla definizione delle pagine lente.

  1. Aprire il sito Web per il quale si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Opzioni applicazioni dal menu Strumenti.

  3. Fare clic sulla scheda Visualizzazione Report.

    Finestra di dialogo Opzioni applicazione con la scheda Visualizzazione Report visualizzata

  4. Nella casella Considera "lente" le pagine che richiedono almeno immettere il numero di secondi che definiscono la durata del download di una pagina lenta.

  5. Nella casella Velocità di trasmissione presunta immettere il numero di Kbps della velocità di connessione media dell'utente.

  6. Fare clic su OK.

    È possibile ora eseguire i report.

  7. Scegliere Report dal menu Sito, scegliere Problemi e quindi fare clic sul report che si desidera eseguire:

    • File non collegati     Visualizza un elenco di tutti i file del sito per cui non sono presenti collegamenti. Questo elenco consente di trovare i file inutilizzati che devono essere rimossi dal sito. Osservare che questo report non considera i collegamenti creati dai controlli ASP.NET, ad esempio la web part Sommario nei siti di Office SharePoint Server 2007.

    • Pagine lente      Visualizza un elenco delle pagine del sito identificate come lente da caricarsi in base alla definizione specificata al passaggio 3 e alla velocità di connessione media specificata al passaggio 4. Osservare che questo report influisce sul tempo necessario per il caricamento dei tag delle pagine. Non considera il contenuto dinamico creato dai controlli ASP.NET.

    • Collegamenti ipertestuali     Visualizza un elenco di tutti i collegamenti ipertestuali del sito. Dopo aver eseguito questo report, verrà visualizzata una finestra di dialogo in cui viene chiesto se si desidera verificare i collegamenti ipertestuali del sito. Fare clic su se si desidera che Office SharePoint Designer 2007 analizzi e verifichi tutti i collegamenti ipertestuali. Il risultato di questo processo è un elenco di collegamenti ipertestuali contrassegnati con OK o Interrotto. Per modificare un collegamento interrotto, fare clic sul collegamento nel report e quindi fare clic su Modifica collegamento ipertestuale sulla barra degli strumenti visualizzata nell'angolo superiore destro della finestra del documento in Visualizzazione Report.

      Nota :  Finestra di dialogo Modifica collegamento ipertestuale

    • Errori componenti     Visualizza un elenco di tutti i componenti, ad esempio Pulsanti interattivi o contatore visite (precedentemente noti genericamente come webbot), che generano errori. È possibile visualizzare un elenco di componenti Web selezionando Componente Web dal menu Inserisci.

Torna all'inizio

Visualizzare il report Riepilogo utilizzo

I report sull'utilizzo del sito offrono ai proprietari del sito alcune risposte alle domande più frequenti relative al sito. Consentono ad esempio di conoscere quante persone utilizzano il sito, quali sono le risorse più utilizzate, chi utilizza principalmente il sito e da dove i visitatori accedono al sito. Il report Riepilogo utilizzo include un riepilogo delle visite totali, delle pagine visitate e dei byte scaricati e molto altro ancora.

Report Riepilogo utilizzo

Per eseguire il report Riepilogo utilizzo, eseguire la procedura seguente:

  1. Aprire il sito Web per il quale si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Report dal menu Sito, scegliere Utilizzo e quindi fare clic su Riepilogo utilizzo.

    Verrà creato il report. È possibile fare clic su un elemento con collegamento ipertestuale nella colonna Nome per visualizzare i report dettagliati.

Torna all'inizio

Visualizzare i report dettagliati sull'utilizzo

È possibile eseguire report dettagliati sull'utilizzo per conoscere il modo in cui gli utenti accedono al sito. Ad esempio, sebbene il report Riepilogo utilizzo creato nella sezione precedente mostri il numero totale di visite, il report Visite mensili offre informazioni dettagliate sul numero di visite a ogni pagina del sito. Per eseguire i report dettagliati sull'utilizzo, eseguire la procedura seguente:

  1. Aprire il sito Web per il quale si desidera eseguire il report in Office SharePoint Designer 2007.

  2. Scegliere Report dal menu Sito, scegliere Utilizzo e quindi fare clic sul report che si desidera eseguire:

    • Riepilogo mensile     Riepiloga il numero di visite, di pagine visitate, di visite totali e le dimensioni di download del sito al mese.

    • Riepilogo settimanale     Riepiloga il numero di visite, di pagine visitate, di visite totali e le dimensioni di download del sito alla settimana.

    • Riepilogo giornaliero     Riepiloga il numero di visite, di pagine visitate, di visite totali e le dimensioni di download del sito al giorno.

    • Visite mensili     Riepiloga il numero di visite totali e di visite al mese per ogni pagina del sito Web.

    • Visite settimanali     Riepiloga il numero di visite totali e di visite alla settimana per ogni pagina del sito Web.

    • Visite giornaliere     Riepiloga il numero di visite totali e di visite al giorno per ogni pagina del sito Web.

    • Visitatori     Riepiloga il numero di visitatori e la relativa percentuale del totale per un mese selezionato.

    • Sistemi operativi     Riepiloga il numero di sistemi operativi dei visitatori e la relativa percentuale del totale per un mese selezionato.

    • Browser     Riepiloga il numero di browser dei visitatori e la relativa percentuale del totale per un mese selezionato.

    • Domini di riferimento     Riepiloga il numero di visite provenienti da un dominio specifico e la relativa percentuale del totale per un mese selezionato.

    • URL di riferimento     Riepiloga il numero di viste provenienti da un URL specifico e la relativa percentuale del totale per un mese selezionato.

    • Stringhe di ricerca     Elenca il numero di stringhe di ricerca digitate nella casella di ricerca del sito e la relativa percentuale del totale per un mese selezionato.

Torna all'inizio

Rappresentare in un grafico i risultati dei dati sull'utilizzo

È possibile creare facilmente un grafico che mostri i dati sull'utilizzo in modo da delineare le tendenze e individuare i modelli di utilizzo.

  1. Scegliere Report dal menu Sito, scegliere Utilizzo e quindi fare clic sul report che si desidera eseguire.

  2. Nell'elenco Grafico della barra degli strumenti, che si trova nell'angolo superiore destro della finestra del documento, fare clic sul tipo di grafico che si desidera creare, ad esempio Istogramma.

    Barra degli strumenti in Visualizzazione Report con l'elenco Grafico visualizzato

    Il report verrà aperto in una nuova finestra.

    Grafico dei dati sull'utilizzo

    Nota : Per impostazione predefinita, i dati del grafico vengono creati insieme ai report sull'utilizzo. Se quando si prova a eseguire il report non sono presenti i dati del grafico, scegliere Opzioni applicazioni dal menu Strumenti, fare clic sulla scheda Visualizzazione Report e quindi verificare che la casella di controllo Includi un grafico nel report sull'utilizzo sia selezionata.

Torna all'inizio

Ordinare un report

In Visualizzazione Report è possibile ordinare un report facendo clic sulle intestazioni di colonna.

Torna all'inizio

Filtrare un report

È possibile restringere i risultati del report in modo da visualizzare solo le informazioni desiderate. È possibile filtrare in base a una sola colonna o a più colonne in modo da creare un filtro progressivo.

  1. Scegliere Report dal menu Sito e quindi fare clic sul report che si desidera eseguire.

  2. Fare clic sulla freccia accanto all'intestazione della colonna in base alla quale si desidera filtrare e quindi fare clic sui dati che si desidera filtrare.

    Ad esempio, quando si filtra in base al tipo di file, è possibile fare clic sulla freccia accanto all'intestazione di colonna Tipo e quindi fare clic su bmp in modo da visualizzare nel report solo i file bitmap.

    Colonna Tipo con il menu del filtro visualizzato

  3. Se si desidera filtrare in base a più colonne, ripetere il passaggio 2 per ogni colonna.

  4. Per creare un filtro personalizzato per una colonna, fare clic sulla freccia accanto all'intestazione di colonna e quindi su (Personalizzata). Immettere i criteri di ricerca e quindi fare clic su OK.

    Ad esempio, è possibile utilizzare un filtro automatico personalizzato per individuare nel sito tutti i file di immagini con estensione bmp e gif.

    Finestra di dialogo Personalizza filtro automatico

  5. Per eliminare un filtro da una colonna, fare clic sulla freccia accanto all'intestazione di colonna e quindi scegliere (tutti).

Nota : Le impostazioni del filtro applicato vengono salvate alla chiusura del sito. Se in un report appena eseguito non vengono visualizzati file, è possibile che i filtri applicati in una sessione precedente nascondano i file desiderati.

Per rimuovere tutti i filtri da un report, fare clic con il pulsante destro del mouse su un'intestazione di colonna e quindi scegliere Rimuovi filtri dal menu di scelta rapida.

Torna all'inizio

Copiare un report

Dopo aver eseguito un report, è possibile copiare e incollare i risultati in un messaggio di posta elettronica o in un altro documento, ad esempio un foglio di lavoro di Microsoft Office Excel. È possibile copiare tutti i report tranne il report Riepilogo sito.

  1. Fare clic con il pulsante destro del mouse su un'intestazione di colonna nel report eseguito e quindi scegliere Copia report dal menu di scelta rapida.

    Menu della colonna Nome con il comando  Copia report selezionato

  2. Incollare i dati nel documento o nel messaggio.

Torna all'inizio

Salvare un report

È possibile salvare i report se si desidera utilizzare Microsoft Office Excel 2007 per visualizzare e analizzare i risultati o per creare grafici personalizzati.

  1. Scegliere Report dal menu Sito e quindi fare clic sul report che si desidera eseguire.

  2. Scegliere Salva dal menu File oppure premere CTRL+S.

  3. Nella casella Nome file digitare un nome per il report e quindi fare clic su Salva. Il report verrà salvato nel sito come file con estensione htm.

    Report aperto in Excel

  4. Per aprire il report, fare doppio clic su di esso.

    Il report verrà aperto in Office Excel 2007.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×