Utilizzare un rapporto di tabella pivot per rendere disponibili i dati di tabelle esterne in Excel Services

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Se si desidera utilizzare i dati di una tabella con una connessione a dati esterni in Excel Services, non sarà possibile utilizzare un intervallo di dati esterni, detto anche tabella Query. Sarà invece necessario creare un rapporto di tabella pivot che renda lineari, o bidimensionali, i dati gerarchici multidimensionali di una tabella. A tale scopo, effettuare le operazioni illustrate di seguito.

Confronto tra dati multidimensionali e dati bidimensionali

1. Convertire un rapporto di tabella pivot multidimensionale…

2. …in un rapporto di tabella pivot bidimensionale…

3. …in modo da visualizzare dati di tabella bidimensionali in Excel Services.

Per saperne di più

Informazioni su come Excel Services supporta connessioni a origini dati esterne

Informazioni sulle differenze tra un rapporto di tabella pivot connessa ai dati esterni e intervalli di dati esterni

Impostare un report di tabella pivot bidimensionale, tabulare

Creare il rapporto di tabella pivot e connettersi all'origine dati esterna

Aggiungere, il layout e disporre i campi nell'area etichette di riga

Modificare le opzioni di tabella pivot e impostazioni campo

Layout del rapporto di tabella pivot sotto forma di tabella bidimensionale

Personalizzare la struttura di rapporto di tabella pivot

Pubblicare la cartella di lavoro in Excel Services

Informazioni sul supporto di connessioni a origini dati esterne da parte di Excel Services

I rapporti di tabella pivot sono progettati per consentire l'aggregazione di molti dati numerici in somme e totali e per essere utilizzati con dati multidimensionali organizzati in una gerarchia. Al contrario, gli intervalli di dati esterni sono tabelle bidimensionali strutturate in righe e colonne che consentono di visualizzare record non aggregati dei dati di origine.

Quando si usa la connessione guidata dati o la Query di Microsoft per connettersi a dati esterni, in genere si crea un intervallo di dati esterni. L'unica eccezione è quando si crea un rapporto di tabella pivot è collegato a dati esterni. Un rapporto di tabella pivot non viene creato un intervallo di dati esterni. Questa differenza in modo che le connessioni vengono create è importante tenere presente quando si pubblica una cartella di lavoro in Excel Services, perché Excel Services solo supporta connessioni a dati esterni in base a rapporti di tabella pivot e non supporta gli intervalli di dati esterni.

Torna all'inizio

Differenze tra rapporti di tabella pivot connessi a dati esterni e a intervalli di dati esterni

Quando si lavora con un rapporto di tabella pivot connessa a dati esterni, non vi sono differenze tra il comportamento di un rapporto di tabella pivot e un intervallo di dati esterno che dovrebbe essere presente, incluse le operazioni seguenti:

I rapporti di tabella pivot determinano la creazione di gruppi e sottogruppi di dati secondo l'ordine da sinistra verso destra.

In generale, i dati vengono raggruppati secondo un ordinamento dei dati basato su una o più colonne. Se, ad esempio, si desidera visualizzare tutti i dipendenti raggruppati per il relativo reparto, sarà possibile eseguire un ordinamento principale dei dati per reparti e un ordinamento secondario per dipendenti. Sarà inoltre possibile nidificare i gruppi, ad esempio Linea di prodotti, Categoria e Prodotto oppure Area geografica, Paese, Provincia e Città. Per impostazione predefinita, i rapporti di tabella pivot vengono ordinati automaticamente in gruppi e sottogruppi secondo l'ordine da sinistra verso destra, in modo da rendere più facile la visualizzazione di dati correlati, intestazioni e informazioni di riepilogo, nonché l'espansione o la compressione di elementi correlati.

Dati raggruppati per Linea di prodottie sqlusername all'interno di ogni Linea di prodotti per categoria

Linea di prodotti

Categoria

Prodotto

Motori

Aeroplano

Da installare sull'ala

Da installare sulla coda

Booster

Automobile

269 cavalli

454 cavalli

Ventilatori

Passeggero

Molto caldo

Standard

SUV

Piccolo

Inserendo una colonna con valori univoci nell'area Etichette di riga, è possibile rendere automaticamente bidimensionali i dati.

Gli stessi dati Linea di prodotti appiattimento dalla visualizzazione aggiungendo la colonna ID Num

Codice

Linea di prodotti

Categoria

Prodotto

WM-345

Motori

Aeroplano

Da installare sull'ala

TM-231

Motori

Aeroplano

Da installare sulla coda

BSTR-567

Motori

Aeroplano

Booster

6C-734

Motori

Automobile

269 cavalli

8C-121

Motori

Automobile

454 cavalli

MF-202

Ventilatori

Passeggero

Molto caldo

MF-321

Ventilatori

Passeggero

Standard

MF-211

Ventilatori

SUV

Piccolo

Se non si desidera visualizzare la colonna dopo averla aggiunta al rapporto di tabella pivot, sarà possibile nasconderla. A tale scopo, selezionare la colonna, quindi nel gruppo Celle della scheda Home fare clic sulla freccia accanto a Formato, scegliere Nascondi e scopri, quindi fare clic su Nascondi colonne.

Importante : Se un rapporto di tabella pivot rileva due o più righe di dati duplicati in un'origine dati, verrà visualizzata solo una riga. Se si desidera che nel rapporto di tabella pivot vengano visualizzate tutte le righe, anche quelle duplicate, sarà necessario aggiungere una colonna contenente dati univoci alla tabella, alla query o alla visualizzazione importata dall'origine dati. Se i dati di origine non dispongono di una colonna univoca, sarà possibile aggiungerne una all'origine dati. È ad esempio possibile aggiungere una colonna con il tipo di dati Contatore a una tabella di Microsoft Office Access, una colonna con il tipo di dati Identità a una tabella di Microsoft SQL Server oppure aggiungere una colonna calcolata che consenta di visualizzare un numero univoco per ogni record a una query su database o a una visualizzazione.

Modifica dei dati di cella e aggiunta di colonne calcolate

Prima di pubblicare la cartella di lavoro in Excel Services, è possibile modificare i dati di un intervallo di dati esterni, mentre i dati di una tabella pivot rimarranno sempre di sola lettura.

Quando si fa doppio clic su una cella di un intervallo di dati esterni, viene attivata la modalità di modifica che consente di modificarne il valore o di immettere una formula. Si consideri tuttavia che il valore originale presente nell'origine dati non verrà modificato e che il nuovo valore potrebbe venire sovrascritto al successivo aggiornamento dei dati, a seconda di come è impostata per l'intervallo di dati esterni la proprietà relativa alla modifica del numero di righe a seguito di un aggiornamento dei dati.

Quando si fa doppio clic su una cella di etichette di riga in un rapporto di tabella pivot, gli elementi inclusi nell'etichetta di riga si espandono o comprimono. Quando si rende lineare un rapporto di tabella pivot trasformandolo in una tabella bidimensionale, tutti i valori di riga presenti nel gruppo a sinistra della cella scompaiono o compaiono di nuovo.

È possibile aggiungere colonne calcolate in qualsiasi punto di una tabella di Microsoft Office Excel basata su un intervallo di dati esterni oppure è possibile inserire colonne e copiare in basso le formule in un intervallo di dati esterni. All'interno di un rapporto di tabella pivot non è possibile inserire colonne calcolate, sebbene sia possibile inserire campi calcolati. All'immediata sinistra o destra del rapporto di tabella pivot è tuttavia possibile aggiungere una colonna per copiare in basso dati o formule e, in una formula copiata in basso, è possibile utilizzare riferimenti a celle poste all'interno del rapporto di tabella pivot.

Creazione di grafici

Se si desidera creare un grafico in base ai dati nel rapporto di tabella pivot, è possibile creare un rapporto di grafico pivot, è simile a un grafico standard, ma sono disponibili alcune differenze, tra cui le operazioni seguenti:

Interazione     Con i grafici standard, si crea un grafico per ogni visualizzazione dei dati desiderata, ma tali visualizzazioni non sono interattive. Con i rapporti di grafico pivot, si crea un solo grafico ed è possibile visualizzare i dati in modi diversi in maniera interattiva modificando il layout del rapporto o i dettagli visualizzati. In Excel Services è possibile aggiornare sia un grafico standard sia un rapporto di grafico pivot in base a un'interazione dell'utente con la cartella di lavoro, ma entrambi i grafici vengono visualizzati come immagini statiche.

Tipi di grafico     Il tipo di grafico predefinito per un grafico standard è un istogramma raggruppato, in cui vengono confrontati i valori di più categorie. Il tipo di grafico predefinito per un rapporto di grafico pivot è un istogramma in pila, in cui viene confrontato il contributo di ogni valore rispetto a un totale in più categorie. È possibile modificare un rapporto di grafico pivot in qualsiasi tipo di grafico, tranne a dispersione (XY), azionario o a bolle.

Elementi del grafico     Rapporti di grafico pivot contengono gli stessi elementi di un grafico standard, ma contengono anche campi ed elementi che possono essere aggiunto a, ruotati o rimosso, per visualizzare diverse visualizzazioni dei dati. Categorie e serie di dati in un grafico standard sono campi categoria, campi serie e campi valore nei rapporti di grafico pivot. Rapporti di grafico pivot possono inoltre contenere filtri rapporto. I singoli campi contiene elementi, in un grafico standard vengono visualizzati come nomi di etichette o serie di categoria legende.

La formattazione     La maggior parte delle formattazione, inclusi gli elementi, il layout e stile, viene mantenuta quando si aggiornare un rapporto di grafico pivot. Tuttavia, le linee di tendenza, le etichette dati, barre di errore e altre modifiche alle serie di dati non vengono mantenute. Un grafico standard non perdita una volta applicata questa formattazione.

Spostamento o ridimensionamento degli elementi     In un rapporto di grafico pivot non è possibile spostare né ridimensionare l'area del tracciato, la legenda, i titoli del grafico e i titoli degli assi. È tuttavia possibile selezionare una delle diverse posizioni preimpostate per la legenda e modificare le dimensioni dei caratteri dei titoli. In un grafico standard è possibile spostare e ridimensionare tutti questi elementi.

Dopo aver creato un rapporto di grafico pivot, se si preferisce, è possibile convertirlo in un grafico standard. Per ulteriori informazioni, vedere l'articolo creare una tabella pivot ai dati del foglio di lavoro anaylzeo creare un grafico pivot.

Confronto tra le proprietà di intervalli di dati esterni e le opzioni di tabella pivot

Gli intervalli di dati esterni e i rapporti di tabella pivot dispongono di proprietà che è possibile utilizzare per controllare la formattazione dei dati e il layout, nonché la modalità di aggiornamento dei dati.

Sia gli intervalli di dati esterni sia i rapporti di tabella pivot consentono di regolare la larghezza delle colonne, mantenere le modifiche apportate all'ordinamento, al filtro, alla formattazione di cella e al layout dei dati quando i dati esterni vengono aggiornati.

In un intervallo di dati esterni, è inoltre la possibilità di includere i numeri di riga come prima colonna di dati. In un rapporto di tabella pivot, non è simile. Vedere la sezione, di gruppo e sottogruppo dei dati in un ordine da sinistra a destra di rapporti di tabella pivot, per informazioni sull'aggiunta di una colonna univoca nell'origine dati.

Quando si aggiorna un intervallo di dati esterni, è possibile controllare gli effetti di tale operazione sui dati esistenti, ovvero se il numero di righe nell'intervallo di dati cambia, impostando una delle seguenti opzioni:

  • Inserisci celle per i nuovi dati e elimina le celle inutilizzate (impostazione predefinita)

  • Inserisci righe intere per i nuovi dati e elimina le celle inutilizzate

  • Sovrascrivi le celle esistenti con i nuovi dati e elimina le celle inutilizzate

Quando si aggiorna un rapporto di tabella pivot, che offre solo nuovi dati. Tuttavia, è possibile richiesto e viene chiesto di decidere se sovrascrivere le celle esistenti di sotto del report corrente.

Filtro dei dati

Il filtro dei dati in un intervallo di dati esterni e in un rapporto di tabella pivot è simile, sebbene presenti alcune differenze, incluse le seguenti:

  • Per filtrare i dati di intervalli di dati esterni si utilizzano i comandi Filtri per testo, Filtri per numeri e Filtri per date, mentre per filtrare i dati nei rapporti di tabella pivot si utilizzano i comandi Filtri per etichette, Filtri per valori e Filtri per date.

  • Il menu di filtro di un intervallo di dati esterni sempre rimuove gli elementi che non sono più validi, e il menu di filtro non sono mai inclusi nuovi elementi con un filtro applicato dopo un'operazione di aggiornamento, ma un rapporto di tabella pivot è disponibili opzioni per controllare questo comportamento. Per ulteriori informazioni, vedere la sezione Opzioni tabella pivot Cambia impostazioni e campi.

  • Un rapporto di tabella pivot dispone di una funzionalità per il filtro del rapporto, non disponibile per un intervallo di dati esterni, che consente agli utenti di utilizzare un sottoinsieme di dati nel rapporto di tabella pivot.

Ordinamento dei dati

In un intervallo di dati esterni è possibile eseguire l'ordinamento per un massimo di 64 colonne, è possibile scegliere qualsiasi colonna come colonna di ordinamento principale nonché qualsiasi altra colonna come colonna di ordinamento secondario. I processi di ordinamento dei dati in un rapporto di tabella pivot e in un intervallo di dati esterni sono tuttavia diversi. A differenza di un intervallo di dati esterni, in un rapporto di tabella pivot è possibile eseguire un ordinamento principale solo per la colonna più a sinistra. Per tutte le altre colonne vengono eseguiti ordinamenti secondari in base alla colonna posta immediatamente a sinistra. In altre parole, è possibile eseguire un ordinamento principale e un ordinamento secondario solo nell'ordine da sinistra verso destra.

Inoltre, quando si posiziona una colonna con valori univoci come prima colonna a sinistra, è possibile eseguire l'ordinamento solo per tale colonna, poiché di fatto si sta creando un gruppo primario per ogni riga. A seconda delle necessità specifiche, è possibile che si desideri eseguire un ordinamento preliminare dei dati in Excel, quindi pubblicare la cartella di lavoro in Excel Services e infine disattivare l'ordinamento deselezionando la casella di controllo Ordinamento nel riquadro Strumenti della web part di Microsoft Office Excel Web Access.

Utilizzo di collegamenti ipertestuali

A differenza degli intervalli di dati esterni, i collegamenti ipertestuali attivi non sono supportati nelle celle di tabelle pivot. Il collegamento ipertestuale viene considerato come testo, ma non è possibile seguire il collegamento ipertestuale alla pagina Web o al documento in Excel o Excel Services.

Torna all'inizio

Creare un rapporto di tabella pivot tabulare bidimensionale

Per rendere lineari i dati multidimensionali, trasformandoli in un rapporto di tabella pivot tabulare bidimensionale, è necessario effettuare un certo numero di operazioni. Per ottenere i risultati migliori, eseguire le seguenti procedure nella sequenza descritta.

Torna all'inizio

Creare il rapporto di tabella pivot e stabilirne la connessione all'origine dati esterna

  1. Selezionare una cella vuota.

  2. Nel gruppo Tabelle della scheda Inserisci fare clic su Tabella pivot, quindi su Tabella pivot.

    Immagine della barra multifunzione di Excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

  3. Fare clic su Origine dati esterna.

  4. Fare clic su Seleziona connessione.

    Il Verrà visualizzata la finestra di dialogo Connessioni esistenti.

  5. Nell'elenco Mostra, nella parte superiore della finestra di dialogo, selezionare la categoria di connessioni per la quale si desidera scegliere una connessione oppure selezionare Tutte le connessioni (impostazione predefinita).

  6. Selezionare una connessione nell'elenco Selezionare una connessione, quindi fare clic su Apri.

  7. Immettere una posizione. Effettuare una delle seguenti operazioni:

    • Per posizionare il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1, fare clic su Nuovo foglio di lavoro.

    • Per posizionare il rapporto di tabella pivot in un foglio di lavoro esistente, selezionare Foglio di lavoro esistente, quindi digitare la prima cella dell'intervallo di celle in cui si desidera posizionare il rapporto di tabella pivot.

      In alternativa, fare clic su Comprimi finestra Icona del pulsante per nascondere temporaneamente la finestra di dialogo, selezionare la cella di inizio del foglio di lavoro e quindi fare clic su Espandi finestra Icona del pulsante .

  8. Scegliere OK.

Alla posizione immessa verrà aggiunto un rapporto di tabella pivot vuoto con l'elenco dei campi della tabella pivot visualizzato.

Torna all'inizio

Aggiungere e disporre i campi nell'area Etichette di riga

Utilizzare l'elenco dei campi della tabella pivot per aggiungere e disporre i campi, nonché per verificare che tutti i campi siano stati aggiunti all'area Etichette di riga.

  1. Fare clic sul rapporto di tabella pivot.

  2. Effettuare una o più delle seguenti operazioni:

    • Per aggiungere campi al rapporto, effettuare una o più delle seguenti operazioni:

      • Selezionare la casella di controllo accanto a ogni nome di campo nella relativa sezione dell'elenco dei campi. Sebbene ogni campo sia posizionato in un'area predefinita della sezione relativa al layout, è possibile modificare la disposizione dei campi.

        Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Etichette di riga, i campi numerici all'area Valori, mentre i campi data/ora vengono aggiunti all'area Etichette di colonna.

      • Per spostare un campo nell'area Etichette di riga, fare clic con il pulsante destro del mouse sul nome del campo, quindi scegliere Aggiungi a etichette di riga dal menu di scelta rapida.

        Suggerimento : È inoltre possibile fare clic su un nome di campo e tenere premuto il pulsante del mouse, quindi trascinare il campo dalla sezione dei campi in un'area all'interno della sezione relativa al layout.

    • Per ridisporre i campi, fare clic sul nome del campo in una delle aree e quindi selezionare uno dei comandi seguenti:

Sposta su   

Sposta su di una posizione il campo nell'area.

Sposta giù   

Sposta il campo in giù di una posizione nell'area.

Sposta all'inizio   

Sposta il campo all'inizio dell'area.

Sposta alla fine   

Sposta il campo alla fine dell'area.

Sposta nelle etichette di riga   

Sposta il campo nell'area Etichette di riga.

  • Per rimuovere un campo, fare clic sul campo nome in una delle aree layout e quindi fare clic su Rimuovi campo oppure deselezionare la casella di controllo accanto a ciascun nome di campo che si desidera rimuovere, nella sezione dei campi.

    Suggerimento : È inoltre possibile fare clic su un campo nella sezione relativa al layout e tenere premuto il pulsante del mouse, quindi trascinare il nome di campo all'esterno dell'elenco dei campi della tabella pivot.

    Nota : La deselezione di una casella di controllo nella sezione dei campi determina la rimozione di tutte le istanze del campo dal rapporto.

Torna all'inizio

Modificare le opzioni di tabella pivot e le impostazioni di campo

Per assicurarsi che il comportamento del rapporto di tabella pivot sia simile a quello di un intervallo esterno, effettuare le seguenti operazioni:

Modificare le opzioni di tabella pivot   

  1. Fare clic sul rapporto di tabella pivot.

  2. Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni.

    Verrà visualizzata la finestra di dialogo Opzioni tabella pivot.

  3. Per fare in modo che la larghezza di una colonna venga adattata automaticamente dopo un'operazione di aggiornamento, scegliere la scheda Layout e formato, quindi nella sezione Formato selezionare la casella di controllo Adatta larghezza colonne all'aggiornamento.

  4. Per mantenere la formattazione ogni volta che i dati vengono aggiornati, scegliere la scheda Layout e formato, quindi nella sezione Formato selezionare la casella di controllo Mantieni formattazione celle all'aggiornamento.

  5. Per fare in modo che nel menu Filtro vengano rimossi gli elementi non più validi, dopo un'operazione di aggiornamento scegliere la scheda Dati quindi, nella casella Numero di elementi da mantenere per campo selezionare Nessuno.

Modificare le impostazioni del campo   

  1. Fare clic sul rapporto di tabella pivot.

  2. Per includere nuovi elementi in un rapporto di tabella pivot con un filtro applicato, per ogni campo fare clic con il pulsante destro del mouse su una cella, scegliere Impostazioni campo dal menu di scelta rapida, scegliere la scheda Subtotali e filtri quindi, nella sezione Filtro, selezionare la casella di controllo Includi nuovi elementi nel filtro manuale.

Torna all'inizio

Disporre il rapporto di tabella pivot come tabella bidimensionale

Per disporre il rapporto di tabella pivot come una tabella bidimensionale, effettuare le seguenti operazioni:

  1. Fare clic sul rapporto di tabella pivot.

  2. Nel gruppo Layout della scheda Progettazione fare clic su Subtotali, quindi su Non mostrare i subtotali.

  3. Nel gruppo Layout della scheda Progettazione fare clic su Totali complessivi, quindi su Disattivati per righe e colonne.

  4. Nel gruppo Layout della scheda Progettazione fare clic su Layout rapporto, quindi su Mostra in formato tabella.

  5. Nel gruppo Mostra/Nascondi della scheda Opzioni fare clic su Intestazioni campi.

Torna all'inizio

Personalizzare la struttura del rapporto di tabella pivot

Le opzioni di stile e stili di tabella pivot sono progettate per dati multidimensionali, non una tabella bidimensionale. Quando si trasformare il report in una tabella bidimensionale, gli stili non sono visualizzati i bordi delle celle e le Righe alternate evidenziate e Colonne alternate evidenziate le caselle di controllo nel gruppo Opzioni stile tabella pivot della scheda Progettazione non influiscono il formato delle celle. Tuttavia, è possibile personalizzare uno stile di tabella pivot in modo che ogni cella contiene un bordo delle celle e il rapporto di tabella pivot usa la formattazione condizionale per visualizzare righe alternate evidenziate o colonne.

Personalizzare lo stile di tabella pivot   

  1. Fare clic sul rapporto di tabella pivot.

  2. Nel gruppo Stili veloci tabella pivot della scheda Progettazione selezionare lo stile che si desidera utilizzare, quindi effettuare le seguenti operazioni:

    1. Fare clic con il pulsante destro del mouse su uno stile visualizzato, scorrere la raccolta oppure scegliere Altro nella parte inferiore della barra di scorrimento per visualizzare tutti gli stili disponibili.

    2. Fare clic su Duplica.

      Verrà visualizzata la finestra di dialogo Modifica stile veloce tabella pivot.

    3. Immettere eventualmente un nuovo nome nella casella Nome.

    4. Nella casella Elemento tabella selezionare Tabella intera, quindi fare clic su Formato.

      Verrà visualizzata la finestra di dialogo Formato celle.

    5. Scegliere la scheda Bordo, quindi creare un bordo della cella.

    6. Fare eventualmente clic sulle schede Riempimento e Carattere e apportare altre modifiche.

    7. Scegliere OK due volte.

    8. Fare clic sul pulsante Altro nella parte inferiore della barra di scorrimento, quindi nella categoria Stili personalizzati fare clic sullo stile di tabella pivot appena creato.

Visualizzare righe alternate evidenziate o colonne alternate evidenziate utilizzando la formattazione condizionale   

  1. Selezionare tutte le colonne del rapporto di tabella pivot.

  2. Nel gruppo Stili della scheda Home fare clic sulla freccia accanto a Formattazione condizionale, quindi su Gestisci regole.

    Immagine della barra multifunzione di Excel

    Verrà visualizzata la finestra di dialogo Gestione regole formattazione condizionale.

  3. Per aggiungere un formato condizionale, fare clic su Nuova regola.

    Verrà visualizzata la finestra di dialogo Nuova regola di formattazione.

  4. In Selezionare un tipo di regola fare clic su Utilizza una formula per determinare le celle da formattare.

    1. Nella casella Formatta i valori per cui questa formula restituisce Vero in Modificare la descrizione della regola immettere una formula.

    2. Effettuare una delle seguenti operazioni:

      • Per ottenere righe alternate evidenziate, immettere la seguente formula:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • Per ottenere colonne alternate evidenziate, immettere la seguente formula:

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • Per ottenere righe e colonne alternate evidenziate, immettere la seguente formula:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. Fare clic su Formato per visualizzare la finestra di dialogo Formato celle.

  2. Selezionare il formato del numero, del carattere, del bordo o del riempimento da applicare quando il valore della cella soddisfa la condizione e quindi fare clic su OK.

    È possibile scegliere più di un formato. I formati selezionati vengono visualizzati nel riquadro Anteprima.

Torna all'inizio

Pubblicare la cartella di lavoro in Excel Services

  1. Scegliere il Pulsante Microsoft Office Icona del pulsante Office , fare clic sulla freccia accanto a pubblicazione e quindi fare clic su Excel Services in Distribuisci documento ad altri utenti.

  2. Nella casella Nome file immettere il percorso per il server e accettare il nome suggerito per la cartella di lavoro oppure digitare un nuovo nome, se necessario.

    In un computer che esegue Windows Vista   

    • Nella barra degli indirizzi selezionare un percorso di rete accessibile agli utenti desiderati e quindi fare clic su Salva.

      In un computer che esegue Microsoft Windows XP   

    • Nella casella Salva in selezionare un percorso di rete accessibile agli utenti desiderati e quindi fare clic su Salva.

      Ad esempio, digitare http://server/sito/nome file

      Nota : In Excel è possibile pubblicare una cartella di lavoro sul server solo se questa è nel formato di file basato su XML (xlsx) di Microsoft Office Excel 2007 oppure nel formato di file binario (xlsb) di Office Excel 2007.

  3. Scegliere OK.

  4. Per verificare che le aree visualizzabili della cartella vengano mostrate correttamente nel browser, selezionare la casella di controllo Apri in Excel Services.

  5. Fare clic su Salva.

Per ulteriori informazioni, vedere l'articolo pubblica una cartella di lavoro in Excel Services.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×