Utilizzare funzioni annidate in una formula

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

L'utilizzo di una funzione come uno degli argomenti in una formula che utilizza una funzione è un'operazione nota come annidamento; si farà riferimento a tale funzione come a una funzione annidata. Ad esempio, annidando la funzione MEDIA e SOMMA negli argomenti della funzione SE, la formula seguente somma un gruppo di numeri (G2:G5) solo se la media di un altro gruppo di numeri (F2:F5) è maggiore di 50. In caso contrario, restituisce 0.

funzioni annidate

1. le funzioni Media e somma sono nidificate all'interno della funzione se.

È possibile annidare fino a 64 livelli di funzioni in una formula.

  1. Fare clic sulla cella in cui si desidera immettere la formula.

  2. Per iniziare la formula con la funzione, fare clic su Inserisci funzione Callout 4 sulla barra della formula Callout 4 .

    Verrà inserito automaticamente il segno di uguale (=).

  3. Nella casella Oppure selezionare una categoria selezionare Tutte.

    Se si ha familiarità con le categorie di funzione, è anche possibile selezionare una categoria.

    In caso di incertezze sulla funzione da utilizzare, è possibile digitare nella casella Cerca una funzione una domanda che descriva l'operazione da eseguire. "Aggiungere numeri" ad esempio restituisce la funzione SOMMA.

    Suggerimenti : 

  4. Per immettere un'altra funzione come argomento, immettere la funzione nella casella dell'argomento desiderato.

    Le parti della formula visualizzate nella finestra di dialogo Argomenti funzione riflettono la funzione selezionata nel passaggio precedente.

    Con un clic su SE la finestra di dialogo Argomenti funzione visualizzerà gli argomenti per la funzione SE. Per annidare un'altra funzione, è possibile immetterla nella casella dell'argomento. È possibile ad esempio immettere SOMMA(G2:G5) nella casella Se_vero della funzione SE.

  5. Immettere eventuali argomenti aggiuntivi necessari per completare la formula.

    Anziché digitare riferimenti di cella, è inoltre possibile selezionare le celle a cui si desidera fare riferimento. Fare clic su Callout 4 per ridurre al minimo la finestra di dialogo, selezionare le celle a cui fare riferimento e fare clic su Icona del pulsante per espandere di nuovo la finestra di dialogo.

    Suggerimento : Per ulteriori informazioni sulla funzione e sui relativi argomenti, fare clic sulla Guida relativa a questa funzione.

  6. Dopo avere completato gli argomenti della formula, fare clic su OK.

Esempi

Di seguito viene illustrato un esempio dell'uso annidate se punteggio del test di funzioni per assegnare una votazione a un valore numerico.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Punteggio

45

90

78

Formula

Descrizione

Risultato

'=SE(A2>89,"A",SE(A2>79,"B", SE(A2>69,"C",SE(A2>59,"D","F"))))

Usa condizioni SE annidate per assegnare una votazione al punteggio nella cella A2.

=SE(A2>89,"A",SE(A2>79,"B",SE(A2>69,"C",SE(A2>59,"D","F"))))

'=SE(A3>89,"A",SE(A3>79,"B", SE(A3>69,"C",SE(A3>59,"D","F"))))

Usa condizioni SE annidate per assegnare una votazione al punteggio nella cella A3.

=SE(A3>89,"A",SE(A3>79,"B",SE(A3>69,"C",SE(A3>59,"D","F"))))

'=SE(A4>89,"A",SE(A4>79,"B", SE(A4>69,"C",SE(A4>59,"D","F"))))

Usa condizioni SE nidificate per assegnare una votazione al punteggio nella cella A4.

=SE(A4>89,"A",SE(A4>79,"B",SE(A4>69,"C",SE(A4>59,"D","F"))))

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×