Usare più tabelle per creare una tabella pivot

Le tabelle pivot sono ideali per analizzare i dati e creare rapporti corrispondenti. Se inoltre i dati sono relazionali, ossia sono archiviati in tabelle separate che è possibile raggruppare in base a valori comuni, è possibile creare una tabella pivot come questa in pochi minuti:

Tabella pivot contenente più tabelle

Che cos'ha di diverso questa tabella pivot? Come si noterà, l'elenco dei campi a destra non contiene solo una tabella, ma un'intera raccolta. Ogni tabella contiene campi che possono essere combinati in un'unica tabella pivot per analizzare i dati in più modi. Non è richiesta nessuna formattazione manuale o preparazione dei dati. È possibile creare immediatamente una tabella pivot basata sulle tabelle correlate subito dopo aver importato i dati.

Per inserire più tabelle nell'elenco di campi di una tabella pivot:

  • Eseguire l'importazione da un database relazionale, come Microsoft SQL Server, Oracle o Microsoft Access. È possibile importare più tabelle contemporaneamente.

  • Importare più tabelle da altre origini dati, ad esempio file di testo, feed di dati, fogli di lavoro di Excel e altro ancora. È possibile aggiungere queste tabelle al modello di dati in Excel, creare relazioni e quindi usare il modello di dati per creare la tabella pivot.

Ecco come importare più tabelle da un database SQL Server.

  1. Accertarsi di conoscere il nome del server e del database e quali credenziali utilizzare per connettersi a SQL Server. L'amministratore del database può fornire le informazioni necessarie.

  2. Fare clic su Dati > Recupera dati esterni > Da altre origini > Da SQL Server.

  3. In Nome server immettere il nome di rete del computer che esegue SQL Server.

  4. Nella casella Credenziali di accesso fare clic su Usa autenticazione di Windows se ci si connette con le proprie credenziali. In caso contrario, immettere il nome utente e la password forniti dall'amministratore del database.

  5. Premere INVIO e, in Seleziona database e tabella scegliere il database e quindi fare clic su Abilita la selezione di più tabelle.

    Casella di controllo Abilita la selezione di più tabelle

  6. Scegliere manualmente le tabelle se si sa esattamente quali si vogliono usare. In caso contrario, selezionarne una o due e quindi fare clic su Seleziona tabelle correlate per selezionare automaticamente le tabelle correlate a quelle selezionate.

  7. Se la casella Importa relazioni tra le tabelle selezionate è selezionata, lasciarla invariata per fare in modo che Excel ricrei automaticamente le relazioni di tabelle equivalenti nella cartella di lavoro.

  8. Fare clic su Fine.

  9. Nella finestra di dialogo Importa dati scegliere Rapporto di tabella pivot.

    Finestra di dialogo Opzioni di importazione

  10. Fare clic su OK per avviare l'importazione e popolare l'elenco dei campi.

Si noti che l'elenco di campi contiene più tabelle, ossia tutte quelle selezionate durante l'importazione. È possibile espandere e comprimere ogni tabella per visualizzare i relativi campi. Purché le tabelle siano correlate, è possibile creare una tabella pivot trascinando i campi da qualsiasi tabella nelle aree VALORI, RIGHE o COLONNE.

Elenco Campi tabella pivot

  • Trascinare i campi numerici nell'area VALORI. Se ad esempio si usa un database di esempio di Adventure Works, è possibile trascinare SalesAmount dalla tabella FactInternetSales.

  • Trascinare i campi relativi a data o area nell'area RIGHE o COLONNE per analizzare le vendite in base alla data o all'area.

  • A volte è necessario creare una relazione tra due tabelle prima di poterle usare in una tabella pivot. Se viene visualizzato un messaggio indicante che è necessaria una relazione, fare clic su Crea per iniziare.

    Il pulsante Crea viene visualizzato quando è necessaria una relazione

    Se si usano altri tipi di database:

Importare tabelle da altre origini

Oltre che da SQL Server, è possibile importare tabelle da diversi altri database relazionali:

I database relazionali non sono la sola origine dati che consenta di usare più tabelle in un elenco di campi di una tabella pivot. È possibile usare le tabelle di una cartella di lavoro o importare feed di dati che verranno quindi integrati con altri dati tabulari nella cartella di lavoro. Per consentire a tutti questi dati non correlati di interagire, è necessario aggiungere ogni tabella a un modello di dati e quindi creare relazioni tra le tabelle mediante valori di campo corrispondenti.

Usare il modello di dati per creare una nuova tabella pivot

Si supponga di aver creato relazioni tra tabelle in un modello di dati e che ora si vogliano usare questi dati nell'analisi. Ecco come creare una nuova tabella pivot o un nuovo grafico pivot usando il modello di dati nella cartella di lavoro.

  1. Fare clic su qualsiasi cella del foglio di lavoro.

  2. Fare clic su Inserisci > Tabella pivot.

    Pulsante Tabella pivot nella scheda Inserisci

  3. Nella finestra di dialogo Crea tabella pivot fare clic su Origine dati esterna in Specificare i dati da analizzare.

    Finestra di dialogo Crea tabella pivot con l'opzione Origine dati esterna selezionata

  4. Fare clic su Seleziona connessione.

  5. Nella scheda Tabelle, in Modello di dati della cartella di lavoro, selezionare Tabelle nel modello di dati della cartella di lavoro.
    Tabelle nel modello di dati

  6. Fare clic su Apri e quindi su OK per visualizzare un elenco di campi contenente tutte le tabelle del modello di dati.

Altre informazioni sulle tabelle pivot e sui modelli di dati

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×