Usare l'argomento matrice_tabella in una funzione di ricerca

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Quando si crea una formula usando la funzione CERCA.VERT o CERCA.ORIZZ, si immette un argomento matrice_tabella, che corrisponde a un intervallo di celle, ad esempio D2:F39. La funzione ricerca i dati da trovare nell'intervallo.

L'argomento matrice_tabella è sempre il secondo argomento di una funzione CERCA.VERT o CERCA.ORIZZ (il primo argomento è il valore che si vuole trovare). Queste funzioni non possono essere usate senza tale argomento.

Il primo argomento può essere un valore specifico, ad esempio "41" o "rossi" oppure un riferimento di cella come F2. Il primo argomento avrà quindi il seguente aspetto:

=CERCA.VERT(F2,...

L'argomento matrice_tabella segue sempre il valore di ricerca, ad esempio:

=CERCA.VERT(F2,B4:D39, ...

Per l'intervallo di celle indicato nell'argomento matrice_tabella si possono usare riferimenti di cella relativi o assoluti. Se si prevede di copiare la formula in altre celle, è necessario usare riferimenti di cella assoluti (notare i segni $), come i seguenti:

=CERCA.VERT(F2,$B$2:BD$39, ...

Se le cellule nell'argomento matrice_tabella sono in un altro foglio di lavoro nella cartella di lavoro, l'argomento deve includere il nome del foglio seguito da un punto esclamativo. La sintassi è simile alla seguente:

=CERCA.VERT(F2,Foglio2!$C$14:E$42, ...

La colonna che contiene i valori da trovare è il terzo argomento da immettere, la cosiddetta colonna di ricerca. Se i valori da visualizzare si trovano nella colonna D (la terza colonna della matrice_tabella), l'ultimo argomento è un 3.

=CERCA.VERT(F2,B4:D39,3)

Anche se è facoltativo, è consigliabile usare un quarto argomento, True o False. Usare False per cercare una corrispondenza esatta.

=CERCA.VERT(F2,B4:D39,3,False)

Se si usa True o si lascia vuoto il quarto argomento, la funzione restituisce una corrispondenza approssimativa con il valore del primo argomento. Pertanto, se il primo argomento è "rossi" e si usa True, CERCA.VERT restituirà "Rossi", "Rossini" e così via. Se invece si usa False, restituirà solo "Rossi", una corrispondenza esatta, proprio ciò che desidera la maggior parte delle persone.

Per rendere l'uso di True ancora più complesso, se la colonna di ricerca, ovvero la colonna specificata nel terzo argomento, non è disposta in ordine crescente (dalla A alla Z o dal numero più piccolo al più alto), potrebbe essere restituito il risultato errato.

Per altre informazioni sulle funzioni CERCA.VERT e CERCA.ORIZZ, vedere Funzioni di ricerca e di riferimento (riferimento).

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×