Usare Strumenti di analisi per effettuare analisi di dati complessi

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Per sviluppare analisi statistiche o ingegneristiche complesse, è possibile velocizzare la procedura usando il componente aggiuntivo Strumenti di analisi. Questo componente include strumenti che analizzano dati e parametri e mediante funzioni macro statistiche o ingegneristiche appropriate calcolano e visualizzano i risultati in una tabella di output. Oltre alle tabelle di output, alcuni di questi strumenti rappresentano i risultati su grafici.

È possibile usare le funzioni di analisi dei dati solo in un foglio di lavoro alla volta. Quando si eseguono analisi di dati su gruppi di fogli di lavoro, i risultati verranno visualizzati sul primo foglio di lavoro, mentre negli altri fogli verranno visualizzate delle tabelle formattate vuote. Per analizzare i dati dei rimanenti fogli di lavoro, usare nuovamente lo strumento di analisi per ciascuno di essi.

Gli strumenti del componente aggiuntivo Strumenti di analisi sono descritti nelle sezioni seguenti. Per accedervi, fare clic su Analisi dati nel gruppo Analisi della scheda Dati. Se il comando Analisi dati non è disponibile, è necessario caricare il componente aggiuntivo Strumenti di analisi.

  1. Fare clic sulla scheda File, quindi su Opzioni e infine scegliere la categoria Componenti aggiuntivi.

    Se si usa Excel 2007, fare clic sul pulsante Microsoft Office Icona del pulsante Office e quindi su Opzioni di Excel

  2. Nella casella Gestisci selezionare Componenti aggiuntivi di Excel e quindi fare clic su Vai.

    Se si usa Excel per Mac, nel menu File passare a Strumenti > Componenti aggiuntivi di Excel.

  3. Nella finestra di dialogo Componenti aggiuntivi selezionare la casella di controllo Strumenti di analisi e quindi fare clic su OK.

    • Se Strumenti di analisi non è incluso nell'elenco Componenti aggiuntivi disponibili, fare clic su Sfoglia per trovarlo.

    • Se viene visualizzato un messaggio indicante che il componente aggiuntivo Strumenti di analisi non è installato nel computer, scegliere per installarlo.

Nota: Per includere le funzioni di Visual Basic, Applications Edition (VBA) per il componente aggiuntivo Strumenti di analisi, è possibile caricare il componente aggiuntivo Strumenti di analisi - VBA con le stesse modalità con cui viene caricato il componente aggiuntivo Strumenti di analisi. A tale scopo, nell'elenco Componenti aggiuntivi disponibili selezionare la casella di controllo accanto a Strumenti di analisi - VBA.

Gli strumenti Analisi varianza offrono diversi tipi di analisi della varianza. La scelta dello strumento dipende dal numero di fattori e di campioni di cui si dispone relativi alle popolazioni che si vuole verificare.

Analisi varianza a un fattore

Questo strumento esegue una semplice analisi della varianza dei dati per due o più campioni. L'analisi fornisce un test dell'ipotesi che ogni campione sia tratto dalla stessa distribuzione di probabilità sottostante rispetto all'ipotesi alternativa che le distribuzioni di probabilità sottostanti non siano uguali per tutti gli esempi. Se sono presenti solo due esempi, è possibile usare la funzione del foglio di lavoro T.Prova. Con più di due esempi, non esiste una generalizzazione conveniente di T.Teste il modello di varianza a singolo fattore possono essere chiamati al suo posto.

Analisi varianza a due fattori con replica

Questo strumento di analisi risulta utile quando i dati possono essere classificati lungo due dimensioni diverse. Ad esempio, in un esperimento in cui viene misurata l'altezza di alcune piante è possibile che si usino marche di fertilizzante diverse (ad esempio A, B, C) e che le piante vengano mantenute a temperature diverse (ad esempio bassa o alta). Per ognuna delle sei coppie di valori {fertilizzante, temperatura} possibili, si dispone dello stesso numero di osservazioni delle altezze delle piante. Tramite lo strumento Analisi varianza è possibile verificare:

  • Se i valori delle altezze delle piante in relazione alle diverse marche di fertilizzante vengono estratti dalla stessa popolazione sottostante. Per questa analisi vengono ignorate le temperature.

  • Se i valori delle altezze delle piante in relazione ai diversi livelli di temperatura vengono estratti dalla stessa popolazione sottostante. Per questa analisi vengono ignorate le marche di fertilizzante.

Dopo aver considerato gli effetti delle differenze tra le marche di fertilizzante rilevate al primo punto dell'elenco e le differenze tra le temperature rilevate al secondo punto dell'elenco, i sei campioni che rappresentano tutte le coppie di valori {fertilizzante, temperatura} vengono estratti dalla stessa popolazione. L'ipotesi alternativa prevede l'esistenza di effetti dovuti a coppie di valori {fertilizzante, temperatura} specifiche oltre alle differenze basate sul solo fertilizzante o sulla sola temperatura.

Impostazione dell'intervallo di input per lo strumento Analisi varianza

Analisi varianza a due fattori senza replica

Questo strumento di analisi risulta utile quando i dati vengono classificati in due dimensioni diverse come nell'analisi a due fattori con replica. Per questo strumento si presuppone tuttavia di disporre di una sola osservazione per ogni coppia, ad esempio per ogni coppia di valori {fertilizzante, temperatura} dell'esempio precedente.

Le funzioni del foglio di lavoro correlazione e Pearson calcolano il coefficiente di correlazione tra due variabili di misura quando vengono osservate le misure di ogni variabile per ognuno dei soggetti N. Qualsiasi osservazione mancante per qualsiasi argomento causa l'ignoranza dell'oggetto nell'analisi. Lo strumento di analisi della correlazione è particolarmente utile quando sono presenti più di due variabili di misura per ognuno dei soggetti N. Fornisce una tabella di output, una matrice di correlazione, che mostra il valore di correlazione (o Pearson) applicato a ogni possibile coppia di variabili di misura.

Il coefficiente di correlazione, come la covarianza, misura l'estensione della varianza di due variabili di misura che "variano insieme". A differenza della covarianza, il valore del coefficiente di correlazione è proporzionale, in modo da risultare indipendente dalle unità di misura in cui vengono espresse le due variabili. Ad esempio, se queste variabili corrispondono a peso e altezza, il valore del coefficiente di correlazione non varia anche se il valore del peso viene convertito da chilogrammi in libbre. Il valore di qualsiasi coefficiente di correlazione deve essere compreso tra -1 e +1.

È possibile usare lo strumento Correlazione per analizzare ogni coppia di variabili di misura e determinare se le due variabili di misura tendono a crescere proporzionalmente, ovvero se i valori elevati di una variabile tendono a essere associati ai valori elevati dell'altra (correlazione positiva), se i valori bassi di una variabile tendono a essere associati ai valori elevati dell'altra (correlazione negativa) o se non esiste correlazione tra i valori delle due variabili (correlazione prossima a 0 (zero)).

Gli strumenti di correlazione e covarianza possono essere entrambi utilizzati nella stessa impostazione, quando si hanno N diverse variabili di misura osservate su un set di singoli utenti. Gli strumenti di correlazione e covarianza forniscono ciascuno una tabella di output, una matrice, che mostra il covarianza di correlazione o la covarianza, rispettivamente, tra ogni coppia di variabili di misura. La differenza è che i coefficienti di correlazione vengono ridimensionati in modo che si trovino tra-1 e + 1 incluso. Le covarianze corrispondenti non vengono ridimensionate. Sia il coefficiente di correlazione che la covarianza sono misure della misura in cui due variabili "variano insieme".

Lo strumento Covarianza calcola il valore della coVARIAnza della funzione foglio di lavoro . P per ogni coppia di variabili di misura. (Uso diretto della coVARIAnza. P invece dello strumento covarianza è un'alternativa ragionevole quando sono presenti solo due variabili di misura, ovvero N = 2. La voce nella diagonale della tabella di output dello strumento Covarianza nella riga i, colonna i è la covarianza della variabile di misura i-esima con se stessa. Questa è solo la varianza della popolazione per quella variabile, come viene calcolata dalla funzione vardel foglio di lavoro.P.

È possibile usare lo strumento Covarianza per analizzare ogni coppia di variabili di misura per determinare se le due variabili di misura tendono a crescere proporzionalmente, ovvero se i valori elevati di una variabile tendono a essere associati ai valori elevati dell'altra (covarianza positiva), se i valori bassi di una variabile tendono a essere associati ai valori elevati dell'altra (covarianza negativa) o se non esiste correlazione tra i valori delle due variabili (covarianza prossima a 0 (zero)).

Lo strumento di analisi Statistica descrittiva genera un rapporto di statistica univariata per i dati dell'intervallo di input, fornendo informazioni sulla tendenza centrale e la variabilità dei dati.

Lo strumento di analisi Smorzamento esponenziale consente di prevedere un valore basato sulla previsione per il periodo precedente, con la correzione dell'errore della previsione precedente. Questo strumento usa una costante di smorzamento a, il cui valore assoluto determina in quale misura le previsioni rispondono agli errori della previsione precedente.

Nota: I valori da 0,2 a 0,3 sono costanti di smussatura ragionevoli. Questi valori indicano che la previsione corrente deve essere regolata dal 20% al 30% per errori nelle previsioni precedenti. Le costanti più grandi generano una risposta più rapida, ma possono produrre proiezioni irregolari. Le costanti più piccole possono determinare un ritardo lungo per i valori previsti.

Lo strumento di analisi Test F a due campioni per varianze consente di eseguire un test F a due campioni per confrontare le varianze di due popolazioni.

È ad esempio possibile usarlo su campioni di tempi ottenuti da due squadre in una gara di nuoto. Questo strumento fornisce il risultato della verifica dell'ipotesi nulla secondo cui i due campioni provengono da distribuzioni con varianze uguali rispetto all'alternativa secondo cui le varianze nelle distribuzioni sottostanti non sono uguali.

Lo strumento calcola il valore f di una Statistica F (o rapporto F). Un valore di f prossimo a 1 dimostra che le varianze delle popolazioni sottostanti sono uguali. Nella tabella di output, se f < 1, "P(F <= f) una coda" fornisce la probabilità di osservare un valore della Statistica F inferiore a f quando le varianze delle popolazioni sono uguali e "F critico una coda" fornisce il valore critico inferiore a 1 per il livello di significatività scelto, ovvero Alfa. Se f > 1, "P(F <= f) una coda" fornisce la probabilità di osservare un valore della Statistica F maggiore di f quando le varianze delle popolazioni sono uguali e "F critico una coda" fornisce il valore critico maggiore di 1 per Alfa.

Lo strumento Analisi di Fourier consente di risolvere i problemi nei sistemi lineari e di analizzare i dati periodici usando il metodo Fast Fourier Transform (FFT) per la trasformazione dei dati. Questo strumento supporta anche le trasformazioni inverse, in cui l'inversa dei dati trasformati restituisce i dati originali.

Intervalli di input e di output per l'analisi di Fourier

Lo strumento di analisi Istogramma consente di calcolare le frequenze individuali e cumulative per un intervallo di celle e di classi di dati. Questo strumento genera dati per il numero di occorrenze di un valore in un set di dati.

È ad esempio possibile determinare la distribuzione dei voti espressi in lettere in una classe di 20 studenti. Nella tabella dell'istogramma vengono illustrati i limiti dei voti espressi in lettere e il numero di voti compresi tra il limite inferiore e il limite corrente. Il singolo voto più frequente rappresenta la modalità dei dati.

Suggerimento: In Excel 2016 è ora possibile creare un istogramma o un grafico di Pareto.

Lo strumento di analisi Media mobile consente di proiettare valori nel periodo di previsione sulla base del valore medio della variabile calcolata su un numero specifico di periodi precedenti. Una media mobile fornisce le informazioni sulla tendenza che una semplice media di tutti i dati cronologici non sarebbe in grado di fornire. Usare questo strumento per prevedere vendite, inventari e altre tendenze. Ciascun valore di previsione si basa sulla formula seguente:

Formula per il calcolo delle medie mobili

dove:

  • N è il numero di periodi precedenti da includere nella media mobile

  • A j è il valore effettivo nel momento j

  • F j è il valore previsto nel momento j

Lo strumento di analisi Generazione di un numero casuale consente di riempire un intervallo con numeri casuali indipendenti estratti da una delle distribuzioni. È possibile caratterizzare i soggetti di una popolazione con una distribuzione di probabilità. È ad esempio possibile usare una distribuzione normale per caratterizzare la popolazione di altezze di individui oppure usare una distribuzione di Bernoulli a due possibili esiti per caratterizzare la popolazione di risultati del lancio di una moneta.

Lo strumento di analisi Rank e perCentile genera una tabella che contiene l'ordinale e il rango percentuale di ogni valore in un set di dati. È possibile analizzare la posizione relativa dei valori in un set di dati. Questo strumento usa le funzioni del foglio di lavoro Rank. EQ epercent. INC. Se si vuole tenere conto dei valori legati, usare il rango. Funzione EQ , che considera i valori legati come aventi lo stesso rango o usa il rango.Funzione AVG , che restituisce il rango medio per i valori collegati.

Lo strumento di analisi Regressione consente di eseguire un'analisi lineare della regressione usando il metodo dei minimi quadrati per adattare una retta a un insieme di osservazioni. È possibile analizzare l'effetto di una o più variabili indipendenti su una singola variabile dipendente. È ad esempio possibile analizzare il modo in cui le prestazioni di un atleta sono influenzate da fattori quali l'età, la statura e il peso. È possibile ripartire la misura delle prestazioni tra questi tre fattori in base a un set di dati delle prestazioni e quindi usare i risultati per prevedere le prestazioni di un altro atleta non analizzato.

Lo strumento di reGressione usa la funzione del foglio di lavoro line.

Lo strumento di analisi Campionamento consente di creare un campione da una popolazione considerando l'intervallo di input come una popolazione. Quando la popolazione è troppo vasta per essere elaborata o tracciata in un grafico, è possibile usare un campione rappresentativo. È anche possibile creare un campione che contenga solo i valori di una determinata parte di un ciclo, se si ritiene che i dati di input siano periodici. Se ad esempio l'intervallo di input contiene i valori delle vendite trimestrali, il campionamento con un tasso periodico di quattro determinerà l'inserimento nell'intervallo di output dei valori relativi allo stesso trimestre.

Gli strumenti di analisi Test t: due campioni consentono di verificare l'uguaglianza delle medie della popolazione sottostante ogni campione. Questi tre strumenti si basano su presupposti diversi, ovvero che le varianze della popolazione siano uguali, che le varianze della popolazione non siano uguali e che i due campioni rappresentino osservazioni degli stessi soggetti prima e dopo un esperimento.

Per tali strumenti viene calcolato un valore di una Statistica t, ovvero t, e tale valore viene indicato nelle tabelle di output come "Stat t". A seconda dei dati, il valore t può essere negativo o non negativo. A partire dal presupposto di medie della popolazione sottostante uguali, se t < 0, "P(T <= t) una coda" fornisce la probabilità che venga osservato un valore della Statistica t più negativo di t. Se t >=0, "P(T <= t) una coda" fornisce la probabilità che venga osservato un valore della Statistica t più positivo di t. "t critico una coda" fornisce il valore massimo, in modo che la probabilità di osservare un valore della Statistica t maggiore o uguale a "t critico una coda" corrisponda ad Alfa.

"P(T <= t) due code" fornisce la probabilità che venga osservato un valore della Statistica t maggiore in termini di valore assoluto di t. "P critico due code" fornisce il valore massimo, in modo che la probabilità di osservare un valore della Statistica t maggiore in termini di valore assoluto di "P critico due code" corrisponda ad Alfa.

Test t: due campioni accoppiati per medie

È possibile usare un test accoppiato quando esiste un naturale appaiamento tra le osservazioni dei campioni, come nel caso di una duplice verifica di un gruppo campione, prima e dopo un esperimento. Questo strumento di analisi e la relativa formula consentono di eseguire un test t di Student a due campioni accoppiati per determinare la probabilità che le osservazioni precedenti e quelle successive a un esperimento derivino da distribuzioni con medie di popolazione uguali. Questa forma del test t non presuppone che le varianze di entrambe le popolazioni siano uguali.

Nota: Tra i risultati generati da questo strumento è inclusa la varianza complessiva, una misura cumulativa della distribuzione dei dati rispetto alla media, derivata dalla formula seguente:

Formula per il calcolo della varianza complessiva

Test t: due campioni presupponendo uguale varianza

Questo strumento di analisi esegue un test t di Student a due campioni. Questo modulo di test t presuppone che i due set di dati provengano da distribuzioni con le stesse varianti. Viene indicato come test t omoscedastico. Puoi usare questo test t per determinare se i due campioni sono probabilmente provenire da distribuzioni con mezzi di popolazione uguali.

Test t: due campioni presupponendo varianze diverse

Questo strumento di analisi esegue un test t di Student a due campioni. Questo modulo di test t presuppone che i due set di dati provengano da distribuzioni con varianze diversi. Viene indicato come test t eteroschedastico. Come per il caso di varianze uguali precedenti, puoi usare questo test t per determinare se i due esempi sono probabilmente provenire da distribuzioni con mezzi di popolazione uguali. Usare questo test quando sono presenti oggetti distinti nei due esempi. Usare il test associato, descritto nell'esempio seguente, quando esiste un singolo set di argomenti e i due esempi rappresentano le misure per ogni oggetto prima e dopo un trattamento.

Per determinare il valore statistico t viene usata la formula seguente:

Formula per il calcolo del valore t

La formula seguente viene usata per calcolare i gradi di libertà, DF. Poiché il risultato del calcolo in genere non è un numero intero, il valore di DF viene arrotondato al numero intero più vicino per ottenere un valore critico dalla tabella t. Foglio di lavoro di Excel T.Test usa il valore DF calcolato senza arrotondamento, perché è possibile calcolare un valore per T.Eseguire il test con un valore non integer DF. A causa di questi approcci diversi per determinare i gradi di libertà, i risultati di T.Test e questo strumento test t differiscono nel caso delle varianze non paritarie.

Formula per l'arrotondamento dei gradi di libertà

Lo strumento di analisi z-test: Two per lo strumento di analisi consente di eseguire due test z di esempio per i mezzi con variazioni note. Questo strumento viene usato per verificare l'ipotesi nulla che non esista alcuna differenza tra due mezzi di popolazione rispetto alle ipotesi alternative unilaterali o fronte-retro. Se gli scostamenti non sono noti, la funzione del foglio di lavoro Z.Deve invece essere usato il test .

Quando si usa lo strumento Test z, è necessario fare attenzione all'interpretazione dell'output. "P(Z <= z) una coda" corrisponde a P(Z >= ABS(z)), ovvero la probabilità di un valore z diverso da 0 nella stessa direzione del valore z osservato quando non esiste differenza tra le medie della popolazione. "P(Z <= z) due code" corrisponde a P(Z >= ABS(z) o Z <= -ABS(z)), ovvero la probabilità di un valore z diverso da 0 in entrambe le direzioni rispetto al valore z osservato quando non esiste differenza tra le medie della popolazione. Il risultato a due code corrisponde al risultato a una coda moltiplicato per 2. Lo strumento Test z può inoltre essere usato nel caso in cui l'ipotesi nulla preveda l'esistenza di un valore specifico diverso da zero per la differenza tra le medie delle due popolazioni. È ad esempio possibile usare questo test per determinare le differenze tra le prestazioni di due modelli di automobili.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

Creare un istogramma in Excel 2016

Creare un grafico di Pareto in Excel 2016

Caricare Analysis Analisi in Excel

Funzioni di progettazione (riferimento)

Funzioni statistiche (riferimento)

Panoramica delle formule in Excel

Come evitare errori nelle formule

Trovare e correggere errori nelle formule

Scelte rapide da tastiera e tasti funzione di Excel

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×