Unire più moduli di InfoPath

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

InfoPath Forms Services è una tecnologia server, disponibile in Microsoft Office Forms Server 2007 e Microsoft Office SharePoint Server 2007, che consente agli utenti di compilare i moduli Microsoft Office InfoPath 2007 tramite un Web browser anziché o in aggiunta ai, il programma client Office InfoPath 2007. Questa tecnologia consente l'accesso più ampio ai moduli rispetto alle versioni precedenti di Microsoft Office InfoPath.

In questo articolo viene illustrato come unire i moduli di Office InfoPath 2007 in un server in cui è in esecuzione InfoPath Forms Services.

Contenuto dell'articolo

Panoramica

Unire più moduli di InfoPath in una raccolta

Panoramica

Una raccolta è una posizione in un sito nella quale è possibile creare, raccogliere, aggiornare e gestire file insieme agli altri membri del team. In ogni raccolta vengono visualizzati un elenco dei file e le informazioni principali su tali file, in modo che gli utenti possano individuare e utilizzare facilmente i file per attività di collaborazione.

Archiviando i moduli di InfoPath in una raccolta, è possibile condividerli e tenerne traccia in modo semplice. È ad esempio possibile creare una raccolta per i moduli di rapporto di stato del proprio team. Se il progettista ha attivato l'opzione di unione moduli per il modello di modulo, è anche possibile unire i moduli in una raccolta. L'unione di moduli consente agli utenti di consolidare i dati di diversi moduli basati sullo stesso modello. L'unione dei dati dei moduli è utile se si desidera confrontare o riepilogare i dati di diversi moduli. Il responsabile di un team che compila moduli di rapporto di stato settimanali potrebbe ad esempio unire i dati di diversi moduli in un unico modulo di riepilogo da presentare a sua volta al proprio manager. Quando si uniscono i moduli, i dati dei moduli originali non vengono eliminati e gli utenti possono comunque visualizzare i dati originali aprendo ogni singolo modulo.

Per unire i moduli in una raccolta, è possibile utilizzare il comando Unisci documenti disponibile nel menu Visualizza della raccolta. Questo comando viene aggiunto al menu Visualizza di una raccolta documenti quando il progettista del modello di modulo pubblica un modello in una nuova raccolta da Microsoft Office InfoPath. Il comando viene inoltre visualizzato quando a una raccolta esistente viene aggiunto un tipo di contenuto del sito che supporta l'unione di moduli.

Quando il comando Unisci documenti è disponibile, è possibile selezionare i file che si desidera unire senza aprirli. Quando si uniscono moduli di InfoPath tramite il comando Unisci documenti, InfoPath viene aperto e viene visualizzato un nuovo modulo contenente i dati uniti dei moduli selezionati. Il nuovo modulo viene aperto in InfoPath anche se i moduli sono basati su un modello di modulo abilitato per i browser. Se si salva un nuovo modulo nella stessa raccolta dei moduli originali, tale modulo sarà abilitato per i browser come gli altri moduli della raccolta.

Note : 

  • Per fare in modo che un modello di modulo abilitato per i browser venga sempre aperto nel browser, fare clic su Visualizza come pagina Web nella pagina Impostazioni avanzate della raccolta.

  • Per impostazione predefinita, quando più moduli vengono uniti in un unico modulo, gli unici dati uniti sono quelli contenuti in una tabella ripetuta o in una sezione ripetuta oppure i dati associati a un elenco o a un controllo casella di testo formato RTF. Quando si progetta il modello di modulo, è tuttavia possibile specificare che vengano uniti anche i dati inclusi negli altri tipi di controlli.

Torna all'inizio

Unire più moduli di InfoPath in una raccolta

Per unire più moduli archiviati in un raccolta documenti, effettuare le seguenti operazioni:

  1. Se la raccolta non è già aperta, fare clic sul relativo nome sulla barra di avvio veloce.

    Se il nome della raccolta non viene visualizzato, fare clic su Visualizza tutto il contenuto del sito e quindi fare clic sul nome della raccolta.

  2. Il menu visualizzazione immagine del menu , scegliere Unisci revisioni.

  3. Nella colonna Unisci selezionare le caselle di controllo accanto ai moduli che si desidera unire.

  4. Sulla barra degli strumenti elenco fare clic su Unisci documenti selezionati.

    InfoPath verrà aperto con un nuovo modulo basato sullo stesso modello di modulo e contenente i dati uniti.

    Nota : Quando un utente unisce moduli di posta elettronica di InfoPath, i dati uniti da controlli ripetuti potrebbero contenere una riga vuota. Se, ad esempio, un utente unisce tre moduli nota spese, ognuno dei quali contiene una singola riga di spese in una tabella ripetuta, la tabella ripetuta nel modulo di posta elettronica di InfoPath in cui sono inclusi i dati uniti potrebbe contenere una riga vuota, seguita da tre righe di dati di ognuno degli altri moduli di posta elettronica di InfoPath.

  5. Per salvare il modulo contenente i dati uniti, scegliere Salva con nome dal menu File, individuare il percorso in cui si desidera salvare il modulo, quindi scegliere Salva.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×