Strutturare (raggruppare) i dati in un foglio di lavoro

Se si dispone di un elenco di dati da raggruppare e riepilogare, è possibile creare una struttura con fino a otto livelli, uno per ogni gruppo. Ogni livello interno, rappresentato da un numero più alto nei simboli di struttura, visualizza i dati dettaglio per il livello immediatamente superiore, rappresentato da un numero più basso nei simboli di struttura. È possibile usare una struttura per visualizzare rapidamente righe o colonne di riepilogo o per mostrare i dati di dettaglio per ogni gruppo. È possibile creare una struttura di righe, come quella illustrata nell'esempio seguente, una struttura di colonne o una struttura di righe e colonne.

elenco strutturato
Riga strutturata di dati di vendita raggruppati per aree geografiche e mesi con diverse righe di riepilogo e di dettaglio.

1. Per visualizzare le righe per un livello, fare clic sui simboli di struttura uno due tre appropriati.

2.  Il livello 1 contiene le vendite totali per tutte le righe di dettaglio.

3.  Il livello 2 contiene le vendite totali per ogni mese in ogni regione.

4.  Il livello 3 contiene le righe di dettaglio, in questo caso le righe da 11 a 13.

5.  Per espandere o comprimere i dati nella struttura, fare clic sui simboli di struttura più e meno .

Per saperne di più

Creare una struttura di righe

Creare una struttura di colonne

Mostrare o nascondere i dati strutturati

Personalizzare una struttura mediante gli stili

Copiare dati strutturati

Nascondere o rimuovere una struttura

Creare un riepilogo con un grafico

Creare una struttura di righe

  1. Verificare che nella prima riga di ogni colonna dei dati da strutturare sia presente un'etichetta, che in ogni colonna siano contenute informazioni dello stesso tipo e che nell'intervallo non siano presenti righe o colonne vuote.

  2. Assicurarsi che per le righe di dettaglio sia disponibile anche una riga di riepilogo, ovvero un subtotale. Eseguire una delle operazioni seguenti:

    Inserire le righe di riepilogo usando il comando Subtotale    

    • Il comando Subtotale consente di inserire la funzione SUBTOTALE immediatamente sotto o sopra ogni gruppo di righe di dettaglio e crea automaticamente la struttura. Per ulteriori informazioni sull'uso della funzione SUBTOTALE, vedere Funzione SUBTOTALE.

      Inserire le proprie righe di riepilogo    

    • Inserire le proprie righe di riepilogo con le formule immediatamente sotto o sopra ogni gruppo di righe di dettaglio. Ad esempio, sotto (o sopra) le righe dei dati sulle vendite per marzo e aprile, usare la funzione SOMMA per calcolare il subtotale delle vendite per tali mesi. La tabella più avanti in questo argomento mostra un esempio di questa operazione.

  3. Specificare se le righe di riepilogo si trovano sopra o sotto le righe di dettaglio. Nella scheda Dati fare clic sul pulsante di visualizzazione della finestra di dialogo Struttura nel gruppo Struttura.
    Nel gruppo Struttura fare clic sul pulsante di visualizzazione della finestra di dialogo

  4. Se la righe di riepilogo si trovano sopra le righe di dettaglio, deselezionare la casella di controllo Righe di riepilogo sotto il dettaglio. In caso contrario, lasciare la casella di controllo selezionata.

  5. Strutturare i dati. Eseguire una delle operazioni seguenti:

    Strutturare i dati automaticamente

    1. Se necessario, selezionare una cella nell'intervallo di celle da strutturare.

    2. Nel gruppo Struttura della scheda Dati fare clic sulla freccia sotto a Raggruppa e quindi fare clic su Struttura automatica.

      fare clic sulla freccia al di sotto di raggruppa, quindi su struttura automatica

    Strutturare i dati manualmente

    Importante : Quando si raggruppano livelli di struttura manualmente, è preferibile che i dati siano tutti visualizzati per evitare di raggruppare le righe in modo non corretto.

    1. Strutturare il gruppo esterno.

      Come strutturare il gruppo esterno

      1. Selezionare tutte le righe di riepilogo subordinate e le righe di dettaglio correlate.

        Nei dati riportati di seguito, ad esempio, la riga 6 contiene il subtotale per le righe da 2 a 5, la riga 10 contiene il subtotale per le righe da 7 a 9 e la riga 11 contiene il totale complessivo. Per raggruppare tutti i dati di dettaglio per la riga 11, selezionare le righe da 2 a 10.

         

        A

        B

        C

        1

        Regione

        Mese

        Vendite

        2

        Est

        Marzo

        € 9.647

        3

        Est

        Marzo

        € 4.101

        4

        Est

        Marzo

        € 7.115

        5

        Est

        Marzo

        € 2.957

        6

        Est

        Totale marzo

        € 23.820

        7

        Est

        Aprile

        € 4.257

        8

        Est

        Aprile

        € 1.829

        9

        Est

        Aprile

        € 6.550

        10

        Est

        Totale aprile

        € 12.636

        11

        Totale est

        € 36.456

        Importante : Non includere nella selezione la riga di riepilogo (riga 11) in questione.

      2. Nel gruppo Struttura della scheda Dati fare clic su Raggruppa, su Righe, quindi su OK.

        Fare clic su Righe, quindi su OK

        Accanto al gruppo verranno visualizzati i simboli di struttura.

    2. È possibile strutturare facoltativamente un gruppo interno annidato, ovvero le righe di dettaglio per una particolare sezione dei dati.

      Come strutturare gruppi interni annidati (gruppi di righe di dettaglio)

      1. Per ogni gruppo interno annidato, selezionare le righe di dettaglio adiacenti alla riga contenente la riga di riepilogo.

        Nell'esempio riportato di seguito, per raggruppare le righe da 2 a 5, con una riga di riepilogo 6, selezionare le righe da 2 a 5. Per raggruppare le righe da 7 a 9, con una riga di riepilogo 10, selezionare le righe da 7 a 9.

         

        A

        B

        C

        1

        Regione

        Mese

        Vendite

        2

        Est

        Marzo

        € 9.647

        3

        Est

        Marzo

        € 4.101

        4

        Est

        Marzo

        € 7.115

        5

        Est

        Marzo

        € 2.957

        6

        Est

        Totale marzo

        € 23.820

        7

        Est

        Aprile

        € 4.257

        8

        Est

        Aprile

        € 1.829

        9

        Est

        Aprile

        € 6.550

        10

        Est

        Totale aprile

        € 12.636

        11

        Totale est

        € 36.456

        Importante : Non includere la riga di riepilogo nella selezione.

      2. Nel gruppo Struttura della scheda Dati fare clic su Raggruppa.

        Fare clic su Raggruppa nella scheda Dati

        Accanto al gruppo verranno visualizzati i simboli di struttura.

      3. Continuare a selezionare e raggruppare le righe interne fino a creare tutti i livelli desiderati per la struttura.

      4. Per separare le righe, selezionarle e fare clic su Separa nel gruppo Struttura della scheda Dati.

        È anche possibile separare le sezioni della struttura senza rimuovere l'intera struttura. Fare clic su casella Più o su casella Meno del gruppo mentre si tiene premuto MAIUSC, quindi fare clic su Separa nel gruppo Struttura della scheda Dati.

        Importante : Se si separa una struttura mentre i dati di dettaglio sono nascosti, è possibile che le righe di dettaglio rimangano nascoste. Per visualizzare i dati, trascinare il cursore sui numeri di riga visibili adiacenti alle righe nascoste. Nel gruppo Celle della scheda Home fare clic su Formato, scegliere Nascondi e scopri, quindi fare clic su Scopri righe.

Inizio pagina

Creare una struttura di colonne

  1. Verificare che nella prima colonna di ogni riga dei dati da strutturare sia presente un'etichetta, che in ogni riga siano contenute informazioni dello stesso tipo e che nell'intervallo non siano presenti righe o colonne vuote.

  2. Inserire le proprie colonne di riepilogo con formule immediatamente a destra o a sinistra di ogni gruppo di colonne di dettaglio. La tabella indicata nel passaggio 4 più avanti mostra un esempio.

    Nota :  Per strutturare i dati per colonne, è necessario che siano presenti colonne di riepilogo contenenti formule che fanno riferimento a celle in ogni colonna di dettaglio del gruppo in questione.

  3. Specificare se la colonna di riepilogo deve essere posizionata a destra o a sinistra delle colonne di dettaglio. Nella scheda Dati fare clic sul pulsante di visualizzazione della finestra di dialogo Struttura nel gruppo Struttura.

    Come specificare la posizione della colonna di riepilogo

    1. Nella scheda Dati fare clic sul pulsante di visualizzazione della finestra di dialogo Struttura nel gruppo Struttura.

      Nel gruppo Struttura fare clic sul pulsante di visualizzazione della finestra di dialogo

    2. Per specificare che una colonna di riepilogo deve trovarsi a sinistra della colonna di dettaglio, deselezionare la casella di controllo Colonne di riepilogo a destra del dettaglio. Selezionarla se la colonna di riepilogo deve trovarsi a destra della colonna di dettaglio.

    3. Fare clic su OK.

  4. Per strutturare i dati, eseguire una delle operazioni seguenti:

    Strutturare i dati automaticamente

    1. Se necessario, selezionare una cella dell'intervallo.

    2. Nel gruppo Struttura della scheda Dati fare clic sulla freccia sotto a Raggruppa e quindi fare clic su Struttura automatica.

    Strutturare i dati manualmente

    Importante : Quando si raggruppano manualmente i livelli di struttura, è preferibile che i dati siano tutti visualizzati per evitare di raggruppare le colonne in modo non corretto.

    1. Strutturare il gruppo esterno.

      Come strutturare il gruppo esterno (tutte le colonne ad eccezione del totale complessivo)

      1. Selezionare tutte le colonne di riepilogo subordinate nonché i dati di dettaglio correlati.

        Nell'esempio riportato di seguito, la colonna E contiene i subtotali relativi alle colonne da B a D e la colonna I contiene i subtotali relativi alle colonne da F a H, mentre la colonna J contiene i totali complessivi. Per raggruppare tutti i dati di dettaglio relativi alla colonna J, selezionare le colonne da B a I.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Regione

        Gen

        Feb

        Mar

        T1

        Apr

        Mag

        Giu

        T2

        H1

        2

        Est

        371

        504

        880

        1.755

        186

        653

        229

        1.068

        2.823

        3

        Ovest

        192

        185

        143

        520

        773

        419

        365

        1.557

        2.077

        4

        Nord

        447

        469

        429

        1.345

        579

        180

        367

        1.126

        2.471

        5

        Sud

        281

        511

        410

        1.202

        124

        750

        200

        1.074

        2.276

        Importante : Non includere la colonna di riepilogo J (totali complessivi) nella selezione.

      2. Nel gruppo Struttura della scheda Dati fare clic su Raggruppa.

        Fare clic su Raggruppa nella scheda Dati

        Accanto al gruppo verranno visualizzati i simboli di struttura.

    2. È possibile strutturare facoltativamente un gruppo interno annidato (singoli gruppi di colonne di dettaglio).

      Come strutturare il gruppo interno annidato (gruppi di colonne di dettaglio)

      1. Per ogni gruppo interno annidato, selezionare le colonne di dettaglio adiacenti alla colonna contenente la colonna di riepilogo.

        Nell'esempio riportato di seguito, per raggruppare le colonne da B a D, con una colonna di riepilogo E, selezionare le colonne da B a D. Per raggruppare le colonne da F a H, con una colonna di riepilogo I, selezionare le colonne da F a H.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Regione

        Gen

        Feb

        Mar

        T1

        Apr

        Mag

        Giu

        T2

        H1

        2

        Est

        371

        504

        880

        1.755

        186

        653

        229

        1.068

        2.823

        3

        Ovest

        192

        185

        143

        520

        773

        419

        365

        1.557

        2.077

        4

        Nord

        447

        469

        429

        1.345

        579

        180

        367

        1.126

        2.471

        5

        Sud

        281

        511

        410

        1.202

        124

        750

        200

        1.074

        2.276

        Importante :  Non includere nella selezione la colonna di riepilogo per il gruppo in questione.

      2. Nel gruppo Struttura della scheda Dati fare clic su Raggruppa.

        Fare clic su Raggruppa nella scheda Dati

        Accanto al gruppo verranno visualizzati i simboli di struttura.

  5. Continuare a selezionare e a raggruppare le colonne interne fino a creare tutti i livelli desiderati per la struttura.

  6. Per separare le colonne, selezionarle, quindi fare clic su Separa nel gruppo Struttura della scheda Dati.

Nella scheda Dati fare clic su Separa

È inoltre possibile separare le sezioni della struttura senza rimuovere l'intera struttura. Fare clic sulla casella Più o sulla casella Meno relativa al gruppo mentre si tiene premuto il tasto MAIUSC, quindi fare clic su Separa nel gruppo Struttura della scheda Dati.

Se si separa una struttura mentre i dati di dettaglio sono nascosti, è possibile che le colonne di dettaglio rimangano nascoste. Per visualizzare i dati, trascinare il cursore sulle lettere di colonna visibili adiacenti alle colonne nascoste. Nel gruppo Celle della scheda Home fare clic su Formato, scegliere Nascondi e scopri, quindi fare clic su Scopri colonne

Inizio pagina

Mostrare o nascondere i dati strutturati

  1. Se i simboli di struttura uno due tre , più e meno non vengono visualizzati, fare clic sul pulsante Microsoft Office Icona del pulsante Office , fare clic su Opzioni di Excel (Excel 2007) oppure sulla scheda File (altre versioni), quindi scegliere Opzioni e selezionare la categoria Impostazioni avanzate. Nella sezione Opzioni di visualizzazione per il foglio di lavoro selezionare il foglio di lavoro e quindi selezionare la casella di controllo Visualizza simboli di struttura se è applicata una struttura.

  2. Fare clic su OK.

  3. Eseguire una o più delle operazioni seguenti:

    Mostrare o nascondere i dati di dettaglio di un gruppo    

    • Per visualizzare i dati di dettaglio di un gruppo, fare clic sul simbolo più relativo al gruppo.

    • Per nascondere i dati di dettaglio di un gruppo, fare clic sul simbolo meno relativo al gruppo.

      Espandere o comprimere l'intera struttura a un livello particolare    

    • Nei simboli di struttura uno due tre fare clic sul numero corrispondente al livello desiderato. I dati di dettaglio dei livelli inferiori verranno nascosti.

      Se ad esempio una struttura contiene quattro livelli, è possibile nascondere il quarto livello e visualizzare gli altri facendo clic su tre .

      Mostrare o nascondere tutti i dati di dettaglio strutturati    

    • Per mostrare tutti i dati di dettaglio, fare clic sul livello inferiore nei simboli di struttura uno due tre . Se ad esempio sono presenti tre livelli, fare clic su tre .

    • Per nascondere tutti i dati di dettaglio, fare clic su uno .

Inizio pagina

Personalizzare una struttura mediante gli stili

In Microsoft Excel sono disponibili stili come LivelloRiga_1 e LivelloRiga_2 per le righe strutturate e stili come LivelloCol_1 e LivelloCol_2 per le colonne strutturate. Questi stili usano il grassetto, il corsivo e altri formati di testo per distinguere le righe o le colonne di riepilogo nei dati. Modificando le modalità di definizione di ogni stile, è possibile applicare formati di cella e di testo diversi per personalizzare l'aspetto della struttura. È possibile applicare uno stile a una struttura in fase di creazione o in un momento successivo.

Eseguire una o più delle operazioni seguenti:

Applicare automaticamente uno stile a una riga o a una colonna di riepilogo    

  1. Nella scheda Dati fare clic sul pulsante di visualizzazione della finestra di dialogo Struttura nel gruppo Struttura.

    Nel gruppo Struttura fare clic sul pulsante di visualizzazione della finestra di dialogo

  2. Selezionare la casella di controllo Stili automatici.

Applicare uno stile a una riga o a una colonna di riepilogo esistente    

  1. Selezionare le celle a cui si desidera applicare gli stili di struttura.

  2. Nella scheda Dati fare clic sul pulsante di visualizzazione della finestra di dialogo Struttura nel gruppo Struttura.

    Nel gruppo Struttura fare clic sul pulsante di visualizzazione della finestra di dialogo

  3. Selezionare la casella di controllo Stili automatici.

  4. Fare clic su Applica stili.

Per formattare i dati strutturati è anche possibile usare formati automatici.

Inizio pagina

Copiare dati strutturati

  1. Se i simboli di struttura uno due tre , più e meno non vengono visualizzati, fare clic sul pulsante Microsoft Office Icona del pulsante Office , fare clic su Opzioni di Excel (Excel 2007) oppure sulla scheda File (altre versioni), quindi scegliere Opzioni e selezionare la categoria Impostazioni avanzate. Nella sezione Opzioni di visualizzazione per il foglio di lavoro selezionare il foglio di lavoro e quindi selezionare la casella di controllo Visualizza simboli di struttura se è applicata una struttura.

  2. Usare i simboli di struttura uno due tre , meno e più per nascondere i dati di dettaglio che non si vogliono copiare.

    Per altre informazioni, vedere la sezione Mostrare o nascondere i dati strutturati.

  3. Selezionare l'intervallo di righe di riepilogo.

  4. Nel gruppo Modifica della scheda Home fare clic su Trova e sostituisci e quindi su Vai a.

    Fare clic su Trova e seleziona, quindi su Vai a

  5. Fare clic sul pulsante Vai a formato speciale.

  6. Fare clic sul pulsante di opzione Solo celle visibili.

  7. Fare clic su OK e quindi copiare i dati.

Inizio pagina

Nascondere o rimuovere una struttura

Nota : Quando si nasconde o si rimuove una struttura i dati non vengono eliminati.

Nascondere una struttura

  • (Excel 2007) Fare clic sul pulsante Microsoft Office Icona del pulsante Office , selezionare Opzioni di Excel oppure sulla scheda File (altre versioni), quindi scegliere Opzioni e selezionare la categoria Impostazioni avanzate. Nella sezione Opzioni di visualizzazione per il foglio di lavoro selezionare il foglio di lavoro che contiene la struttura da nascondere e deselezionare la casella di controllo Visualizza simboli di struttura se è applicata una struttura.

Rimuovere una struttura

  1. Fare clic sul foglio di lavoro.

  2. Nel gruppo Struttura della scheda Dati fare clic su Separa e quindi su Cancella struttura.

    Fare clic su Separa, quindi su Cancella struttura

    Importante : Se si rimuove una struttura mentre i dati di dettaglio sono nascosti, le righe o le colonne di dettaglio potrebbero rimanere nascoste. Per visualizzare i dati, trascinare il cursore sulle lettere di colonna o sui numeri di riga visibili adiacenti alle colonne e alle righe nascoste. Nel gruppo Celle della scheda Home fare clic su Formato, scegliere Nascondi e scopri e quindi fare clic su Scopri righe o Scopri colonne.

Inizio pagina

Creare un riepilogo con un grafico

Si supponga di voler creare un riepilogo dei dati in cui vengono visualizzati solo i totali accompagnati dal rispettivo grafico. In generale è possibile eseguire l'operazione seguente:

  1. Creare un riepilogo

    1. Strutturare i dati.

      Per ulteriori informazioni, vedere le sezioni Creare una struttura di righe o Creare una struttura di colonne.

    2. Nascondere i dati di dettaglio facendo clic sui simboli di struttura uno due tre , più e meno per mostrare solo i totali come illustrato nell'esempio di struttura di righe seguente:

      Elenco strutturato in cui sono visualizzate solo le righe del totale

    3. Per altre informazioni, vedere la sezione Mostrare o nascondere i dati strutturati.

  2. Tracciare il rapporto di riepilogo in un grafico.

    1. Selezionare i dati di riepilogo che si desidera tracciare in un grafico.

      Per tracciare ad esempio solo i totali di Barbariol e Giorgi ma non i totali complessivi, selezionare le celle da A1 a C11, come nell'esempio precedente.

    2. Creare il grafico. Ad esempio, nel gruppo Grafici della scheda Inserisci fare clic su Grafici consigliati o scegliere un altro tipo di grafico.

      Un grafico creato con la Creazione guidata Grafico risulterebbe simile a quello raffigurato nell'illustrazione seguente.

      Grafico dei dati dei subtotali

      Se si mostrano o si nascondono i dettagli nell'elenco strutturato dei dati, anche il grafico verrà aggiornato per mostrare o nascondere i dati.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×