Stampare una tabella pivot

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Stampa di una tabella pivot il modo in cui si vuole spesso richiede l'uso di una combinazione di funzionalità di stampa per fogli di lavoro e tabelle pivot. Per usare queste funzionalità, è necessario disporre di un solo report nel foglio di lavoro oppure è necessario impostare un area di stampa che includa un solo report.

Suggerimento: Per ottenere risultati ottimali, seguire queste sezioni in sequenza.

Se nel foglio di lavoro sono presenti più rapporto di tabella pivot, impostare un area di stampa che includa solo il report che si vuole stampare.

  1. Fare clic sulla tabella pivot.

  2. Nel gruppo azioni della scheda analizza fare clic su Selezionae quindi su intera tabella pivot.

  3. Nel gruppo Imposta pagina della scheda layout di pagina fare clic su area di stampae quindi su Imposta area di stampa.

    Imposta area di stampa

La visualizzazione layout di pagina è utile per ottenere i dati pronti per la stampa. Ad esempio, è possibile usare i righelli per misurare la larghezza e l'altezza dei dati, modificare l'orientamento della pagina, aggiungere o modificare le intestazioni e i piè di pagina, impostare i margini per la stampa e nascondere o visualizzare le intestazioni di riga e di colonna.

  1. Nel gruppo visualizzazioni cartella di lavoro della scheda Visualizza fare clic su layout di pagina.

    Suggerimento: È anche possibile fare clic su visualizzazione layout di pagina icona del pulsante sulla barra di stato.

  2. Apportare modifiche al layout di pagina.

È possibile ripetere le etichette di riga e le etichette di colonna di un report in tutte le pagine stampate come titoli di stampa. Quando si modifica il layout del report in modo che le etichette vengano visualizzate in righe e colonne del foglio di lavoro diverse, le nuove righe e colonne dell'etichetta vengono ripetute automaticamente alla successiva stampa del report.

  1. Nel gruppo Imposta pagina della scheda Layout di pagina fare clic su Stampa titoli.

    Stampare titoli

  2. Nella finestra di dialogo Imposta pagina verificare che le righe da ripetere in alto e le colonne da ripetere alle caselle di controllo a sinistra siano deselezionate.

  3. Chiudere la finestra di dialogo Imposta pagina .

  4. Nel gruppo tabella pivot della scheda analizza fare clic su Opzioni.

  5. Nella finestra di dialogo Opzioni tabella pivot fare clic sulla scheda stampa e quindi selezionare la casella di controllo Imposta titoli di stampa .

  6. Se il report contiene più etichette di riga e si vogliono anche ripetere gli elementi dell'etichetta della riga esterna in ogni pagina, selezionare la casella di controllo Ripeti etichette di riga in ogni pagina stampata .

Quando il report include più etichette di riga e un'interruzione di pagina rientra in un gruppo di elementi dell'etichetta di riga, è possibile impostare il report in modo da ripetere automaticamente le etichette degli elementi per le etichette esterne nella parte superiore della pagina successiva. In un report con due o più etichette di riga, tutte tranne l'etichetta più a destra sono etichette di riga esterne. Nell'esempio seguente il report viene impostato in modo che gli elementi Oriente e Trim2 dall' area etichette di riga esterna e Qtr vengano stampati nella pagina successiva dopo l'interruzione di pagina.

Griglia di struttura della query

1. interruzione di pagina all'interno di un gruppo di elementi.

2. le etichette degli elementi delle etichette di riga esterne vengono ripetute a pagina 2.

  1. Fare clic con il pulsante destro del mouse sull'etichetta di riga esterna che contiene gli elementi da stampare in pagine separate e quindi scegliere Impostazioni campo dal menu di scelta rapida.

  2. Nella finestra di dialogo Impostazioni campo fare clic sulla scheda Stampa layout & .

  3. Selezionare la casella di controllo Inserisci interruzione di pagina dopo ogni elemento .

È consigliabile esaminare l'intera tabella pivot in anteprima interruzioni di pagina, in caso sia necessario apportare ulteriori modifiche alle interruzioni di pagina.

  • Nel gruppo Visualizzazioni cartella di lavoro della scheda Visualizza fare clic su Anteprima interruzioni di pagina.

    È possibile inserire nuove interruzioni di pagina manuali e rimuovere ed eliminare le interruzioni di pagina automatiche. Per altre informazioni, vedere aggiungere, eliminare o trasferire interruzioni di pagina.

Potrebbe essere necessario stampare i pulsanti Espandi e Comprimi. Per decidere se si desidera stampare i pulsanti Espandi e Comprimi, eseguire le operazioni seguenti:

  • Per visualizzare o nascondere i pulsanti Espandi e Comprimi nel foglio di lavoro, nel gruppo Mostra/Nascondi della scheda analizza fare clic su +/-.

  • Per visualizzare o nascondere i pulsanti Espandi e Comprimi nel report stampato, eseguire le operazioni seguenti:

    1. Nel gruppo tabella pivot della scheda analizza fare clic su Opzioni.

    2. Fare clic sulla scheda stampa e quindi selezionare o deselezionare la casella di controllo stampa pulsanti Espandi/Comprimi quando viene visualizzata nella tabella pivot .

      Nota: Questa casella di controllo richiede il comando +/-Buttons nel gruppo Mostra/Nascondi della scheda Opzioni che deve essere attivata.

  1. Per controllare il layout di stampa finale, fare clic su stampa file >e visualizzare l'anteprima.

    Tasti di scelta rapida: è inoltre possibile premere CTRL+F2.

    Apportare le modifiche finali necessarie. Per altre informazioni, vedere anteprima delle pagine del fogliodi lavoro prima della stampa.

  2. Quando l'anteprima ha un aspetto corretto, fare clic su stampa.

Se nel foglio di lavoro sono presenti più rapporto di tabella pivot, impostare un area di stampa che includa solo il report che si vuole stampare.

  1. Fare clic sulla tabella pivot.

  2. Nel gruppo Azioni della scheda Opzioni fare clic su Seleziona, quindi su Intera tabella pivot.

    Immagine del manuale

  3. Nel gruppo Imposta pagina della scheda layout di pagina fare clic su area di stampae quindi su Imposta area di stampa.

    Immagine della barra multifunzione di Excel

La visualizzazione layout di pagina è utile per ottenere i dati pronti per la stampa. Ad esempio, è possibile usare i righelli per misurare la larghezza e l'altezza dei dati, modificare l'orientamento della pagina, aggiungere o modificare le intestazioni e i piè di pagina, impostare i margini per la stampa e nascondere o visualizzare le intestazioni di riga e di colonna.

  1. Nel gruppo visualizzazioni cartella di lavoro della scheda Visualizza fare clic su layout di pagina.

    Informativa criteri di gestione delle informazioni visualizzata nella barra messaggi

    Suggerimento: È anche possibile fare clic su visualizzazione layout di pagina icona del pulsante sulla barra di stato.

  2. Apportare modifiche al layout di pagina.

È possibile ripetere le etichette di riga e le etichette di colonna di un report in tutte le pagine stampate come titoli di stampa. Quando si modifica il layout del report in modo che le etichette vengano visualizzate in righe e colonne del foglio di lavoro diverse, le nuove righe e colonne dell'etichetta vengono ripetute automaticamente alla successiva stampa del report.

  1. Nel gruppo Imposta pagina della scheda Layout di pagina fare clic su Stampa titoli.

    Immagine della barra multifunzione di Excel

  2. Nella finestra di dialogo Imposta pagina verificare che le righe da ripetere in alto e le colonne da ripetere alle caselle di controllo a sinistra siano deselezionate.

  3. Chiudere la finestra di dialogo Imposta pagina .

  4. Nel gruppo tabella pivot della scheda Opzioni fare clic su Opzioni.

    Barra multifunzione di Outlook

  5. Nella finestra di dialogo Opzioni tabella pivot fare clic sulla scheda stampa e quindi selezionare la casella di controllo Imposta titoli di stampa .

  6. Se il report contiene più etichette di riga e si vogliono anche ripetere gli elementi dell'etichetta della riga esterna in ogni pagina, selezionare la casella di controllo Ripeti etichette di riga in ogni pagina stampata .

Quando il report include più etichette di riga e un'interruzione di pagina rientra in un gruppo di elementi dell'etichetta di riga, è possibile impostare il report in modo da ripetere automaticamente le etichette degli elementi per le etichette esterne nella parte superiore della pagina successiva. In un report con due o più etichette di riga, tutte tranne l'etichetta più a destra sono etichette di riga esterne. Nell'esempio seguente il report viene impostato in modo che gli elementi Oriente e Trim2 dall' area etichette di riga esterna e Qtr vengano stampati nella pagina successiva dopo l'interruzione di pagina.

Griglia di struttura della query

1. interruzione di pagina all'interno di un gruppo di elementi.

2. le etichette degli elementi delle etichette di riga esterne vengono ripetute a pagina 2.

  1. Fare clic con il pulsante destro del mouse sull'etichetta di riga esterna che contiene gli elementi da stampare in pagine separate e quindi scegliere Impostazioni campo dal menu di scelta rapida.

  2. Nella finestra di dialogo Impostazioni campo fare clic sulla scheda Stampa layout & .

  3. Selezionare la casella di controllo Inserisci interruzione di pagina dopo ogni elemento .

È consigliabile esaminare l'intera tabella pivot in anteprima interruzioni di pagina, in caso sia necessario apportare ulteriori modifiche alle interruzioni di pagina.

  • Nel gruppo Visualizzazioni cartella di lavoro della scheda Visualizza fare clic su Anteprima interruzioni di pagina.

    Informativa criteri di gestione delle informazioni visualizzata nella barra messaggi

    Suggerimento: È anche possibile fare clic su Anteprima interruzioni di pagina Icona del pulsante sulla barra di stato.

    È possibile inserire nuove interruzioni di pagina manuali e rimuovere ed eliminare le interruzioni di pagina automatiche. Per altre informazioni, vedere aggiungere, eliminare o trasferire interruzioni di pagina.

Potrebbe essere necessario stampare i pulsanti Espandi e Comprimi. Per decidere se si desidera stampare i pulsanti Espandi e Comprimi, eseguire le operazioni seguenti:

  • Per visualizzare o nascondere i pulsanti Espandi e Comprimi nel foglio di lavoro, nel gruppo Mostra/Nascondi della scheda Opzioni fare clic su +/-.

    Gruppo Dimensioni sulla barra multifunzione di Excel

  • Per visualizzare o nascondere i pulsanti Espandi e Comprimi nel report stampato, eseguire le operazioni seguenti:

    1. Nel gruppo tabella pivot della scheda Opzioni fare clic su Opzioni.

      Barra multifunzione di Outlook

    2. Fare clic sulla scheda stampa e quindi selezionare o deselezionare la casella di controllo stampa pulsanti Espandi/Comprimi quando viene visualizzata nella tabella pivot .

      Nota: Questa casella di controllo richiede il comando +/-Buttons nel gruppo Mostra/Nascondi della scheda Opzioni che deve essere attivata.

  1. Per controllare il layout di stampa finale, eseguire le operazioni seguenti:

    • Excel 2010: fare clic su file > Print.

    • Excel 2007: fare clic sul pulsante Microsoft Office Icona del pulsante Office , fare clic sulla freccia accanto a stampae quindi fare clic su Anteprima di stampa.

    Tasti di scelta rapida: è inoltre possibile premere CTRL+F2.

    Apportare le modifiche finali necessarie. Per altre informazioni, vedere anteprima delle pagine del fogliodi lavoro prima della stampa.

  2. Quando l'anteprima ha un aspetto corretto, fare clic su stampa.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×