Spostare un modello di modulo pubblicato in una nuova raccolta di SharePoint

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

In questo articolo

Panoramica

Prima di iniziare

Ottenere una copia del modello di modulo

Passaggio 1: Pubblicare il modello di modulo per la nuova raccolta documenti

Passaggio 2: Copiare e ricollegato i moduli esistenti

Panoramica

Dopo avere pubblicato un modello di modulo in una raccolta documenti a disposizione degli utenti per la compilazione, può essere necessario spostarlo in un'altra raccolta documenti, ad esempio in un server con una capacità maggiore per consentire a un numero superiore di utenti di compilare i moduli contemporaneamente. È possibile che alcuni utenti abbiano già compilato moduli basati sul modello di modulo memorizzato nella raccolta documenti originale. Quando si sposta il modello di modulo in una nuova raccolta documenti, sarà necessario spostare anche tali moduli esistenti e assicurarsi che funzionino nella nuova raccolta documenti prima di archiviare o eliminare la raccolta documenti precedente.

Suggerimento : Prima di spostare i modelli di modulo pubblicati in una nuova raccolta documenti, creare un piano che preveda la notifica agli utenti dell'avvenuto spostamento dei relativi moduli in una nuova raccolta documenti, che gli utenti dovranno utilizzare per memorizzare i nuovi moduli o modificare quelli esistenti. Il piano deve prevedere inoltre un processo per l'archiviazione o l'eliminazione della raccolta documenti originale.

Per spostare un modello di modulo e i moduli corrispondenti in una nuova raccolta moduli, è necessario innanzitutto pubblicare la copia di lavoro del modello di modulo nella nuova raccolta documenti. La copia di lavoro è la versione memorizzata nel computer o in un programma di controllo delle versioni, quale Microsoft Visual SourceSafe.

Suggerimento : Se non si dispone di una copia di lavoro del modello di modulo, è possibile salvare una copia dalla raccolta documenti originale nel computer, da utilizzare come copia di lavoro.

Dopo la pubblicazione della copia di lavoro nella nuova raccolta documenti, è necessario copiare in quest'ultima tutti i moduli presenti in quella precedente e quindi ricollegare i moduli della nuova raccolta documenti al modello di modulo appena pubblicato.

Le modifiche eventualmente necessarie in seguito allo spostamento del modello di modulo dovranno essere effettuate prima della pubblicazione del modello di modulo. Lo spostamento del modello di modulo può comportare, ad esempio, la variazione della posizione delle origini dati esterne utilizzate dai moduli basati sul modello di modulo. In questo caso, è necessario impostare la connessione dati nel modello di modulo sulla nuova posizione delle origini dati esterne prima di pubblicare il modello di modulo. Per ulteriori informazioni sulla modifica delle connessioni dati, fare clic sui collegamenti nella sezione Vedere anche.

Nota : Pubblicare un modello di modulo non corrisponde al salvataggio di un modello di modulo. Quando si pubblica un modello di modulo, la pubblicazione guidata aggiunge il percorso di pubblicazione e l'elaborazione di istruzioni per il modello di modulo in modo che gli utenti possono aprire i moduli basati sul modello di modulo. Quando si salva un modello di modulo, si salva una copia del modello di modulo, esattamente come quando si salva un file nel computer in uso. Utilizzare la pubblicazione guidata sempre quando si desidera rendere disponibile per gli utenti di compilare il modello di modulo.

Torna all'inizio

Prima di iniziare

Prima di spostare il modello di modulo e i moduli esistenti basati su di esso in una nuova raccolta documenti, sarà necessario disporre di quanto segue:

  • La copia di lavoro del modello di modulo    Si tratta di una copia del modello di modulo che verrà modificata e quindi pubblicata nella nuova raccolta documenti. La copia di lavoro può essere memorizzata nel computer o in un programma di controllo delle versioni, ad esempio Visual SourceSafe.

  • Le posizioni delle nuove origini dati esterne    Se i moduli basati sul modello di modulo utilizzano origini dati esterne che sono cambiate, saranno necessarie le nuove posizioni delle origini dati esterne. Rivolgersi all'amministratore per verificare che tutti gli utenti dispongano delle autorizzazioni appropriate per l'utilizzo delle origini dati esterne. Se il modello di modulo utilizza le impostazioni incluse in un file di connessione dati per la connessione a un'origine dati esterna, verificare che il file di connessione dati sia stato aggiornato con la nuova posizione dell'origine dati esterna.

  • I diritti appropriati sul server che esegue Windows SharePoint Services 3.0    Sarà necessario disporre dei diritti appropriati sul server per pubblicare un modello di modulo e copiare i moduli esistenti dalla raccolta documenti precedente a quella nuova. Rivolgersi all'amministratore del server per assicurarsi di disporre di tali diritti.

Torna all'inizio

Ottenere una copia di lavoro del modello di modulo

Se si desidera modificare un modello di modulo pubblicato in una raccolta documenti o in un percorso di rete condiviso ma non si dispone di una copia di lavoro del modello di modulo, è possibile salvarne una dalla posizione di pubblicazione nel computer.

Suggerimento : Utilizzare un programma di controllo delle versioni, ad esempio Microsoft Visual SourceSafe, per gestire le copie di lavoro dei propri modelli di modulo.

Salvare una copia del modello di modulo da una raccolta documenti nel computer

  1. In un Web browser, aprire la raccolta documenti in cui è stato pubblicato il modello di modulo.

  2. Nel menu Impostazioni, fare clic su Impostazioni e quindi fare clic su Impostazioni raccolta moduli.

  3. Nella sezione Impostazioni generali fare clic su Impostazioni avanzate.

  4. Nella sezione Modello documento, fare clic su Modifica modello.

    Il modello di modulo verrà aperto in Microsoft Office InfoPath.

  5. Nella finestra di dialogo Microsoft Office InfoPath fare clic su .

  6. Scegliere Salva con nome dal menu File.

  7. Nella finestra di dialogo Microsoft Office InfoPath, fare clic su OK.

  8. Nella finestra di dialogo Salva con nome selezionare la posizione in cui si desidera salvare una copia del modello di modulo e quindi fare clic su Salva.

Salvare una copia del modello di modulo dalla cartella di rete condivisa nel computer

  1. Nel menu File fare clic su Progetta modello di modulo.

  2. In Apri modello di modulo fare clic su In questo computer.

  3. Passare alla cartella di rete condivisa del modello di modulo pubblicato, fare clic sul modello di modulo e quindi fare clic su Apri.

  4. Scegliere Salva con nome dal menu File.

  5. Nella finestra di dialogo Microsoft Office InfoPath, fare clic su OK.

  6. Nella finestra di dialogo Salva con nome selezionare un percorso diverso da quello originale pubblicare posizione in cui si desidera salvare una copia del modello di modulo e quindi fare clic su Salva.

Torna all'inizio

Passaggio 1: Pubblicare il modello di modulo nella nuova raccolta documenti

  1. Aprire la copia di lavoro del modello di modulo in modalità progettazione.

  2. Scegliere Pubblica dal menu File.

  3. Nella Pubblicazione guidata fare clic su In un server di SharePoint con o senza InfoPath Forms Services e quindi fare clic su Avanti.

  4. Nella casella Immettere il percorso del sito di SharePoint o InfoPath Forms Services digitare il percorso del sito di SharePoint contenente la nuova raccolta documenti in cui si desidera spostare il modello di modulo e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Raccolta documenti e quindi su Avanti.

  6. Fare clic su Crea nuova raccolta documenti e quindi fare clic su Avanti.

  7. Nella pagina successiva della procedura guidata digitare un nome e una descrizione per la nuova raccolta documenti e quindi fare clic su Avanti.

  8. Selezionare i campi nel modello di modulo che si desidera visualizzare come colonne nella visualizzazione predefinita della raccolta documenti.

    Procedura

    1. Fare clic su Aggiungi.

    2. Selezionare il campo che si desidera aggiungere come colonna nella raccolta documenti e quindi eseguire una delle operazioni seguenti:

      • Digitare un nome per la colonna nella casella nome colonna.

      • Selezionare la colonna del sito nell'elenco gruppo di colonne sito, selezionare un nome nella casella nome colonna e quindi fare clic su OK.

        Nota : Se si seleziona un campo ripetuto per visualizzare i dati nella raccolta documenti, è possibile definire come si desidera visualizzare il campo nella raccolta documenti, fare clic su un valore nell'elenco funzione. È possibile scegliere se visualizzare il primo valore nel campo, l'ultimo valore nel campo o un conteggio di tutte le occorrenze del campo o se unire tutti i valori.

    3. Scegliere OK.

    Per ulteriori informazioni sulla visualizzazione dei dati in colonne in una raccolta documenti, fare clic sui collegamenti nella sezione Vedere anche.

  9. Fare clic su Avanti.

  10. Nella pagina successiva della procedura guidata verificare che le informazioni visualizzate siano corrette e quindi fare clic su Pubblica.

  11. Per aprire la raccolta documenti e verificare il processo per la compilazione di un modulo basato su questo modello di modulo, selezionare la casella di controllo Apri raccolta documenti e quindi fare clic su Chiudi.

    La raccolta documenti verrà aperta in un browser. Quando si fa clic su Nuovo sulla barra degli strumenti Elenco, verrà aperto un nuovo modulo basato su questo modello di modulo in Microsoft Office InfoPath.

Dopo la pubblicazione del modello di modulo in una nuova raccolta documenti, i moduli esistenti basati sulla versione precedente del modello di modulo potranno essere copiati dalla raccolta documenti precedente a quella nuova. Al termine di questa operazione, sarà possibile ricollegare i moduli esistenti alla nuova versione del modello di modulo. In caso contrario, gli utenti potrebbero non essere in grado di aprire i moduli esistenti.

Torna all'inizio

Passaggio 2: Copiare e ricollegare i moduli esistenti

Questa procedura presume che entrambe le raccolte documenti si trovino su un server che esegue Windows SharePoint Services 3.0.

  1. Aprire la raccolta documenti precedente in un browser.

  2. Scegliere Visualizzazione Esplora risorse dal menu Visualizza.

  3. Tenere premuto CTRL e selezionare i moduli da spostare e quindi fare clic con il pulsante destro del mouse su uno di essi.

  4. Nella finestra di dialogo Internet Explorer fare clic su e scegliere Copia dal menu di scelta rapida.

  5. Aprire la nuova raccolta documenti.

  6. In Selezionare una visualizzazione fare clic su Visualizzazione Esplora risorse.

  7. Fare clic con il pulsante destro del mouse nell'area vuota della finestra delle cartelle.

  8. Nella finestra di dialogo Internet Explorer fare clic su e quindi scegliere Incolla dal menu di scelta rapida.

  9. Scegliere Ricollega documenti dal menu Visualizza.

  10. Nella colonna Ricollega selezionare le caselle di controllo relative a tutti i moduli che si desidera collegare al nuovo modello di modulo.

  11. Fare clic su Ricollega documenti selezionati sulla barra degli strumenti Elenco.

Dopo avere ricollegato i moduli esistenti al nuovo modello di modulo, gli utenti potranno modificare i moduli esistenti copiati nella nuova raccolta documenti o compilare nuovi moduli basati sul modello di modulo appena pubblicato.

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×