Sommare valori in base a più condizioni

Sommare valori in base a più condizioni

Per sommare valori in base a più di una condizione, ad esempio le vendite di un determinato prodotto in una certa area, utilizzare la funzione SOMMA.PIÙ.SE in una formula.

In questo esempio abbiamo impostato due condizioni per sommare le vendite di Carne (colonna C) nell'area Sud (colonna A).

Dati in un foglio di lavoro di Excel

La formula da usare sarà la seguente:

=SOMMA.PIÙ.SE(D2:D11;A2:A11;"Sud";C2:C11;"Carne")Il risultato è 14719 e il funzionamento è illustrato di seguito.

=SOMMA.PIÙ.SE è una formula aritmetica. Calcola numeri che in questo caso si trovano nella colonna D. È quindi necessario indicare alla formula dove si trovano i numeri:

  • =SOMMA.PIÙ.SE(D2:D11;

In altre parole, la formula deve sommare i numeri in questa colonna se soddisfano le condizioni. L'intervallo di celle è il primo argomento o il singolo dato che la funzione deve eseguire.

A questo punto, per trovare i dati che soddisfano due condizioni, è necessario immettere la prima condizione indicando alla funzione dove risiedono i dati (A2:A11) e quindi specificare la condizione, ovvero "Sud". Notare le virgole tra gli argomenti.

  • =SOMMA.PIÙ.SE(D2:D11,A2:A11,"Sud",

Le virgolette che delimitano "Sud" indicano a Excel che i dati sono di testo.

Infine, immettere gli argomenti per la seconda condizione, l'intervallo di celle (C2:C11) che contiene la parola "carne", più la parola stessa (delimitata da virgolette) in modo che Excel possa trovare la corrispondenza. Terminare la formula con una parentesi di chiusura ), quindi premere INVIO per ottenere il risultato 14719.

  • =SOMMA.PIÙ.SE(D2:D11;A2:A11;"Sud";C2:C11;"Carne")

Mentre si digita la funzione SOMMA.PIÙ.SE in Excel, se non si ricordano gli argomenti è possibile ricorrere alla Guida. Dopo avere digitato =SOMMA.PIÙ.SE( Completamento automatico formule compare sotto la formula, con l'elenco di argomenti nell'ordine appropriato.

Facendo riferimento all'immagine di Completamento automatico formule e all'elenco di argomenti, nell'esempio int_somma è D2:D11, la colonna di numeri che si desidera sommare. intervallo_criteri1 è A2.A11, la colonna di dati in cui risiede criteri1 "Sud".

Uso di Completamento automatico formule per immettere la funzione SOMMA.PIÙ.SE

Mentre si digita, gli altri argomenti vengono visualizzati in Completamento automatico formule (non mostrato in questo articolo). intervallo_criteri2 è C2:C11, la colonna di dati in cui risiede criteri2 "Carne".

Se si fa clic su SOMMA.PIÙ.SE in Completamento automatico formule, viene visualizzato un articolo contenente ulteriori informazioni.

Esercitazione

Per esercitarsi con la funzione SOMMA.PIÙ.SE, ecco alcuni dati di esempio e una formula che la usa.

È possibile usare i dati di esempio e le formule in questa cartella di lavoro di Excel Online. Modificare i valori e le formule esistenti o aggiungere i propri valori e le proprie formule e osservare come i risultati cambiano in tempo reale.

Copiare tutte le celle della tabella sotto e incollarle nella cella A1 all'interno di un nuovo foglio di lavoro di Excel. Per visualizzare meglio le formule può essere necessario modificare la larghezza delle colonne

Regione

Venditore

Tipo

Vendite

Sud

Longo

Bevande

3571

Ovest

Dellucci

Latticini

3338

Est

Esposito

Bevande

5122

Nord

Esposito

Latticini

6239

Sud

Milano

Prodotti agricoli

8677

Sud

Dellucci

Carne

450

Sud

Dellucci

Carne

7673

Est

Esposito

Prodotti agricoli

664

Nord

Dellucci

Prodotti agricoli

1500

Sud

Milano

Carne

6596

Formula

 

Descrizione

Risultato

'=SOMMA.PIÙ.SE(D2:D11;A2:A11;
"Sud"; C2:C11;"Carne")

Somma le vendite di carne della
colonna C nell'area Sud
della colonna A (il risultato è 14719).

=SOMMA.PIÙ.SE(D2:D11,A2:A11,
"Sud", C2:C11,"Carne")

Note : 

  • Altri esempi sono disponibili nell'articolo Funzione SOMMA.PIÙ.SE.

  • Per creare un valore totale per un solo intervallo basato su un valore di un altro intervallo, usare la funzione SOMMA.SE.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×