Salvare in SharePoint (Power Pivot)

È possibile salvare cartelle di lavoro di Excel che contengono modelli di dati di Power Pivot in un sito di SharePoint esteso per supportare l'accesso ai modelli di dati. Dopo la pubblicazione della cartella di lavoro, le autorizzazioni e le proprietà dei documenti di SharePoint determinano le modalità con cui gli altri utenti possono visualizzare e usare la cartella di lavoro.

Prima di iniziare

Per pubblicare cartelle di lavoro in SharePoint è necessario disporre di autorizzazioni sufficienti e software adeguato e sapere come preparare la cartella di lavoro per la pubblicazione.

Software server

Per visualizzare le cartelle di lavoro in un browser, nel server SharePoint in uso devono essere installati Power Pivot per SharePoint ed Excel Services. Entrambi i servizi sono necessari per l'elaborazione e il rendering delle cartelle di lavoro in SharePoint.

A volte è possibile verificare se si dispone del software corretto esaminando le raccolte e i menu di scelta rapida del sito, ma potrebbe essere necessario chiedere all'amministratore di SharePoint se il server richiesto è installato. Se il sito include la raccolta Power Pivot, significa che Power Pivot per SharePoint è installato. Allo stesso modo, se è possibile aprire una cartella di lavoro di Excel in una finestra del browser senza dover scaricare il file nell'applicazione desktop Excel, significa che Excel Services è in esecuzione nel server SharePoint.

Se si intende pianificare un aggiornamento automatico dei dati della cartella di lavoro, consultare l'amministratore del server per accertarsi che i provider di dati usati per importare i dati siano disponibili anche nel server.

Autorizzazioni

Quando si salva un documento in SharePoint, le autorizzazioni di SharePoint determinano chi può visualizzarlo, modificarlo ed eliminarlo. La tabella seguente descrive le autorizzazioni di SharePoint e i diritti specifici che concedono sulle cartelle di lavoro pubblicate:

Autorizzazione

Diritti

Visualizzazione

Chiunque disponga dell'autorizzazione di visualizzazione può aprire la cartella di lavoro tramite l'indirizzo URL del file. Inoltre, questa autorizzazione consente anche ad alcuni utenti di usare la cartella di lavoro come origine dati esterna di sola lettura per altre cartelle di lavoro o report di Excel.

Collaborazione

L'autorizzazione di collaborazione è più estesa perché consente di aggiungere, modificare o eliminare documenti in una raccolta di SharePoint.

Controllo completo

Questa autorizzazione include tutti i diritti associati all'autorizzazione di collaborazione, oltre alla possibilità di creare o gestire l'elenco o la raccolta e di annullare un'estrazione.

L'accesso a qualsiasi sito o raccolta di SharePoint viene concesso tramite le autorizzazioni specificate da un amministratore o un proprietario di sito per gruppi o singoli utenti.

La maggior parte degli utenti dispone dell'autorizzazione di visualizzazione o collaborazione. Per verificare di quali autorizzazioni si dispone, controllare il menu Azioni sito nel proprio sito di SharePoint. Se l'unica voce del menu è Visualizza tutto il contenuto del sito, si dispone delle autorizzazioni di visualizzazione e non è possibile pubblicare file nel sito di SharePoint. Se sono presenti più voci di menu o se nella barra multifunzione è presente la scheda Strumenti raccolta, si dispone delle autorizzazioni di collaborazione.

Preparare la cartella di lavoro

Prima di pubblicare una cartella di lavoro di Excel che contiene dati di Power Pivot, seguire l'elenco di controllo riportato di seguito per preparare il documento:

  1. Leggere la documentazione sulla creazione di una cartella di lavoro che usa informazioni di connessione che rimangono valide dopo la pubblicazione del file.

  2. È opportuno valutare le considerazioni sulla sicurezza legate alla pubblicazione di dati di Power Pivot in SharePoint.

  3. È possibile migliorare la presentazione visiva della cartella di lavoro in SharePoint seguendo questi suggerimenti:

    • Assegnare nomi descrittivi ai fogli di lavoro di Excel. I nomi dei fogli di lavoro diventano etichette di pagina quando il documento viene pubblicato nella raccolta Power Pivot.

    • Disattivare gli elementi visivi inutilizzati. Nella barra multifunzione di Excel, nell'area Mostra della scheda Visualizza, disattivare Griglia, Barra della formula e Intestazioni.

    • Nascondere i fogli di lavoro di Excel vuoti o non rilevanti per il report. Nella finestra di Excel fare clic con il pulsante destro del mouse su una scheda del foglio e scegliere Nascondi foglio.

    • Selezionare la cella A1 prima di salvare e pubblicare la cartella di lavoro. Quando un file pubblicato è aperto in una finestra del browser, lo stato attivo è sull'ultima cella attiva della cartella di lavoro. Posizionando il cursore nella cella A1, si fa in modo che l'angolo superiore sinistro del foglio di lavoro sia posizionato in corrispondenza dell'angolo superiore sinistro della finestra del browser.

Controllare le impostazioni di autenticazione e aggiornamento

Per ottenere risultati ottimali, usare le impostazioni predefinite di Excel per l'autenticazione e l'aggiornamento dei dati.

Verificare l'autenticazione di Windows

Per impostazione predefinita, Excel specifica l'autenticazione di Windows, quindi l'identità della persona che visualizza la cartella di lavoro viene usata durante l'accesso ai dati del modello di dati. L'impostazione predefinita consente al software server di Power Pivot di acquisire informazioni accurate sugli utenti che usano le cartelle di lavoro di Power Pivot, migliorando la collaborazione con i colleghi che usano gli stessi dati. Se si specifica Nessuno o un ID servizio di archiviazione sicura, i dati sull'utilizzo delle cartelle di lavoro verranno registrati per l'account utente automatico di Excel Services (o per l'ID servizio di archiviazione sicura) invece che per una persona reale dell'organizzazione.

  1. Nella scheda Dati della barra multifunzione di Excel fare clic su Connessioni esistenti.

  2. Nella finestra di dialogo Connessioni esistenti fare clic su una connessione nella cartella di lavoro e quindi su Apri.

  3. Fare clic su Proprietà > Definizione > Impostazioni di autenticazione.

  4. Verificare che l'opzione Usa l'account utente autenticato sia selezionata.

Specificare le impostazioni di controllo dell'aggiornamento

Le impostazioni di controllo dell'aggiornamento possono influire sulla modalità di visualizzazione in anteprima di una cartella di lavoro di Power Pivot nella raccolta Power Pivot. Ad esempio, se la cartella di lavoro usa la proprietà Aggiorna all'apertura ed Excel Services è configurato per generare un avviso per le operazioni di aggiornamento dei dati, verrà visualizzata un'immagine in anteprima di tale avviso invece dell'immagine in anteprima di un documento.

  1. Nella scheda Dati della barra multifunzione di Excel fare clic su Connessioni > Proprietà.

  2. In Utilizzo > Controllo aggiornamento selezionare o deselezionare la casella di controllo Aggiorna dati all'apertura del file in base ai suggerimenti seguenti, che variano a seconda della modalità di accesso al modello di dati:

Accesso ai dati

Suggerimento per il controllo dell'aggiornamento

Dati incorporati nella cartella di lavoro (scenario più comune)

Deselezionare la cartella di lavoro Aggiorna dati all'apertura del file. Poiché tutti i dati sono incorporati, non è necessario aggiornarli ogni volta che si apre la cartella di lavoro.

Dati archiviati come origine dati esterna (ad esempio, se si configura una connessione a dati esterni a una cartella di lavoro invece di importarne i dati)

Selezionare la casella di controllo Aggiorna dati all'apertura del file. Poiché i dati si trovano in un percorso diverso, è consigliabile aggiornarli per applicare le modifiche recenti.

Per consentire la generazione di immagini di anteprima, chiedere all'amministratore di SharePoint di personalizzare l'impostazione Avviso in caso di aggiornamento in Excel Services. Per altre informazioni, vedere l'articolo sulla creazione di un percorso attendibile per i siti di Power Pivot su TechNet.

Operazioni di aggiornamento dei dati lato server (si applica alle cartelle di lavoro salvate in SharePoint e pianificate per l'aggiornamento dei dati di Power Pivot).

Selezionare la casella di controllo Aggiorna dati all'apertura del file. Poiché l'aggiornamento dei dati è pianificato per questa cartella di lavoro, Power Pivot abiliterà automaticamente la proprietà Aggiorna dati all'apertura del file sulla cartella di lavoro in modo che la cache tabella pivot venga sostituita con dati più recenti. Se si deseleziona la casella di controllo, verrà selezionata automaticamente quando si salva di nuovo la cartella di lavoro in SharePoint.

Scegliere una posizione per il file

I documenti condivisi in un sito vengono in genere conservati in una raccolta documenti. Documenti condivisi è la raccolta documenti più comune, ma un sito di SharePoint in cui è installato Power Pivot per SharePoint contiene spesso una raccolta Power Pivot che offre anteprime, visualizzazioni di raccolte personalizzate e facile accesso alle pianificazioni di configurazione dell'aggiornamento dei dati della cartella di lavoro.

È necessario scegliere un server di SharePoint in cui è installato Power Pivot per SharePoint. Se si pubblica su un server in cui non è installato il software server di Power Pivot, i dati non verranno caricati quando si apre un documento da una raccolta.

È possibile scegliere Documenti condivisi, Raccolta Power Pivot o qualsiasi altra raccolta documenti in cui archiviare la cartella di lavoro. Per usare questi percorsi, è necessario conoscere l'URL Web della raccolta. In un sito di SharePoint predefinito, gli URL Web di queste raccolte sono i seguenti:

  • http://<nome server>/Shared%20Documents

  • http://<nome server>/PowerPivot%20Gallery

  • Per trovare l'URL Web di una raccolta, fare clic con il pulsante destro del mouse su un documento della raccolta e scegliere Proprietà. Il campo Indirizzo (URL) mostra il percorso SharePoint del documento. Usare il mouse per selezionare l'intero URL. A volte gli URL lunghi possono essere parzialmente nascosti.

  • Molto probabilmente sarà necessario modificare l'URL prima di usarlo. Nello specifico, se l'URL include proprietà per il visualizzatore e l'origine, occorre rimuoverle per ottenere un percorso utilizzabile costituito dai nomi del server, del sito e della raccolta. Ad esempio, partendo dall'URL seguente, è possibile derivare il percorso dell'URL effettivo mantenendo la parte in grassetto ed eliminando il resto: http://Contoso/Sales/_layouts/xlviewer.aspx?id=/PowerPivot%20Gallery/ContosoSales.xlsx&Source=http%3A%2F%2FContoso%2FPowerPivot%2520Gallery%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1. In base alla proprietà URL, il percorso effettivo da usare per la pubblicazione dovrà essere "http://Contoso/Sales/PowerPivot%20Gallery/ContosoSales.xlsx" per pubblicare il file ContosoSales.xlsx o semplicemente "http://Contoso/Sales/PowerPivot%20Gallery" se si vuole solo il sito e la raccolta.

  • Nella scelta del percorso, selezionare una raccolta che sia disponibile alle persone con cui si vuole condividere la cartella di lavoro. Potrebbe essere necessario richiedere le autorizzazioni per la raccolta o il documento per assicurare la disponibilità della cartella di lavoro.

Salvare il file in SharePoint

  1. In Excel fare clic su File > Salva con nome > SharePoint oppure Siti > Sfoglia, quindi selezionare un percorso.

  2. Nella casella Nome file della finestra di dialogo Salva con nome digitare un nome per il file se si usa un percorso esistente oppure, se si è scelto Cerca percorso, immettere tutto o parte dell'URL di un sito di SharePoint. Se si immette solo una parte dell'URL, ad esempio http://<nome server>, fare clic su Salva per aprire una connessione al server specificato e quindi cercare nel sito la raccolta da usare. Per esempi di URL di SharePoint, vedere Scegliere una posizione per il file in questo argomento.

  3. Fare clic su Salva per pubblicare la cartella di lavoro nella raccolta.

In una finestra del browser verificare che il documento sia visualizzato nella raccolta. I documenti appena pubblicati sono visualizzati nell'elenco. Le impostazioni della raccolta determinano la posizione in cui viene visualizzato il documento (ad esempio, in ordine crescente per data o in ordine alfabetico per nome). Potrebbe essere necessario aggiornare le finestra del browser per visualizzare le aggiunte più recenti.

Caricare una cartella di lavoro di Power Pivot da SharePoint

Un altro approccio per l'aggiunta di una cartella di lavoro di Power Pivot consiste nel caricarla da un sito di SharePoint. Questo approccio è ideale se si vuole usare SharePoint come punto di partenza.

  1. In un sito di SharePoint aprire una raccolta documenti.

  2. In Strumenti raccolta fare clic su Documenti > Carica documento, > Carica documento .

  3. Individuare il percorso in cui è stato salvato il file con estensione xlsx, selezionarlo e fare clic su OK.

Il file viene caricato nel sito di SharePoint e visualizzato nella cartella. Per visualizzarlo potrebbe essere necessario fare clic sul pulsante Aggiorna nel browser. Il file può ora essere aperto in SharePoint. È possibile indicare ad altri utenti dove si trova fornendo loro l'URL del file.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×