SOMMA.SE (funzione SOMMA.SE)

In questo articolo vengono illustrati la sintassi delle formule e l'utilizzo della funzioneSOMMA.SE in Microsoft Excel.

Descrizione

È possibile utilizzare la funzione SOMMA.SE per sommare i valori di un intervallo che soddisfano i criteri specificati. Si supponga ad esempio che in una colonna contenente numeri si desideri sommare solo i valori maggiori di 5. In tal caso, utilizzare la formula seguente:

=SOMMA.SE(B2:B25;">5")

In questo esempio il criterio viene applicato agli stessi valori da sommare. Se lo si desidera, è possibile applicarlo a un intervallo e sommare i valori corrispondenti di un altro intervallo. La formula =SOMMA.SE(B2:B5; "Luca"; C2:C5) ad esempio sommerà solo i valori dell'intervallo C2:C5 per cui il contenuto delle celle corrispondenti nell'intervallo B2:B5 è uguale a "Luca".

Nota   Per sommare le celle in base a più criteri, vedere Funzione SOMMA.PIÙ.SE.

Sintassi

SUMIF(range, criteria, [sum_range])

Nella sintassi della funzione SOMMA.SE sono previsti gli argomento seguenti:

  • intervallo    Obbligatorio. Intervallo di celle da valutare in base al criterio. Le celle di ogni intervallo devono contenere numeri oppure nomi, matrici o riferimenti che includono numeri. Le celle vuote e i valori di testo verranno ignorati.

  • criterio    Obbligatorio. Criterio in forma di numero, espressione, riferimento di cella, testo o funzione che definisce le celle che verranno sommate. È ad esempio possibile esprimere il criterio come 32, ">32", B5, 32, "32", "mele" oppure OGGI().

    Importante   Qualsiasi criterio di testo o di altro tipo comprendente simboli logici o matematici deve essere racchiuso tra virgolette doppie ("). Se il criterio è numerico, le virgolette doppie non saranno necessarie.

  • int_somma    Facoltativo. Celle effettivamente da sommare, se si desidera sommare celle diverse da quelle specificate nell'argomento intervallo. Se l'argomento int_somma è omesso, verranno sommate le celle specificate nell'argomento intervallo, ovvero le stesse celle a cui viene applicato il criterio.

Nota   

  • Nell'argomento criterio è possibile utilizzare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Utilizzare il punto interrogativo e l'asterisco per indicare rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere.

Osservazioni

  • La funzione SOMMA.SE restituirà risultati non corretti se utilizzata per trovare stringhe contenenti più di 255 caratteri rispetto alla stringa #VALORE!.

  • L'argomento int_somma non deve necessariamente avere le stesse dimensioni e forma dell'argomento intervallo. Le celle effettivamente da sommare vengono determinate utilizzando la cella superiore sinistra dell'argomento int_somma come cella iniziale e includendo le celle che corrispondono all'argomento intervallo in termini di dimensioni e forma. Ad esempio:

Se intervallo è

E int_somma è

Le celle effettive sono

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Quando tuttavia gli argomenti intervallo e int_somma nella funzione SOMMA.SE non contengono lo stesso numero di celle, il ricalcolo di un foglio di lavoro può richiedere più tempo del previsto.

Esempi

Esempio 1

La cartella di lavoro mostrata in seguito illustra alcuni esempi di questa funzione. È possibile verificarli, modificare le formule esistenti o immettere le proprie formule per scoprire le loro modalità di funzionamento.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Valore proprietà

Commissione

Dati

€ 100.000,00

€ 7.000,00

€ 250.000,00

€ 200.000,00

€ 14.000,00

€ 300.000,00

€ 21.000,00

€ 400.000,00

€ 28.000,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A5;">160000";B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori di 160.000.

€ 63.000,00

=SOMMA.SE(A2:A5;">160000")

Somma dei valori di proprietà maggiori di 160.000.

€ 900.000,00

=SOMMA.SE(A2:A5;300000;B2:B5)

Somma delle commissioni relative ai valori di proprietà uguali a 300.000.

€ 21.000,00

=SOMMA.SE(A2:A5;">" & C2;B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori del valore in C2.

€ 49.000,00

Per usare i dati di esempio in modo più completo in Excel, scaricare la cartella di lavoro incorporata sul computer e aprirla in Excel.

Esempio 2

La cartella di lavoro mostrata in seguito illustra alcuni esempi di questa funzione. È possibile verificarli, modificare le formule esistenti o immettere le proprie formule per scoprire le loro modalità di funzionamento.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Categoria

Cibo

Vendite

Verdura

Pomodori

€ 2.300,00

Verdura

Sedano

€ 5.500,00

Frutta

Arance

€ 800,00

Burro

€ 400,00

Verdura

Carote

€ 4.200,00

Frutta

Mele

€ 1.200,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A7;"Frutta";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Frutta".

€ 2.000,00

=SOMMA.SE(A2:A7;"Verdura";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Verdura".

€ 12.000,00

=SOMMA.SE(B2:B7;"*e";C2:C7)

Somma delle vendite di tutti gli alimenti il cui nome finisce per "e" (Zucchine, Arance e Mele).

€ 4.300,00

=SOMMA.SE(A2:A7;"";C2:C7)

Somma delle vendite di tutti gli alimenti non assegnati a una categoria specifica.

€ 400,00

Per usare i dati di esempio in modo più completo in Excel, scaricare la cartella di lavoro incorporata sul computer e aprirla in Excel.

Torna all'inizio

Si applica a: Excel 2013, Excel Online



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua