SOMMA.SE (funzione SOMMA.SE)

Questo articolo descrive la sintassi della formula e l'uso della funzione SOMMA.SE in Microsoft Excel.

Descrizione

È possibile usare la funzione SOMMA.SE per sommare i valori di un intervallo che soddisfano i criteri specificati. Si supponga ad esempio che in una colonna contenente numeri si desideri sommare solo i valori maggiori di 5. In tal caso, usare la formula seguente:

=SOMMA.SE(B2:B25,">5")

In questo esempio il criterio viene applicato ai valori da sommare. Se si vuole, è possibile applicarlo a un intervallo e sommare i valori corrispondenti in un altro intervallo. Ad esempio, la formula =SOMMA.SE(B2:B5; "Luca"; C2:C5) sommerà solo i valori dell'intervallo C2:C5 per cui il contenuto delle celle corrispondenti nell'intervallo B2:B5 è uguale a "Luca".

Nota   Per sommare le celle in base a più criteri, vedere la funzione SOMMA.PIÙ.SE.

Sintassi

SOMMA.SE(intervallo; criteri; [int_somma])

Gli argomenti della sintassi della funzione SOMMA.SE sono i seguenti:

  • intervallo   Obbligatorio. Intervallo di celle da valutare in base ai criteri. Le celle di ogni intervallo devono contenere numeri oppure nomi, matrici o riferimenti che includono numeri. Le celle vuote e i valori di testo verranno ignorati.

  • criteri   Obbligatorio. Criteri in forma di numero, espressione, riferimento di cella, testo o funzione che definisce le celle che verranno sommate. Ad esempio, è possibile esprimere i criteri come 32, ">32", B5, "32", "mele" oppure OGGI().

    Importante   Qualsiasi criterio di testo o di altro tipo comprendente simboli logici o matematici deve essere racchiuso tra virgolette doppie ("). Se il criterio è numerico, le virgolette doppie non saranno necessarie.

  • int_somma   Facoltativo. Celle effettivamente da sommare, se si vogliono sommare celle diverse da quelle specificate nell'argomento intervallo. Se l'argomento int_somma è omesso, verranno sommate le celle specificate nell'argomento intervallo, ovvero le stesse celle a cui vengono applicati i criteri.

  • Nell'argomento criteri è possibile usare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Usare il punto interrogativo e l'asterisco per indicare rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere.

Osservazioni

  • La funzione SOMMA.SE restituirà risultati non corretti se usata per la corrispondenza con stringhe contenenti più di 255 caratteri o con la stringa #VALORE!.

  • L'argomento int_somma non deve necessariamente avere le stesse dimensioni e forma dell'argomento intervallo. Le celle effettivamente da sommare vengono determinate usando la cella superiore sinistra dell'argomento int_somma come cella iniziale e includendo le celle che corrispondono all'argomento intervallo in termini di dimensioni e forma. Ad esempio:

Se intervallo è

E int_somma è

Le celle effettive sono

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Quando tuttavia gli argomenti intervallo e int_somma nella funzione SOMMA.SE non contengono lo stesso numero di celle, il ricalcolo di un foglio di lavoro può richiedere più tempo del previsto.

Esempi

Esempio 1

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Valore proprietà

Commissione

Dati

€ 100.000,00

€ 7.000,00

€ 250.000,00

€ 200.000,00

€ 14.000,00

€ 300.000,00

€ 21.000,00

€ 400.000,00

€ 28.000,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A5;">160000";B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori di 160.000.

€ 63.000,00

=SOMMA.SE(A2:A5;">160000")

Somma dei valori di proprietà maggiori di 160.000.

€ 900.000,00

=SOMMA.SE(A2:A5;300000;B2:B5)

Somma delle commissioni relative ai valori di proprietà uguali a 300.000.

€ 21.000,00

=SOMMA.SE(A2:A5;">" & C2;B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori del valore in C2.

€ 49.000,00

Esempio 2

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Categoria

Cibo

Vendite

Verdura

Pomodori

€ 2.300,00

Verdura

Sedano

€ 5.500,00

Frutta

Arance

€ 800,00

Burro

€ 400,00

Verdura

Carote

€ 4.200,00

Frutta

Mele

€ 1.200,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A7;"Frutta";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Frutta".

€ 2.000,00

=SOMMA.SE(A2:A7;"Verdura";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Verdura".

€ 12.000,00

=SOMMA.SE(B2:B7;"*e";C2:C7)

Somma delle vendite di tutti gli alimenti il cui nome finisce per "e" (Zucchine, Arance e Mele).

€ 4.300,00

=SOMMA.SE(A2:A7;"";C2:C7)

Somma delle vendite di tutti gli alimenti non assegnati a una categoria specifica.

€ 400,00

Inizio pagina

Si applica a: Excel 2016, Excel 2013, Excel 2010, Excel 2007, Excel 2016 per Mac, Excel per Mac 2011, Excel Online, Excel Starter



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Cambia lingua