SE.ERRORE (funzione SE.ERRORE)

Questo articolo descrive la sintassi della formula e l'uso della funzione SE.ERRORE in Microsoft Excel.

Descrizione

Restituisce un valore specificato se una formula fornisce come risultato un errore. In caso contrario, restituisce il risultato della formula. Utilizzare la funzione SE.ERRORE per intercettare e gestire gli errori di una formula.

Sintassi

SE.ERRORE(valore; se_errore)

Gli argomenti della sintassi della funzione SE.ERRORE sono i seguenti:

  • Valore    Obbligatorio. Argomento in cui viene verificata la presenza di un errore.

  • se_errore    Obbligatorio. Valore da restituire se la formula fornisce come risultato un errore. Vengono valutati i tipi di errore seguenti: #N/D, #VALORE!, #RIF!, #DIV/0!, #NUM!, #NOME? o #NULLO!.

Osservazioni

  • Se Valore o Se_errore è una cella vuota, viene considerato da SE.ERRORE come un valore stringa vuoto ("").

  • Se Valore è una formula in forma di matrice, SE.ERRORE restituirà una matrice di risultati per ogni cella nell'intervallo specificato nel valore. Vedere il secondo esempio riportato di seguito.

Esempi

Copiare i dati di esempio nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per mostrare i risultati delle formule, selezionarle, premere F2 e quindi INVIO. Se necessario, è possibile adattare la larghezza delle colonne in modo da vedere i dati per intero.

Quota

Unità vendute

210

35

55

0

23

Formula

Descrizione

Risultato

=SE.ERRORE(A2/B2; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (210 diviso 35), non trova errori e quindi restituisce i risultati della formula.

6

=SE.ERRORE(A3/B3; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=SE.ERRORE(A4/B4; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento ("" diviso 23), non trova errori e quindi restituisce i risultati della formula.

0

Esempio 2

Quota

Unità vendute

Rapporto

210

35

6

55

0

Errore nel calcolo

23

0

Formula

Descrizione

Risultato

=C2

Verifica la presenza di un errore nella formula nel primo argomento nel primo elemento della matrice (A2/B2 o 210 diviso 35), non trova errori e quindi restituisce il risultato della formula.

6

=C3

Verifica la presenza di un errore nella formula nel primo argomento nel secondo elemento della matrice (A3/B3 o 55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=C4

Verifica la presenza di un errore nella formula nel primo argomento nel terzo elemento della matrice (A4/B4 o "" diviso 23), non trova errori e quindi restituisce il risultato della formula.

0

Nota: la formula dell'esempio deve essere immessa come formula di matrice. Dopo aver copiato l'esempio in un foglio di lavoro vuoto, selezionare l'intervallo C2:C4, premere F2 e quindi premere CTRL+MAIUSC+INVIO.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×